[webkit-dev] We should rename layoutTestController to testController

2012-05-31 Thread Darin Adler
I am thinking we should rename layoutTestController to testController. Or if 
you don’t like that name, maybe testHarness or some even better name.

The old name is too long and the word “layout” is so strange.

We could expose the object under the new name and the old one, and then over 
time convert all the tests to the new name, then get rid of the old one.

What do you all think?

-- Darin
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] We should rename layoutTestController to testController

2012-05-31 Thread Jacob Goldstein

On 5/31/12 11:56 AM, Darin Adler da...@apple.com wrote:

I am thinking we should rename layoutTestController to testController. Or
if you don¹t like that name, maybe testHarness or some even better name.



testHarness is probably not a good choice as the W3C JavaScript framework
that recently landed in WebKit, and that we are going to encourage people
to use for DOM-only tests, is called testharness.js




The old name is too long and the word ³layout² is so strange.

We could expose the object under the new name and the old one, and then
over time convert all the tests to the new name, then get rid of the old
one.

What do you all think?

-- Darin
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] We should rename layoutTestController to testController

2012-05-31 Thread Ojan Vafai
testController seems fine to me. I agree it's an improvement.

On the other hand there are other tasks that have more benefit in terms of
code maintenance for people wanting to spend time working in this area. A
couple ideas:

   - Move more APIs that only depend WebCore code to internals. Reduces
   code duplication and complexity.
   - Work on exposing things like eventSender through an NPAPI plugin. That
   way it can be shared across browser vendors and could be used by the W3C
   test harness as well. This would be for APIs that we want for testing but
   don't make sense to expose to the web.

Ojan

On Thu, May 31, 2012 at 11:56 AM, Darin Adler da...@apple.com wrote:

 I am thinking we should rename layoutTestController to testController. Or
 if you don’t like that name, maybe testHarness or some even better name.

 The old name is too long and the word “layout” is so strange.

 We could expose the object under the new name and the old one, and then
 over time convert all the tests to the new name, then get rid of the old
 one.

 What do you all think?

 -- Darin
 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] We should rename layoutTestController to testController

2012-05-31 Thread Ryosuke Niwa
On Thu, May 31, 2012 at 11:56 AM, Darin Adler da...@apple.com wrote:

 I am thinking we should rename layoutTestController to testController. Or
 if you don’t like that name, maybe testHarness or some even better name.


testController seems like a misnomer since it doesn't really control the
test itself. I would prefer testRunnerController or simply testRunner since
it's quite self-evident that methods on testRunner would act on the test
runner itself.

We could expose the object under the new name and the old one, and then
 over time convert all the tests to the new name, then get rid of the old
 one.


That sounds like a good idea.

Can we also rename LayoutTests to RegressionTests? I know Dave (Hyatt)
suggested to cleanup the render tree dump format to get rid of all hacks
and tweaks we've added over years, and my preference is to combine all
these efforts and put new types of tests in trunk/RegressionTests. We'll
move tests from LayoutTests to RegressionTests as we convert. We'll get rid
of LayoutTests directory once all tests have been converted to use
testRunner and new render tree dump format.

- Ryosuke
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] We should rename layoutTestController to testController

2012-05-31 Thread Ryosuke Niwa
On Thu, May 31, 2012 at 12:07 PM, Ojan Vafai o...@chromium.org wrote:

 testController seems fine to me. I agree it's an improvement.

 On the other hand there are other tasks that have more benefit in terms of
 code maintenance for people wanting to spend time working in this area. A
 couple ideas:

- Move more APIs that only depend WebCore code to internals. Reduces
code duplication and complexity.
- Work on exposing things like eventSender through an NPAPI plugin.
That way it can be shared across browser vendors and could be used by the
W3C test harness as well. This would be for APIs that we want for testing
but don't make sense to expose to the web.

 W3C is developing a WebDriver specification which tries to automate tests
that require mouse/keyboard events, etc...:
https://dvcs.w3.org/hg/webdriver/raw-file/tip/webdriver-spec.html  If we're
trying to share code across browser vendors, then we should probably use
this API instead.  I suspect we can emulate the most of API surface using
eventSender even if we could not natively support it.

- Ryosuke
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] We should rename layoutTestController to testController

2012-05-31 Thread Dan Bernstein

On May 31, 2012, at 12:11 PM, Ryosuke Niwa rn...@webkit.org wrote:

 On Thu, May 31, 2012 at 11:56 AM, Darin Adler da...@apple.com wrote:
 I am thinking we should rename layoutTestController to testController. Or if 
 you don’t like that name, maybe testHarness or some even better name.
 
 testController seems like a misnomer since it doesn't really control the 
 test itself. I would prefer testRunnerController or simply testRunner since 
 it's quite self-evident that methods on testRunner would act on the test 
 runner itself.

I like the name testRunner.

 
 We could expose the object under the new name and the old one, and then over 
 time convert all the tests to the new name, then get rid of the old one.
 
 That sounds like a good idea.
 
 Can we also rename LayoutTests to RegressionTests? I know Dave (Hyatt) 
 suggested to cleanup the render tree dump format to get rid of all hacks and 
 tweaks we've added over years, and my preference is to combine all these 
 efforts and put new types of tests in trunk/RegressionTests. We'll move tests 
 from LayoutTests to RegressionTests as we convert. We'll get rid of 
 LayoutTests directory once all tests have been converted to use testRunner 
 and new render tree dump format.
 
 - Ryosuke
 
 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] We should rename layoutTestController to testController

2012-05-31 Thread Jesus Sanchez-Palencia
2012/5/31 Ojan Vafai o...@chromium.org:
 testController seems fine to me. I agree it's an improvement.

 On the other hand there are other tasks that have more benefit in terms of
 code maintenance for people wanting to spend time working in this area. A
 couple ideas:

 Move more APIs that only depend WebCore code to internals. Reduces code
 duplication and complexity.

Just a heads-up: there is a meta bug tracking this at
https://bugs.webkit.org/show_bug.cgi?id=87284 .

A few folks have been going through the list created during the
hackathon (https://trac.webkit.org/wiki/Internals_Hackathon) and
picking a method to port every now and then.

We were following the
if-it-depends-only-on-WebCore-code-it-should-be-moved idea quite
strictly, but now it seems we are facing a trade-off about internals x
private WebKit APIs/SPIs from a few ports being tested. In other
words, a few methods from layoutTestController are also testing code
(private?) from WebKit and moving them to internals can leave these
untested... For Qt I'm removing private methods that were only used by
DRT or WTR, but I can't make this decision for other ports.

Anyway, if you know something that can be moved for sure, just open a
bug blocking b87284 and I'm quite sure there will be people happy to
work on it.

Cheers,
jesus


 Work on exposing things like eventSender through an NPAPI plugin. That way
 it can be shared across browser vendors and could be used by the W3C test
 harness as well. This would be for APIs that we want for testing but don't
 make sense to expose to the web.

 Ojan

 On Thu, May 31, 2012 at 11:56 AM, Darin Adler da...@apple.com wrote:

 I am thinking we should rename layoutTestController to testController. Or
 if you don’t like that name, maybe testHarness or some even better name.

 The old name is too long and the word “layout” is so strange.

 We could expose the object under the new name and the old one, and then
 over time convert all the tests to the new name, then get rid of the old
 one.

 What do you all think?

 -- Darin
 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev



 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] We should rename layoutTestController to testController

2012-05-31 Thread Jesus Sanchez-Palencia
2012/5/31 Dan Bernstein m...@apple.com:

 On May 31, 2012, at 12:11 PM, Ryosuke Niwa rn...@webkit.org wrote:

 On Thu, May 31, 2012 at 11:56 AM, Darin Adler da...@apple.com wrote:

 I am thinking we should rename layoutTestController to testController. Or
 if you don’t like that name, maybe testHarness or some even better name.


 testController seems like a misnomer since it doesn't really control the
 test itself. I would prefer testRunnerController or simply testRunner since
 it's quite self-evident that methods on testRunner would act on the test
 runner itself.


 I like the name testRunner.

I like it too.






 We could expose the object under the new name and the old one, and then
 over time convert all the tests to the new name, then get rid of the old
 one.


 That sounds like a good idea.

 Can we also rename LayoutTests to RegressionTests? I know Dave (Hyatt)
 suggested to cleanup the render tree dump format to get rid of all hacks and
 tweaks we've added over years, and my preference is to combine all these
 efforts and put new types of tests in trunk/RegressionTests. We'll move
 tests from LayoutTests to RegressionTests as we convert. We'll get rid of
 LayoutTests directory once all tests have been converted to use testRunner
 and new render tree dump format.

 - Ryosuke

 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev



 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] We should rename layoutTestController to testController

2012-05-31 Thread Ojan Vafai
Darin, sorry for derailing this thread. I suppose I should have changed the
subject. :)

On Thu, May 31, 2012 at 1:51 PM, Jesus Sanchez-Palencia je...@webkit.orgwrote:

 Just a heads-up: there is a meta bug tracking this at
 https://bugs.webkit.org/show_bug.cgi?id=87284 .

 A few folks have been going through the list created during the
 hackathon (https://trac.webkit.org/wiki/Internals_Hackathon) and
 picking a method to port every now and then.


Awesome!


 We were following the
 if-it-depends-only-on-WebCore-code-it-should-be-moved idea quite
 strictly, but now it seems we are facing a trade-off about internals x
 private WebKit APIs/SPIs from a few ports being tested. In other
 words, a few methods from layoutTestController are also testing code
 (private?) from WebKit and moving them to internals can leave these
 untested... For Qt I'm removing private methods that were only used by
 DRT or WTR, but I can't make this decision for other ports.


If any of these involve the Chromium port, I'm sure we'd be happy to
accommodate whatever is needed to move the API to internals. Feel free to
CC me on bugs where that's the case.


 Anyway, if you know something that can be moved for sure, just open a
 bug blocking b87284 and I'm quite sure there will be people happy to
 work on it.

 Cheers,
 jesus


  Work on exposing things like eventSender through an NPAPI plugin. That
 way
  it can be shared across browser vendors and could be used by the W3C test
  harness as well. This would be for APIs that we want for testing but
 don't
  make sense to expose to the web.
 
  Ojan
 
  On Thu, May 31, 2012 at 11:56 AM, Darin Adler da...@apple.com wrote:
 
  I am thinking we should rename layoutTestController to testController.
 Or
  if you don’t like that name, maybe testHarness or some even better name.
 
  The old name is too long and the word “layout” is so strange.
 
  We could expose the object under the new name and the old one, and then
  over time convert all the tests to the new name, then get rid of the old
  one.
 
  What do you all think?
 
  -- Darin
  ___
  webkit-dev mailing list
  webkit-dev@lists.webkit.org
  http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
 
 
 
  ___
  webkit-dev mailing list
  webkit-dev@lists.webkit.org
  http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
 

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] We should rename layoutTestController to testController

2012-05-31 Thread Maciej Stachowiak

On May 31, 2012, at 3:11 PM, Ryosuke Niwa rn...@webkit.org wrote:

 On Thu, May 31, 2012 at 11:56 AM, Darin Adler da...@apple.com wrote:
 I am thinking we should rename layoutTestController to testController. Or if 
 you don’t like that name, maybe testHarness or some even better name.
 
 testController seems like a misnomer since it doesn't really control the 
 test itself. I would prefer testRunnerController or simply testRunner since 
 it's quite self-evident that methods on testRunner would act on the test 
 runner itself.
 
 We could expose the object under the new name and the old one, and then over 
 time convert all the tests to the new name, then get rid of the old one.
 
 That sounds like a good idea.
 
 Can we also rename LayoutTests to RegressionTests? I know Dave (Hyatt) 
 suggested to cleanup the render tree dump format to get rid of all hacks and 
 tweaks we've added over years, and my preference is to combine all these 
 efforts and put new types of tests in trunk/RegressionTests. We'll move tests 
 from LayoutTests to RegressionTests as we convert. We'll get rid of 
 LayoutTests directory once all tests have been converted to use testRunner 
 and new render tree dump format.

I don't think renaming the directory should be tired to changing the output 
format. In particular, it would be confusing to have both RegressionTests and 
LayoutTests exist at the same time for an extended period. I don't think it has 
worked out very well to have both WebCore/platform/ and Platform/ exist at the 
same time, for instance. There are other ways to track an incremental 
conversion effort.

Regards,
Maciej


___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] We should rename layoutTestController to testController

2012-05-31 Thread Ryosuke Niwa
On Thu, May 31, 2012 at 2:05 PM, Maciej Stachowiak m...@apple.com wrote:

 On May 31, 2012, at 3:11 PM, Ryosuke Niwa rn...@webkit.org wrote:

 On Thu, May 31, 2012 at 11:56 AM, Darin Adler da...@apple.com wrote:

 I am thinking we should rename layoutTestController to testController. Or
 if you don’t like that name, maybe testHarness or some even better name.


 testController seems like a misnomer since it doesn't really control the
 test itself. I would prefer testRunnerController or simply testRunner since
 it's quite self-evident that methods on testRunner would act on the test
 runner itself.

 We could expose the object under the new name and the old one, and then
 over time convert all the tests to the new name, then get rid of the old
 one.


 That sounds like a good idea.

 Can we also rename LayoutTests to RegressionTests? I know Dave (Hyatt)
 suggested to cleanup the render tree dump format to get rid of all hacks
 and tweaks we've added over years, and my preference is to combine all
 these efforts and put new types of tests in trunk/RegressionTests. We'll
 move tests from LayoutTests to RegressionTests as we convert. We'll get rid
 of LayoutTests directory once all tests have been converted to use
 testRunner and new render tree dump format.

 I don't think renaming the directory should be tired to changing the
 output format. In particular, it would be confusing to have both
 RegressionTests and LayoutTests exist at the same time for an extended
 period. I don't think it has worked out very well to have both
 WebCore/platform/ and Platform/ exist at the same time, for instance. There
 are other ways to track an incremental conversion effort.


I don't expect it to exist for an extended period of time since it's just a
matter of rebaselining results. Given a good tool (which we're going to
write), I'd expect it to be done in a matter of weeks if not in days.

- Ryosuke
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev