[webkit-dev] Rename AtomicString to AtomString

2019-01-30 Thread Darin Adler
So, did we reach consensus that we should rename AtomicString to AtomString? — Darin ___ webkit-dev mailing list webkit-dev@lists.webkit.org https://lists.webkit.org/mailman/listinfo/webkit-dev

Re: [webkit-dev] Rename AtomicString to AtomString

2019-01-30 Thread Chris Dumez
Fine by me. --  Chris Dumez > On Jan 30, 2019, at 9:35 AM, Antti Koivisto wrote: > > Sounds good to me. > > > antti > > On Wed, Jan 30, 2019 at 6:33 PM Darin Adler > wrote: > So, did we reach consensus that we should rename AtomicString to AtomString? > > —

Re: [webkit-dev] Rename AtomicString to AtomString

2019-01-30 Thread Antti Koivisto
Sounds good to me. antti On Wed, Jan 30, 2019 at 6:33 PM Darin Adler wrote: > So, did we reach consensus that we should rename AtomicString to > AtomString? > > — Darin > ___ > webkit-dev mailing list > webkit-dev@lists.webkit.org >

Re: [webkit-dev] Rename AtomicString to AtomString

2019-01-30 Thread Michael Catanzaro
On Wed, Jan 30, 2019 at 10:31 AM, Darin Adler wrote: So, did we reach consensus that we should rename AtomicString to AtomString? +1 from me, it seems like a much less confusing name. ___ webkit-dev mailing list webkit-dev@lists.webkit.org

Re: [webkit-dev] Rename AtomicString to AtomString

2019-01-30 Thread Adrian Perez de Castro
Hi, On Wed, 30 Jan 2019 08:31:49 -0800, Darin Adler wrote: > So, did we reach consensus that we should rename AtomicString to AtomString? Let's go with it  Cheers, -Adrián pgpCXmm7f6QX0.pgp Description: PGP signature ___ webkit-dev mailing list

Re: [webkit-dev] Reducing globals

2019-01-30 Thread Michael Catanzaro
Sorry again for the delay. I've started here: https://bugs.webkit.org/show_bug.cgi?id=194075 That covers the first two out of six parameters. I'll do CookieAcceptPolicy next, separately, since it requires modifying cross-platform stuff to do properly. And then the second half. Michael