Re: [webkit-dev] Rename Bugzilla component "ANGLE" to "WebGL"

2019-02-01 Thread Maciej Stachowiak
ANGLE is a separate chunk of code, and one the we periodically sync with an upstream repository, so I am not sure this is a good idea. > On Feb 1, 2019, at 10:59 AM, Lucas Forschler wrote: > > I just realized we already have a WebGL Bugzilla component. So I propose > deprecating the ANGLE

[webkit-dev] Rename Bugzilla's "WebKit2" component to "WebKit Process Model"

2019-02-01 Thread Lucas Forschler
Hello all, I am modernizing/cleaning up our Bugzilla component names. The first one I’d to rename is the WebKit2 component. I would like to rename this component to “WebKit Process Model”. Are there any objections or concerns with this rename? Thanks, Lucas

[webkit-dev] Rename Bugzilla Component "Media Elements" to "Media"

2019-02-01 Thread Lucas Forschler
Hello all, I propose renaming the Bugzilla component “Media Elements” to “Media”. Are there any objections or concerns with this rename? Thanks, Lucas ___ webkit-dev mailing list webkit-dev@lists.webkit.org

Re: [webkit-dev] Rename Bugzilla component "ANGLE" to "WebGL"

2019-02-01 Thread Lucas Forschler
I just realized we already have a WebGL Bugzilla component. So I propose deprecating the ANGLE component, and using WebGL moving forward. > On Feb 1, 2019, at 10:47 AM, Lucas Forschler wrote: > > Hello all, > > I would like to rename the Bugzilla component “ANGLE” to “WebGL”. > > Are there

Re: [webkit-dev] Rename Bugzilla's "WebKit2" component to "WebKit Process Model"

2019-02-01 Thread Ryosuke Niwa
Hm... I think WebKit2 component is currently used to implement both WebKit Process Model as well as WKWebView / WebKit2 API. So we probably need to split it into multiple components, one of which is WebKit Process Model. - R. Niwa On Fri, Feb 1, 2019 at 10:27 AM Lucas Forschler wrote: > Hello

[webkit-dev] Rename Bugzilla component "ANGLE" to "WebGL"

2019-02-01 Thread Lucas Forschler
Hello all, I would like to rename the Bugzilla component “ANGLE” to “WebGL”. Are there any objections or concerns with this rename? Thanks, Lucas ___ webkit-dev mailing list webkit-dev@lists.webkit.org

Re: [webkit-dev] Rename Bugzilla Component "Media Elements" to "Media"

2019-02-01 Thread Maciej Stachowiak
Sounds good to me. > On Feb 1, 2019, at 10:52 AM, Lucas Forschler wrote: > > Hello all, > > I propose renaming the Bugzilla component “Media Elements” to “Media”. > > Are there any objections or concerns with this rename? > > Thanks, > Lucas > ___

[webkit-dev] More suggested Bugzilla component renames

2019-02-01 Thread Michael Catanzaro
WebKit Gtk -> WebKitGTK+ (or just WebKitGTK if the + is not allowed) WebKit WPE -> WPE WebKit ___ webkit-dev mailing list webkit-dev@lists.webkit.org https://lists.webkit.org/mailman/listinfo/webkit-dev