Re: [webkit-dev] Moving to Git

2019-02-21 Thread Bug Tracker
Thank you all very much for your help! I really appreciate it. :-) P.S.: I decided to start learning git-svn. ‐‐‐ Original Message ‐‐‐ On Wednesday, February 20, 2019 11:48 PM, Adrian Perez de Castro wrote: > On Wed, 20 Feb 2019 22:30:22 +0300, Konstantin Tokarev annu...@yandex.ru

Re: [webkit-dev] Moving to Git

2019-02-21 Thread Simon Fraser
> On Feb 21, 2019, at 12:18 AM, Bug Tracker > wrote: > > Thank you all very much for your help! I really appreciate it. :-) > > P.S.: I decided to start learning git-svn. https://trac.webkit.org/wiki/UsingGitWithWebKit has the information you

Re: [webkit-dev] Code Style: Opinion on returning void

2019-02-21 Thread Darin Adler
I tried not to weigh in on this, but my view on the materials we should use to build the bike shed must be shared! Generally it seems neat to be able to make the code slightly more tight and terse by merging the function call and the return into a single statement. Other than not being

[webkit-dev] Turning on/off web preferences during iOS development

2019-02-21 Thread Frédéric Wang
Hi everybody, I was wondering if there is an easy way to enable or disable a web preference on iOS (simulator). Some of them are in the "experimental features" menu but (at least with the public SDK) it has not always worked well during development [1]. Moreover, most of the preferences are now

[webkit-dev] WinCairo Intent to Deprecate WebKitLegacy

2019-02-21 Thread Don . Olmstead
Hi WebKittens, Since taking over development of the WinCairo port we've made a lot of good progress with enabling Modern WebKit on Windows. Because of that we plan on beginning to remove support of WebKitLegacy on the WinCairo port and switch to a fully Modern WebKit implementation. This will

Re: [webkit-dev] Code Style: Opinion on returning void

2019-02-21 Thread Ryosuke Niwa
On Thu, Feb 21, 2019 at 9:31 AM Darin Adler wrote: > I tried not to weigh in on this, but my view on the materials we should > use to build the bike shed must be shared! > > Generally it seems neat to be able to make the code slightly more tight > and terse by merging the function call and the

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2019-02-21 Thread Ryosuke Niwa
I guess we never remembered to update our style guideline back in 2013. I've uploaded a patch to do this: https://bugs.webkit.org/show_bug.cgi?id=194930 - R. Niwa ___ webkit-dev mailing list webkit-dev@lists.webkit.org

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2019-02-21 Thread Ryosuke Niwa
For those who joined webkit-dev after June 2013, see https://lists.webkit.org/pipermail/webkit-dev/2013-June/thread.html#25056 On Thu, Feb 21, 2019 at 7:54 PM Ryosuke Niwa wrote: > I guess we never remembered to update our style guideline back in 2013. > > I've uploaded a patch to do this: >