Re: [webkit-dev] Naming convention for static member variables

2020-02-19 Thread Simon Fraser
Thank you. I filed https://bugs.webkit.org/show_bug.cgi?id=207961 


Simon

> On Feb 19, 2020, at 11:39 AM, Konstantin Tokarev  wrote:
> 
> 
> 
> 19.02.2020, 22:31, "Simon Fraser" :
>> class Foo {
>>   static bool thing.
>> };
>> 
>> What's the naming convention for static member variables like this? I've 
>> seen m_foo, which seems positively harmful. I've seen s_foo, which I like.
>> 
>> There are 165 instances of s_ that I can find in the project. There are 17 
>> instances of static m_.
> 
> According to [1], convention is "s_". Apparently, it just lacks an 
> enforcement in style checker.
> 
> [1] https://webkit.org/code-style-guidelines/#names-data-members
> 
> -- 
> Regards,
> Konstantin
> 

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Naming convention for static member variables

2020-02-19 Thread Konstantin Tokarev


19.02.2020, 22:31, "Simon Fraser" :
> class Foo {
>   static bool thing.
> };
>
> What's the naming convention for static member variables like this? I've seen 
> m_foo, which seems positively harmful. I've seen s_foo, which I like.
>
> There are 165 instances of s_ that I can find in the project. There are 17 
> instances of static m_.

According to [1], convention is "s_". Apparently, it just lacks an enforcement 
in style checker.

[1] https://webkit.org/code-style-guidelines/#names-data-members

-- 
Regards,
Konstantin

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


[webkit-dev] Naming convention for static member variables

2020-02-19 Thread Simon Fraser
class Foo {
  static bool thing.
};

What's the naming convention for static member variables like this? I've seen 
m_foo, which seems positively harmful. I've seen s_foo, which I like.

There are 165 instances of s_ that I can find in the project. There are 17 
instances of static m_.

Simon

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev