Re: [webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore

2011-12-15 Thread Hajime Morrita
One concern is that Platform is too generic to put in global
namespace and it might conflict existing symbols from platform SDK or
something. But because we already have generic names like ASSERT() and
it works, this concern is just a theoretical thing.

So if it works with existing platforms, I think it's fine.

--
morrita

On Thu, Dec 15, 2011 at 4:02 PM, Jarred Nicholls jar...@webkit.org wrote:
 On Thu, Dec 15, 2011 at 1:55 AM, Adam Barth aba...@webkit.org wrote:

 I was working backwards from what's going to be needed to move
 WebCore/platform out of WebCore, and it occurred to me that we'll
 probably want a separate namespace for the code once it's outside of
 WebCore, just like WTF has a separate namespace from JSC.

 It seems like introducing the new namespace before the move would be
 beneficial because it would help us sort out whatever layering
 violations we have today (as they'd become apparent because of the
 explicit mention of the WebCore namespace).

 What would be an appropriate name for the namespace?  My first
 instinct is Platform to match the name of the new directory, but I'm
 open to suggestions.


 I think Platform is good.  When explaining it to an outsider, I refer to it
 as the Client Interface or Port Interface.  If Platform doesn't resonate
 well with everyone then maybe something around that verbiage would fit.  But
 honestly I can't think of anything better than Platform.



 Adam
 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev



 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore

2011-12-15 Thread Joe Mason
The BlackBerry port uses BlackBerry::Platform for its system libraries - it 
wouldn't surprise me if some of our files in the platform dirs have using 
BlackBerry so they can just use Platform::symbol instead of 
BlackBerry::Platform::symbol in the source.  Shouldn't be hard to sort out, 
though.

 -Original Message-
 From: webkit-dev-boun...@lists.webkit.org [mailto:webkit-dev-
 boun...@lists.webkit.org] On Behalf Of Hajime Morrita
 Sent: Thursday, December 15, 2011 3:31 AM
 To: Jarred Nicholls
 Cc: webkit-dev@lists.webkit.org
 Subject: Re: [webkit-dev] Incremental steps towards moving
 WebCore/platform out of WebCore
 
 One concern is that Platform is too generic to put in global
 namespace and it might conflict existing symbols from platform SDK or
 something. But because we already have generic names like ASSERT() and
 it works, this concern is just a theoretical thing.
 
 So if it works with existing platforms, I think it's fine.
 
 --
 morrita
 
 On Thu, Dec 15, 2011 at 4:02 PM, Jarred Nicholls jar...@webkit.org
 wrote:
  On Thu, Dec 15, 2011 at 1:55 AM, Adam Barth aba...@webkit.org
 wrote:
 
  I was working backwards from what's going to be needed to move
  WebCore/platform out of WebCore, and it occurred to me that we'll
  probably want a separate namespace for the code once it's outside of
  WebCore, just like WTF has a separate namespace from JSC.
 
  It seems like introducing the new namespace before the move would be
  beneficial because it would help us sort out whatever layering
  violations we have today (as they'd become apparent because of the
  explicit mention of the WebCore namespace).
 
  What would be an appropriate name for the namespace?  My first
  instinct is Platform to match the name of the new directory, but
 I'm
  open to suggestions.
 
 
  I think Platform is good.  When explaining it to an outsider, I refer
 to it
  as the Client Interface or Port Interface.  If Platform doesn't
 resonate
  well with everyone then maybe something around that verbiage would
 fit.  But
  honestly I can't think of anything better than Platform.
 
 
 
  Adam
  ___
  webkit-dev mailing list
  webkit-dev@lists.webkit.org
  http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
 
 
 
  ___
  webkit-dev mailing list
  webkit-dev@lists.webkit.org
  http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
 
 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

-
This transmission (including any attachments) may contain confidential 
information, privileged material (including material protected by the 
solicitor-client or other applicable privileges), or constitute non-public 
information. Any use of this information by anyone other than the intended 
recipient is prohibited. If you have received this transmission in error, 
please immediately reply to the sender and delete this information from your 
system. Use, dissemination, distribution, or reproduction of this transmission 
by unintended recipients is not authorized and may be unlawful.
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore

2011-12-15 Thread Darin Adler
The namespace name Platform is OK.

I’m concerned that this is over-use of namespace and will make WebCore code 
overall harder to read. One of the notable features of the classes in the 
platform directory is that they fit in smoothly and are easy to use in WebCore. 
Being in the same namespace as the rest of WebCore is part of that.

If we do use a namespace, we’ll have to decide whether to use it in a 
conventional way or use it with the “put using in header” technique that we 
use, somewhat controversially, in WTF.

-- Darin
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore

2011-12-15 Thread Adam Barth
On Thu, Dec 15, 2011 at 8:22 AM, Darin Adler da...@apple.com wrote:
 The namespace name Platform is OK.

 I’m concerned that this is over-use of namespace and will make WebCore code 
 overall harder to read. One of the notable features of the classes in the 
 platform directory is that they fit in smoothly and are easy to use in 
 WebCore. Being in the same namespace as the rest of WebCore is part of that.

 If we do use a namespace, we’ll have to decide whether to use it in a 
 conventional way or use it with the “put using in header” technique that we 
 use, somewhat controversially, in WTF.

My inclination is to put using in the header for exactly this
reason.  I'm hopeful the namespace be useful in preventing
dependencies in the other direction, where WebCore namespaced types
are used in Platform.

Adam
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore

2011-12-14 Thread Ryosuke Niwa
On Wed, Dec 14, 2011 at 10:55 PM, Adam Barth aba...@webkit.org wrote:

 It seems like introducing the new namespace before the move would be
 beneficial because it would help us sort out whatever layering
 violations we have today (as they'd become apparent because of the
 explicit mention of the WebCore namespace).


That sounds great to me.

What would be an appropriate name for the namespace?  My first
 instinct is Platform to match the name of the new directory, but I'm
 open to suggestions.


I can't think of anything better.

- Ryosuke
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore

2011-12-14 Thread Jarred Nicholls
On Thu, Dec 15, 2011 at 1:55 AM, Adam Barth aba...@webkit.org wrote:

 I was working backwards from what's going to be needed to move
 WebCore/platform out of WebCore, and it occurred to me that we'll
 probably want a separate namespace for the code once it's outside of
 WebCore, just like WTF has a separate namespace from JSC.

 It seems like introducing the new namespace before the move would be
 beneficial because it would help us sort out whatever layering
 violations we have today (as they'd become apparent because of the
 explicit mention of the WebCore namespace).

 What would be an appropriate name for the namespace?  My first
 instinct is Platform to match the name of the new directory, but I'm
 open to suggestions.


I think Platform is good.  When explaining it to an outsider, I refer to it
as the Client Interface or Port Interface.  If Platform doesn't resonate
well with everyone then maybe something around that verbiage would fit.
 But honestly I can't think of anything better than Platform.



 Adam
 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev