Re: Generate SQL fails

2008-04-07 Thread Rams
I'm trying to Generate SQL to create my tables and it is failing. My searching leads me to believe it is due to my setup as described here... http://wiki.objectstyle.org/confluence/display/WOL/mail/3047829 I'm using: OS X 10.5 WO 5.4.1 WOLips 3.5? MySQL 5.0.51a and Connector J 5.0.8.

[SOLVED] Generate SQL fails

2008-04-07 Thread Rams
On Apr 7, 2008, at 2:19 AM, Rams wrote: I'm trying to Generate SQL to create my tables and it is failing. My searching leads me to believe it is due to my setup as described here... http://wiki.objectstyle.org/confluence/display/WOL/mail/3047829 I'm using: OS X 10.5 WO 5.4.1 WOLips

Re: Generate SQL fails

2008-04-07 Thread Q
On 07/04/2008, at 4:19 PM, Rams wrote: I'm trying to Generate SQL to create my tables and it is failing. My searching leads me to believe it is due to my setup as described here... http://wiki.objectstyle.org/confluence/display/WOL/mail/3047829 I'm using: OS X 10.5 WO 5.4.1 WOLips

Re: DB2 and WebObjects

2008-04-07 Thread David Avendasora
I'm not sure I'd call it a bug as Chuck's original code does the Right Thing® in 99.9% of the situations you'd use it. But, being the PITA that I am, I've come up with a situation where even though the his code can't verify that what I'm doing is safe from a referential- integrity

Swapping a session on a direct action

2008-04-07 Thread Miguel Arroz
Hi! We're having a problem with zombie sessions. One of our direct actions has some trickery to always create a new session, even if the wosid cookie has a valid session ID, and I believe something is acting up there, but I can't figure out why (yes, this looks strange, but we actually

Best Way® to test for existence of a relationsh ip

2008-04-07 Thread David Avendasora
Hi all, This is more of a Java question than a WO-specific one I have an Inheritance structure in my app: Part (abstract Superclass) RawMaterial (subclass of Part) ManufacturedPart (subclass of Part) I have an NSArray of Parts that could be, RawMaterial instances, ManufacturedPart

Re: Best Way® to test for existence of a relatio nsh ip

2008-04-07 Thread Bob Stuart
Try catch seems expensive to me. Why not just check with if (aPart instanceof ManufacturedPart){ do something with aPart.billsOfMaterial() } At 9:12 AM -0400 4/7/08, David Avendasora wrote: Hi all, This is more of a Java question than a WO-specific one I have an Inheritance structure

Re: Best Way® to test for existence of a rela tionsh ip

2008-04-07 Thread Chuck Hill
I'd expect the instanceof check will be much more efficient than catching an exception. From an OO design point of view, I'd add a billsOfMaterial() method to the Part class that simply returns NSArray.emptyArray. ManufacturedPart will then override this to return the correct result for

Re: DB2 and WebObjects

2008-04-07 Thread Chuck Hill
On Apr 7, 2008, at 2:19 AM, David Avendasora wrote: I'm not sure I'd call it a bug as Chuck's original code does the Right Thing® in 99.9% of the situations you'd use it. If my code does not work in 0.1% of situations, then I'd consider it buggy. But that is just me. :-) But, being

Re: Swapping a session on a direct action

2008-04-07 Thread Chuck Hill
On Apr 7, 2008, at 3:18 AM, Miguel Arroz wrote: Hi! We're having a problem with zombie sessions. One of our direct actions has some trickery to always create a new session, even if the wosid cookie has a valid session ID, and I believe something is acting up there, but I can't figure

Re: Best Way® to test for existence of a rela tionsh ip

2008-04-07 Thread Mike Schrag
I'd expect the instanceof check will be much more efficient than catching an exception. By far ... From an OO design point of view, I'd add a billsOfMaterial() method to the Part class that simply returns NSArray.emptyArray. ManufacturedPart will then override this to return the correct

Re: Best Way® to test for existence of a rela tionsh ip

2008-04-07 Thread David Avendasora
On Apr 7, 2008, at 10:36 AM, Mike Schrag wrote: I'd expect the instanceof check will be much more efficient than catching an exception. By far ... From an OO design point of view, I'd add a billsOfMaterial() method to the Part class that simply returns NSArray.emptyArray.

Re: Best Way® to test for existence of a rela t ionsh ip

2008-04-07 Thread Bob Stuart
At 11:20 AM -0400 4/7/08, David Avendasora wrote: On Apr 7, 2008, at 10:36 AM, Mike Schrag wrote: I'd expect the instanceof check will be much more efficient than catching an exception. By far ... From an OO design point of view, I'd add a billsOfMaterial() method to the Part class that

Re: Best Way® to test for existence of a rela tionsh ip

2008-04-07 Thread Chuck Hill
On Apr 7, 2008, at 7:36 AM, Mike Schrag wrote: I'd expect the instanceof check will be much more efficient than catching an exception. By far ... From an OO design point of view, I'd add a billsOfMaterial() method to the Part class that simply returns NSArray.emptyArray.

Re: Best Way® to test for existence of a rela tionsh ip

2008-04-07 Thread Chuck Hill
On Apr 7, 2008, at 8:26 AM, Bob Stuart wrote: At 11:20 AM -0400 4/7/08, David Avendasora wrote: On Apr 7, 2008, at 10:36 AM, Mike Schrag wrote: I'd expect the instanceof check will be much more efficient than catching an exception. By far ... From an OO design point of view, I'd add a

[Meeting] Chicago CocoaHeads / Cawug - MacRuby

2008-04-07 Thread Bob Frank
The Chicago CocoaHeads / Chicago Cocoa and WebObjects User Group (CAWUG) is holding our next meeting Tuesday, April 8th, at 7:00 PM at the Apple Store on Michigan Ave. Agenda: - Introductions Announcements - Chuck Remes on MacRuby - adjournment to O'Toole's

Re: Best Way® to test for existence of a rela tionsh ip

2008-04-07 Thread Mike Schrag
Using instanceof on a member of an inheritance hierarchy is a bad code smell. It is the code's ways of telling you that your design is wrong. IMO. I was going to say in my original that instanceof is a code smell, also, actually, but we disagree on the level of ugliness :) You're just

Re: Best Way® to test for existence of a rela tionsh ip

2008-04-07 Thread Chuck Hill
On Apr 7, 2008, at 8:45 AM, Ken Anderson wrote: Using instanceof on a member of an inheritance hierarchy is a bad code smell. It is the code's ways of telling you that your design is wrong. IMO. Almost as bad as using case statements! (doh!) Case statements are right out! Chuck

Re: Best Way® to test for existence of a rela tionship

2008-04-07 Thread Alexander Spohr
Fetch only ManufacturedParts. Don’t use the relationship to Parts (if that’s what you do) to get the NSArray. Either create a relationship to ManufacturedParts or fetch them using a qualifier. Iterating over a mixed NSArray wanting only one special class is bad design. Filter it before

Re: Best Way® to test for existence of a rela tionsh ip

2008-04-07 Thread Chuck Hill
On Apr 7, 2008, at 8:45 AM, Mike Schrag wrote: Using instanceof on a member of an inheritance hierarchy is a bad code smell. It is the code's ways of telling you that your design is wrong. IMO. I was going to say in my original that instanceof is a code smell, also, actually, but we

Re:[SOLVED] ERXMigration Problem with Multiple Models

2008-04-07 Thread Aleksey Novicov
I updated Wonder using last night's build, and it does in fact fix the exception I was seeing. Thanks again Mike. Aleksey On Apr 6, 2008, at 6:52 PM, Aleksey Novicov wrote: Thanks Mike. Where is the signup for the Wonder list? I do have a third model for accessing legacy data in a

Re: Best Way® to test for existence of a rela tionship

2008-04-07 Thread David Avendasora
You know, I was hoping to avoid the whole question if the domain was actually well-modeled or not, but with such dispersions cast on my flawless modeling skills, I must respond! :-P I have 2 types of Parts. One purchased from an outside vendor (RawMaterial), and ones that are manufactured

Re: File name issue

2008-04-07 Thread Chuck Hill
On Apr 7, 2008, at 9:17 AM, Yury Peskin wrote: Hello list, I'm having a problem with the file download. I'd like to be able to have the name of the file show up in the save as box, but right now I'm getting the webobjects form id instead. This is on any windows browser: Firefox, or IE 7.

RE: File name issue

2008-04-07 Thread Yury Peskin
Thanks Chuck. It works as expected. Yury Peskin Director of IT Services Cycle Software Services 8711 Lyndale Ave S. Bloomington, MN 55420 -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of Chuck Hill Sent: Monday, April 07, 2008 11:50 AM To: Yury Peskin

Re: Best Way® to test for existence of a rela tionship

2008-04-07 Thread Chuck Hill
On Apr 7, 2008, at 9:02 AM, David Avendasora wrote: You know, I was hoping to avoid the whole question if the domain was actually well-modeled or not, but with such dispersions cast on my flawless modeling skills, I must respond! :-P :-) I have 2 types of Parts. One purchased from an

Development vs Deployment Error

2008-04-07 Thread jeremy_rosenberg
I'm experimenting with ERRest and I got the following error: You attempted to create an unsafe request handler when you were not in development mode! Which is a good thing as I understand it from reading the API. But I am just testing and running it from Intellij. Is there a flag I am

Re: Development vs Deployment Error

2008-04-07 Thread Chuck Hill
Hi Jeremy, I have not used it, but I would guess the standard Wonder property is what you want: er.extensions.ERXApplication.developmentMode=true Chuck On Apr 7, 2008, at 10:29 AM, [EMAIL PROTECTED] wrote: I'm experimenting with ERRest and I got the following error: You attempted to

Re: Development vs Deployment Error

2008-04-07 Thread Mike Schrag
If you're using ERXApplication it should know automatically (from a param WOLips sets). If you're not, you need to set the property: er.extensions.ERXApplication.developmentMode=true ms On Apr 7, 2008, at 1:29 PM, [EMAIL PROTECTED] wrote: I'm experimenting with ERRest and I got the

Re: Best Way® to test for existence of a rela tionship

2008-04-07 Thread David Avendasora
On Apr 7, 2008, at 1:23 PM, Chuck Hill wrote: I have 2 types of Parts. One purchased from an outside vendor (RawMaterial), and ones that are manufactured (ManufacturedPart). A ManufacturedPart is made up of any number of component Parts. These component Parts can be _either_ a

Re: Best Way® to test for existence of a rela tionship

2008-04-07 Thread Alexander Spohr
What are the other differences between RawMaterial and ManufacturedPart? Wouldn’t it be enough to just flag the RawMaterial ones as such and just have one class for both? atze Am 07.04.2008 um 18:02 schrieb David Avendasora: You know, I was hoping to avoid the whole question if the

Re: stateless component

2008-04-07 Thread Tonny Staunsbrink
Hi Pierre and Chuck Could you give an example of what a warning log messsage should look like? /Tonny On Fri, Apr 4, 2008 at 3:00 AM, Mr. Pierre Frisch [EMAIL PROTECTED] wrote: May be we should log a warning for this? Pierre -- Pierre Frisch [EMAIL PROTECTED] On Apr 3, 2008, at 10:39,

Re: stateless component

2008-04-07 Thread Chuck Hill
pageWithName called for stateless com.foo.bar.SomePage, new instance being created. Chuck On Apr 7, 2008, at 12:38 PM, Tonny Staunsbrink wrote: Hi Pierre and Chuck Could you give an example of what a warning log messsage should look like? /Tonny On Fri, Apr 4, 2008 at 3:00 AM, Mr.

Re: Best Way® to test for existence of a rela tionship

2008-04-07 Thread David Avendasora
Unfortunately, no. There's _lots_ of differences. There are a number of attributes that they share, but they each have completely different business logic for deriving those values, and they each have attributes that are unique to themselves that would make no sense to have on the other.

ERXRestEntityDelegate

2008-04-07 Thread jeremy_rosenberg
Thanks Mike and Chuck for your quick responses to my development flag question. I got the test running and it's pretty slick. Now I want to do it right. Looking at the API I understand that I need to create an Authentication Delegate and an Entity Delegate (at least) and the documentation is

Re: ERXRestEntityDelegate

2008-04-07 Thread Mike Schrag
This one should be on the Wonder list, but: Is that a class that extends ERXStandardRestEntityDelegate? Yes I'm confused because the methods in ERXStandardRestEntityDelegate appear to require an EOEntity be passed in, but the name PersonRestEntityDelegate implies that it only handles the