Re: Actions from D2W pages

2009-12-12 Thread Mark Wardle
I've created my own custom look that removes the edit and inspect actions on a list page in favour of using a pagecontroller. I subclassed the erdcontrollerbutton to redo the list of actions as an unordered list of list suitable for css styling and it works well. I didn't then need to have

Re: JUnit4 testing of EOs: InvocationTargetException on subsequent runs

2009-12-12 Thread Q
On 11/12/2009, at 6:34 PM, Paul Hoadley wrote: On 11/12/2009, at 4:41 PM, Q wrote: I ran into this recently too. It seemed to resolve itself after I did the following: 1. Update wonder 2. Ensure all tests classes that use EOF inherit from ERXTestCase I'm somewhat of a JUnit novice:

JUnit test method generation

2009-12-12 Thread Ramsey Lee Gurley
Hi all, I'm wondering if there is an easier way to generate a JUnit test method stub for a test class that already exists. Let's say I have a class Foo with method bar(). When I generate the JUnit test FooTest in eclipse, I can select the methods and generate the source stub for testBar()

Re: JUnit test method generation

2009-12-12 Thread Ray Kiddy
On Dec 12, 2009, at 8:14 AM, Ramsey Lee Gurley wrote: Hi all, I'm wondering if there is an easier way to generate a JUnit test method stub for a test class that already exists. Let's say I have a class Foo with method bar(). When I generate the JUnit test FooTest in eclipse, I can

Re: JUnit test method generation

2009-12-12 Thread Ramsey Lee Gurley
On Dec 12, 2009, at 7:02 PM, Ray Kiddy wrote: On Dec 12, 2009, at 8:14 AM, Ramsey Lee Gurley wrote: Hi all, I'm wondering if there is an easier way to generate a JUnit test method stub for a test class that already exists. Let's say I have a class Foo with method bar(). When I

Re: JUnit test method generation

2009-12-12 Thread Katya Yurukova
Hi Ramsey, You should try the moreUnit plug-in for Eclipse. It is capable of adding single method stubs for already existing test classes. It needs a bit of adjustment so it can find your test classes, but if you have some naming convention for your test classes you should be OK. Here's