[weewx-user] Re: Installed extension and edited config, but still shows simulator

2019-10-14 Thread gjr80
The reason you cannot find any reports is that none are being produced, you need to look back earlier to see why. These lines indicate that WeeWX is saving something to the database: Oct 14 14:05:17 raspberrypi weewx[8036]: manager: Added record 2019-10-14 14:05:00 MDT (1571083500) to database

[weewx-user] Re: Installed extension and edited config, but still shows simulator

2019-10-13 Thread gjr80
Never said the station wasn’t producing data. You asked why ‘Simulator’ is still being shown, it is simply a symptom of WeeWX not receiving data from the driver. Gary -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe from this

[weewx-user] Re: Installed extension and edited config, but still shows simulator

2019-10-13 Thread gjr80
You can ignore the 'Simulator' web page, it is an old page generated from when you were running the simulator. It is clear from the log WeeWX is using the weatherflow driver. WeeWX is not receiving any data from the driver so hence no archive records are produced and hence no reports being

[weewx-user] Re: Windchill stored as heatindex

2019-10-13 Thread gjr80
windchill and heatindex are only available in the LOOP2 loop packets and LOOP2 support will not be available until v4.0. Under 4.0 if you set WeeWX to use LOOP2 packets and set record_generation = software under [StdArchive] in weewx.conf you should be able to get heatindex and windchill from

[weewx-user] Re: MaxSolarRad (from pyephm) is not alligned with Solar-Rad from my Weatherstation

2019-10-13 Thread gjr80
Hi, Your station has a sensor that reports illuminance in lux and the fineoffset driver approximates solar insolation using a simple linear multiplier. From the comments in fousb.py: Illuminance and Radiation The 30xx stations include a sensor that reports illuminance (lux). The conversion

[weewx-user] Re: Windchill stored as heatindex

2019-10-13 Thread gjr80
Hi, Actually what you are seeing is not heatindex being stored as windchill but rather heatindex and windchill being set to outTemp. I am not intimately acquainted with the NOAA heat index and wind chill calculations (in Australia we tend to use apparent temperature) but you will find that

Re: [weewx-user] Import from Weathercat

2019-10-12 Thread gjr80
Thank you, seems I did commit WeatherCat support back in April 2017 but it appears (for reasons unknown) to have been largely removed. I will have a look at resurrecting it (it shouldn’t be too hard) though it was a first cut so may still have some rough edges plus documentation is still to be

[weewx-user] Import from Weathercat

2019-10-12 Thread gjr80
Hi, I recall doing some work with WeatherCat log files and wee_import at home, but I don’t recall ever pushing anything to the WeeWX repo. I had a quick look just now and I can find nothing. Can you point me to the information that makes you believe wee_import can import WeatherCat data. Gary

[weewx-user] Re: Sunshine Time

2019-10-12 Thread gjr80
If you must modify the code then yes that will do what you want provided there is no min_sunshine setting in weewx.conf. Gary -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe from this group and stop receiving emails from it, send

[weewx-user] Re: Sunshine Time

2019-10-12 Thread gjr80
The single [ ] tell you it needs to be its own top level stanza. Easiest thing is to put it at the end of the file. Gary -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe from this group and stop receiving emails from it, send an

[weewx-user] Re: Sunshine Time

2019-10-12 Thread gjr80
So did you put the following in weewx.conf: [Radiation Days] min_sunshine = 200 then save weewx.conf and restart WeeWX? Why do you think it is not working? The author gives you a means to set the threshold value in weewx.conf rather than modifying code. Try setting debug = 1 and see what

[weewx-user] Temperature probe plugged into VP2 UV socket

2019-10-11 Thread gjr80
Hi, Interesting project, I’ll make no comment on accuracy/usefulness (what happens for negative temperature or temperatures off the UV scale for example), guess some testing and development will show one way or another. As for your questions these can be easily done, depending on exact

Re: [weewx-user] Re: minmax and maxmin with span killing page?

2019-10-10 Thread gjr80
Whilst it is true that the report_timing option only works down to the report level (ie it cannot discriminate between templates) this is easily overcome with a little lateral thinking. Duplicate the skin (with a

[weewx-user] Re: Unit conversion rule in conf file

2019-10-10 Thread gjr80
The other side of the coin is the actual tag that is used in the template. For example, $current.windSpeed will show the current archive record wind speed formatted/converted as per weewx.conf and skin.conf but $current.windSpeed.knot will always display the current archive record wind speed

[weewx-user] Re: New Davis2 weewx install............no data from last year from the dongle

2019-10-08 Thread gjr80
uld store at least a year of data or two. > > > On Tuesday, October 8, 2019 at 8:31:01 PM UTC-5, gjr80 wrote: >> >> Hi, >> >> By 'dongle' I presume you mean one of the Davis data loggers. If so the >> logger has a fixed memory and stores archive record

[weewx-user] Re: New Davis2 weewx install............no data from last year from the dongle

2019-10-08 Thread gjr80
Hi, By 'dongle' I presume you mean one of the Davis data loggers. If so the logger has a fixed memory and stores archive records in a round robin fashion (ie once memory is full the oldest record is overwritten with the newest). How long a history you can store depends on your archive

[weewx-user] Re: wee_import PWS station not found.

2019-10-08 Thread gjr80
Hi, Sorry for the tardy reply. You are doing nothing wrong, the released versions of WeeWX do not support importing from WU since WUs changes earlier this year. I have updated wee_import to import from WU using an API key; however, that change will not be rolled out until WeeWX v4.0 is

[weewx-user] weewx barmeter offset

2019-10-05 Thread gjr80
Hi, The StdCalibrate service (http://weewx.com/docs/usersguide.htm#StdCalibrate) will allow you to apply corrections to fields. Though if as you say the issue is your console displays a different pressure it may be that your console is displaying one of the three available ‘pressures’

[weewx-user] weewx barmeter offset

2019-10-05 Thread gjr80
Hi, The StdCalibrate service (http://weewx.com/docs/usersguide.htm#StdCalibrate) will allow you to apply corrections to fields. Though if as you say the issue is your console displays a different pressure it may be that your console is displaying one of the three available ‘pressures’

Re: [weewx-user] Bash: get current weather data

2019-10-05 Thread gjr80
As usual the documentation is your friend. Have a look at the ‘Where to find things’ section (http://weewx.com/docs/usersguide.htm#Where_to_find_things) in the User’s Guide. Gary -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe

[weewx-user] new install 3.9 import 2.6.1

2019-10-04 Thread gjr80
Hi, Am sure Tom will come along with some succinct wise words but in the interim I would say it depends. There was a fundamental change in database structure (and hence some key portions of the source code) between version 2 and version 3. You will likely find the upgrade process is

[weewx-user] Re: Max Temp ClientRaw Node Red Dashboard/

2019-10-02 Thread gjr80
Interesting, I am looking at your node red dashboard, Belchertown main page and realtime clientraw.txt at 5:30am 3 October your time and they all agree in terms of day min and max outTemp. When I look at your clientraw.txt (link from your first post) it updates every 5 minutes, is that link now

[weewx-user] Re: Timestamps in import data

2019-10-02 Thread gjr80
Hi, Provided (1) you have a single field in your CSV data that is consistently formatted in local time and (2) you define an appropriate format string for your CSV date-time data (the raw_datetime_format config option) in your import config file wee_import should be able to decode the CSV

[weewx-user] Re: Max Temp ClientRaw Node Red Dashboard/

2019-10-02 Thread gjr80
Thanks. That gives me enough to work on. There is definitely an issue with the realtime clientraw; not too many places have a daytime max of 64C which is what I saw in your clientraw.txt last night. Gary On Thursday, 3 October 2019 00:42:33 UTC+10, Andy Hudson-Smith wrote: > > I am using

[weewx-user] Re: How to change from simulator to a station

2019-10-02 Thread gjr80
Chances are the user account you are using when editing the file does not have write access to the file. You can either change the permissions on the file or run your editor using sudo so that you have privileged access. Probably worthwhile seeking out a little bit of basic Linux training, this

[weewx-user] How to change from simulator to a station

2019-10-02 Thread gjr80
Actually, you may find that FineOffsetUSB is not presented in the list of available drivers. If that is the case it is likely that the python USB library is not installed. Exit from wee_config and install the python USB library using the following (assuming a Debian based system): $ sudo

[weewx-user] How to change from simulator to a station

2019-10-02 Thread gjr80
Hi, It’s a fairly straightforward process, especially if using SQLite for your database: 1. Stop WeeWX 2. Move or delete your database file, for a default install it will be /home/weewx/archive/weewx.sdb or /var/lib/weewx/weewx.sdb 3. Run the wee_config utility

[weewx-user] Re: Max Temp ClientRaw Node Red Dashboard/

2019-10-02 Thread gjr80
Ok, thanks Andy. Been a while since I put together the core of weewx-clientraw, I just had a quick look and didn’t see an obvious issue. Thought it could have been an incorrect C to C or F to F conversion but that doesn’t appear to be the case. Will look into it. A couple of things, what unit

[weewx-user] Re: Max Temp ClientRaw Node Red Dashboard/

2019-10-01 Thread gjr80
ension <https://github.com/gjr80/weewx-realtime_clientraw> or the clientraw portion of WeeWX-WD <https://bitbucket.org/ozgreg/weewx-wd/wiki/Home> or something else? Gary On Tuesday, 1 October 2019 23:06:09 UTC+10, Andy Hudson-Smith wrote: > > Afternoon - i have a test node red

[weewx-user] Re: Install basic report in Weewx

2019-10-01 Thread gjr80
Hi, Comments below: Gary On Wednesday, 2 October 2019 03:50:12 UTC+10, Harry Nieuwdorp wrote: > > 1- Command not found. Made directories myself. > home/pi/Weewx/Examples and home//pi/Weewx/Skins > The ls command was not found? Odd. Could you please post screen (text) captures showing the

Re: [weewx-user] Multiple Data Bindings

2019-10-01 Thread gjr80
Maybe it's just my brain, but when I first read the OP I thought the question was along the lines of dual storing of archive data rather than reporting/plotting from multiple archives. Might be handy if the OP clarified. Gary On Wednesday, 2 October 2019 09:09:19 UTC+10, Thomas Keffer

[weewx-user] Re: WeeWX doesnt run in daemon or startup after reboot - any help?

2019-09-30 Thread gjr80
Something is not right. WeeWX was started but then did nothing: Oct 1 16:02:20 raspberrypi kernel: [ 366.572146] rpi_firmware_get_throttled: 4 callbacks suppressed Oct 1 16:02:20 raspberrypi kernel: [ 366.572153] Voltage normalised ( 0x) Oct 1 16:02:34 raspberrypi kernel: [

[weewx-user] Re: Install basic report in Weewx

2019-09-30 Thread gjr80
Hi, Does the directory home/pi/Weewx/Examples/basic exist and what are its contents? Try using the following command: $ ls -ail home/pi/Weewx/Examples/basic What output do you see? If i understand your weewx.conf question correctly you cannot make any changes to weewx.conf. There are a

[weewx-user] Re: WeeWX doesnt run in daemon or startup after reboot - any help?

2019-09-30 Thread gjr80
Thanks. Starting to reach the limits of my expertise but I don't think there is anything wrong with the /etc/init.d/weewx script; rather I think there is some other fundamental problem. The run script is identical to the distributed Debian based version and since you can start and stop WeeWX

[weewx-user] Re: Best way to get available cheetah variables

2019-09-27 Thread gjr80
Unfortunately there is no single link (largely because the answer is 'it depends'). Firstly, the Archive Types appendix in the Customisation Guide will tell you what fields you have in your archive (provided you are using the default

[weewx-user] Re: image caching problem with Chrome

2019-09-23 Thread gjr80
Hi, Reports are processed in the order listed in weewx.conf under [StdReport], have a look under [StdReport], is [[RSYNC]] before or after [[SeasonsReport]]? Based on the log extract provided I am guessing it is before. If so try moving then entire [[RSYNC]] stanza to be after (the entire)

Re: [weewx-user] Re: Importing from cumulus give a python error

2019-09-23 Thread gjr80
gt; will need to split the import as you said. As for the version of weewx it's > 3.9.2. I don't mind changing code in scripts of weewx either i'm a > programmer as well I just don't know python (yet). > > Thanks for the help. > > Hyrules > > On Sun, Sep 22, 2019 at 11:25

[weewx-user] Re: Importing from cumulus give a python error

2019-09-22 Thread gjr80
records, so if your historical data later changes to say a five minute interval you would need to split your imports). Gary On Monday, 23 September 2019 12:16:38 UTC+10, gjr80 wrote: > > Hi, > > No you are not missing anything, wee_import is expecting there to be more > fields in y

[weewx-user] Re: Importing from cumulus give a python error

2019-09-22 Thread gjr80
Hi, No you are not missing anything, wee_import is expecting there to be more fields in your Cumulus log file than you currently have. I think I see why and a way ahead, just going to take a day or two to put together an updated Cumulus import module for wee_import. I trust you are using

[weewx-user] Re: WeeWX doesnt run in daemon or startup after reboot - any help?

2019-09-20 Thread gjr80
OK, still seems to be some unusual output; I have never seen the entry: Sep 20 11:17:10 raspberrypi systemd[1]: Started Daemon to control my Weewx weather station. plus WeeWX does not normally log the following, that looks more like the output from running WeeWX directly: Sep 20 11:17:11

[weewx-user] Re: Field Meanings / Units

2019-09-20 Thread gjr80
Hi, The fields you are seeing are those that your driver emits, so apart from the obvious (eg outTemp etc) you need to look to your driver. For the Aercus 3083 I expect your are using the fousb driver. Have a look through the fousb driver file, it should be in

Re: [weewx-user] The odd miss with the WOW upload

2019-09-20 Thread gjr80
Almost sounds like that despite the first upload appearing to time out it actually takes and the second and subsequent uploads are deemed too frequent based upon the first attempted upload. Perhaps a few laid off WU employees have moved across the Atlantic? :) Gary On Saturday, 21 September

Re: [weewx-user] day is out of range for month

2019-09-19 Thread gjr80
Just get rid of it! Problem solved :) Gary On Friday, 20 September 2019 10:30:34 UTC+10, Thomas Keffer wrote: > > Damn. I just realized we have the same problem with years. Quick, what is > 2016-02-29 minus one year? > -- You received this message because you are subscribed to the Google

[weewx-user] Re: WeeWX doesnt run in daemon or startup after reboot - any help?

2019-09-19 Thread gjr80
OK, so WeeWX runs fine, the issue is purely one of WeeWX not starting after a reboot. So was that log extract the startup of WeeWX as part of a reboot? I'm guessing not if your problem is that WeeWX does not start after a reboot. What is in the log on reboot? Might also help to know what

Re: [weewx-user] day is out of range for month

2019-09-19 Thread gjr80
On Friday, 20 September 2019 02:07:37 UTC+10, p q wrote: > > Might as well set Pi=3 while you're at it > > (sarcasm) > > Seriously. Please don't set month=30 days. It won't end well. > > Well I guess we need to standby for complaints about the 'month' plots... Gary -- You received this message

Re: [weewx-user] day is out of range for month

2019-09-19 Thread gjr80
On Thursday, 19 September 2019 23:00:20 UTC+10, Thomas Keffer wrote: > > On Wed, Sep 18, 2019 at 11:37 PM gjr80 > > wrote: > >> That aside, whether you call it a bug or not I don't think we should have >> a tag that when you give it an allowed value/parameter

[weewx-user] Re: WeeWX doesnt run in daemon or startup after reboot - any help?

2019-09-19 Thread gjr80
Hi, Regards your daemon problem, have you been able to run WeeWX directly ? If not then you need to address that first, otherwise the best place to start is by posting the log from when WeeWX attempts to start. Have a look at the Help!

Re: [weewx-user] day is out of range for month

2019-09-19 Thread gjr80
I had a similar issue with WeeWX-WD some years back, the Saratoga templates needed to display some observation (temp or rain - can't remember) for the same time past month. To be honest I can't remember what I had it return for 'problem' dates, it certainly was not None or some other undefined

[weewx-user] Re: cheetahgenerator: Generate failed with exception ''

2019-09-17 Thread gjr80
On Tuesday, 17 September 2019 23:48:50 UTC+10, Cat22 wrote: > > BTW the link to github on the weewx extensions page is broken or outdated, > it 404's > Interesting, the link worked yesterday arvo when I made the 2.7.4 extension available and I just checked again now and the wiki link works as

[weewx-user] Re: cheetahgenerator: Generate failed with exception ''

2019-09-17 Thread gjr80
On Tuesday, 17 September 2019 15:04:35 UTC+10, Cat22 wrote: > > Well i seem to have an older copy, are there any relevant changes? > > Heaps :) , the most significant being a number of changes to harden the template so it can handle obs that are None. I would be updating to the latest version.

[weewx-user] Re: cheetahgenerator: Generate failed with exception ''

2019-09-14 Thread gjr80
That is the CSS file, we are interested in gauge-data.txt.tmpl, this link is to the current version https://raw.githubusercontent.com/mcrossley/SteelSeries-Weather-Gauges/master/weather_server/WeeWX/gauge-data.txt.tmpl Gary -- You received this message because you are subscribed to the Google

[weewx-user] Re: cheetahgenerator: Generate failed with exception ''

2019-09-14 Thread gjr80
Interesting, because humidity going to zero does not fit the error. Even humidity going to None should not cause the cheetah error you are seeing (provided you are using the latest version of the template). Will be interesting to see how things go when you replace the sensor. Gary -- You

[weewx-user] Re: cheetahgenerator: Generate failed with exception ''

2019-09-11 Thread gjr80
Hi, These sorts of template/Cheetah errors can be difficult to pinpoint and time consuming to track down. That being said the error message gives us a couple of clues. The error message indicates there is a an expression somewhere in the gauge-data.txt.tmpl that is trying to calculate the

[weewx-user] Caught unrecoverable exception in generator ImageGenerator

2019-09-10 Thread gjr80
Hi, Would help to see more of the log in the lead up to the error (so we know which skin caused the error). Can you also post the [StdReport] section of weewx.conf (you can use wee_debug (http://weewx.com/docs/utilities.htm#wee_debug_utility) for this if you want) but make sure you check for

[weewx-user] update barometric pressure statistics in weewx 3.1.0

2019-09-08 Thread gjr80
Dropping the daily summaries is generally taken to mean using one of the WeeWX utilities to drop the daily summaries rather than using SQL directly. The current utility used to manage the database is wee_database; however, in v3.1.0 the utility is wee_config_database. Try running

Re: [weewx-user] Rainfall YTD only showing value since weewx has been installed

2019-09-05 Thread gjr80
Don’t know what Belchertown does, but depending on how the wview to WeeWX port occurred I thought it might be a case of incomplete daily summaries. Stopping WeeWX and using wee_database (http://weewx.com/docs/utilities.htm#wee_database_utility) to drop then rebuild the daily summaries might

[weewx-user] Re: wee_import PWS station not found.

2019-08-30 Thread gjr80
Hi, The wee_import WU module has not yet been updated to use the new WU API. Give me a few days and I should have the new API incorporated and it should work then. Gary On Saturday, 31 August 2019 04:30:37 UTC+10, Clint Parrish wrote: > > I got a different error. Here is the output. Not

Re: [weewx-user] Re: No Updates on new system

2019-08-26 Thread gjr80
The preferred method to change the archive interval is to use the wee_device utility with the —set-interval action (http://www.weewx.com/docs/hardware.htm#vantage_archive_interval46). Make sure you stop WeeWX before using wee_device. Gary -- You received this message because you are

[weewx-user] Re: Image plots only have tiny dots

2019-08-26 Thread gjr80
Hi, Have a read of Dots in plots in the User's Guide . Gary On Tuesday, 27 August 2019 08:51:58 UTC+10, Larry Lewis wrote: > > We moved and installed a new weather station at our new home, when the >

Re: [weewx-user] Re: No Updates on new system

2019-08-26 Thread gjr80
A default install will see CWOP posts made every archive interval or 600 seconds, whichever is the greater. This period can be changed using the post_interval config option under [StdRESTful] [[CWOP]] in weewx.conf but it cannot be reduced to a value less than your archive interval. Chances

Re: [weewx-user] ET Evapotranspiration / Evaporation - calculation

2019-08-20 Thread gjr80
Also be aware that ET is not calculated for loop packets, only archive records. So services using loop only data will not see calculated ET. Gary -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe from this group and stop receiving

Re: [weewx-user] Re: radiation and uv graph query

2019-08-20 Thread gjr80
Have a look in the relevant skin.conf under [ImageGenerator] and then look at the aggregate_type and aggregate_interval config options under each [[ ]] stanza. By default the plots for week and longer periods plot an average (set by aggregate_type config option) calculated over the

[weewx-user] Re: te923 driver rain calculation is missing data

2019-08-20 Thread gjr80
Hi, Andrew is right you are going to have to look at the TE923 driver. However, I think what you need to see is what the driver is picking up from your station and how this data is decoded (WeeWX will just be processing the data fed by the driver so you probably won’t find out too much more

[weewx-user] Re: Davis Vantage Vue - probably shouldn't have cleared memory

2019-08-18 Thread gjr80
Apologies, I missed the ‘not downloading data’ part of the issue and focussed on the template error. The lack of data from the station will be the root cause of the template error. You are correct that the dump will dump archive records from logger to archive but that won’t fix the problem. Do

[weewx-user] Re: Update of rain data to wunderground

2019-08-18 Thread gjr80
Interesting. I just spent 10 minutes watching a Davis VP2 on WU using RF displaying and updating wind gust data. It also happened to be raining and rainfall data was updating albeit at a slower rate (as expected given a Davis does not update rainfall data as frequently as wind). The station

[weewx-user] Problem with Rain in Weewx.

2019-08-18 Thread gjr80
Hi, Suggest you put some logging into the modified driver you are using so you can see what is being read when. Likely unrelated but I get uneasy when loop interval == archive interval. Sooner or later you are likely to have an archive interval with no loop data. Shouldn’t really cause any

[weewx-user] Davis Vantage Vue - probably shouldn't have cleared memory

2019-08-18 Thread gjr80
Hi, What version of WeeWX are you running and have you modified /home/weewx/skins/Standard/index.html.tmpl? The error message indicates an error in /home/weewx/skins/Standard/index.html.tmpl involving a * (multiplication) but as far as I can tell /home/weewx/skins/Standard/index.html.tmpl

[weewx-user] Re: Update of rain data to wunderground

2019-08-15 Thread gjr80
Ok, so we can see that WeeWX is indeed sending RF updates to WU many times each archive period. What we can’t see is any non-zero rain values being sent (assume this is because it was not raining during the log extract - if it was raining we have a more fundamental data issue). What you should

[weewx-user] Wrong rain numbers on Weather Underground

2019-08-15 Thread gjr80
Hi, The units used in your database and reports are irrelevant when it comes to WU. Provided WeeWX was properly installed and your station is correctly configured for the rain collector size you are using everything should just work. The best way to troubleshoot most WU upload issues is to set

[weewx-user] Re: Update of rain data to wunderground

2019-08-15 Thread gjr80
The point of running Weewx directly was to see the loop and archive data that Weewx is processing and you can then reconcile this against what is appearing on WU. If you set debug=2 you will see the data posted to WU on the log. This was never going to fix anything, rathet if will provoke a

Re: [weewx-user] examples of skins - enhancement to registration

2019-08-14 Thread gjr80
Think this one has come up before, can't remember the outcome though (other than it doesn't exist). Not in a position to search just now. Gary -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe from this group and stop receiving

[weewx-user] Re: Installing WeatherCloud Extension - Error

2019-08-12 Thread gjr80
Could be any one of a number of things. Need to see the exact command being issued and the exact error message. Text based screen captures are best. Also what is the full path to the downloaded extension archive file. Gary -- You received this message because you are subscribed to the Google

Re: [weewx-user] Re: ws28xx: no backfill of values when contact to console is lost and regained

2019-08-07 Thread gjr80
Didn’t pickup on that. The ws28xx driver has no genArchiveRecords method, there is a comment in the driver to the effect that hardware record generation should not be implemented until archive records can be read at a faster rate than they are currently. Gary -- You received this message

[weewx-user] Re: ws28xx: no backfill of values when contact to console is lost and regained

2019-08-07 Thread gjr80
Not sure the WeeWX engine behaviour (backfill only requested during WeeWX startup/restart) will change, you probably have more chance of changing the driver behaviour. Regarding your loop data question. Unfortunately there is little that can be done if the station does not maintain the same

[weewx-user] Re: ws28xx: no backfill of values when contact to console is lost and regained

2019-08-07 Thread gjr80
If you call the ‘top of the hour’ archive records rogue records then yes they had a hand in preventing backfill, provided a restart occurred only those archive records stored in the station after the most recent ‘top of the hour’ archive record would be downloaded. Arguably though the reason

[weewx-user] Re: ws28xx: no backfill of values when contact to console is lost and regained

2019-08-07 Thread gjr80
Hi, The backfill behaviour you are seeing is expected behaviour for the current codebase, in a nutshell WeeWX only attempts to download historical records when WeeWX starts. Explanation. Drivers for stations that have the ability to store archive records may implement a genStartupRecords

Re: [weewx-user] Re: weewx only posts to db...no cheetah or images.

2019-08-05 Thread gjr80
Hmmm, this (perhaps) sounds like a recent issue where a user was having problems getting debug = 1 to take, seem to remember that user was using SDR as well. Unfortunately, searching google groups on this iPad is somewhat limited In capability (and convenience). Perhaps a wee_debug report

[weewx-user] Re: strange behavior with outtemp

2019-08-03 Thread gjr80
I cannot add anything further, since the issue was with a day minimum the problem almost certainly lay in the daily summaries. The fact the rebuild fixed it confirms this. Perhaps there was some obscure problem that a complete rebuild fixed but a day rebuild did not. At least it is working as

[weewx-user] Issue with: Weewx not starting when date is not current

2019-08-03 Thread gjr80
Just to take a step back here, since v3.8.1 WeeWX should now wait until the system time is greater than the creation time of the weewx.conf file before starting up. If this is not what is happening please let us know. Gary -- You received this message because you are subscribed to the Google

[weewx-user] Re: remote directory

2019-08-03 Thread gjr80
Apologies, was out. Good that you have it sorted Miguel. Just to go back to your previous post, there is only one HTML_ROOT but it can be set in many places, the location of the setting in the config hierarchy determines where that particular value is applied. You might like to read the section

[weewx-user] Re: remote directory

2019-08-03 Thread gjr80
What did you set HTML_ROOT to? /var/www/html/weewx/exfoliation? Gary -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe from this group and stop receiving emails from it, send an email to weewx-user+unsubscr...@googlegroups.com. To

[weewx-user] Re: remote directory

2019-08-03 Thread gjr80
OK, so under [[FTP]] uncomment the HTML_ROOT setting and set it to the directory that contains the generated exfoliation files. Save weewx.conf and restart Weewx. Gary -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe from this

[weewx-user] Re: remote directory

2019-08-03 Thread gjr80
Hi, I know you said ftp but are you ftp’ing to another server or are the files generated and saved/copied on the same server as WeeWX? If the former it should be a simple case of altering some config settings under the [StdReport] [[FTP]] stanza in weewx.conf, if the latter then some skin

[weewx-user] Re: strange behavior with outtemp

2019-08-02 Thread gjr80
When you say “it didn’t work for you” do you mean using —rebuild-daily only (ie no —drop-daily first) or using —today? I don’t know why, rebuilding just the affected day(s) is useful for retaining loop high/low value and time stamps for unaffected days. Also, sometimes the daily summary tables

[weewx-user] strange behavior with outtemp

2019-08-01 Thread gjr80
Hi, High/low data for days, weeks, months etc usually comes from the daily summaries. If you modify the archive to remove/fix erroneous data you need to rebuild the daily summaries using wee_database with the —rebuild-daily option (http://weewx.com/docs/utilities.htm#Action_--rebuild-daily).

[weewx-user] Re: special character support

2019-08-01 Thread gjr80
Forgot to add, there should be no sensitive info in the [StdReport] stanza or skin.conf but do check before posting. Gary -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe from this group and stop receiving emails from it, send an

[weewx-user] Re: special character support

2019-08-01 Thread gjr80
My mistake, too used to index.html.tmpl. The correct setting is of course the name of the template file being used. One more thought, there could be an override coming from weewx.conf. Could you post the [StdReport] stanza from weewx.conf as well as skin.conf from the neowx skin. Gary -- You

Re: [weewx-user] Re: Porting data from WVIEW

2019-07-31 Thread gjr80
Hmmm, seems your wview database is indeed different. You might need some input from Tom or another wview user. I was under the impression the wview database contained a table named ‘archive’ that is identical in structure to the archive table in the WeeWX database. Many wview users have changed

Re: [weewx-user] Re: Porting data from WVIEW

2019-07-31 Thread gjr80
Ok, so wee_ debug says there is only 54 odd days of data in your archive, expect these records are the history downloaded from the logger. So we are not going to get any reports using your historical wview data from that database. Not convinced this a schema issue. Just to step back a bit,

[weewx-user] WeeWX on Raspberry Pi

2019-07-31 Thread gjr80
Hi, First up did you restart WeeWX after changing weewx.conf. If not try that. If so then edit weewx.conf, set debug = 1, save weewx.conf then restart WeeWX. Let WeeWX run for at least two archive periods and then post the log from restarting WeeWX until the two archive periods elapsed. Gary

[weewx-user] special character support

2019-07-31 Thread gjr80
Hi, In /etc/weewx/skins/neowx/skin.conf look for the line: template = index.html.tmpl under the [CheetahGenerator], it will probably be something like: [CheetahGenerator] [[ToDate]] [[[xx]]] template = index.html.tmpl Is there an

[weewx-user] Can i grab loop data in a shell script

2019-07-31 Thread gjr80
Robin, There is no practical way for your shell script to access loop data directly, best solution I can think of is to write a custom service bound to the NEW_LOOP_PACKET event that writes the required data to a text file that you then read as you currently do. The service will be very basic,

Re: [weewx-user] Re: Porting data from WVIEW

2019-07-31 Thread gjr80
Ok, a couple of more things to do/try. First run wee_debug and post the output here. Just make sure you check the wee_debug output for any sensitive info such as user names, passwords, keys etc before posting; wee_debug should obfuscate such info but it’s not perfect. The wee_debug report

Re: [weewx-user] Re: Porting data from WVIEW

2019-07-31 Thread gjr80
If just copying and renaming the archive database then you likely need to build/rebuild the daily summaries using wee_database (http://weewx.com/docs/utilities.htm#wee_database utility). Once done don't forget to delete all NOAA format reports to force generation of the older reports. Gary

[weewx-user] rain 10x

2019-07-26 Thread gjr80
Hi, I suggest that when you have some rain coming you run WeeWX in debug mode (debug = 1 in weewx.conf) and then post a log extract from when it was raining. That way we can see what data is being collected via SDR and how the packet is assembled so we can look at where the issue is. Gary --

Re: [weewx-user] Sunshine Time

2019-07-26 Thread gjr80
As for changing the W/m2 try setting the config option ‘y_label’ to an empty string, something like (untested): y_label = “” Gary -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe from this group and stop receiving emails from it,

Re: [weewx-user] Sunshine Time

2019-07-26 Thread gjr80
To change the bar colour try using the config option ‘fill_color’. The config option ‘color’ will set the outline colour of the bar. Gary -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe from this group and stop receiving emails

[weewx-user] Re: Customised logwatch

2019-07-26 Thread gjr80
I’m sorry but I don’t understand the confusion here. WeeWX ships with 3 logwatch files; 2 config files and a script. The script is what analyses the WeeWX log and produces the WeeWX logwatch report. The WeeWX installer does not ‘install’ the WeeWX logwatch files, rather the user must install

[weewx-user] Re: maxSolarRad not available

2019-07-26 Thread gjr80
In that case pyephem is either not installed or not installed properly (previous post re import seems to indicate the latter). Try uninstalling pyephem then install following the instructions in the User’s Guide (http://weewx.com/docs/setup.htm). Gary -- You received this message because you

[weewx-user] Re: maxSolarRad not available

2019-07-26 Thread gjr80
Given the maxSolarRad pre-requisites I still think we need to make sure pyephem is not somehow causing the calculation to be aborted (and set to None as a result). Is WeeWX producing the Standard or Seasons skin? If so is it publicly visible or are the extended sun properties (elevation,

  1   2   3   4   5   6   7   8   9   10   >