Re: [weewx-user] Re: Upgrade won't start

2016-07-28 Thread Thomas Keffer
Oops. I found the 'install' command. Does /home/weewx/skins/Rsync/skin.conf exist? How about the skin directory /home/weewx/skins? What are its contents? It looks like something got messed up in your skin subdirectory... -tk On Thu, Jul 28, 2016 at 5:18 AM, Thomas Keffer <tkef...@gmail.

Re: [weewx-user] Re: Upgrade won't start

2016-07-28 Thread Thomas Keffer
Did you do an "install" after the "build?" Haven't seen a SheevaPlug in a while! -tk On Thu, Jul 28, 2016 at 12:00 AM, lonehighway wrote: > Here is the log of the build, install, and attempted start, with the tail > log showing the previous stop and nothing new. I

Re: [weewx-user] Re: Apache is not showing /weewx on Ubuntu 16.04.1

2016-07-27 Thread Thomas Keffer
Mystery solved! Thanks, Matthew I've started issue #137 to track it. -tk On Wed, Jul 27, 2016 at 2:50 PM, mwall wrote: > On Wednesday, July 27, 2016 at 4:47:09 PM UTC-4, Tom Keffer wrote: >> >> I am not an apache expert

Re: [weewx-user] Re: Thank you!

2016-08-02 Thread Thomas Keffer
No donation asked for, nor expected. However, I am a big Mercy Corps supporter, and make lots of trips on their behalf. If you're feeling generous, make a donation to them! -tk On Tue, Aug 2, 2016 at 8:23 AM, jmltech wrote: > I agree!!! I

Re: [weewx-user] wee_device --info error

2016-08-01 Thread Thomas Keffer
Hard to say without seeing the log. I'm sure your laptop is plenty fast enough. -tk On Mon, Aug 1, 2016 at 10:01 AM, Dawei Zhang wrote: > I am using T440s Ubuntu 14.04 and Davis vintage pro2 > > T440s: > Processor / Chipset > CPUIntel Core i7 (4th Gen) 4600U / 2.1 GHz > Max

Re: [weewx-user] wee_device --info error

2016-08-01 Thread Thomas Keffer
?? This looks unlike any other log I have seen. What is it from? It's certainly nothing generated by weewx. What is in /var/log/syslog? -tk -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe from this group and stop receiving emails

Re: [weewx-user] Re: Davis Vantage Vue

2016-08-04 Thread Thomas Keffer
​You want Davis part #6510, available from Amazon , Ambient Weather , and other vendors. Throw the software away, keep the connector. It is grotesquely overpriced for

Re: [weewx-user] question on wind direction chart after upgrade to 3.5

2016-08-05 Thread Thomas Keffer
Setting wind direction to null when wind speed is zero is now done by the service StdWxCalculate. This way it is consistent across all drivers. Option ignore_zero_wind turns this behavior on or off. The default is true, so I have no explanation for why your experience would be any different.

Re: [weewx-user] Wind Graph with Wind Direction ?

2016-08-08 Thread Thomas Keffer
Unfortunately, the plotting engine does not support this. -tk On Mon, Aug 8, 2016 at 12:50 AM, 'Ralf Buck' via weewx-user < weewx-user@googlegroups.com> wrote: > hello > > my graph for wind show only degrees. > can i add the wind direction? > > > 360° (N) > 270° (W) > 180° (S) > 90° (E) > 0°

Re: [weewx-user] Re: Graphs with 2 different y-axis

2016-08-08 Thread Thomas Keffer
On Mon, Aug 8, 2016 at 12:51 AM, 'Ralf Buck' via weewx-user < weewx-user@googlegroups.com> wrote: > svg? have you a example? > are this graphics like in jqplot or highcharts? > > ​Exactly. -tk​ -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To

Re: [weewx-user] Missing wind vector data

2017-01-31 Thread Thomas Keffer
On Tue, Jan 31, 2017 at 8:11 AM, Gabriel Jackson wrote: > The setting was : > > ignore_zero_wind > > It was suggested on this very forum to set it to false to fix a wind speed > data N/A. > > Even after setting it true, the wind direction is N/A, wind speed is OK, > as

Re: [weewx-user] wunderground password or key ?

2017-02-04 Thread Thomas Keffer
Is there a difference? Why don't you try it? You can't hurt anything. -tk On Sat, Feb 4, 2017 at 4:16 PM, Ruben Navarro Huedo wrote: > My wu login? > Or my wu password used for login ? > > -- > You received this message because you are subscribed to the Google Groups >

Re: [weewx-user] Raspberry Pi and Vantage Pro2 ... not communicating properly

2017-02-06 Thread Thomas Keffer
Unfortunately, I am not an expert at this --- I regard hardware as a necessary evil to run software. :-) Here's the definitive guide to getting around the serial lock out problem: *A fix for the firmware v. 3.xx problem in Davis Instruments Corp. weather stations by Torkel M. Jodalen

Re: [weewx-user] Raspberry Pi and Vantage Pro2 ... not communicating properly

2017-02-06 Thread Thomas Keffer
I'm not sure what you're trying to do. Do you own a logger? If so, why would you want to use it to "pull the data out and convert to RS232 levels?" Why not just use it directly? If you don't own a logger, are you trying to avoid buying one by connecting your VP2 directly to the RPi via serial

Re: [weewx-user] Reading weewx.sdb file with Python program

2017-02-06 Thread Thomas Keffer
Simple typo. *con = lite.connect('weewx.sdb')* -tk On Mon, Feb 6, 2017 at 3:10 AM, Janez Kranjski wrote: > Noob question - I copied weewx.sdb file to temp folder on my Linux (so it > is not opened or accessible). > Then I tried simple Python program: > > *#!/usr/bin/python*

Re: [weewx-user] Re: windgust period

2017-02-05 Thread Thomas Keffer
Depends on the hardware and the setting of record_generation. If record_generation=hardware, and the hardware emits it, then that value is used. Otherwise, weewx calculates it as the average wind speed over the archive interval. -tk On Sun, Feb 5, 2017 at 11:16 AM, Eelco F

Re: [weewx-user] Re: Adding archive data to daily report

2017-02-05 Thread Thomas Keffer
The initializer for the TimespanBinder object takes an argument 'context', which is what formatting to use for time. The default is "current". Other options are "hour", "day", "week", "month", "year", and "rainyear". Choose one of those, depending on whether you are displaying an aggregate over a

Re: [weewx-user] Raspberry Pi and Vantage Pro2 ... not communicating properly

2017-02-06 Thread Thomas Keffer
Ah, I see. Unfortunately, I don't have any experience with the APRS logger, but I do recall hearing from a few other users who have one. For example, here is one thread on the topic. -tk On Mon, Feb 6, 2017 at 2:01 PM,

Re: [weewx-user] wunderground password or key ?

2017-02-05 Thread Thomas Keffer
It is almost surely the Weather Underground, but here is a way to check. Copy and paste the following URL into a browser: http://weatherstation.wunderground.com/weatherstation/updateweatherstation.php?action=updateraw=YOURSTATION=YOURPASSWORD=weewx-3.7.0a1=26.8=2017-02-02%2023%3A25%3A00 Then

Re: [weewx-user] Using WS2801 La Crosse. Why weewx reports windchill and heatindex the same as temperature?

2017-02-04 Thread Thomas Keffer
Wind chill kicks in only for temperatures less than 50F and wind speeds over 3mph. Ref: http://www.nws.noaa.gov/om/winter/windchill.shtml Heat index kicks in for temperatures above 80F and humidities above 40%. Ref: http://www.wpc.ncep.noaa.gov/html/heatindex_equation.shtml Otherwise, you get

Re: [weewx-user] wunderground password or key ?

2017-02-04 Thread Thomas Keffer
The password is your WU login. -tk On Sat, Feb 4, 2017 at 11:37 AM, Ruben Navarro Huedo wrote: > Hello again. > > Trying configure wunderground. > > What password must i use in weewx.conf? > My wundergroud login password or the Station Key ? > > A lot of thank's > > -- > You

Re: [weewx-user] Re: Adding archive data to daily report

2017-02-04 Thread Thomas Keffer
http://weewx.com/docs/customizing.htm#wee_reports -tk On Sat, Feb 4, 2017 at 12:03 PM, Thomas Carlin wrote: > I'm making pretty good progress on this, but it is slow going to > troubleshoot my extension script since I have to wait for the Cheetah > Generator to run.

Re: [weewx-user] Re: Missing index.html

2017-02-03 Thread Thomas Keffer
I've found that when trying to help people with limited English skills, it's best to have one person handle the exchange. Otherwise, the user has to follow a confusing mish-mash of solution paths. Matthew is on this one. -tk On Fri, Feb 3, 2017 at 8:24 AM, Andrew Milner

Re: [weewx-user] upgrading from 2.0 to 3.6

2017-01-22 Thread Thomas Keffer
And otherwise, it went OK? -tk On Sun, Jan 22, 2017 at 12:35 PM, tds wrote: > OK, I did the migration today. My weewx.sdb was about 74MB. It only took > the manager a bit over 10 minutes to finish the backfilling. The process > started at 22:13:07 and finished at

Re: [weewx-user] WRM300 barometer problem.

2017-01-23 Thread Thomas Keffer
Unfortunately, as far as we can tell, this is normal behavior for the WMR300. See the Hardware Guide . Version 3.7 will include a crude cache for pressure (no aging). You can download the driver

Re: [weewx-user] Write a program to display the days data

2017-01-23 Thread Thomas Keffer
I'm not sure quite what you mean "via the web," but assuming what you mean is you want to generate an HTML file, V3.7 will allow you to have direct access to individual records. For example, to create a table with the time and temperature of each record since midnight: #for record in

Re: [weewx-user] 3rd Party Database Access

2017-01-23 Thread Thomas Keffer
On Mon, Jan 23, 2017 at 3:20 PM, Louis De Lange wrote: > > 1. The meteotemplate database uses a type datetime primary key, rather > than unix epoch. I could not get addRecord to work in that circumstance so > I ended up using a getsql function to write the record to

Re: [weewx-user] Write a program to display the days data

2017-01-23 Thread Thomas Keffer
V3.7 is not out yet. No estimates when, but we're working on it. If you're the adventurous type, you can try cloning the 'development ' branch and give it a try, but there will be minimal (that is to say, no) support for it. -tk On Mon, Jan 23,

Re: [weewx-user] Write a program to display the days data

2017-01-23 Thread Thomas Keffer
Which suggestion? To use the code from the development branch? -tk On Mon, Jan 23, 2017 at 6:34 PM, Barton Phillips wrote: > I tried your suggestion but it does not work. Is there no way to get an > iterable object and get the fields (like outTemp) from it? I would

Re: [weewx-user] rxCheckPercent on Raspberry Pi

2017-01-24 Thread Thomas Keffer
I doubt it takes much more processing power to access the serial port on an RPi, than on any other machine --- the baud rates are pretty slow --- but, I could certainly be wrong. I have also had mysterious increases and decreases in my rxCheckPercent. There was one period a few weeks ago, when it

Re: [weewx-user] Re: UnicodeDecodeError: 'ascii' codec can't decode byte

2017-01-26 Thread Thomas Keffer
Put the line #encoding UTF-8 at the very top of navibar.inc and your problems will go away. Cheetah processes the files separately. Finding no UTF-8 directive in navibar.inc, it assumed that the file was in ASCII, not UTF-8, so it was unable to decode it. The #encoding directive tells it that

Re: [weewx-user] Re: attaching a raspberry Pi weather station to the weewx system

2017-01-30 Thread Thomas Keffer
> > > 2. The requirement for US units is because of weewx requiring US units. > The driver doesn't do any conversion, just passes the data through. That > might be a good enhancement to make. > > ​A weeWX driver can send data using US, METRIC, or METRICWX. It doesn't care which. It just has to be

Re: [weewx-user] How to show Rain only when there is rain

2017-01-30 Thread Thomas Keffer
#if $day.rain.sum.raw There's rain! #else No rain today. :-( #end if should do it -tk On Mon, Jan 30, 2017 at 3:36 PM, Barton Phillips wrote: > I want to show the rain only when there is rain. I tried > #if $day.rain.has_data > > #end if > > But that does

Re: [weewx-user] Missing wind vector data

2017-01-28 Thread Thomas Keffer
On Fri, Jan 27, 2017 at 8:11 PM, Gabriel Jackson wrote: > Running weewx on a C.H.I.P. Computer (Debian) and pulling data from a > Davis vantage vue. Wind speed seems off, but it registers, but wind > direction and vector graph are N/A. > > Tried wipe and re-pair,

Re: [weewx-user] Re: Davis Vantage Pro 2 - ethernet blues....

2017-01-28 Thread Thomas Keffer
Again, I don't own one of these, so I don't know the details, but I believe that by default it always tries to contact weatherlink. I don't think there is a setting on the console where you can switch off this communication. I think you have to do it through a browser. Any WLIP owners out there

Re: [weewx-user] Re: Davis Vantage Pro 2 - ethernet blues....

2017-01-27 Thread Thomas Keffer
I take it you have a Weatherlink IP logger? Have you disabled it from talking to the Davis Weatherlink site? Unfortunately, the way weewx is written, it is not possible to use weewx AND send data to the WL website. You must choose one or the other. To disable it, open a web browser, using the IP

Re: [weewx-user] Re: Davis Vantage Pro 2 - ethernet blues....

2017-01-27 Thread Thomas Keffer
When you say "I tried to connect via port 80" did you mean that you used a browser to go to http://172.20.100.40:80? Or something else? -tk On Fri, Jan 27, 2017 at 3:32 PM, wrote: > Thanks for the tip. The only device I have in addition to the Vantage Pro > 2 is the Davis

Re: [weewx-user] N/A at N/A on Current Weather Conditions page

2017-01-29 Thread Thomas Keffer
One way to do this would be to include the 'at' in the format string, then leave it out of the template. It would have to be included in the string used for formatting a None, *and* the normal formatting string. -tk On Sun, Jan 29, 2017 at 8:40 AM, Steve2Q wrote: > > Thanks,

Re: [weewx-user] A few newbie questions

2017-01-29 Thread Thomas Keffer
You need to change the archive interval on your VPro2. If you do not have a lot of data in your database yet, I would recommend deleting it and starting over. Otherwise, your database will have different archive intervals in it. -tk On

Re: [weewx-user] Re: UnicodeDecodeError: 'ascii' codec can't decode byte

2017-01-25 Thread Thomas Keffer
Unfortunately, I cannot replicate your problem. I used your index.html.tmpl file, and your skin.conf file, and things worked fine. For Cheetah to recognize that a template uses UTF-8, it must have an 'encoding' directive. You have one, but for some reason it is not recognizing it. ​Why, I don't

Re: [weewx-user] Re: Write a program to display the days data

2017-01-25 Thread Thomas Keffer
Good idea. I've taken to using the Wayback Machine for their old docs, which are so much better than what you can find on pythonhosted.org/cheetah or anywhere else. I'll try appealing to GitHub

Re: [weewx-user] Re: UnicodeDecodeError: 'ascii' codec can't decode byte

2017-01-26 Thread Thomas Keffer
> > > i think. that its not bad idea to put info that any file that work > with text must have this line > > Good idea. Included in commit 4edce9 ​ -tk -- You received this message because you are subscribed

Re: [weewx-user] N/A at N/A on Current Weather Conditions page

2017-01-27 Thread Thomas Keffer
See the docs, formatting option .string() . -tk On Fri, Jan 27, 2017 at 5:32 AM, Steve2Q wrote: > Hello: Some time ago, I made changes so that the Current Conditions will > display: * Undefined: T<80 F or RH<40%* for

Re: [weewx-user] UnicodeDecodeError: 'ascii' codec can't decode byte

2017-01-24 Thread Thomas Keffer
You need to include more of the log: we can't see what file it was working on. -tk On Tue, Jan 24, 2017 at 11:27 AM, 'pterodaktil' via weewx-user < weewx-user@googlegroups.com> wrote: > Hi. > I try repair my weather station. Last time i used weewx 2.7 > Now i intalled last weewx, and put

Re: [weewx-user] Re: UnicodeDecodeError: 'ascii' codec can't decode byte

2017-01-25 Thread Thomas Keffer
? What result did you get for sys.getdefaultencoding()? So, the original skin worked? What happened when you put a single UTF-8 character in it? Adding setdefaultencoding('UTF8') did not help? -tk On Wed, Jan 25, 2017 at 10:39 AM, 'pterodaktil' via weewx-user < weewx-user@googlegroups.com>

Re: [weewx-user] Re: FTP upload period

2017-01-29 Thread Thomas Keffer
On Sun, Jan 29, 2017 at 3:36 AM, Andrew Milner wrote: > It IS based on the archive period. If you want to update every 10 minutes > then you need to: > a) stop weewx > b) edit weewx.conf and change archive_interval (in SECONDS) in the > stdArchive section > c)

Re: [weewx-user] Re: wind gust direction

2017-02-19 Thread Thomas Keffer
It's certainly possible to do, but only by writing a search list extension. The reason is technical. A tag like $week.wind.gustdir actually uses the *daily summaries*, a set of precompiled statistics, stored in some database tables. One of the statistics is gustdir, the direction of the max wind

Re: [weewx-user] Name of "day of week"

2017-02-17 Thread Thomas Keffer
How about (NOT TESTED): #set $day=$current.dateTime.format("%A") The day of the week is $day.capitalize() -tk On Fri, Feb 17, 2017 at 3:15 AM, Ruben Navarro Huedo wrote: > Hello: > > I have been reading customization guide but i don't find how i could do > this. > > Using

Re: [weewx-user] CWOP (MADIS) reporting dew point errors

2017-02-11 Thread Thomas Keffer
Hello, William What version of weewx? If you run it directly from the command line, what values of dewpoint does it print out? Did you change anything around 23 January? -tk On Sat, Feb 11, 2017 at 10:59 AM, William Phelps wrote: > Starting on January 23, I have been

Re: [weewx-user] Help debugging alarm.py

2017-02-13 Thread Thomas Keffer
The "alarm" example is intended to be run as a service within weewx. The assignment to "None" only happens if you try to run alarm as a standalone program. Follow the instructions at the top of the file alarm.py. It will cause weewx to load it and run it as a service. -tk On Mon, Feb 13, 2017

Re: [weewx-user] Co-opting the RSYNC skin as a backup solution - even better with report_timing

2017-02-13 Thread Thomas Keffer
Very clever! -tk On Mon, Feb 13, 2017 at 3:35 PM, Glenn McKechnie wrote: > > In looking for a backup solution for the weewx sqlite databases, I found > one in the most unlikely of places - weewx. :-) > > Because the read only pi >

Re: [weewx-user] Re: New User, New Install, no run

2017-02-12 Thread Thomas Keffer
Please do not attempt to set this up yourself. Use setup.py to do it. -tk On Sun, Feb 12, 2017 at 10:55 AM, wrote: > looks like I have some unresolved setup issues, used Vantage with the > question RE: Driver ( no pyserial option ) > > > > On Sunday, February 12, 2017 at

Re: [weewx-user] NEW USER Problems posting to CWOP and PWStation

2017-02-12 Thread Thomas Keffer
A few things 1. The CWOP section of weewx.conf should not have a "protocol" entry. 2. Your CWOP station id "w2irt" looks suspicious. Usually they are one or two letters, followed by a four digit number. Something like CW1234. The reason why you are getting the error "APRS station

Re: [weewx-user] New User, New Install, no run

2017-02-12 Thread Thomas Keffer
Did you install the prerequisites ? -tk On Sun, Feb 12, 2017 at 10:03 AM, wrote: > Just installed on Ubuntu Server 16.10 > Install directory /opt > when I start ( sudo ./weewxd weewx.conf > get error > > > -- > You received this message

Re: [weewx-user] New User, New Install, no run

2017-02-12 Thread Thomas Keffer
If you use the setup.py install method, setting up the driver will be taken care of for you. Don't try to do it manually if you don't know what you're doing. -tk On Sun, Feb 12, 2017 at 10:25 AM, wrote: > Thanks.. off and running setup > > what driver do I need for Davis

Re: [weewx-user] NEW USER Problems posting to CWOP and PWStation

2017-02-12 Thread Thomas Keffer
> > > 2) My ID is, in fact, w2irt (my ham callsign). It's been running > successfully since 2012 like that. It was a special request to the site > admin at the time. I don't use the APRS network, I just upload like any > other PWS, but I am very proud of my call and wanted it as my CWOP ID, >

Re: [weewx-user] Sum of cold hours per day

2017-02-10 Thread Thomas Keffer
weewx cannot do the aggregation type "min_le" for an "hour" time span. Nor has it ever been able to. $day.outTemp.min_le($HorasFrio).nolabel($Count,$NONE) $day.outTemp.max_ge($ HorasCalor).nolabel($Count,$NONE)$hour.outTemp.min_le($ HorasFrio).nolabel($Count,$NONE) $hour.outTemp.max_ge($

Re: [weewx-user] Creating custom graphs to display archive data

2017-02-09 Thread Thomas Keffer
Unfortunately, neither of those are possible with the present image generation engine. You could run wee_reports, using a timestamp of a year ago, saving the images to a separate spot. Then you would be able to display this month's graph, and the same month a year ago. But, they would be in

Re: [weewx-user] How to backup weewx data and restore it after a new OS installation

2017-02-11 Thread Thomas Keffer
See the section *Making backups* in the User's Guide. -tk On Fri, Feb 10, 2017 at 8:56 PM, Rakesh R wrote: > I'm running Weewx in a raspberry pi for past 1 year. > My SD card is showing some problems, so i want to replace it

Re: [weewx-user] WeeWX just stops processing service still running

2017-02-14 Thread Thomas Keffer
You didn't post anything from the log, but I would guess weewx is blocking, trying to read something that is not forthcoming. Perhaps fileparse needs a time out? -tk On Tue, Feb 14, 2017 at 6:51 AM, Robert Mantel wrote: > I'm having a peculiar problem that doesn't seem to

Re: [weewx-user] Can't get MySql to work

2017-02-12 Thread Thomas Keffer
> > I could find no reference to those dependence's in any of the weewx > documentation. > ​See *Install Prerequisites *. -tk​ -- You received this message because you are subscribed to the Google Groups "weewx-user" group. To unsubscribe from this group

Re: [weewx-user] FTP-fault: type object 'set' has no attribute 'append'

2017-02-12 Thread Thomas Keffer
Thanks, Per For reasons I don't quite understand, your #FTP.last file has a slight corruption. The encoding for monthouthumid.png reads aaS'/var/www/weewx/brf_garnisonen/monthouthumid.png' p86 when it should read aS'/var/www/weewx/brf_garnisonen/monthouthumid.png' p86 This is not the first

Re: [weewx-user] Can't get MySql to work

2017-02-12 Thread Thomas Keffer
You need the client libraries for MySQL: sudo apt-get install mysql-client sudo apt-get install python-mysqldb -tk On Sun, Feb 12, 2017 at 12:31 PM, Carl Forster wrote: > Hello. Have a fresh install running on an Rpi 3 and all is working finr > using default

Re: [weewx-user] Re: Steel Series Gauges and RealTime update - 2.5 second interval - how?

2017-02-13 Thread Thomas Keffer
That could work. With this thinking, we could even do away with the report generator. Instead, image generation and file generation would be separate weewx services. Each would invoke its own FTP session when done. Because the set of generated files are disjoint, there would be no duplicated

Re: [weewx-user] Re: Steel Series Gauges and RealTime update - 2.5 second interval - how?

2017-02-13 Thread Thomas Keffer
> > someone should write an rsync and an ftp service that can be bound to > NEW_LOOP_PACKET. it could use the same code used by the ftp/rsync reports, > just wrapped in a StdService instead of report generator. > > ​ The problem with this approach is that then you need some sort of lock for the

Re: [weewx-user] No configuration for device 'driver' when running wee_device

2017-02-09 Thread Thomas Keffer
Your missing a line in your configuration file. It should be: [FineOffsetUSB] model = WH1080 polling_mode = ADAPTIVE driver = weewx.drivers.fousb -tk On Thu, Feb 9, 2017 at 5:12 AM, Russell Seymour < russell.seym...@turtlesystems.co.uk> wrote: > I have just rebuilt my Raspberry PI

Re: [weewx-user] FTP-fault: type object 'set' has no attribute 'append'

2017-02-11 Thread Thomas Keffer
Hello, Per What version and platform of Python are you using? Please send me the file #FTP.last. If you used the setup.py installation method, it will be /home/weewx/public_html/#FTP.last. Otherwise, /var/www/html/weewx/#FTP.last. I'm wondering if it's corrupt -tk On Sat, Feb 11, 2017 at

Re: [weewx-user] Running more than one driver?

2017-02-11 Thread Thomas Keffer
Unfortunately, no, it's not possible. -tk On Sat, Feb 11, 2017 at 7:28 AM, Bill Morrow wrote: > Is it possible to run more than one driver, simultaneously? For example, > this configuration > > # Set to type of station hardware. There must be a corresponding stanza >

Re: [weewx-user] Re: Error charts update

2017-01-18 Thread Thomas Keffer
It does not do us any good to be debugging files that you are not using. In summary, your problem seems to be that the skin.conf file you are actually using references the template data.txt.tmpl, but you are not providing that template. Either remove the reference to data.txt.tmpl from the

Re: [weewx-user] Re: engine: Unable to load driver: (5, 'Input/output error')

2017-01-19 Thread Thomas Keffer
Things to try: Does /dev/ttyS0 actually exist? It looks like you are running weewxd as a daemon, which is usually run as root, so adding yourself to the dialout group will not make any difference. In any case, try running from the command line, and try running as root (by using a 'sudo' prefix).

Re: [weewx-user] weewx[5570]: engine: Caught database OperationalError: (1054, "Unknown column 'usUnits' in 'field list'")

2017-01-19 Thread Thomas Keffer
I have been unable to get these to work with any debug message on my copy of Sierra. For example, try this: Log a message: logger -p user.debug "Hello weewx" Now try to find it: log show --debug --start "2017-01-19" |grep weewx Nothing... Clunky non-intuitive interface. This is an

Re: [weewx-user] Re: engine: Unable to load driver: (5, 'Input/output error')

2017-01-19 Thread Thomas Keffer
; On Thu, Jan 19, 2017 at 4:40 AM, Thomas Keffer > <tkef...@gmail.com> wrote: > Things to try: > > Does /dev/ttyS0 actually exist? > > It looks like you are running weewxd as a daemon, which is usually run as > root, so adding yourself to the dialout group will not make any

Re: [weewx-user] Weewx does't upload the Data online

2017-01-17 Thread Thomas Keffer
Filippo, You must send the logs *from the initial weewx startup*. You are missing some of the early entries. They will have key clues such as which weewx.conf you are using. My suspicion is that you are editing a different weewx.conf than the one that weewx is actually using. If you do not know

Re: [weewx-user] Re: Error charts update

2017-01-17 Thread Thomas Keffer
Please post the file /etc/weewx/skins/Standard/skin.conf. -tk On Tue, Jan 17, 2017 at 12:11 PM, wrote: > I don't resolved the problem. Can you explain me how to resolve it please? > Thanks for the support. > > -- > You received this message because you are subscribed to

Re: [weewx-user] Re: Error charts update

2017-01-17 Thread Thomas Keffer
According to the screenshot of the log you posted, the Cheetah generator is looking for a template called "data.txt.tmpl". I have no idea what that template could be --- it is not part of the standard weewx distribution and it is not mentioned in the skin configuration file, skin.conf, that you

Re: [weewx-user] Fix USB-device to usable dev-link

2017-01-15 Thread Thomas Keffer
Per, this is valuable information that can easily get lost in the vast depths of the weewx-user group. There is already a section in the User's Guide that covers some of the same material. How about combining the two into a comprehensive Wiki

Re: [weewx-user] Re: Weewx, R.Pi and Vantage Pro 2

2017-01-17 Thread Thomas Keffer
On Tue, Jan 17, 2017 at 6:03 AM, Robert Mantel wrote: > I know this is an old thread but I want to ask you about another possible > solution. I have a Particle Photon based weather station that I have > dumping sensor readings to a phant server I have running on my network. >

Re: [weewx-user] upgrading from 2.0 to 3.6

2017-01-19 Thread Thomas Keffer
> > Would it be better if I allow the database upgrade to finish before I > connect the weather station (Vantage Pro 2 + Envoy) or it doesn't really > matter? > My suggested sequence. This assumes you are using the setup.py install method (Debian install was not introduced until V2.2) and that

Re: [weewx-user] upgrading from 2.0 to 3.6

2017-01-19 Thread Thomas Keffer
This will be a good test of the automatic upgrade. :-) Unless you are using an extension, or have done a searchlist extension, it should just work. Note that there is no longer a statistical summary file (stats.sdb). Instead, the daily summaries are now included inside the weewx.sdb file. So,

Re: [weewx-user] Matching rain corrections with weewx and Weather Underground

2017-01-20 Thread Thomas Keffer
The URLs you have posted show values of 0.06 or 0.07, but your narrative talks about 0.6 and 0.7. I assume the former is correct and the latter is just a typo? The value for dailyrainin comes from field dayRain in the current record, which, in turn, is pulled off the Vantage weather station. This

Re: [weewx-user] memleak using Byteweather theme since Weewx 2.x

2016-08-18 Thread Thomas Keffer
an <weewx2...@warpspeed.dyndns.dk> wrote: > Den 07-07-2016 kl. 17:57 skrev Allan: > >> Den 07-07-2016 kl. 01:54 skrev Thomas Keffer: >> >>> Which Python graphics library are you using? PIL or Pillow? >>> >>> PIL has a known problem where it does not re

Re: [weewx-user] Newbie Issues Starting weewx

2016-08-21 Thread Thomas Keffer
A PR would be welcome. -tk On Sun, Aug 21, 2016 at 11:03 AM, vince wrote: > Tom/Matthew - should the python code fix the case for folks perhaps for > these kinds of typos ? > > > On Saturday, August 20, 2016 at 10:53:44 AM UTC-7, Kerry Saylor wrote: >> >> Of course it's

Re: [weewx-user] memleak using Byteweather theme since Weewx 2.x

2016-08-19 Thread Thomas Keffer
If you can find a reproducible problem in the standard skin, that would get my attention. :-) -tk On Fri, Aug 19, 2016 at 3:48 PM, Allan <weewx2...@warpspeed.dyndns.dk> wrote: > Den 20-08-2016 kl. 00:37 skrev Thomas Keffer: > >> Hello, Allan >> >> Do yo

Re: [weewx-user] memleak using Byteweather theme since Weewx 2.x

2016-08-19 Thread Thomas Keffer
Hello, Allan Do you get a memory leak if you use the standard skin? -tk On Fri, Aug 19, 2016 at 3:28 PM, Allan <weewx2...@warpspeed.dyndns.dk> wrote: > Hi Thomas... > > Den 19-08-2016 kl. 03:19 skrev Thomas Keffer: > >> Python itself is garbage collected, so it does

Re: [weewx-user] memleak using Byteweather theme since Weewx 2.x

2016-08-19 Thread Thomas Keffer
reported a problem (so far). -tk On Fri, Aug 19, 2016 at 3:37 PM, Thomas Keffer <tkef...@gmail.com> wrote: > Hello, Allan > > Do you get a memory leak if you use the standard skin? > > -tk > > On Fri, Aug 19, 2016 at 3:28 PM, Allan <weewx2...@warpspeed.dynd

Re: [weewx-user] Problem with wee_device and FIneOffsetUSB

2016-08-20 Thread Thomas Keffer
Try running as root: sudo wee_device --set-interval=5 -tk On Sat, Aug 20, 2016 at 9:14 AM, David Bernstein wrote: > I am trying to change the logging interval for my WS-2080 using FOUSB, but > wee_device is giving me errors. Here is what it said: > > pi@raspberrypi

Re: [weewx-user] Newbie Issues Starting weewx

2016-08-20 Thread Thomas Keffer
Welcome, Kerry Take a look in your weewx.conf configuration file. You probably have something like: [Station] # Altitude of the station, with unit it is in. This is downloaded from # from the station if the hardware supports it. altitude = 700, Foot# Choose 'foot' or 'meter'

Re: [weewx-user] USB over Ethernet & Belfryboy Clone USB logger

2016-08-22 Thread Thomas Keffer
I seem to recall several people doing just that, albeit using a conventional Davis logger. Search the archives. My hunch is that the results will not be super reliable, but it can probably be made to work. -tk On Mon, Aug 22, 2016 at 5:38 AM, zkab wrote: > I have ordered

Re: [weewx-user] USB over Ethernet & Belfryboy Clone USB logger

2016-08-22 Thread Thomas Keffer
​Why not ask Belfryboy? -tk​ On Mon, Aug 22, 2016 at 5:57 AM, zkab wrote: > OK - thanks. > But my main concern is if it will work with Belfryboy Clone USB logger > > Den måndag 22 augusti 2016 kl. 14:49:10 UTC+2 skrev Tom Keffer: >> >> I seem to recall several people

Re: [weewx-user] No rain reporting to Weather Underground, PWSWeather.com

2016-09-02 Thread Thomas Keffer
Starting at 0820 this morning, I'm seeing rain on your WU page. Did you reset the hardware or something? Is it working now? -tk On Fri, Sep 2, 2016 at 5:28 AM, Dan Brown wrote: > I'm running weewx 3.5.0 on a Raspberry Pi, connected to an Ambient Weather > (rebadged Fine

Re: [weewx-user] Weewex on Debian 8.5.0 install failure problem error QDBusConnection: system D-Bus connection created before QCoreApplication. Application may misbehave.

2016-09-02 Thread Thomas Keffer
I'm not sure what that error is, but it has nothing to do with weewx. It's being emitted by Qt (a user-interface library). The log you want is /var/log/syslog (not /var/log/user.log). See what's in there. -tk On Fri, Sep 2, 2016 at 6:41 PM, 'Don l' via weewx-user < weewx-user@googlegroups.com>

Re: [weewx-user] Re: REST api into weewx?

2016-09-05 Thread Thomas Keffer
Wow! A Vantage driver written in Go! :-) Another approach that both Peter Finley's mesowx and my own WeeRT take is to use a weewx service that POSTs the loop packets to an external server. This way, both weewx and the

Re: [weewx-user] Re: REST api into weewx?

2016-09-05 Thread Thomas Keffer
ith the top-row readings updated in real-time by a persistent connection > over Websockets to the real-time service. > > C > > On Mon, Sep 5, 2016 at 10:11 AM, Thomas Keffer <tkef...@gmail.com> wrote: > >> Wow! A Vantage driver written in Go! :-) >> >> A

Re: [weewx-user] memleak using Byteweather theme since Weewx 2.x

2016-09-05 Thread Thomas Keffer
it up) - it leaks 1GB mem/day. > > So we can eleminate ByteWeather here as the problem - it is the font > loading system, that leaks. > > Again, it worked with Weewx 2.7 > > > Allan. > > > > Den 20-08-2016 kl. 01:17 skrev Thomas Keffer: > >> I

Re: [weewx-user] has anyone made an ajax solution for continous update?

2016-09-01 Thread Thomas Keffer
Peter Finley's mesowx does this. Take a look. -tk On Tue, Aug 30, 2016 at 1:26 PM, Niels Østergaard wrote: > Hi > > I have had our Yacht Clubs Vantage set up to a Raspberry Pi running Weewx > 2.6.3 for a couple of years. Recently I

Re: [weewx-user] StdArchive and archive_delay

2016-09-04 Thread Thomas Keffer
​The way weewx works, the driver blocks until a data packet is ready. Weewx cannot do anything else --- archive data, run reports, etc. --- until the packet is ready and the driver unblocks. So, I suspect that your Observer is not offering up a data packet until 45 seconds or so after the top of

Re: [weewx-user] weewx.com down?

2016-08-31 Thread Thomas Keffer
Works fine for me. -tk On Wed, Aug 31, 2016 at 10:10 AM, Buzz K wrote: > Trying to access www.weewx.com and site is timeing out. > > Weewx.com is Down > Checked URL > weewx.com > Response Time > - > Response Code > - > > -- > You received this message because you are

Re: [weewx-user] Re: Current ET data not showing on main index page

2016-09-01 Thread Thomas Keffer
That's the way the Vantage series emits ET. Quoting the manual: '[Archive records include] ET accumulated over the last hour. Only records "on the hour" will have a non-zero value.' This is why only aggregated ET values make sense. -tk On Thu, Sep 1, 2016 at 10:16 AM, Joachim Puttkammer

Re: [weewx-user] memleak using Byteweather theme since Weewx 2.x

2016-09-11 Thread Thomas Keffer
That's good news! Glad to help. -tk On Sun, Sep 11, 2016 at 7:38 AM, Allan <weewx2...@warpspeed.dyndns.dk> wrote: > Den 10-09-2016 kl. 14:54 skrev Thomas Keffer: > >> OK, so there is clearly a leak in the text rendering algorithm on Centos >> 7. That narrows thing

Re: [weewx-user] memleak using Byteweather theme since Weewx 2.x

2016-09-09 Thread Thomas Keffer
GB ram after 23h run (it is restartet every 24h) > > It sure looks like a problem with Centos 7 - but I have no clue, what to > do about it. > > Allan. > > > Den 06-09-2016 kl. 03:54 skrev Thomas Keffer: > >> The only thing that changed in the plotting

  1   2   3   4   5   6   7   8   9   10   >