Re: [Wicket-user] Passing arguments from HTML to component

2004-12-28 Thread Juergen Donnerstag
Search for ComponentTag and the way it is used for rendering. It provides you access to the attributes of tag identified as wicket-tag (e.g. id=wcn-xxx). Juergen --- SF email is sponsored by - The IT Product Guide Read honest candid reviews

Re: [Wicket-user] Re: Wicket context path

2004-12-28 Thread Gili
Damn, that's too bad. To clarify, though, why can't you set the context path to "/" and then check if the invoked URL refers to a path? If it is a path, read it and send it back down the stream. The downside is that you'll be overriding any behavior set in the server (i.e. maybe you want

Re: [Wicket-user] Wicket.Container problem

2004-12-28 Thread Gili
On Tue, 28 Dec 2004 09:36:41 +0100, Juergen Donnerstag wrote: In a nutshell: A superclass should never reference one of its own subclasses directly. You can expose properties that might be common to Panel, Border, etc at the superclass level, but you shouldn't reference them directly

Re: [Wicket-user] Wicket.Container problem

2004-12-28 Thread Juergen Donnerstag
Lets give some of the other developers a chance to respond to it. I'm sure there is some reason why it has been designed like it currently is. Juergen On Tue, 28 Dec 2004 10:38:39 -0500, Gili [EMAIL PROTECTED] wrote: On Tue, 28 Dec 2004 09:36:41 +0100, Juergen Donnerstag wrote: In

Re: [Wicket-user] Table with round corners

2004-12-28 Thread Juergen Donnerstag
I've yet thought about how exactly to implement it. But two point came into my mind: 1) As far as I know Wicket does currenlty not support forwarding attributes like span id=.. width=80%. Your component must have a setter like setWidth(int width) which you could use to define the width of the

Re: [Wicket-user] Table with round corners

2004-12-28 Thread Gili
On Tue, 28 Dec 2004 17:06:26 +0100, Juergen Donnerstag wrote: I've yet thought about how exactly to implement it. But two point came into my mind: 1) As far as I know Wicket does currenlty not support forwarding attributes like span id=.. width=80%. Your component must have a setter like

[Wicket-user] Component lifecycle

2004-12-28 Thread Gili
Hi, I am aware of Wicket parsing two different HTML files: ApplicationName.html (the Generated markup) and, ComponentName.html (the Component markup) First of all, we should discuss this topic formally in the documentation (what files Wicket expects) since there does not seem to

Re: [Wicket-user] Table with round corners

2004-12-28 Thread Juergen Donnerstag
On Tue, 28 Dec 2004 11:30:27 -0500, Gili [EMAIL PROTECTED] wrote: On Tue, 28 Dec 2004 17:06:26 +0100, Juergen Donnerstag wrote: I've yet thought about how exactly to implement it. But two point came into my mind: 1) As far as I know Wicket does currenlty not support forwarding attributes

Re: [Wicket-user] Component lifecycle

2004-12-28 Thread Juergen Donnerstag
On Tue, 28 Dec 2004 11:44:39 -0500, Gili [EMAIL PROTECTED] wrote: Hi, I am aware of Wicket parsing two different HTML files: ApplicationName.html (the Generated markup) and, ComponentName.html (the Component markup) First of all, we should discuss this topic formally in

Re: [Wicket-user] Wicket.Container problem

2004-12-28 Thread Jonathan Locke
there are a number of issues here at least. gili, the method you refer to is private and should remain private. the method is also subtly and multiply recursive in rendering borders, which have very special behavior. the only reason for the downcast is to retrieve the open tag for the

Re: [Wicket-user] Wicket.Container problem

2004-12-28 Thread Gili
Ah, that's great news. I look forward to your email tonight :) :) Gili On Tue, 28 Dec 2004 09:30:42 -0800, Jonathan Locke wrote: heh. as soon as i just said "good luck with that" i might have thought of a solution. unfortunately, i have a series of appointments and won't

Re: [Wicket-user] Component lifecycle

2004-12-28 Thread Juergen Donnerstag
As the name implies handleBody() deals only with the body, assuming span .. has already been written. ApplicationSettings() contains an option to automatically remove span tags from html output. Juergen --- SF email is sponsored by - The IT

Re: [Wicket-user] Table with round corners

2004-12-28 Thread Gili
On Tue, 28 Dec 2004 18:36:33 +0100, Juergen Donnerstag wrote: may be this one helps http://www.w3.org/TR/REC-CSS2/selector.html Are you saying that it is possible to use multiple DIVs with the same ID on one page and they will all share the same style? (didn't know that). like

Re: [Wicket-user] Table with round corners

2004-12-28 Thread Juergen Donnerstag
On Tue, 28 Dec 2004 13:24:27 -0500, Gili [EMAIL PROTECTED] wrote: On Tue, 28 Dec 2004 19:06:32 +0100, Juergen Donnerstag wrote: Having got that far, why use inline CSS? Since CSS is now independent from the markup, why not use external CSS with the additional benefit of a smaller HTML, a web

Re: [Wicket-user] Table with round corners

2004-12-28 Thread Gili
On Tue, 28 Dec 2004 19:50:08 +0100, Juergen Donnerstag wrote: Ok, I understand, but I have no clue how to dynamically create images. Jon did the example. What about starting with a simple RoundCornerPanel which requires static images and impriove it with the next step. Sounds like a

Re: [Wicket-user] Table with round corners

2004-12-28 Thread Gili
It seems to me I'm not going to reuse the logic that comes with Panel because it doesn't give me the ability to add support for [width] or [body] embedded tags. So either I will implement everything from scratch, or we somehow make the Panel behavior extensible so it is possible to layer

Re: [Wicket-user] Table with round corners

2004-12-28 Thread Eelco Hillenius
It'd do it more like: (using a Label or MultiLineLabel) span id=wcn-[panel] div class=ContainerTop div class=ContainerRight div class=ContainerBottom div class=ContainerLeft div class=ContainerTopLeft div class=ContainerTopRight

Re: [Wicket-user] Table with round corners

2004-12-28 Thread Gili
Very smooth! I'm impressed! Two problems: 1) If width="100%" we don't want a table tag to show, but its body should continue showing. How do we do this? 2) Since we are kinda cheating and using Wicket to render a presentation element, we want to be able to specify the width, corner

Re: [Wicket-user] Table with round corners

2004-12-28 Thread Eelco Hillenius
0. I'm used to wcn, and I've no problem with it. If new users find it easier it would be a good idea I guess. Eelco Jonathan Locke wrote: one other related thing that's been bugging me is the wcn prefix is so cryptic. it's more typing, but i almost wish it was just wicket- so it's more

Re: [Wicket-user] Table with round corners

2004-12-28 Thread Eelco Hillenius
Pls don't forget to file an issue for this if you're gonna change it. That way, it will be in the Maven generated change log automatically. Eelco Jonathan Locke wrote: good point. anyone who doesn't want to break doesn't have to. the change would just be ComponentTag:53: public static final

[Wicket-user] wcn -- wicket

2004-12-28 Thread Jonathan Carlson
I'd support the change to "wicket-". "wcn-" feels strange and cryptic to a new user.I wouldwantnew users first impressions to be "intuitive". The first thing viewed by new users is the HTML. I have another reallyminor request: Can we drop the extra generated spaces around the equal signs

Re: [Wicket-user] Dynamic Form

2004-12-28 Thread Eelco Hillenius
Just use the Ognl backed PropertyModel for this, combined with either your business objects (in fact any JavaBean you want) or e.g. a HashMap. Eelco Jonathan Carlson wrote: I've been working on a dynamic form component (during my lunch hour so the progress is a little slow). I'm curious how

Re: [Wicket-user] wcn -- wicket

2004-12-28 Thread Jonathan Locke
i think we should make it configurable, with the default being to remove the spaces. as you point out, this is normal in HTML. i personally like the spaces... but then i'm wierd... ;-) Jonathan Carlson wrote: I'd support the change to wicket-. wcn- feels strange and cryptic to a new user.

Re: [Wicket-user] Table with round corners

2004-12-28 Thread Jonathan Locke
yup. the right way of implementing this will be important if we're going to do it... this is the kind of change it's best to bat around for a while before implementing it. i think this is a 1.1 feature at the earliest... i'm going to suggest something in a minute to fix the container/border

[Wicket-user] Proposal for new markup format

2004-12-28 Thread Gili
On Tue, 28 Dec 2004 16:10:57 -0800, Jonathan Locke wrote: yup. the right way of implementing this will be important if we're going to do it... this is the kind of change it's best to bat around for a while before implementing it. i think this is a 1.1 feature at the earliest... i'm going to