[Bug 59798] CategoryTree displays no results for some parameters

2014-02-19 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

Gerrit Notification Bot gerritad...@wikimedia.org changed:

   What|Removed |Added

 Status|REOPENED|PATCH_TO_REVIEW

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-02-19 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

--- Comment #31 from Gerrit Notification Bot gerritad...@wikimedia.org ---
Change 114142 had a related patch set uploaded by Brian Wolff:
Unbreak this extension by killing $wgCategoryTreeDynamicTag

https://gerrit.wikimedia.org/r/114142

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-02-10 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

Andre Klapper aklap...@wikimedia.org changed:

   What|Removed |Added

   See Also||https://bugzilla.wikimedia.
   ||org/show_bug.cgi?id=61097

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-02-09 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

sp...@wikimedia.org changed:

   What|Removed |Added

 CC||sp...@wikimedia.org

--- Comment #30 from sp...@wikimedia.org ---
renderNode() in CategoryTreeFunctions.php may insert a script tag that calls
categoryTreeExpandNode().  See
https://git.wikimedia.org/blob/mediawiki%2Fextensions%2FCategoryTree/05bafcafdbd3e5b959dba593b8656c24ef0d4a54/CategoryTreeFunctions.php#L846

but as Reedy notes there's no such function.  categoryTreeExpandNode and
categoryTreeLoadChildren used to be defined in CategoryTree.js, but that file
was deleted in 2011. 

This is indirectly causing a problem with Flow, see bug 61097. Flow can somehow
render subst'd page content with this script tag and then JS processing halts
with
ReferenceError: categoryTreeExpandNode is not defined

FWIW Flow boards don't load the JS module 'ext.categoryTree'. Maybe when that
module is loaded it masks the problem. But it can't be good to invoke deleted
functions :)

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-02-05 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

--- Comment #29 from Andre Klapper aklap...@wikimedia.org ---
Greg: Do you know if somebody in Engineering has expertise to give fixing this
ticket another shot?

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-02-04 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

--- Comment #28 from bennylin bknl...@yahoo.com ---
Hi, I've made a use case in
https://id.wiktionary.org/wiki/Pengguna:Bennylin/Categorytree, because id.wikt
relies heavily on CategoryTree to display phrases that uses the lemma. 

Any update on this bug?

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-22 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

bennylin bknl...@yahoo.com changed:

   What|Removed |Added

 CC||bknl...@yahoo.com

--- Comment #27 from bennylin bknl...@yahoo.com ---
We're in id.wp also noticed this, and we're going to watch this progress too.
Fortunately no major damage is done.

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-20 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

Karmela karmela.wikipe...@gmail.com changed:

   What|Removed |Added

 CC||karmela.wikipe...@gmail.com

--- Comment #25 from Karmela karmela.wikipe...@gmail.com ---
At hu.wiki the empty categorytree has been noticed too. Our mentor-system
depends on it. Do we need to develop a workaround, or will the bug be fixed
soon? 

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-20 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

--- Comment #26 from bamyers99 bugzilla.wikime...@brucemyers.com ---
I have implemented a workaround at
https://en.wikipedia.org/wiki/Wikipedia_talk:WikiProject_Geographical_coordinates/to_do#Fix

Example:
categorytree class=toccolours namespaces=- Talk style=margin:0
1ex;Articles requiring geodata verification/categorytree
:{{PAGESINCATEGORY:Articles requiring geodata verification|pages}} pages

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-13 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

Andre Klapper aklap...@wikimedia.org changed:

   What|Removed |Added

 Status|PATCH_TO_REVIEW |RESOLVED
 Resolution|--- |FIXED

--- Comment #18 from Andre Klapper aklap...@wikimedia.org ---
bamyers99: Thanks for your comment and investigation, this was very helpful!

https://gerrit.wikimedia.org/r/#/c/107008/ has been merged - closing as FIXED.

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-13 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

Nemo federicol...@tiscali.it changed:

   What|Removed |Added

 Status|RESOLVED|REOPENED
 CC||federicol...@tiscali.it
 Resolution|FIXED   |---

--- Comment #19 from Nemo federicol...@tiscali.it ---
Reverted: https://gerrit.wikimedia.org/r/#/c/107158/

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-13 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

Faidon Liambotis fai...@wikimedia.org changed:

   What|Removed |Added

 CC||fai...@wikimedia.org

--- Comment #20 from Faidon Liambotis fai...@wikimedia.org ---
https://gerrit.wikimedia.org/r/#/c/107008/ was emergency reverted by Mark
moments ago (2014-01-13 15:12 UTC). It produced a massive poolcounter
contention, as well as database contention on s6, causing jawiki  ruwiki to
spew errors for many hours yesterday and for the most part today.

https://graphite.wikimedia.org/render/?title=PoolCounter%20Client%20Average%20Latency%20%28ms%29%20log%282%29%20-1weekfrom=-1weekwidth=1024height=500until=nowareaMode=nonehideLegend=falselogBase=2lineWidth=1lineMode=connectedtarget=cactiStyle%28MediaWiki.PoolCounter.Client.*.tavg%29



http://ganglia.wikimedia.org/latest/?c=MySQL%20eqiadh=db1006.eqiad.wmnetm=cpu_reportr=hours=descendinghc=4mc=2

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-13 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

--- Comment #21 from Faidon Liambotis fai...@wikimedia.org ---
extensions/CategoryTree/CategoryTreeFunctions.php has this piece of code:

  if ( $parser  $wgCategoryTreeDisableCache  !$wgCategoryTreeDynamicTag ) {
  $parser-disableCache();
  }

(with $wgCategoryTreeDisableCache having a value of true, its default)

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-13 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

--- Comment #22 from bamyers99 bugzilla.wikime...@brucemyers.com ---
Sorry, I did not see this commit:
https://git.wikimedia.org/commitdiff/operations%2Fmediawiki-config.git/670fe932d04b948c1aa73033a00a722fc0269c9e

I thought that $wgCategoryTreeDisableCache = false;
was still in CommonSettings.php.

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-13 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

--- Comment #23 from Sam Reed (reedy) s...@reedyboy.net ---
[17:08:10] Reedy I'm confused how CategoryTree didn't cause problems before
[17:08:11] Reedy
https://github.com/wikimedia/operations-mediawiki-config/commit/4de2857061bc79128dc429f2aac6964a86c8f38a
[17:08:26] Reedy $wgCategoryTreeDynamicTag was set before the require
[17:08:32] Reedy So it wouldn't have had any effect at all
[17:08:48] Reedy I fixed that, which apparently broke some configurations
[17:09:01] Reedy But then removing it (so it was the same as original) and it
causes major problems?

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-13 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

--- Comment #24 from Nemo federicol...@tiscali.it ---
For the records, the empty categorytree has been noticed at it.wiki too.
https://it.wikipedia.org/w/index.php?title=Aiuto:Sportello_informazionioldid=63532785#Problema_con_il_categorytree_per_le_segnalazioni_automatiche_ai_progetti

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-11 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

bamyers99 bugzilla.wikime...@brucemyers.com changed:

   What|Removed |Added

 CC||bugzilla.wikimedia@brucemye
   ||rs.com

--- Comment #12 from bamyers99 bugzilla.wikime...@brucemyers.com ---
*** Bug 59887 has been marked as a duplicate of this bug. ***

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-11 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

--- Comment #13 from bamyers99 bugzilla.wikime...@brucemyers.com ---
The $wgCategoryTreeDynamicTag option is not working. See
https://www.mediawiki.org/wiki/Extension:CategoryTree#Configuration When the
javascript was refactored to use jQuery, some of the code did not get
refactored.

In CategoryTreeFunctions.php

line 447 categoryTreeLoadChildren - old function name

line 846 categoryTreeExpandNode - old function name

Test page: https://en.wikipedia.org/wiki/User:Bamyers99/sandbox/LV

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-11 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

db duplicate...@googlemail.com changed:

   What|Removed |Added

 CC||kiran.inaga...@cmcltd.com

--- Comment #14 from db duplicate...@googlemail.com ---
*** Bug 59896 has been marked as a duplicate of this bug. ***

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-11 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

--- Comment #15 from bamyers99 bugzilla.wikime...@brucemyers.com ---
Here is my analysis of what happened.

On January 6, 2014, CommonSettings.php was changed here:
https://git.wikimedia.org/commitdiff/operations%2Fmediawiki-config.git/4de2857061bc79128dc429f2aac6964a86c8f38a

Before the change, CommonSettings.php looked like this:
$wgCategoryTreeDynamicTag = true;
require( $IP . '/extensions/CategoryTree/CategoryTree.php' );

Currently it looks like this:
require( $IP . '/extensions/CategoryTree/CategoryTree.php' );
$wgCategoryTreeDynamicTag = true;

Before the change, setting $wgCategoryTreeDynamicTag = true had no effect
because it was set before the require statement and CategoryTree.php sets it
back to the default of false.

Since the $wgCategoryTreeDynamicTag feature is broken, setting it to true has
caused issues.

Can we get $wgCategoryTreeDynamicTag set back to false in CommonSettings.php
until this bug is fixed?

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-11 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

--- Comment #16 from Gerrit Notification Bot gerritad...@wikimedia.org ---
Change 107008 had a related patch set uploaded by Reedy:
Remove $wgCategoryTreeDynamicTag = true

https://gerrit.wikimedia.org/r/107008

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-11 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

Gerrit Notification Bot gerritad...@wikimedia.org changed:

   What|Removed |Added

 Status|REOPENED|PATCH_TO_REVIEW

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-11 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

--- Comment #17 from Gerrit Notification Bot gerritad...@wikimedia.org ---
Change 107008 merged by jenkins-bot:
Remove $wgCategoryTreeDynamicTag = true

https://gerrit.wikimedia.org/r/107008

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l


[Bug 59798] CategoryTree displays no results for some parameters

2014-01-08 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=59798

Sam Reed (reedy) s...@reedyboy.net changed:

   What|Removed |Added

Summary|Categorytree returns|CategoryTree displays no
   |nothing for categories  |results for some parameters

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
___
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l