[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-05-16 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 Jon jrob...@wikimedia.org changed: What|Removed |Added Status|PATCH_TO_REVIEW |RESOLVED

[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-04-16 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #64 from Jon jrob...@wikimedia.org --- We deep dived this issue again and concluded we should remove getMobileToken in favour of user-getToken Chris says that soon anonymous editors will get a unique token when that is called. In

[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-04-16 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #65 from Arthur Richards aricha...@wikimedia.org --- (In reply to Jon from comment #64) We deep dived this issue again and concluded we should remove getMobileToken in favour of user-getToken Chris says that soon anonymous

[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-04-16 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #66 from Gerrit Notification Bot gerritad...@wikimedia.org --- Change 126873 had a related patch set uploaded by Jdlrobson: Use core token handling https://gerrit.wikimedia.org/r/126873 -- You are receiving this mail because: You

[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-04-16 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 Gerrit Notification Bot gerritad...@wikimedia.org changed: What|Removed |Added Status|NEW

[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-04-16 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #67 from Gerrit Notification Bot gerritad...@wikimedia.org --- Change 126873 merged by jenkins-bot: Use core token handling https://gerrit.wikimedia.org/r/126873 -- You are receiving this mail because: You are the assignee for

[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-04-14 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #63 from Chris McMahon cmcma...@wikimedia.org --- The test for Keep Going registers a new account but also triggers the token-mismatch problem:

[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-04-11 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #61 from Jon jrob...@wikimedia.org --- There have been 8708 hits to this error in the last 30 days on our production wikis. -- You are receiving this mail because: You are the assignee for the bug. You are on the CC list for the

[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-04-11 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #62 from Chris McMahon cmcma...@wikimedia.org --- For reference, history:

[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-04-10 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #59 from Jon jrob...@wikimedia.org --- So this problem seems to only happen when the user is anonymous... It seems that $this-getRequest()-getSessionData( 'wsMobileToken' ) is returning null which results in a new session getting

[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-04-10 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #60 from Jon jrob...@wikimedia.org --- The problematic function seems to be MobileContext::getMobileToken -- You are receiving this mail because: You are the assignee for the bug. You are on the CC list for the bug.

[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-04-09 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #58 from Chris McMahon cmcma...@wikimedia.org --- Jon updated the editor_ve.feature test today, but I cannot get a clean run of the test on beta labs. In every case one token seems to persist longer than it should, on the order

[Bug 62614] Problem with getMobileToken in MobileContext

2014-04-02 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #54 from Chris McMahon cmcma...@wikimedia.org --- From the log in beta labs on eqiad just now: -04-02 07:46:39 deployment-apache02 enwiki: SpecialMobileOptions::submitSettingsForm(): token mismatch, received

[Bug 62614] Problem with getMobileToken in MobileContext

2014-04-02 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #55 from Chris Steipp cste...@wikimedia.org --- Thanks Chris, that narrows down the problem significantly. Can you rerun the tests with a different (or new) username, so we can rule out that this is a race condition with multiple

[Bug 62614] Problem with getMobileToken in MobileContext

2014-04-02 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #56 from Chris McMahon cmcma...@wikimedia.org --- These tests manipulate the ON/OFF toggle settings before logging in, and each browser starts with a fresh profile on every run of every scenario. Username should be immaterial. --

[Bug 62614] Problem with getMobileToken in MobileContext

2014-04-02 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #57 from Chris McMahon cmcma...@wikimedia.org --- I set the editor_ve.feature test to log in with a different user anyway and generated the following errors in the second run of the test on my local host: 2014-04-02 17:52:34

[Bug 62614] Problem with getMobileToken in MobileContext causing browser tests to fail

2014-04-02 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 Jon jrob...@wikimedia.org changed: What|Removed |Added Summary|Problem with getMobileToken |Problem with getMobileToken

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-31 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #53 from Max Semenik maxsem.w...@gmail.com --- https://gerrit.wikimedia.org/r/121879 added logging of token details to mobile.log -- You are receiving this mail because: You are the assignee for the bug. You are on the CC list for

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-28 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #51 from Chris McMahon cmcma...@wikimedia.org --- Created attachment 14959 -- https://bugzilla.wikimedia.org/attachment.cgi?id=14959action=edit WireShark capture of error conversation This should be the entire conversation

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-28 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #50 from Jon jrob...@wikimedia.org --- chris steipp, it's however worth noting that we've been unable to replicate this with the above steps on OS X -- You are receiving this mail because: You are the assignee for the bug. You are

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-28 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #49 from Chris McMahon cmcma...@wikimedia.org --- Chris Steipp: Pretty reliable repo for me has been to run the editor_ve.feature test, and the second Scenario fails with the error almost every time. Watch the browser as the

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-28 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #52 from Chris Steipp cste...@wikimedia.org --- Thanks Chris. That confirms that this is different from what Jeremy posted, since his had a Location header come back from the POST request, whereas yours showed the form with the div

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-27 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 Chris Steipp cste...@wikimedia.org changed: What|Removed |Added CC|

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-27 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #41 from Chris McMahon cmcma...@wikimedia.org --- Created attachment 14943 -- https://bugzilla.wikimedia.org/attachment.cgi?id=14943action=edit token mismatch on POST shown in WireShark on Linux -- You are receiving this mail

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-27 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #42 from Chris McMahon cmcma...@wikimedia.org --- The screen shot above I think shows the token-mismatch problem on the POST. However, the test itself behaves strangely on my local machine with WireShark running so I may have

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-27 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #43 from Chris Steipp cste...@wikimedia.org --- Chris, can you do follow TCP Stream and screenshot the result? I'd like to confirm that you're NOT seeing a Location header returned in the result of that call. -- You are receiving

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-27 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #44 from Chris McMahon cmcma...@wikimedia.org --- CSteipp, Wireshark is killing my poor underspec'd laptop. I spent a couple hours on this, but I cannot even get the test to complete or my wlan interface to stay functional with

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-27 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #45 from Arthur Richards aricha...@wikimedia.org --- Chris, in the meantime, can we point the saucelabs test to not use Linux, perhaps to use FF/Chrome in OS X since we haven't been able to replicate the issue there? -- You are

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-27 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 Jon jrob...@wikimedia.org changed: What|Removed |Added Priority|Unprioritized |High --- Comment #46 from

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-27 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #47 from Chris Steipp cste...@wikimedia.org --- Is anyone able to reproduce this in the office yet? If so, I'm happy to work on this in person tomorrow. Or if someone can walk me through the steps to reproduce, I can attempt from a

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-27 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #48 from Arthur Richards aricha...@wikimedia.org --- (In reply to Jon from comment #46) This is now the main source of our failing test builds (the last 3 builds failed solely because of this issue) Thanks for all the attention

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-26 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #37 from Jeremy L Grajales jeremygraja...@gmail.com --- (In reply to Arthur Richards from comment #36) Chris, any luck dumping those headers? I'm increasingly curious to see what's going on there. What headers are you looking for

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-26 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #38 from Chris McMahon cmcma...@wikimedia.org --- Requested by Chris Steipp, Request headers and stuff pulled from the Network tab in Firefox after incurring the token error (I also have the entire response that contains the error

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-26 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #39 from Jeremy L Grajales jeremygraja...@gmail.com --- Created attachment 14914 -- https://bugzilla.wikimedia.org/attachment.cgi?id=14914action=edit (Partial) Wireshark capture of editor_ve test [attachments] I captured the test

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-26 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 Jon jrob...@wikimedia.org changed: What|Removed |Added Status|PATCH_TO_REVIEW |NEW -- You are receiving

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-25 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #28 from Jeremy L Grajales jeremygraja...@gmail.com --- I tested this on Firefox (Windows). http://pastebin.com/yi9FGPVU Seems to reproduce the same issue. Although, I'm not sure. Visually: The browser gets to the settings page.

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-25 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #29 from Jeremy L Grajales jeremygraja...@gmail.com --- (In reply to Jon from comment #9) If someone can help me get Chrome driver setup maybe I can find a way around this... does delaying the opt in event with a wait help at all

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-25 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #30 from Jon jrob...@wikimedia.org --- If the opt into alpha happens after login does this resolve the issue? I wonder if it's something particularly strange with opting in whilst anonymous... -- You are receiving this mail

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-25 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #31 from Jeremy L Grajales jeremygraja...@gmail.com --- (In reply to Jon from comment #30) If the opt into alpha happens after login does this resolve the issue? I wonder if it's something particularly strange with opting in

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-25 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #32 from Gerrit Notification Bot gerritad...@wikimedia.org --- Change 120959 had a related patch set uploaded by Jdlrobson: See if sleeping helps avoid token issues on Special:MobileOptions https://gerrit.wikimedia.org/r/120959 --

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-25 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 Gerrit Notification Bot gerritad...@wikimedia.org changed: What|Removed |Added Status|UNCONFIRMED

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-25 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #33 from Jeremy L Grajales jeremygraja...@gmail.com --- (In reply to Gerrit Notification Bot from comment #32) Change 120959 had a related patch set uploaded by Jdlrobson: See if sleeping helps avoid token issues on

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-25 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #34 from Jeremy L Grajales jeremygraja...@gmail.com --- (In reply to Gerrit Notification Bot from comment #32) Change 120959 had a related patch set uploaded by Jdlrobson: See if sleeping helps avoid token issues on

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-25 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #35 from Gerrit Notification Bot gerritad...@wikimedia.org --- Change 120959 abandoned by Jdlrobson: See if sleeping helps avoid token issues on Special:MobileOptions Reason: Thanks to Jeremy L Grajales we can confirm this doesn't

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-25 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #36 from Arthur Richards aricha...@wikimedia.org --- (In reply to Chris McMahon from comment #27) I chatted with Chris Steipp about this a bit: (03:53:51 PM) csteipp: So yeah, either the user doesn't have a session,

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-24 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 Jeremy L Grajales jeremygraja...@gmail.com changed: What|Removed |Added CC|

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-24 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #25 from Arthur Richards aricha...@wikimedia.org --- Jeremy if you (In reply to Jeremy L Grajales from comment #24) Is there anything I could do to attempt to replicate this on my end? Thanks Jeremy - if you don't have it set up

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-24 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #26 from Arthur Richards aricha...@wikimedia.org --- (In reply to Arthur Richards from comment #23) I agree with Max, in this case a race condition doesn't make sense due to the nature of PHP. However, it is conceivable that there

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-24 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #27 from Chris McMahon cmcma...@wikimedia.org --- I chatted with Chris Steipp about this a bit: (03:53:51 PM) csteipp: So yeah, either the user doesn't have a session, wsMobileToken in the session is getting overwritten, or the

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-21 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #19 from Chris McMahon cmcma...@wikimedia.org --- Seems like a race condition in lines 204-208 of SpecialMobileOptions.php in submitSettingsForm. As I read this: * submitSettingsForm calls out to do $context =

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-21 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #23 from Arthur Richards aricha...@wikimedia.org --- I agree with Max, in this case a race condition doesn't make sense due to the nature of PHP. However, it is conceivable that there are occasional hiccups/something going wrong

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-21 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #22 from Chris McMahon cmcma...@wikimedia.org --- I think the fact that this is passing anywhere is an environment issue. Same error happened twice in Firefox in the build just hours ago:

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-21 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #21 from Jon jrob...@wikimedia.org --- As stated before, I really thing this is an environment issue. Chris what else might be different in your setup to us? -- You are receiving this mail because: You are the assignee for the

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-21 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #20 from Max Semenik maxsem.w...@gmail.com --- Chris, these are synchronous operations, it's really hard to do stufff in parallel in PHP:) So no race condition. -- You are receiving this mail because: You are the assignee for the

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-20 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #17 from Ċ½eljko Filipin zfili...@wikimedia.org --- (In reply to Jon from comment #9) If someone can help me get Chrome driver setup maybe I can find a way around this... does delaying the opt in event with a wait help at all

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-20 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #18 from Jon jrob...@wikimedia.org --- Yep but still unable to replicate this bug in any way either locally or on beta labs... -- You are receiving this mail because: You are the assignee for the bug. You are on the CC list for

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-18 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #9 from Jon jrob...@wikimedia.org --- If someone can help me get Chrome driver setup maybe I can find a way around this... does delaying the opt in event with a wait help at all Chris? -- You are receiving this mail because: You

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-18 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #10 from Jon jrob...@wikimedia.org --- I have run this 6 times locally against beta labs with the latest ChromeDriver (v2.9.248307) and all passed. I'm still not sure what's going on here. -- You are receiving this mail because:

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-18 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #11 from Chris McMahon cmcma...@wikimedia.org --- I got the problem the first time I ran, on the second scenario: $ bundle exec cucumber features/editor_ve.feature @en.m.wikipedia.beta.wmflabs.org @login @test2.m.wikipedia.org

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-18 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #12 from Jon jrob...@wikimedia.org --- I understand but I ran exactly the same test 6 times and can't replicate this. This always passes for me. What version of Chrome Driver are you using? -- You are receiving this mail because:

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-18 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #13 from Chris McMahon cmcma...@wikimedia.org --- Created attachment 14852 -- https://bugzilla.wikimedia.org/attachment.cgi?id=14852action=edit error saving settings -- You are receiving this mail because: You are the assignee

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-18 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #14 from Jon jrob...@wikimedia.org --- I understand - I can see this in the browser test screencast but I'm not seeing this so your environment must be setup slightly different to mine? What version of Chrome Driver are you using?

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-18 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #15 from Chris McMahon cmcma...@wikimedia.org --- ChromeDriver (v2.9.248304) but that has nothing to do with the problem. -- You are receiving this mail because: You are the assignee for the bug. You are on the CC list for the

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-18 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #16 from Chris McMahon cmcma...@wikimedia.org --- and here is the same problem in Firefox, so it is not only Chrome:

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-14 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #5 from Max Semenik maxsem.w...@gmail.com --- Chris, how do I repro this problem locally? -- You are receiving this mail because: You are the assignee for the bug. You are on the CC list for the bug.

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-14 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #6 from Chris McMahon cmcma...@wikimedia.org --- Max, for me when I run the browser test editor_ve.feature (or any test with the step Given I am in alpha mode) against beta labs, I see the Error saving settings. Please make sure

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-14 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #7 from Arthur Richards aricha...@wikimedia.org --- I wonder if it's possibly an issue with Selenium? This is not something I've been able to repro either and certainly not something I've experienced locally or in production. --

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-14 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 --- Comment #8 from Chris McMahon cmcma...@wikimedia.org --- To the extent that it is an issue with Selenium, the speed of the test between clicking the ON toggle and the Save button is probably triggering a race condition that is difficult to

[Bug 62614] Problem with getMobileToken in MobileContext

2014-03-13 Thread bugzilla-daemon
https://bugzilla.wikimedia.org/show_bug.cgi?id=62614 Jon jrob...@wikimedia.org changed: What|Removed |Added Summary|intermittent: attempt to|Problem with getMobileToken