Re: [Ninux-Wireless] Ground Routing

2015-07-04 Per discussione Massimiliano CARNEMOLLA

On 03/07/2015 21.02, Luigi Porto wrote:


Installato luci-lib-json e attivato nella scheda plugins?


Si. Adesso ho anche aggiornato il demone OLSR ma mi da'

OLSR Daemon
Unable to connect to the OLSR daemon!

Make sure that OLSRd is running, the jsoninfo plugin is loaded, 
configured on port 9090 and accepts connections from 127.0.0.1.


Powered by LuCI Trunk (0.12+svn-r10530) OpenWrt Barrier Breaker 14.07



Devo aggiornare anche tutti i plugin ?
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing

2015-07-04 Per discussione Massimiliano CARNEMOLLA

On 04/07/2015 13.03, Michele Salerno wrote:


Vai nella configurazione di OLSR ed edita il plugin di Jsoninfo, devi
attivare la porta e se non c'è l'host devi metterlo.
Io ho su:
accept : 127.0.0.1
port: 9090



Fatto.


Ho aggiornato tutti i plugin.


Questo e' il risultato.

Interfaces
Overview of interfaces where OLSR is running
Interface   State   MTU WLANSource address  Netmask Broadcast 
address
eth0.3  downno  



Sat Jul  4 11:33:45 2015 daemon.info olsrd[1078]: Adding interface eth0.3
Sat Jul  4 11:33:45 2015 daemon.err olsrd[1078]: bind: Cannot assign 
requested address




Potrebbe essere lato antenna il problema ?
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing

2015-07-04 Per discussione Michele Salerno
Il 4 luglio 2015 11:36, Massimiliano CARNEMOLLA
massimili...@null.net ha scritto:
 On 04/07/2015 13.03, Michele Salerno wrote:

 Questo e' il risultato.

 Interfaces
 Overview of interfaces where OLSR is running
 Interface   State   MTU WLANSource address  Netmask Broadcast
 address
 eth0.3  downno


 Potrebbe essere lato antenna il problema ?

state down?
Ma è attaccata ed accesa l'antenna?

Michele
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing

2015-07-04 Per discussione Michele Salerno
2015-07-04 10:52 GMT+02:00 Massimiliano CARNEMOLLA massimili...@null.net:
 On 03/07/2015 21.02, Luigi Porto wrote:

 Installato luci-lib-json e attivato nella scheda plugins?


 Si. Adesso ho anche aggiornato il demone OLSR ma mi da'

 OLSR Daemon
 Unable to connect to the OLSR daemon!

 Make sure that OLSRd is running, the jsoninfo plugin is loaded, configured
 on port 9090 and accepts connections from 127.0.0.1.

Vai nella configurazione di OLSR ed edita il plugin di Jsoninfo, devi
attivare la porta e se non c'è l'host devi metterlo.
Io ho su:
accept : 127.0.0.1
port: 9090
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing

2015-07-04 Per discussione Massimiliano CARNEMOLLA

On 04/07/2015 14.11, Michele Salerno wrote:


state down?
Ma è attaccata ed accesa l'antenna?


Si.

Adesso ho risolto.

C'erano le VLAN 3 sia lato antenna che lato GR che avevano lo stesso IP.

Ne ho cambiato uno su entrambi i nodi e adesso OLSR funziona.


Adesso su un solo nodo o quest'altro problema.

[   19.17] IPv6: br-lan: IPv6 duplicate address 
2001:4c00:893b:::66 detected!




Forse cambiando IP risolvo anche questo.
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing

2015-07-03 Per discussione Massimiliano CARNEMOLLA

In IPV6 con OLSR6 le interfacce rimangono down perche' c'e' un bug

http://olsr.org/bugs/view.php?id=48

Fri Jul  3 18:44:15 2015 daemon.info olsrd[2347]: Adding interface eth0.3
Fri Jul  3 18:44:15 2015 daemon.err olsrd[2347]: bind: Cannot assign 
requested address



che si risolve mettendo ignore a 1 nella conf di OLSR6

ma se lo faccio io mi da' quest'altro errore.


OLSR Daemon

Unable to connect to the OLSR daemon!

Make sure that OLSRd is running, the jsoninfo plugin is loaded, 
configured on port 9090 and accepts connections from 127.0.0.1.

Powered by LuCI Trunk (0.12+svn-r10530) OpenWrt Barrier Breaker 14.07



___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing

2015-07-03 Per discussione Luigi Porto
2015-07-03 20:49 GMT+02:00 Massimiliano CARNEMOLLA massimili...@null.net:



 Unable to connect to the OLSR daemon!

 Make sure that OLSRd is running, the jsoninfo plugin is loaded,
 configured on port 9090 and accepts connections from 127.0.0.1.
 Powered by LuCI Trunk (0.12+svn-r10530) OpenWrt Barrier Breaker 14.07



Installato luci-lib-json e attivato nella scheda plugins?


-- 
#musk from calabria.ninux.org - CS

@openmusk
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing

2015-06-28 Per discussione Massimiliano CARNEMOLLA
Ho configurato un secondo nodo con le stesse impostazioni su Antenna e 
GR (cambiano solo gli IPv6 e HNA6) e tra di loro si pingano sia da una 
parte che dall'altra (utilizzando IP dell'antenna e poi quello del GR).




A questo punto dovrei ricontrollarmi le configurazioni del nodo 
precedente...

___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing

2015-06-28 Per discussione Massimiliano CARNEMOLLA

I dispositivi si sono linkati a livello wireless ma non si pingavano...

Le interfacce di OLSR (le vlan traffico wireless) una diceva di essere 
up, l'altra down)



Ho cambiato qualche impostazione sulle antenne senza sapere cosa stessi 
facendo...


Qualche riavvio di tutti e 4 i dispositivi e adesso lo Status di OLSR6 
mi dice i nodi si vedono tra di loro a livello di rete mesh.

___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing

2015-06-28 Per discussione Massimiliano CARNEMOLLA

Non riesco a pingare di dispositivi tra di loro pero'


utilizzando l'IPv6 delle antenne
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing

2015-06-28 Per discussione Giuseppe De Marco
Il 28 giugno 2015 17:38, Massimiliano CARNEMOLLA
massimili...@null.net ha scritto:
 Ho configurato un secondo nodo con le stesse impostazioni su Antenna e GR
 (cambiano solo gli IPv6 e HNA6) e tra di loro si pingano sia da una parte
 che dall'altra (utilizzando IP dell'antenna e poi quello del GR).



 A questo punto dovrei ricontrollarmi le configurazioni del nodo
 precedente...

Forza Massimiliano, che è quando inizi a risponderti da solo che hai
iniziato a carburare !
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-11 Per discussione Nicola Ruscitto
Buongiorno,
avrei bisogno di un aiutino in merito alla configurazione del ground
routing che sto provando in questi giorni. Sto utilizzando una CPE con
openwrt e pacchetto trelay installato e un router tplink sempre con
openwrt e pacchetto olsrd. L'altra CPE invece ha solo openwrt e olsr.

Le antenne stanno nella sottorete 172.22.0.0 mentre la rete locale l'ho
lasciata sulla 192.168.1.0

Praticamente funziona tutto ovvero olsrd in esecuzione sul ground router
vede il vicino ed aggiorna la tabella di routing. Tuttavia l'IP dell'
antenna remota non é pingabile nonostante abbia  settato i forwarding tra
le dua interfacce (LAN e VLAN dati).

Viceversa, se vado sull'altra antenna riesco a fare un ping sulla prima
antenna.

Cosa ho tralasciato?

Grazie
Nicola


Il giorno 06 aprile 2014 17:26, Nicola Ruscitto
nicolaruscitt...@gmail.comha scritto:

 Ciao ragazzi,
 la prova del router a terra con radio wa7510n openwrt ha dato esiti
 positivi. Una volta impostate le vlan e caricato il modulo trelay
 sull'antenna così come suggerito sulla guida, il router ha aggiornato la
 sua tabella di routing aggiungendo il vicino.

 Saluti
 Nicola

___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-11 Per discussione Gigismi
anche il modello esatto di tp-link su cui hai installato openwrt.


Il giorno 11 aprile 2014 09:54, Nicola Ruscitto
nicolaruscitt...@gmail.comha scritto:

 Buongiorno,
 avrei bisogno di un aiutino in merito alla configurazione del ground
 routing che sto provando in questi giorni. Sto utilizzando una CPE con
 openwrt e pacchetto trelay installato e un router tplink sempre con
 openwrt e pacchetto olsrd. L'altra CPE invece ha solo openwrt e olsr.

 Le antenne stanno nella sottorete 172.22.0.0 mentre la rete locale l'ho
 lasciata sulla 192.168.1.0

 Praticamente funziona tutto ovvero olsrd in esecuzione sul ground router
 vede il vicino ed aggiorna la tabella di routing. Tuttavia l'IP dell'
 antenna remota non é pingabile nonostante abbia  settato i forwarding tra
 le dua interfacce (LAN e VLAN dati).

 Viceversa, se vado sull'altra antenna riesco a fare un ping sulla prima
 antenna.

 Cosa ho tralasciato?

 Grazie
 Nicola


 Il giorno 06 aprile 2014 17:26, Nicola Ruscitto 
 nicolaruscitt...@gmail.com ha scritto:

 Ciao ragazzi,
 la prova del router a terra con radio wa7510n openwrt ha dato esiti
 positivi. Una volta impostate le vlan e caricato il modulo trelay
 sull'antenna così come suggerito sulla guida, il router ha aggiornato la
 sua tabella di routing aggiungendo il vicino.

 Saluti
 Nicola



 ___
 Wireless mailing list
 Wireless@ml.ninux.org
 http://ml.ninux.org/mailman/listinfo/wireless




-- 
__Gigi__
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-11 Per discussione Nicola Ruscitto
Dimenticavo,
le antenne sono due Tp-Link wa7510n e il router é Tp-Link wr841n

Grazie
Nicola


Il giorno 11 aprile 2014 14:26, Nicola Ruscitto
nicolaruscitt...@gmail.comha scritto:

 Vi invio configurazione del router e schema di collegamento (in allegato)
 Grazie
 Nicola

 root@OpenWrt:~# cat /etc/config/network

 config interface 'loopback'
 option ifname 'lo'
 option proto 'static'
 option ipaddr '127.0.0.1'
 option netmask '255.0.0.0'

 config interface 'lan'
 option proto 'static'
 option netmask '255.255.255.0'
 option ipaddr '192.168.1.160'
 option _orig_ifname 'eth1'
 option _orig_bridge 'false'
 option ifname 'eth1.7'
 option gateway '192.168.1.1'
 option dns '192.168.1.1'

 config interface 'wan'
 option ifname 'eth0'
 option proto 'dhcp'

 config switch
 option name 'switch0'
 option reset '1'
 option enable_vlan '1'

 config switch_vlan
 option device 'switch0'
 option vlan '1'
 option vid '1'
 option ports '0t 1t 2t 3t 4t'

 config switch_vlan
 option device 'switch0'
 option vlan '2'
 option ports '0t 3t'
 option vid '3'

 config interface 'antenna_1'
 option proto 'static'
 option ifname 'eth1.3'
 option ipaddr '172.22.66.10'
 option netmask '255.255.0.0'
 option gateway '192.168.1.160'

 config switch_vlan
 option device 'switch0'
 option vlan '3'
 option ports '0t 1 2 3t 4'
 option vid '7'


 e questo é il firewall

 root@OpenWrt:~# cat /etc/config/firewall

 config defaults
 option syn_flood '1'
 option input 'ACCEPT'
 option output 'ACCEPT'
 option forward 'ACCEPT'

 config zone
 option name 'lan'
 option input 'ACCEPT'
 option output 'ACCEPT'
 option forward 'ACCEPT'
 option network 'lan'

 config zone
 option name 'wan'
 option network 'wan'
 option input 'REJECT'
 option output 'ACCEPT'
 option forward 'REJECT'
 option masq '1'
 option mtu_fix '1'

 config rule
 option name 'Allow-DHCP-Renew'
 option src 'wan'
 option proto 'udp'
 option dest_port '68'
 option target 'ACCEPT'
 option family 'ipv4'

 config rule
 option name 'Allow-Ping'
 option src 'wan'
 option proto 'icmp'
 option icmp_type 'echo-request'
 option family 'ipv4'
 option target 'ACCEPT'

 config rule
 option name 'Allow-DHCPv6'
 option src 'wan'
 option proto 'udp'
 option src_ip 'fe80::/10'
 option src_port '547'
 option dest_ip 'fe80::/10'
 option dest_port '546'
 option family 'ipv6'
 option target 'ACCEPT'

 config rule
 option name 'Allow-ICMPv6-Input'
 option src 'wan'
 option proto 'icmp'
 list icmp_type 'echo-request'
 list icmp_type 'echo-reply'
 list icmp_type 'destination-unreachable'
 list icmp_type 'packet-too-big'
 list icmp_type 'time-exceeded'
 list icmp_type 'bad-header'
 list icmp_type 'unknown-header-type'
 list icmp_type 'router-solicitation'
 list icmp_type 'neighbour-solicitation'
 list icmp_type 'router-advertisement'
 list icmp_type 'neighbour-advertisement'
 option limit '1000/sec'
 option family 'ipv6'
 option target 'ACCEPT'

 config rule
 option name 'Allow-ICMPv6-Forward'
 option src 'wan'
 option dest '*'
 option proto 'icmp'
 list icmp_type 'echo-request'
 list icmp_type 'echo-reply'
 list icmp_type 'destination-unreachable'
 list icmp_type 'packet-too-big'
 list icmp_type 'time-exceeded'
 list icmp_type 'bad-header'
 list icmp_type 'unknown-header-type'
 option limit '1000/sec'
 option family 'ipv6'
 option target 'ACCEPT'

 config include
 option path '/etc/firewall.user'

 config forwarding
 option dest 'wan'
 option src 'lan'

 config zone
 option name 'ninux'
 option input 'ACCEPT'
 option forward 'ACCEPT'
 option output 'ACCEPT'
 option network 'antenna_1'

 config forwarding
 option dest 'lan'
 option src 'ninux'

 config forwarding
 option dest 'ninux'
 option src 'lan'



 Il giorno 11 aprile 2014 11:14, Saverio Proto ziopr...@gmail.com ha
 scritto:

 Non si capisce il setup.
 Inviaci:
 schema connessione apparati coinvolti
 configurazione IP interfacce apparati.

 Saverio

 Il 11 aprile 2014 09:54, Nicola Ruscitto nicolaruscitt...@gmail.com
 ha scritto:
  Buongiorno,
  avrei bisogno di un aiutino in merito alla configurazione del ground
 routing
  che sto provando in questi giorni. 

Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-11 Per discussione Nicola Ruscitto
Vi invio configurazione del router e schema di collegamento
Grazie
Nicola


 Schema config 
retehttps://docs.google.com/drawings/d/1DN7WDppIeq1nMBKMlvJ_Sfjtvsy7brlgKMM9IBm47ms/edit?usp=drive_web

 antenna 
192-168-1-170.pnghttps://docs.google.com/file/d/0B-UkxkMKFmofcEpYLU1aSno5d2M/edit?usp=drive_web

 router 
192-168-1-160.pnghttps://docs.google.com/file/d/0B-UkxkMKFmofRk5kQ0l6dHFoTHc/edit?usp=drive_web


root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.1.160'
option _orig_ifname 'eth1'
option _orig_bridge 'false'
option ifname 'eth1.7'
option gateway '192.168.1.1'
option dns '192.168.1.1'

config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 1t 2t 3t 4t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 3t'
option vid '3'

config interface 'antenna_1'
option proto 'static'
option ifname 'eth1.3'
option ipaddr '172.22.66.10'
option netmask '255.255.0.0'
option gateway '192.168.1.160'

config switch_vlan
option device 'switch0'
option vlan '3'
option ports '0t 1 2 3t 4'
option vid '7'


e questo é il firewall

root@OpenWrt:~# cat /etc/config/firewall

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'

config zone
option name 'wan'
option network 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config forwarding
option dest 'wan'
option src 'lan'

config zone
option name 'ninux'
option input 'ACCEPT'
option forward 'ACCEPT'
option output 'ACCEPT'
option network 'antenna_1'

config forwarding
option dest 'lan'
option src 'ninux'

config forwarding
option dest 'ninux'
option src 'lan'


Il giorno 11 aprile 2014 16:17, Nicola Ruscitto
nicolaruscitt...@gmail.comha scritto:

 Dimenticavo,
 le antenne sono due Tp-Link wa7510n e il router é Tp-Link wr841n

 Grazie
 Nicola


 Il giorno 11 aprile 2014 14:26, Nicola Ruscitto 
 nicolaruscitt...@gmail.com ha scritto:

 Vi invio configurazione del router e schema di collegamento (in allegato)
 Grazie
 Nicola

 root@OpenWrt:~# cat /etc/config/network

 config 

Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-11 Per discussione Saverio Proto
questo non ha senso !

config interface 'antenna_1'
option proto 'static'
option ifname 'eth1.3'
option ipaddr '172.22.66.10'
option netmask '255.255.0.0'
option gateway '192.168.1.160'

a parte questo puoi disabilitare il firewall di openwrt come primo step.
/etc/init.d/firewall stop  /etc/init.d/firewall disable

poi ci sta un po di confusione. 192.168.1.0/24 la puoi usare solo su un
nodo, sul nodo remoto devi usare una seconda subnet se vuoi fare routing.

grazie

Saverio



Il giorno 11 aprile 2014 16:25, Nicola Ruscitto
nicolaruscitt...@gmail.comha scritto:

 Vi invio configurazione del router e schema di collegamento
 Grazie
 Nicola


  Schema config 
 retehttps://docs.google.com/drawings/d/1DN7WDppIeq1nMBKMlvJ_Sfjtvsy7brlgKMM9IBm47ms/edit?usp=drive_web

  antenna 
 192-168-1-170.pnghttps://docs.google.com/file/d/0B-UkxkMKFmofcEpYLU1aSno5d2M/edit?usp=drive_web

  router 
 192-168-1-160.pnghttps://docs.google.com/file/d/0B-UkxkMKFmofRk5kQ0l6dHFoTHc/edit?usp=drive_web


 root@OpenWrt:~# cat /etc/config/network

 config interface 'loopback'
 option ifname 'lo'
 option proto 'static'
 option ipaddr '127.0.0.1'
 option netmask '255.0.0.0'

 config interface 'lan'
 option proto 'static'
 option netmask '255.255.255.0'
 option ipaddr '192.168.1.160'
 option _orig_ifname 'eth1'
 option _orig_bridge 'false'
 option ifname 'eth1.7'
 option gateway '192.168.1.1'
 option dns '192.168.1.1'

 config interface 'wan'
 option ifname 'eth0'
 option proto 'dhcp'

 config switch
 option name 'switch0'
 option reset '1'
 option enable_vlan '1'

 config switch_vlan
 option device 'switch0'
 option vlan '1'
 option vid '1'
 option ports '0t 1t 2t 3t 4t'

 config switch_vlan
 option device 'switch0'
 option vlan '2'
 option ports '0t 3t'
 option vid '3'

 config interface 'antenna_1'
 option proto 'static'
 option ifname 'eth1.3'
 option ipaddr '172.22.66.10'
 option netmask '255.255.0.0'
 option gateway '192.168.1.160'

 config switch_vlan
 option device 'switch0'
 option vlan '3'
 option ports '0t 1 2 3t 4'
 option vid '7'


 e questo é il firewall

 root@OpenWrt:~# cat /etc/config/firewall

 config defaults
 option syn_flood '1'
 option input 'ACCEPT'
 option output 'ACCEPT'
 option forward 'ACCEPT'

 config zone
 option name 'lan'
 option input 'ACCEPT'
 option output 'ACCEPT'
 option forward 'ACCEPT'
 option network 'lan'

 config zone
 option name 'wan'
 option network 'wan'
 option input 'REJECT'
 option output 'ACCEPT'
 option forward 'REJECT'
 option masq '1'
 option mtu_fix '1'

 config rule
 option name 'Allow-DHCP-Renew'
 option src 'wan'
 option proto 'udp'
 option dest_port '68'
 option target 'ACCEPT'
 option family 'ipv4'

 config rule
 option name 'Allow-Ping'
 option src 'wan'
 option proto 'icmp'
 option icmp_type 'echo-request'
 option family 'ipv4'
 option target 'ACCEPT'

 config rule
 option name 'Allow-DHCPv6'
 option src 'wan'
 option proto 'udp'
 option src_ip 'fe80::/10'
 option src_port '547'
 option dest_ip 'fe80::/10'
 option dest_port '546'
 option family 'ipv6'
 option target 'ACCEPT'

 config rule
 option name 'Allow-ICMPv6-Input'
 option src 'wan'
 option proto 'icmp'
 list icmp_type 'echo-request'
 list icmp_type 'echo-reply'
 list icmp_type 'destination-unreachable'
 list icmp_type 'packet-too-big'
 list icmp_type 'time-exceeded'
 list icmp_type 'bad-header'
 list icmp_type 'unknown-header-type'
 list icmp_type 'router-solicitation'
 list icmp_type 'neighbour-solicitation'
 list icmp_type 'router-advertisement'
 list icmp_type 'neighbour-advertisement'
 option limit '1000/sec'
 option family 'ipv6'
 option target 'ACCEPT'

 config rule
 option name 'Allow-ICMPv6-Forward'
 option src 'wan'
 option dest '*'
 option proto 'icmp'
 list icmp_type 'echo-request'
 list icmp_type 'echo-reply'
 list icmp_type 'destination-unreachable'
 list icmp_type 'packet-too-big'
 list icmp_type 'time-exceeded'
 list icmp_type 'bad-header'
 list icmp_type 'unknown-header-type'
 option limit '1000/sec'
 option family 'ipv6'
 option target 'ACCEPT'

 config include
 option path '/etc/firewall.user'

 config forwarding
 option dest 'wan'
 option src 

Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-06 Per discussione Nicola Ruscitto
Ciao ragazzi,
la prova del router a terra con radio wa7510n openwrt ha dato esiti
positivi. Una volta impostate le vlan e caricato il modulo trelay
sull'antenna così come suggerito sulla guida, il router ha aggiornato la
sua tabella di routing aggiungendo il vicino.

Saluti
Nicola
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-03 Per discussione vilgio [BIGHAT]
Il giorno 03 aprile 2014 01:05, Nicola Ruscitto
nicolaruscitt...@gmail.comha scritto:

 Ciao,
 Ho un paio di tplink wa7510n con su caricato openwrt. Se installo olsrd
 sulle antenne funziona tutto. Ora vorrei fare delle prove con router a
 terra tplink wr841n con openwrt. Purtroppo non riesco a capire come
 configurare l'antenna in modalità bridge ovvero come creare un bridge tra
 vlanx e l'interfaccia wifi.

Stesso problema con il SW originale, in effetti senza brige ci potrebbero
essere dei problemi con il routing.
Il brige dovresti farlo con attraverso la funzione creates a bridge over
specified interface di Openwrt.




-- 
Villella Giovanni
http://www.giovannivillella.it
Telefono : 09841806618
FAX : 09841801305

vilgio [BIGHAT]

|_|0|_|
|_|_|0|
|0|0|0|

BLOG : www.vilgio.hacklab.info

Giovanni Villella
Email: villella.giova...@gmail.com
I use Free Software - Io uso il software libero

~~~
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-03 Per discussione Stefano De Carlo
Il 03/04/2014 01:05, Nicola Ruscitto ha scritto:

 Ciao,
 Ho un paio di tplink wa7510n con su caricato openwrt. Se installo
 olsrd sulle antenne funziona tutto. Ora vorrei fare delle prove con
 router a terra tplink wr841n con openwrt. Purtroppo non riesco a
 capire come configurare l'antenna in modalità bridge ovvero come
 creare un bridge tra vlanx e l'interfaccia wifi.


Ciao Nicola,

di default OpenWRT mette in bridge la wlan0 con eth0 (o eth0.x, qualora
ci fossero le due vlan di default, vedi HOWTO).
Vai in Interfaces  [Network Coperta dalla vlanx da bridgare]  Edit.
In Physical Settings selezioni Create a bridge over specified interface.
Inserisci nel bridge la VLANx di tuo gradimento e l'interfaccia wireless.

LuCI dovrebbe capire che deve togliere l'interfaccia wireless da dove
era precedentemente in bridge, per metterla nel bridge che vuoi tu.
Ma se riscontri problemi, puoi provare in un doppio passaggio
rimozione-wifi-dal-bridge-vecchio + aggiunta-wifi-al-bridge-con-vlan.

Uno dei TODO dell'howto è senza dubbio la sezione radio-openwrt :)

 Nella guida si parla di bridge tra queste due interfacce ma non si
 accenna ad un indirizzo ip che invece viene settato sul router a
 terra. È corretto?


Corretto. Niente IP sul bridge.

 Come fa il router a sapere dove mandare i pacchetti (attraverso la vlan3)?


OLSR, che aggiorna la tabella di routing specificando chiaramente qual'è
l'interfaccia di uscita (eth0.3). L'IP mancante sul bridge poco importa
in questa situazione. :)

Stefanauss.



signature.asc
Description: OpenPGP digital signature
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-03 Per discussione Gianmaria Allisiardi
Per questo ed altri documenti potrebbe tornare utile generare degli schemi
grafici con tool come questo:

http://www.gliffy.com/uses/network-diagram-software/

sono rapidi da usare e hanno già tutti gli elementi di rete che possono
servire.

Una volta aperto il progetto andare in basso a sx e caricare la libreria
network


Il giorno 03 aprile 2014 11:00, vilgio [BIGHAT] villella.giova...@gmail.com
 ha scritto:

 Il giorno 03 aprile 2014 01:05, Nicola Ruscitto 
 nicolaruscitt...@gmail.com ha scritto:

 Ciao,

 Ho un paio di tplink wa7510n con su caricato openwrt. Se installo olsrd
 sulle antenne funziona tutto. Ora vorrei fare delle prove con router a
 terra tplink wr841n con openwrt. Purtroppo non riesco a capire come
 configurare l'antenna in modalità bridge ovvero come creare un bridge tra
 vlanx e l'interfaccia wifi.

 Stesso problema con il SW originale, in effetti senza brige ci potrebbero
 essere dei problemi con il routing.
 Il brige dovresti farlo con attraverso la funzione creates a bridge over
 specified interface di Openwrt.




 --
 Villella Giovanni
 http://www.giovannivillella.it
 Telefono : 09841806618
 FAX : 09841801305
 
 vilgio [BIGHAT]

 |_|0|_|
 |_|_|0|
 |0|0|0|

 BLOG : www.vilgio.hacklab.info

 Giovanni Villella
 Email: villella.giova...@gmail.com
 I use Free Software - Io uso il software libero

 ~~~

 ___
 Wireless mailing list
 Wireless@ml.ninux.org
 http://ml.ninux.org/mailman/listinfo/wireless


___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-03 Per discussione Saverio Proto
Ecco un esempio di configurazione per fare il bridge da la vlan14 e
l'interfaccia WiFi

root@BM5NazzaOpenWrt:~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option proto 'static'
option ipaddr '10.135.1.14'
option netmask '255.255.255.0'
option gateway '10.135.1.8'
option dns 8.8.8.8

config interface 'quattordici'
option type bridge
option ifname 'eth0.14'


root@BM5NazzaOpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11na'
option macaddr '00:15:6d:8c:b8:c1'
option htmode 'HT20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option noscan '1'
option distance '9000'

config wifi-iface
option device 'radio0'
option encryption 'none'
option network 'quattordici'
option mode 'ap'
option isolate 1
option ssid 'ninux.org'

root@BM5NazzaOpenWrt:~#

Il 03 aprile 2014 01:05, Nicola Ruscitto nicolaruscitt...@gmail.com
ha scritto:
 Ciao,
 Ho un paio di tplink wa7510n con su caricato openwrt. Se installo olsrd
 sulle antenne funziona tutto. Ora vorrei fare delle prove con router a terra
 tplink wr841n con openwrt. Purtroppo non riesco a capire come configurare
 l'antenna in modalità bridge ovvero come creare un bridge tra vlanx e
 l'interfaccia wifi. Nella guida si parla di bridge tra queste due interfacce
 ma non si accenna ad un indirizzo ip che invece viene settato sul router a
 terra. È corretto? Come fa il router a sapere dove mandare i pacchetti
 (attraverso la vlan3)?

 Saluti
 Nicola


 ___
 Wireless mailing list
 Wireless@ml.ninux.org
 http://ml.ninux.org/mailman/listinfo/wireless

___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-03 Per discussione Nicola Ruscitto
Grazie ragazzi,
credo di aver capito. Farò un po di prove appena ho un po di tempo libero.
Vi farò sapere come va

Saluti
Nicola


Il giorno 03 aprile 2014 16:52, Gianmaria Allisiardi g.allisia...@gmail.com
 ha scritto:

 Per questo ed altri documenti potrebbe tornare utile generare degli schemi
 grafici con tool come questo:

 http://www.gliffy.com/uses/network-diagram-software/

 sono rapidi da usare e hanno già tutti gli elementi di rete che possono
 servire.

 Una volta aperto il progetto andare in basso a sx e caricare la libreria
 network


 Il giorno 03 aprile 2014 11:00, vilgio [BIGHAT] 
 villella.giova...@gmail.com ha scritto:

 Il giorno 03 aprile 2014 01:05, Nicola Ruscitto 
 nicolaruscitt...@gmail.com ha scritto:

 Ciao,

 Ho un paio di tplink wa7510n con su caricato openwrt. Se installo olsrd
 sulle antenne funziona tutto. Ora vorrei fare delle prove con router a
 terra tplink wr841n con openwrt. Purtroppo non riesco a capire come
 configurare l'antenna in modalità bridge ovvero come creare un bridge tra
 vlanx e l'interfaccia wifi.

 Stesso problema con il SW originale, in effetti senza brige ci
 potrebbero essere dei problemi con il routing.
 Il brige dovresti farlo con attraverso la funzione creates a bridge over
 specified interface di Openwrt.




 --
 Villella Giovanni
 http://www.giovannivillella.it
 Telefono : 09841806618
 FAX : 09841801305
 
 vilgio [BIGHAT]

 |_|0|_|
 |_|_|0|
 |0|0|0|

 BLOG : www.vilgio.hacklab.info

 Giovanni Villella
 Email: villella.giova...@gmail.com
 I use Free Software - Io uso il software libero

 ~~~

 ___
 Wireless mailing list
 Wireless@ml.ninux.org
 http://ml.ninux.org/mailman/listinfo/wireless



 ___
 Wireless mailing list
 Wireless@ml.ninux.org
 http://ml.ninux.org/mailman/listinfo/wireless


___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-02 Per discussione federico la morgia
Io credo che nel momento in cui si riuscirà a realizzare un cluster di routing 
a terra anche questo problema sarà sanato.
D'altra parte in azienda esistono sistemi ridondati che portano connettività ai 
rack server.
Noi in minuscolo basterebbe imparare a configurare 2 router di terra che 
cooperino per il rounting.
Credo che prima o poi qualche mago delle reti Ninux arriverà a mettere in piedi 
una soluzione del genere.
Ovviamente se poi entrambi i router uno li dovesse collegare allo stesso ups 
sarebbe vano tutto perchè rotto quell'ups il nodo comunque andrebbe giù.
Andando ad analizzare i singoli SPOF comunque una qualche soluzione efficente 
si potrebbe trovare.
Poi alla sfiga invece non c'è soluzione !
Grande benessere e tanta abbondanza !

Date: Tue, 1 Apr 2014 18:50:04 +0200
From: g.allisia...@gmail.com
To: wireless@ml.ninux.org
Subject: Re: [Ninux-Wireless] Ground Routing HOWTO

Il fatto di aver un apparato in più che eventualmente si può rompere ed un 
maggior consumo energetico sono comunque due aspetti negativi della scelta del 
ground routing. Sicuramente poi i pro sono maggiori dei contro. 

Il 01/apr/2014 18:42 Stefano De Carlo stefana...@gmail.com ha scritto:

Il 01/04/2014 14:20, Nemesis ha scritto:

 On 04/01/2014 01:36 PM, Massimiliano CARNEMOLLA wrote:

 On 30/03/2014 14.43, Stefano De Carlo wrote:

 https://docs.google.com/document/d/1tEp4rFNDis4RAwwo4wwg6xDMdqeJKAi8FVYh_FsPEdk/edit





 I miei complimenti a tutti, ottimo lavoro.

 Ottimo lavoro, grandi.



 E' già linkata sul wiki nella pagina GUIDE?



 Se così non fosse vi prego di farlo.



 Nemesis



Fatto.



Stefanauss.




___

Wireless mailing list

Wireless@ml.ninux.org

http://ml.ninux.org/mailman/listinfo/wireless




___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless   
  ___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-02 Per discussione Stefano De Carlo
Il 01/04/2014 18:50, Gianmaria Allisiardi ha scritto:

 Il fatto di aver un apparato in più che eventualmente si può rompere
 ed un maggior consumo energetico sono comunque due aspetti negativi
 della scelta del ground routing.


Ma non è così. :)
Che fai Ground Routing o meno, il router domestico ce l'hai comunque nel
99% dei casi.
Solo che non ci centralizzi la configurazione sopra.
Non hai un device in più.

Stefanauss.



signature.asc
Description: OpenPGP digital signature
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-02 Per discussione Gianmaria Allisiardi
Il giorno 02 aprile 2014 00:24, Stefano De Carlo stefana...@gmail.com ha
scritto:

 non è così. :)
 Che fai Ground Routing o meno, il router domestico ce l'hai comunque nel
 99% dei casi.
 Solo che non ci centralizzi la configurazione sopra.
 Non hai un device in più.


Scusa, leggendo il documento mi era sfuggito questo passaggio. E' chiaro.
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-01 Per discussione Massimiliano CARNEMOLLA

On 30/03/2014 14.43, Stefano De Carlo wrote:

https://docs.google.com/document/d/1tEp4rFNDis4RAwwo4wwg6xDMdqeJKAi8FVYh_FsPEdk/edit



I miei complimenti a tutti, ottimo lavoro.
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-01 Per discussione Nemesis
On 04/01/2014 01:36 PM, Massimiliano CARNEMOLLA wrote:
 On 30/03/2014 14.43, Stefano De Carlo wrote:
 https://docs.google.com/document/d/1tEp4rFNDis4RAwwo4wwg6xDMdqeJKAi8FVYh_FsPEdk/edit



 I miei complimenti a tutti, ottimo lavoro.

Ottimo lavoro, grandi.

E' già linkata sul wiki nella pagina GUIDE?

Se così non fosse vi prego di farlo.

Nemesis
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-01 Per discussione Stefano De Carlo
Il 01/04/2014 14:20, Nemesis ha scritto:
 On 04/01/2014 01:36 PM, Massimiliano CARNEMOLLA wrote:
 On 30/03/2014 14.43, Stefano De Carlo wrote:
 https://docs.google.com/document/d/1tEp4rFNDis4RAwwo4wwg6xDMdqeJKAi8FVYh_FsPEdk/edit


 I miei complimenti a tutti, ottimo lavoro.
 Ottimo lavoro, grandi.

 E' già linkata sul wiki nella pagina GUIDE?

 Se così non fosse vi prego di farlo.

 Nemesis

Fatto.

Stefanauss.



signature.asc
Description: OpenPGP digital signature
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-04-01 Per discussione Gianmaria Allisiardi
Il fatto di aver un apparato in più che eventualmente si può rompere ed un
maggior consumo energetico sono comunque due aspetti negativi della scelta
del ground routing. Sicuramente poi i pro sono maggiori dei contro.
Il 01/apr/2014 18:42 Stefano De Carlo stefana...@gmail.com ha scritto:

 Il 01/04/2014 14:20, Nemesis ha scritto:
  On 04/01/2014 01:36 PM, Massimiliano CARNEMOLLA wrote:
  On 30/03/2014 14.43, Stefano De Carlo wrote:
 
 https://docs.google.com/document/d/1tEp4rFNDis4RAwwo4wwg6xDMdqeJKAi8FVYh_FsPEdk/edit
 
 
  I miei complimenti a tutti, ottimo lavoro.
  Ottimo lavoro, grandi.
 
  E' già linkata sul wiki nella pagina GUIDE?
 
  Se così non fosse vi prego di farlo.
 
  Nemesis

 Fatto.

 Stefanauss.


 ___
 Wireless mailing list
 Wireless@ml.ninux.org
 http://ml.ninux.org/mailman/listinfo/wireless


___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-03-31 Per discussione Luca Postregna
ho letto la guida, bel lavoro.
due considerazioni

   - per la creazione e la gestione delle vlan/bridge sul router a terra
   metterei esempi di comandi shell basati su iproute2/brctl
   - per quel che riguarda openwrt lascierei perdere la configurazione via
   luci a scapito della configurazione manuale editando /etc/config/network

saluti
LP


2014-03-30 15:30 GMT+02:00 Massimiliano CARNEMOLLA massimili...@null.net:

 On 30/03/2014 14.43, Stefano De Carlo wrote:

 https://docs.google.com/document/d/1tEp4rFNDis4RAwwo4wwg6xDMdqeJK
 Ai8FVYh_FsPEdk/edit


 Grazie a tutti, scusatemi se vi ho rotto le scatole continuamente riguardo
 le lacune personali inerenti a questa tematica.
 ___
 Wireless mailing list
 Wireless@ml.ninux.org
 http://ml.ninux.org/mailman/listinfo/wireless




-- 
luca.postregna.name
twitter.com/lucapost
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-03-31 Per discussione Stefano De Carlo
Il 31/03/2014 11:06, Luca Postregna ha scritto:
 ho letto la guida, bel lavoro.
 due considerazioni

   * per la creazione e la gestione delle vlan/bridge sul router a
 terra metterei esempi di comandi shell basati su iproute2/brctl


Su OpenWRT, come hai detto tu, c'è /etc/config/network. Dove c'è un
framework/wrapper centralizzato delle impostazioni è meglio usar quello.
I comandi shell generici, che se uno proprio vuole si applicano anche su
OpenWRT, verranno trattati nella sezione Linux Box.

   * per quel che riguarda openwrt lascierei perdere la configurazione
 via luci a scapito della configurazione manuale editando
 /etc/config/network


Immagino intendessi a favore.
Eh, ma un motivo? :)

 saluti
 LP


Stefanauss.


signature.asc
Description: OpenPGP digital signature
___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless


Re: [Ninux-Wireless] Ground Routing HOWTO

2014-03-30 Per discussione Massimiliano CARNEMOLLA

On 30/03/2014 14.43, Stefano De Carlo wrote:

https://docs.google.com/document/d/1tEp4rFNDis4RAwwo4wwg6xDMdqeJKAi8FVYh_FsPEdk/edit



Grazie a tutti, scusatemi se vi ho rotto le scatole continuamente 
riguardo le lacune personali inerenti a questa tematica.

___
Wireless mailing list
Wireless@ml.ninux.org
http://ml.ninux.org/mailman/listinfo/wireless