Re: [WSG] lack of 'lang' attribute fails WAI

2007-09-09 Thread Patrick H. Lauke
Tee G. Peng wrote: Hi Andrew, I am curious, is there guideline from WCAG that state there should only be one language for the title? WCAG states that changes in language need to be identified. However, this can't be done in title, as that element can only carry PCDATA, so no inline elements

Re: [WSG] lack of 'lang' attribute fails WAI

2007-09-09 Thread Andrew Cunningham
On Sun, September 9, 2007 3:33 pm, Tee G. Peng wrote: On Sep 8, 2007, at 2:40 AM, Andrew Cunningham wrote: Hi Andrew, I am curious, is there guideline from WCAG that state there should only be one language for the title? Hi Tee, since Patrick has answered it, I'll jump to your last

Re: [WSG] lack of 'lang' attribute fails WAI

2007-09-08 Thread Andrew Cunningham
On Sat, September 8, 2007 8:32 am, Tee G. Peng wrote: There is also this possibility that a site needs two languages in one page, for instance, a site offers language learning. There is nothing wrong with pages have two or more languages for each page. Just as long as the CHANGE in

Re: Re: [WSG] lack of 'lang' attribute fails WAI

2007-09-08 Thread nroper
Thank you for your email. I shall be away from the office between September 8th and September 17th. If your enquiry is urgent, then please call my assistant on 01749 676798 in my absence. Kind regards, Nick Roper *** List

Re: [WSG] lack of 'lang' attribute fails WAI

2007-09-08 Thread Tee G. Peng
On Sep 8, 2007, at 2:40 AM, Andrew Cunningham wrote: Its passible to have metadata in more than one language, but it came become problematic. Anyway the title element should realistically only have one langauge. Hi Andrew, I am curious, is there guideline from WCAG that state there

Re: Re: [WSG] lack of 'lang' attribute fails WAI

2007-09-08 Thread nroper
Thank you for your email. I shall be away from the office between September 8th and September 17th. If your enquiry is urgent, then please call my assistant on 01749 676798 in my absence. Kind regards, Nick Roper *** List

Re: Re: Re: [WSG] lack of 'lang' attribute fails WAI

2007-09-08 Thread nroper
Thank you for your email. I shall be away from the office between September 8th and September 17th. If your enquiry is urgent, then please call my assistant on 01749 676798 in my absence. Kind regards, Nick Roper *** List

Re: [WSG] lack of 'lang' attribute fails WAI

2007-09-07 Thread Diego La Monica
I suggest to use for the default lang the language which starts the body: the first word is english or chinese? And for each section that is in the other language (that not is the default) you should specify the other language. I hope it will be hopefull. -- Diego La Monica Web:

Re: [WSG] lack of 'lang' attribute fails WAI

2007-09-07 Thread Jixor - Stephen I
I did read about this somewhere, I thought the guidelines touched upon it. Patrick Lauke wrote: Tee G. Peng I am working on a bilingual site (chinese/english) that needs to pass at least WCAG AA, the site is UTF-8 charset and I didn't use lang attribute in the meta because it's a

RE: [WSG] lack of 'lang' attribute fails WAI

2007-09-07 Thread Patrick Lauke
Tee G. Peng I am working on a bilingual site (chinese/english) that needs to pass at least WCAG AA, the site is UTF-8 charset and I didn't use lang attribute in the meta because it's a bilingual site. [...] What do you propose I should do to make the 'failure' goes away? Is every page

Re: [WSG] lack of 'lang' attribute fails WAI

2007-09-07 Thread Tee G. Peng
Patrick, Diego Jixor, thank you. Is every page on your site in both chinese and english, all in one page? Some pages contain two languages and that was the reason I thought 'lang=en' isn't quite appropriate. I guess I must draw the dice and pick one. According to WCAG 1.0: 4.3 Identify

RE: [WSG] lack of 'lang' attribute fails WAI

2007-09-07 Thread Kepler Gelotte
Some pages contain two languages and that was the reason I thought 'lang=en' isn't quite appropriate. ... Up till this point, the whole purpose of lang attribute is at fault. Will WCAG2 amend this or perhaps introduce a new attribute for bilingual site? Hi Tee, Personally I think

Re: [WSG] lack of 'lang' attribute fails WAI

2007-09-07 Thread Tee G. Peng
Hi Kepler, Personally I think it is an accessibility issue to mix two languages on the same page. I am not sure about this, I don't find it an issue at all, due to my background it's actually a rather common thing to read/speak two different langagues in a single conversation/page. If

RE: [WSG] lack of 'lang' attribute fails WAI

2007-09-07 Thread Kepler Gelotte
Wow!! Powered by Zencart! I know it's not ready for production environment, but did you check the Magento? Yes, I did look at Magneto briefly. I like their checkout screen much better than ZenCart's checkout process, but when I saw it was still Beta I decided I needed something more stable.