Re: [Xen-devel] [PATCH v2 00/13] Refactor common part of xen backend and frontend

2016-10-25 Thread Xuquan (Quan Xu)
On October 13, 2016 2:02 PM, Emil Condrea  wrote:
>This patch series was splitted from QEMU:Xen stubdom vTPM for HVM virtual
>machine http://markmail.org/message/fkix7g3a5zdj7lvr
>
>It contains a reorganization of xen backend and frontend functions together 
>with
>code style fixes.
>Common functions shared by backends and frontends are moved to xen_pvdev
>file.
>
>---
>Changes in v2:
>* fixed parameter alignment when spliting long lines
>* removed patches for creating xen_frontend
>

As I discussed with Paolo, we doesn't need to remove patches for creating 
xen_frontend.

Paolo, could you help me double check it?


Quan

>
>Emil Condrea (13):
>  xen: Fix coding style errors
>  xen: Fix coding style warnings
>  xen: Create a new file xen_pvdev.c
>  xen: Move xenstore_update to xen_pvdev.c
>  xen: Move evtchn functions to xen_pvdev.c
>  xen: Prepare xendev qtail to be shared with frontends
>  xen: Move xenstore cleanup and mkdir functions
>  xen: Rename xen_be_printf to xen_pv_printf
>  xen: Rename xen_be_unbind_evtchn
>  xen: Rename xen_be_send_notify
>  xen: Rename xen_be_evtchn_event
>  xen: Rename xen_be_find_xendev
>  xen: Rename xen_be_del_xendev
>
> hw/block/xen_disk.c  |  65 
> hw/char/xen_console.c|  32 ++--
> hw/display/xenfb.c   | 127 
> hw/net/xen_nic.c |  36 +++--
> hw/usb/xen-usb.c |  46 +++---
> hw/xen/Makefile.objs |   2 +-
> hw/xen/xen_backend.c | 348 +--
> hw/xen/xen_devconfig.c   |   4 +-
> hw/xen/xen_pvdev.c   | 316
>+++
> include/hw/xen/xen_backend.h |  72 +
> include/hw/xen/xen_pvdev.h   |  78 ++
> xen-common.c |   4 +-
> 12 files changed, 604 insertions(+), 526 deletions(-)  create mode 100644
>hw/xen/xen_pvdev.c  create mode 100644 include/hw/xen/xen_pvdev.h
>
>--
>1.9.1

___
Xen-devel mailing list
Xen-devel@lists.xen.org
https://lists.xen.org/xen-devel


Re: [Xen-devel] [PATCH v2 00/13] Refactor common part of xen backend and frontend

2016-10-13 Thread Emil Condrea
+ cc Paolo Bonzini

On Thu, Oct 13, 2016 at 9:01 AM, Emil Condrea  wrote:
> This patch series was splitted from QEMU:Xen stubdom vTPM for HVM virtual 
> machine
> http://markmail.org/message/fkix7g3a5zdj7lvr
>
> It contains a reorganization of xen backend and frontend functions together
> with code style fixes.
> Common functions shared by backends and frontends are moved to xen_pvdev file.
>
> ---
> Changes in v2:
> * fixed parameter alignment when spliting long lines
> * removed patches for creating xen_frontend
>
>
> Emil Condrea (13):
>   xen: Fix coding style errors
>   xen: Fix coding style warnings
>   xen: Create a new file xen_pvdev.c
>   xen: Move xenstore_update to xen_pvdev.c
>   xen: Move evtchn functions to xen_pvdev.c
>   xen: Prepare xendev qtail to be shared with frontends
>   xen: Move xenstore cleanup and mkdir functions
>   xen: Rename xen_be_printf to xen_pv_printf
>   xen: Rename xen_be_unbind_evtchn
>   xen: Rename xen_be_send_notify
>   xen: Rename xen_be_evtchn_event
>   xen: Rename xen_be_find_xendev
>   xen: Rename xen_be_del_xendev
>
>  hw/block/xen_disk.c  |  65 
>  hw/char/xen_console.c|  32 ++--
>  hw/display/xenfb.c   | 127 
>  hw/net/xen_nic.c |  36 +++--
>  hw/usb/xen-usb.c |  46 +++---
>  hw/xen/Makefile.objs |   2 +-
>  hw/xen/xen_backend.c | 348 
> +--
>  hw/xen/xen_devconfig.c   |   4 +-
>  hw/xen/xen_pvdev.c   | 316 +++
>  include/hw/xen/xen_backend.h |  72 +
>  include/hw/xen/xen_pvdev.h   |  78 ++
>  xen-common.c |   4 +-
>  12 files changed, 604 insertions(+), 526 deletions(-)
>  create mode 100644 hw/xen/xen_pvdev.c
>  create mode 100644 include/hw/xen/xen_pvdev.h
>
> --
> 1.9.1
>

___
Xen-devel mailing list
Xen-devel@lists.xen.org
https://lists.xen.org/xen-devel