Re: [PATCH for-9.1 v5 09/14] memory: Add Error** argument to .log_global_start() handler

2024-03-20 Thread Cédric Le Goater
On 3/20/24 15:42, Peter Xu wrote: On Wed, Mar 20, 2024 at 07:49:05AM +0100, Cédric Le Goater wrote: Modify all .log_global_start() handlers to take an Error** parameter and return a bool. Adapt memory_global_dirty_log_start() to interrupt on the first error the loop on handlers. In such case

[PATCH for-9.1 v5 09/14] memory: Add Error** argument to .log_global_start() handler

2024-03-20 Thread Cédric Le Goater
: Stefano Stabellini Cc: Anthony Perard Cc: Paul Durrant Cc: "Michael S. Tsirkin" Cc: Paolo Bonzini Cc: David Hildenbrand Signed-off-by: Cédric Le Goater --- Changes in v5: - Removed memory_global_dirty_log_rollback - Introduced memory_global_dirty_log_do_start() to call .log_gl

[PATCH for-9.1 v5 11/14] memory: Add Error** argument to the global_dirty_log routines

2024-03-20 Thread Cédric Le Goater
Cc: Paolo Bonzini Cc: David Hildenbrand Cc: Hyman Huang Signed-off-by: Cédric Le Goater --- Changes in v5: - Removed Yong Huang's R-b - Made use of ram_bitmaps_destroy() in ram_init_bitmaps() to cleanup allocated bitmaps include/exec/memory.h | 5 - hw/i386/xen/xen-hvm.c | 2 +-

Re: [PATCH v4 22/47] hw/arm/aspeed: use qemu_configure_nic_device()

2024-02-01 Thread Cédric Le Goater
On 1/26/24 18:24, David Woodhouse wrote: From: David Woodhouse Signed-off-by: David Woodhouse Acked-by: Cédric Le Goater and Reviewed-by: Cédric Le Goater Thanks, C. --- hw/arm/aspeed.c | 9 - 1 file changed, 4 insertions(+), 5 deletions(-) diff --git a/hw/arm/aspeed.c b

Re: [PATCH v3 22/46] hw/arm/aspeed: use qemu_configure_nic_device()

2024-01-16 Thread Cédric Le Goater
VICE(>soc->ftgmac100[i]), + true, NULL)) { + break; /* No configs left; stop asking */ } } Acked-by: Cédric Le Goater Thanks, C.

Re: [PATCH v3 5/5] Rename "QEMU global mutex" to "BQL" in comments and docs

2024-01-02 Thread Cédric Le Goater
i Acked-by: Markus Armbruster Reviewed-by: Philippe Mathieu-Daudé Reviewed-by: Cédric Le Goater Thanks, C.

Re: [PATCH v3 4/5] Replace "iothread lock" with "BQL" in comments

2024-01-02 Thread Cédric Le Goater
On 1/2/24 16:35, Stefan Hajnoczi wrote: The term "iothread lock" is obsolete. The APIs use Big QEMU Lock (BQL) in their names. Update the code comments to use "BQL" instead of "iothread lock". Signed-off-by: Stefan Hajnoczi Reviewed-by: Philippe Mathieu-Daudé

Re: [PATCH 4/6] system/cpus: rename qemu_global_mutex to qemu_bql

2023-11-30 Thread Cédric Le Goater
-by: Stefan Hajnoczi Reviewed-by: Cédric Le Goater Thanks, C.

Re: [PATCH 3/6] qemu/main-loop: rename qemu_cond_wait_iothread() to qemu_cond_wait_bql()

2023-11-30 Thread Cédric Le Goater
On 11/29/23 22:26, Stefan Hajnoczi wrote: The name "iothread" is overloaded. Use the term Big QEMU Lock (BQL) instead, it is already widely used and unambiguous. Signed-off-by: Stefan Hajnoczi Reviewed-by: Cédric Le Goater Thanks, C.

Re: [PATCH 2/6] qemu/main-loop: rename QEMU_IOTHREAD_LOCK_GUARD to QEMU_BQL_LOCK_GUARD

2023-11-30 Thread Cédric Le Goater
On 11/29/23 22:26, Stefan Hajnoczi wrote: The name "iothread" is overloaded. Use the term Big QEMU Lock (BQL) instead, it is already widely used and unambiguous. Signed-off-by: Stefan Hajnoczi Reviewed-by: Cédric Le Goater Thanks, C.

Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock()

2023-11-30 Thread Cédric Le Goater
mes. Subsequent patches will rename them. There are also comments and documentation that will be updated in later patches. Signed-off-by: Stefan Hajnoczi Reviewed-by: Cédric Le Goater Thanks, C.

Re: [PATCH 7/7] qobject atomics osdep: Make a few macros more hygienic

2023-09-01 Thread Cédric Le Goater
On 9/1/23 16:50, Markus Armbruster wrote: Cédric Le Goater writes: On 8/31/23 16:30, Eric Blake wrote: On Thu, Aug 31, 2023 at 03:25:46PM +0200, Markus Armbruster wrote: [This paragraph written last: Bear with my stream of consciousness review below, where I end up duplicating some

Re: [PATCH 7/7] qobject atomics osdep: Make a few macros more hygienic

2023-09-01 Thread Cédric Le Goater
On 8/31/23 16:30, Eric Blake wrote: On Thu, Aug 31, 2023 at 03:25:46PM +0200, Markus Armbruster wrote: [This paragraph written last: Bear with my stream of consciousness review below, where I end up duplicating some of the conslusions you reached before the point where I saw where the patch was

Re: [PATCH 3/3] Use g_new() & friends where that makes obvious sense

2022-03-14 Thread Cédric Le Goater
insertions(+), 202 deletions(-) PPC part: Reviewed-by: Cédric Le Goater Thanks, C.

Re: [patch] genirq/msi: Populate sysfs entry only once

2022-01-11 Thread Cédric Le Goater
of the loop so it works correctly for single and multi-MSI. Fixes: bf5e758f02fc ("genirq/msi: Simplify sysfs handling") Reported-by: Borislav Petkov Signed-off-by: Thomas Gleixner Reviewed-by: Cédric Le Goater Thanks, C. --- kernel/irq/msi.c | 11 +-- 1 file

Re: [patch V3 28/35] PCI/MSI: Simplify pci_irq_get_affinity()

2021-12-18 Thread Cédric Le Goater
see on my screen; open to ideas on that front! Bah. Fix below. That's a fix for the issue I was seeing on pseries with NVMe. Tested-by: Cédric Le Goater Thanks, C. Thanks, tglx --- diff --git a/drivers/pci/msi/msi.c b/drivers/pci/msi/msi.c index 71802410e2ab..9b4910befeda 100644 ---

Re: [patch V2 01/23] powerpc/4xx: Remove MSI support which never worked

2021-12-08 Thread Cédric Le Goater
On 12/7/21 21:42, Thomas Gleixner wrote: Cedric, On Tue, Dec 07 2021 at 16:50, Cédric Le Goater wrote: On 12/7/21 12:36, Michael Ellerman wrote: This patch should drop those selects I guess. Can you send an incremental diff for Thomas to squash in? Sure. Removing all the tendrils

Re: [patch V2 29/36] PCI/MSI: Simplify pci_irq_get_affinity()

2021-12-07 Thread Cédric Le Goater
Thomas, On 12/6/21 23:39, Thomas Gleixner wrote: Replace open coded MSI descriptor chasing and use the proper accessor functions instead. Signed-off-by: Thomas Gleixner Reviewed-by: Greg Kroah-Hartman Reviewed-by: Jason Gunthorpe --- drivers/pci/msi/msi.c | 26 ++

Re: [patch V2 01/23] powerpc/4xx: Remove MSI support which never worked

2021-12-07 Thread Cédric Le Goater
On 12/7/21 12:36, Michael Ellerman wrote: Cédric Le Goater writes: Hello Thomas, On 12/6/21 23:27, Thomas Gleixner wrote: This code is broken since day one. ppc4xx_setup_msi_irqs() has the following gems: 1) The handling of the result of msi_bitmap_alloc_hwirqs() is completely

Re: [patch V2 18/36] genirq/msi: Add msi_device_data::properties

2021-12-07 Thread Cédric Le Goater
properties(struct device *dev, unsigned long prop) +{ + if (WARN_ON_ONCE(!dev->msi.data)) + return ; + dev->msi.data->properties = 0; It would work better if the prop variable was used instead of 0. With that fixed, Reviewed-by: Cédric Le

Re: [patch V2 01/23] powerpc/4xx: Remove MSI support which never worked

2021-12-06 Thread Cédric Le Goater
Hello Thomas, On 12/6/21 23:27, Thomas Gleixner wrote: This code is broken since day one. ppc4xx_setup_msi_irqs() has the following gems: 1) The handling of the result of msi_bitmap_alloc_hwirqs() is completely broken: When the result is greater than or equal 0 (bitmap

Re: [patch 05/22] genirq/msi: Fixup includes

2021-11-30 Thread Cédric Le Goater
On 11/30/21 23:41, Thomas Gleixner wrote: On Tue, Nov 30 2021 at 23:10, Thomas Gleixner wrote: On Tue, Nov 30 2021 at 22:48, Cédric Le Goater wrote: On 11/29/21 22:38, Thomas Gleixner wrote: On Mon, Nov 29 2021 at 08:33, Cédric Le Goater wrote: thanks for having a look. I fixed up

Re: [patch 05/22] genirq/msi: Fixup includes

2021-11-30 Thread Cédric Le Goater
On 11/29/21 22:38, Thomas Gleixner wrote: Cedric, On Mon, Nov 29 2021 at 08:33, Cédric Le Goater wrote: On 11/27/21 02:18, Thomas Gleixner wrote: Remove the kobject.h include from msi.h as it's not required and add a sysfs.h include to the core code instead. Signed-off-by: Thomas Gleixner

Re: [patch 00/22] genirq/msi, PCI/MSI: Spring cleaning - Part 1

2021-11-29 Thread Cédric Le Goater
On 11/27/21 02:18, Thomas Gleixner wrote: The [PCI] MSI code has gained quite some warts over time. A recent discussion unearthed a shortcoming: the lack of support for expanding PCI/MSI-X vectors after initialization of MSI-X. PCI/MSI-X has no requirement to setup all vectors when MSI-X is

Re: [patch 17/22] PCI/MSI: Split out !IRQDOMAIN code

2021-11-28 Thread Cédric Le Goater
+void __weak arch_teardown_msi_irqs(struct pci_dev *dev) +{ + struct msi_desc *desc; + int i; + + for_each_pci_msi_entry(desc, dev) { + if (desc->irq) { + for (i = 0; i < entry->nvec_used; i++) I guess this is 'desc' ? Thanks, C. +

Re: [patch 17/22] PCI/MSI: Split out !IRQDOMAIN code

2021-11-28 Thread Cédric Le Goater
On 11/27/21 02:19, Thomas Gleixner wrote: Split out the non irqdomain code into its own file. Signed-off-by: Thomas Gleixner --- drivers/pci/msi/Makefile |5 ++-- drivers/pci/msi/legacy.c | 51 +++ drivers/pci/msi/msi.c| 46

Re: [patch 05/22] genirq/msi: Fixup includes

2021-11-28 Thread Cédric Le Goater
On 11/27/21 02:18, Thomas Gleixner wrote: Remove the kobject.h include from msi.h as it's not required and add a sysfs.h include to the core code instead. Signed-off-by: Thomas Gleixner This patch breaks compile on powerpc : CC arch/powerpc/kernel/msi.o In file included from

Re: [PATCH v2 3/3] net: checksum: Introduce fine control over checksum type

2020-12-11 Thread Cédric Le Goater
hardware behavior, introduce a 'csum_flag' parameter to the > net_checksum_calculate() API to allow fine control over what type > checksum is calculated. > > Existing users of this API are updated accordingly. > > Signed-off-by: Bin Meng For the ftgmac100 part, Review

Re: [PATCH 3/3] net: checksum: Introduce fine control over checksum type

2020-12-09 Thread Cédric Le Goater
Hello ! > diff --git a/hw/net/ftgmac100.c b/hw/net/ftgmac100.c > index 782ff19..fbae1f1 100644 > --- a/hw/net/ftgmac100.c > +++ b/hw/net/ftgmac100.c > @@ -573,7 +573,15 @@ static void ftgmac100_do_tx(FTGMAC100State *s, uint32_t > tx_ring, > } > > if (flags &

Re: [PATCH 4/5] [automated] Use OBJECT_DECLARE_TYPE when possible

2020-09-17 Thread Cédric Le Goater
f-by: Eduardo Habkost For the aspeed part, Reviewed-by: Cédric Le Goater > --- > Cc: Peter Maydell > Cc: Andrzej Zaborowski > Cc: Alistair Francis > Cc: Kevin Wolf > Cc: Max Reitz > Cc: Mark Cave-Ayland > Cc: David Gibson > Cc: Richard Henderson > Cc: David Hilden

Re: [PATCH 3/5] qom: Remove module_obj_name parameter from OBJECT_DECLARE* macros

2020-09-17 Thread Cédric Le Goater
UPPERCASE); > > Signed-off-by: Eduardo Habkost For the ppc part, Reviewed-by: Cédric Le Goater > --- > Cc: "Marc-André Lureau" > Cc: Gerd Hoffmann > Cc: "Michael S. Tsirkin" > Cc: "Daniel P. Berrangé" > Cc: Peter Maydell >

Re: [PATCH v2 1/8] hw/arm/aspeed: Correct DRAM container region size

2020-06-01 Thread Cédric Le Goater
0bfff (prio 0, ram): ram > c000- (prio 0, i/o): max_ram > > Reviewed-by: Peter Maydell > Signed-off-by: Philippe Mathieu-Daudé Reviewed-by: Cédric Le Goater Thanks, C. > --- > hw/arm/aspeed.c | 2 +- > 1 file changed, 1 insertion

Re: [PATCH v3 0/3] various: Remove unnecessary casts

2020-05-18 Thread Cédric Le Goater
On 5/18/20 3:17 PM, Markus Armbruster wrote: > Paolo Bonzini writes: > >> On 15/05/20 07:58, Markus Armbruster wrote: >>> Philippe Mathieu-Daudé writes: >>> Remove unnecessary casts using coccinelle scripts. The CPU()/OBJECT() patches don't introduce logical change, The

Re: [PATCH-for-5.1 3/3] hw: Remove unnecessary DEVICE() cast

2020-04-15 Thread Cédric Le Goater
@@ > typedef DeviceState; > DeviceState *s; > @@ > - DEVICE(s) > + s > > Signed-off-by: Philippe Mathieu-Daudé For ftgmac100, Reviewed-by: Cédric Le Goater > --- > hw/display/artist.c | 2 +- > hw/display/cg3.c| 2 +-

Re: [PATCH-for-5.1 1/3] target: Remove unnecessary CPU() cast

2020-04-15 Thread Cédric Le Goater
CPUState *s; > @@ > - CPU(s) > + s > > Signed-off-by: Philippe Mathieu-Daudé Reviewed-by: Cédric Le Goater > --- > target/ppc/mmu_helper.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/target/ppc/mmu_helper.c b/target/ppc/mm