Re: [PATCH v2 1/2] net: Provide MemReentrancyGuard * to qemu_new_nic()

2024-04-26 Thread BALATON Zoltan
seems to actually be commit a2e1753b8054344f32cf94f31c6399a58794a380 Regards, BALATON Zoltan

Re: [RFC PATCH-for-9.1 14/29] hw/i386/pc: Move pc_system_flash_create() to pc_pci_machine_initfn()

2024-03-28 Thread BALATON Zoltan
tem.flash0", "pflash0"); +pcms->flash[1] = pc_pflash_create(pcms, "system.flash1", "pflash1"); } This could just be inlined as it's called once, then no need for assert and a separate function. Regards, BALATON Zoltan void pc_system_flash_cleanup_unused(PCMachineState *pcms)

Re: [RFC PATCH-for-9.1 13/29] hw/i386/pc: Remove non-PCI code from pc_system_firmware_init()

2024-03-28 Thread BALATON Zoltan
r PCI PC machine now? Regards, BALATON Zoltan int i; BlockBackend *pflash_blk[ARRAY_SIZE(pcms->flash)]; -if (!pc_machine_is_pci_enabled(pcms)) { -x86_bios_rom_init(MACHINE(pcms), "bios.bin", rom_memory, true); -return; -} +assert(pc_machine_is_pci_e

Re: [RFC PATCH-for-9.1 09/29] hw/i386/pc: Pass PCMachineState argument to acpi_setup()

2024-03-28 Thread BALATON Zoltan
ACPI_PCIHP_BNMR_BASE 0x10 -void acpi_setup(void); +void acpi_setup(PCMachineState *pcms); This is changed to PcPciMachineState * in a following patch so can't you already introduce it here to avoid some churn? Regards, BALATON Zoltan Object *acpi_get_i386_pci_host(void); #endif diff --git a/hw

Re: [PATCH v3 01/29] bulk: Access existing variables initialized to >F when available

2024-01-29 Thread BALATON Zoltan
can drop the local and chnage next line to use >adb_bus instead. Regards, BALATON Zoltan dev, "adb.0"); adb_register_autopoll_callback(adb_bus, pmu_adb_poll, s); }

Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock()

2023-11-30 Thread BALATON Zoltan
xplainig here and there what bql stands for should be enough for new people to quickly find out. If we want to be more verbose how about "qemu_global_mutex" which is self describing but longer and does not resemble BQL so then comments may be needed to explain this is what was called BQL as wel

Re: [PATCH] bulk: Rename TARGET_FMT_plx -> HWADDR_FMT_plx

2023-01-10 Thread BALATON Zoltan
both TARGET_FMT_plx and HWADDR_PRIx? Why not just use HWADDR_PRIx instead? Regards, BALATON Zoltan

Re: [PATCH 9/9] exec/address-spaces: Inline legacy functions

2022-09-20 Thread BALATON Zoltan
ng because of misnaming sysemu as softmmu. Reagrds, BALATON Zoltan /** * Get the root memory region. This is a legacy function, provided for * compatibility. Prefer using SysBusState::system_memory directly. */ -MemoryRegion *get_system_memory(void); +inline MemoryRegion *get_sys

Re: [PATCH 8/9] softmmu/physmem: Let SysBusState absorb memory region and address space singletons

2022-09-20 Thread BALATON Zoltan
SysBusState anyway instead of accessing globals so is there a performance impact? Regards, BALATON Zoltan }; #define TYPE_SYS_BUS_DEVICE "sys-bus-device" diff --git a/softmmu/physmem.c b/softmmu/physmem.c index 0ac920d446..07e9a9171c 100644 --- a/softmmu/physmem.c +++ b/softmmu/phy

Re: [PATCH v2 04/11] hw/arm: Restrit KVM to the virt & versal machines

2021-02-22 Thread BALATON Zoltan
On Fri, 19 Feb 2021, Philippe Mathieu-Daudé wrote: Restrit KVM to the following ARM machines: Typo: "Restrict" (also in patch title). Regards, BALATON Zoltan - virt - xlnx-versal-virt Signed-off-by: Philippe Mathieu-Daudé --- hw/arm/virt.c | 5 + hw/arm/xlnx-ver

Re: [PATCH 1/5] hw/pci-host/bonito: Make PCI_ADDR() macro more readable

2020-10-12 Thread BALATON Zoltan
) << 8) + (regno)) Are you missing a << 8 somewhere before + (regno) or both of these are equally unreadable and I've missed something? This seems to be completely replaced by next patch so what's the point of this change? Regards, BALATON Zoltan typedef struct BonitoState BonitoState;

Re: [PATCH 24/26] hw/usb/usb-hcd: Use UHCI type definitions

2020-07-04 Thread BALATON Zoltan
On Sat, 4 Jul 2020, Philippe Mathieu-Daudé wrote: On 7/4/20 7:17 PM, BALATON Zoltan wrote: On Sat, 4 Jul 2020, Philippe Mathieu-Daudé wrote: Various machine/board/soc models create UHCI device instances with the generic QDEV API, and don't need to access USB internals. Simplify header

Re: [PATCH 25/26] hw/usb/usb-hcd: Use XHCI type definitions

2020-07-04 Thread BALATON Zoltan
w/usb" headers. Suggested-by: BALATON Zoltan Signed-off-by: Philippe Mathieu-Daudé --- hw/usb/hcd-xhci.h| 2 +- include/hw/usb/usb-hcd.h | 3 +++ hw/ppc/spapr.c | 2 +- 3 files changed, 5 insertions(+), 2 deletions(-) diff --git a/hw/usb/hcd-xhci.h b/hw/usb/hcd-xhci.h index

Re: [PATCH 24/26] hw/usb/usb-hcd: Use UHCI type definitions

2020-07-04 Thread BALATON Zoltan
w/usb" headers. Suggested-by: BALATON Zoltan Signed-off-by: Philippe Mathieu-Daudé --- include/hw/usb/usb-hcd.h | 6 ++ hw/i386/pc_piix.c| 3 ++- hw/i386/pc_q35.c | 13 +++-- hw/isa/piix4.c | 3 ++- hw/mips/fuloong2e.c | 5 +++-- hw/usb/hcd-uhci.c

Re: [PATCH 23/26] hw/usb/usb-hcd: Use EHCI type definitions

2020-07-04 Thread BALATON Zoltan
w/usb" headers. Suggested-by: BALATON Zoltan Signed-off-by: Philippe Mathieu-Daudé --- hw/usb/hcd-ehci.h | 11 +-- include/hw/usb/chipidea.h | 2 +- include/hw/usb/usb-hcd.h | 11 +++ hw/arm/allwinner-h3.c | 1 - hw/arm/exynos4210.c | 2 +- hw/arm/

Re: [PATCH 22/26] hw/usb/usb-hcd: Use OHCI type definitions

2020-07-04 Thread BALATON Zoltan
w/usb" headers. Suggested-by: BALATON Zoltan Signed-off-by: Philippe Mathieu-Daudé --- hw/usb/hcd-ohci.h| 2 +- include/hw/usb/usb-hcd.h | 16 I wonder if we need a new header for this or these could just go in the new public hw/usb/usb.h as machines creating a HC

Re: [Xen-devel] [Qemu-devel] [PATCH v3 1/5] elf: Add optional function ptr to load_elf() to parse ELF notes

2019-01-15 Thread BALATON Zoltan
usually NULL parameters so not adding one more which needs changing so many files seems like a good idea to me and it seems previously adding wrappers for this was the preferred way.. Regards, BALATON Zoltan which needs to read the XEN_ELFNOTE_PHYS32_ENTRY ELF Note while loading