Re: [Xen-devel] [PATCH v6 7/9] x86/mm: provide put_page_type_ptpg{, _preemptible}

2018-03-13 Thread Jan Beulich
>>> On 13.02.18 at 21:04,  wrote:
> @@ -2736,8 +2744,8 @@ int put_old_guest_table(struct vcpu *v)
>  if ( !v->arch.old_guest_table )
>  return 0;
>  
> -switch ( rc = _put_page_type(v->arch.old_guest_table, true,
> - v->arch.old_guest_ptpg) )
> +switch ( rc = put_page_type_ptpg_preemptible(v->arch.old_guest_table,
> + v->arch.old_guest_ptpg) )

Having looked briefly at patch 8, it looks like this - PV only
afaict - function is the only thing not being moved there, and
hence the only reason to have the helpers you introduce here.
Part of your problem is that a fair part of e.g. _put_page_type()
is PV-only, and hence would perhaps want moving or #ifdef-ing.

Jan


___
Xen-devel mailing list
Xen-devel@lists.xenproject.org
https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [PATCH v6 7/9] x86/mm: provide put_page_type_ptpg{, _preemptible}

2018-03-13 Thread Jan Beulich
>>> On 13.02.18 at 21:04,  wrote:
> And replace open-coded _put_page_type where the parent table parameter
> is not null.
> 
> This is in preparation for code movement in which various
> put_page_from_lNe will be moved to pv/mm.c.

I dislike both the proliferation of new functions here and, as
indicated before, them being non-static when they're used in
just a single source file. By this point in the series I have to
admit I'm not convinced of the direction all this is taking.

Jan


___
Xen-devel mailing list
Xen-devel@lists.xenproject.org
https://lists.xenproject.org/mailman/listinfo/xen-devel