[Xen-ia64-devel] [PATCH] [IOEMU] [IA64] Fix memory size calculation on VT-i over 3GB memory

2008-10-08 Thread KUWAMURA Shin'ya
Hi, VT-i domains have two memory holes: VGA I/O (under 1MB) and MMIO (3GB-4GB). This patch calculates the correct memory size with them. # This is based on xen-unstable 10936:a0b3cf802d99. Original patch by Zhang xiantao [EMAIL PROTECTED] Signed-off-by: KUWAMURA Shin'ya [EMAIL PROTECTED] Best

RE: [Xen-devel] Re: [Xen-ia64-devel] [PATCH 0/3] IA64: add cpufreq support

2008-10-08 Thread Yu, Ke
Hi Isaku, Thanks for tesing. Please see my comments below. Isaku Yamahata wrote: Hi Yu. I tested it and have some comments. - When I run xenpm, xen panics It panics at 0xf4000406ba91 = xen-unstable.hg/xen/drivers/acpi/pmstat.c:98 (addr2line told) It looks like

Re: [Xen-devel] Re: [Xen-ia64-devel] [PATCH 0/3] IA64: add cpufreq support

2008-10-08 Thread Isaku Yamahata
On Thu, Oct 09, 2008 at 10:34:00AM +0800, Yu, Ke wrote: Hi Isaku, Thanks for tesing. Please see my comments below. Isaku Yamahata wrote: Hi Yu. I tested it and have some comments. - When I run xenpm, xen panics It panics at 0xf4000406ba91 =

Re: [Xen-devel] Re: [Xen-ia64-devel] [PATCH 0/3] IA64: add cpufreq support

2008-10-08 Thread Isaku Yamahata
I forgot to attach the file. Now attached. I cut off it so that it includes only \_PR becuase it's long. If you need the full of it, please tell me. DefinitionBlock (DSDT.aml, DSDT, 1, Intel, SR870BN4, 0x) { Name (PMBS, 0x0C00) Name (PMLN, 0x08) Name (IOB1, 0x00) Name

Re: [Xen-devel] Re: [Xen-ia64-devel] [PATCH 0/3] IA64: add cpufreq support

2008-10-08 Thread Isaku Yamahata
On Thu, Oct 09, 2008 at 11:54:56AM +0900, Isaku Yamahata wrote: - From the boot message, ondemand governor fails to load. I'm not sure this error is expected because of my hardware. I guess this error case haven't been tested and that it caused the above panic. From the boot

RE: [Xen-devel] Re: [Xen-ia64-devel] [PATCH 0/3] IA64: add cpufreq support

2008-10-08 Thread Yu, Ke
Oh, looks like the BIOS is broken. From the _PSS object , only the P0 state is valid, other two P states P1 and P2 are all zeros. This is not correct. Can you try another machine? Best Regards Ke Isaku Yamahata wrote: I forgot to attach the file. Now attached. I cut off it so that it