Re: [XenPPC] JS20 hangs while 'Quiescing Open Firmware ...'

2006-09-14 Thread poff
SOL is broken on our older model bladecenter. To be clear, this is a problem with _your_specific_ blade center or older models if you can use SOL to talk to your linux console without Xen and you cannot _with_ Xen then we need to get to the bottom of that. SOL is broken on the 'older

Re: [XenPPC] JS20 hangs while 'Quiescing Open Firmware ...'

2006-09-14 Thread Jimi Xenidis
On Sep 14, 2006, at 10:23 AM, poff wrote: SOL is broken on our older model bladecenter. To be clear, this is a problem with _your_specific_ blade center or older models if you can use SOL to talk to your linux console without Xen and you cannot _with_ Xen then we need to get to the bottom

Re: [XenPPC] JS20 hangs while 'Quiescing Open Firmware ...'

2006-09-14 Thread Segher Boessenkool
SOL is broken on the 'older model' bladecenters - this has nothing to do with Xen, ie SOL does not work at all, Xen or not. When I place the blade in a newer bladecenter, SOL works ok. There might be a management module firmware update that fixes this for your older bladecenter. Segher

Re: [XenPPC] JS20 hangs while 'Quiescing Open Firmware ...'

2006-09-13 Thread Jimi Xenidis
You lost console. This can be deceiving. Blades have 2 UARTs and SLOF will multiplex output to both, but input from one. On Sep 13, 2006, at 11:58 AM, poff wrote: boot_of_probemem: memory 0x[0x2000] bootargs = xen console=com2 Here you announce that you will use com2 as

Re: [XenPPC] JS20 hangs while 'Quiescing Open Firmware ...'

2006-09-13 Thread poff
1. Omitting 'console=...' got things much further 2. Looks like system is now sitting with root prompt? Can ping, but ssh gets 'connection refused'. (and cannot type at serial port, per usual) In our lab, SOL is broken, so would really like ssh... from ofd_fixup.c: static char

Re: [XenPPC] JS20 hangs while 'Quiescing Open Firmware ...'

2006-09-13 Thread Hollis Blanchard
On Wed, 2006-09-13 at 14:27 -0400, poff wrote: 1. Omitting 'console=...' got things much further 2. Looks like system is now sitting with root prompt? Can ping, but ssh gets 'connection refused'. (and cannot type at serial port, per usual) How is that usual? In our lab, SOL is

Re: [XenPPC] JS20 hangs while 'Quiescing Open Firmware ...'

2006-09-13 Thread poff
If you want ssh, you need init scripts to run, so you're going to need to drop the init=/bin/bash here. Yes, that worked nicely - Was confused since when booting Dom0 with an nfs root, sshd comes up even though 'init=/sbin/quickinit noshell' ... looks like quickinit provides some services.

Re: [XenPPC] JS20 hangs while 'Quiescing Open Firmware ...'

2006-09-13 Thread Jimi Xenidis
On Sep 13, 2006, at 2:36 PM, Hollis Blanchard wrote: On Wed, 2006-09-13 at 14:27 -0400, poff wrote: 1. Omitting 'console=...' got things much further 2. Looks like system is now sitting with root prompt? Can ping, but ssh gets 'connection refused'. (and cannot type at serial port, per

Re: [XenPPC] JS20 hangs while 'Quiescing Open Firmware ...'

2006-09-13 Thread poff
hollis is correct, you should be able to get input even from SOL. The input is not working with _serial_ port. SOL is broken on our older model bladecenter. Will SOL be necessary for 'reasonable debugging'? ___ Xen-ppc-devel mailing list

Re: [XenPPC] JS20 hangs while 'Quiescing Open Firmware ...'

2006-09-13 Thread Jimi Xenidis
On Sep 13, 2006, at 5:01 PM, poff wrote: hollis is correct, you should be able to get input even from SOL. The input is not working with _serial_ port. SOL is broken on our older model bladecenter. To be clear, this is a problem with _your_specific_ blade center or older models if you

Re: [XenPPC] JS20 hangs while 'Quiescing Open Firmware ...'

2006-09-13 Thread Amos Waterland
On Wed, Sep 13, 2006 at 11:58:07AM -0500, [EMAIL PROTECTED] wrote: This can be deceiving. Blades have 2 UARTs and SLOF will multiplex output to both, but input from one. JS20 blades have only one UART wired up. We actually soldered a connecter for the second serial port for some our

Re: [XenPPC] JS20 hangs while 'Quiescing Open Firmware ...'

2006-09-13 Thread Hollis Blanchard
On Wed, 2006-09-13 at 17:12 -0400, Jimi Xenidis wrote: On Sep 13, 2006, at 5:01 PM, poff wrote: hollis is correct, you should be able to get input even from SOL. The input is not working with _serial_ port. SOL is broken on our older model bladecenter. To be clear, this is a