Re: [Xenomai-core] Analogy: idx_write_subd field in a4l_desc_t

2011-10-04 Thread Daniele Nicolodi
On 01/10/11 00:03, Alexis Berlemont wrote: I'm using xenomai-head on a 2.6.38.8 kernel on x86 with a NI-6251 DAQ board. In this configuration the idx_write_subd field of the a4l_desc_t structure filled by a4l_open() is not set to the proper value but is set to NULL. In previous

Re: [Xenomai-core] Analogy: idx_write_subd field in a4l_desc_t

2011-10-04 Thread Daniele Nicolodi
On 01/10/11 20:07, Gilles Chanteperdrix wrote: For API / ABI compatibility reasons, I waited a major release before removing the fields idx_{read, write}_subd. I should have thought twice before removing their initializations. I will fix that soon, sorry. 2.6 is a new major release, and not

Re: [Xenomai-core] Analogy: idx_write_subd field in a4l_desc_t

2011-10-04 Thread Gilles Chanteperdrix
On 10/04/2011 09:58 AM, Daniele Nicolodi wrote: On 01/10/11 20:07, Gilles Chanteperdrix wrote: For API / ABI compatibility reasons, I waited a major release before removing the fields idx_{read, write}_subd. I should have thought twice before removing their initializations. I will fix that

Re: [Xenomai-core] Analogy: idx_write_subd field in a4l_desc_t

2011-10-04 Thread Daniele Nicolodi
On 04/10/11 13:17, Gilles Chanteperdrix wrote: If you want things merged, send the patches, they will reach xenomai-head repository through Alex. Of course. Here is my simple patch. Thank you. Cheers, -- Daniele From 6944fe7465e1eb614cf9db3eccceb93d77bf95f1 Mon Sep 17 00:00:00 2001 From:

[Xenomai-core] patch: build: restore building of xeno-config man page

2011-10-04 Thread Daniele Nicolodi
Hello, here is a simple patch to the build system to restore the building of xeno-config man page. It got lost some time ago. I noticed that it was missing because debian packages failed to build. Cheers, -- Daniele From 958e522ea5aad32e9cd227e572be4ffbaff73ef9 Mon Sep 17 00:00:00 2001 From:

[Xenomai-core] patch: testsuite: add missing include

2011-10-04 Thread Daniele Nicolodi
Hello, the posix/leks regression test in the test suite failed to build on debian testing due to a missing include. The attached patch fixes the problem. Cheers, -- Daniele From 795a866c1080987ec772492fec223db8d1a2a4a8 Mon Sep 17 00:00:00 2001 From: Daniele Nicolodi nicol...@science.unitn.it