Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-20 Thread Gilles Chanteperdrix
Jan Kiszka wrote: Gilles Chanteperdrix wrote: Hi, I found some code which was referencing directly some CONFIG_XENO_OPT_DEBUG_ variables with things like: #ifdef CONFIG_XENO_OPT_DEBUG_FOO This usage is incompatible with the pre-requisites of the assert.h header that

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-20 Thread Gilles Chanteperdrix
Gilles Chanteperdrix wrote: This is complemented by a check_script whose result on the previous xenomai version you can see at: http://sisyphus.hd.free.fr/~gilles/bx/distcheck/xenomai/log.html Moved it to: http://sisyphus.hd.free.fr/~gilles/pastebin/wcZMMi to be able to run the build-test on

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Jan Kiszka wrote: Gilles Chanteperdrix wrote: Hi, I found some code which was referencing directly some CONFIG_XENO_OPT_DEBUG_ variables with things like: #ifdef CONFIG_XENO_OPT_DEBUG_FOO This usage is incompatible with the pre-requisites of the assert.h header that

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Jan Kiszka
Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Hi, I found some code which was referencing directly some CONFIG_XENO_OPT_DEBUG_ variables with things like: #ifdef CONFIG_XENO_OPT_DEBUG_FOO This usage is incompatible with the pre-requisites of the assert.h

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Philippe Gerum
On Mon, 2010-04-19 at 15:58 +0200, Gilles Chanteperdrix wrote: Hi, I found some code which was referencing directly some CONFIG_XENO_OPT_DEBUG_ variables with things like: #ifdef CONFIG_XENO_OPT_DEBUG_FOO This usage is incompatible with the pre-requisites of the assert.h header that

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Hi, I found some code which was referencing directly some CONFIG_XENO_OPT_DEBUG_ variables with things like: #ifdef CONFIG_XENO_OPT_DEBUG_FOO This usage is incompatible with the pre-requisites of

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Jan Kiszka
Gilles Chanteperdrix wrote: Hi, I found some code which was referencing directly some CONFIG_XENO_OPT_DEBUG_ variables with things like: #ifdef CONFIG_XENO_OPT_DEBUG_FOO This usage is incompatible with the pre-requisites of the assert.h header that CONFIG_XENO_OPT_DEBUG_FOO should be

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Jan Kiszka
Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Hi, I found some code which was referencing directly some CONFIG_XENO_OPT_DEBUG_ variables with things like: #ifdef CONFIG_XENO_OPT_DEBUG_FOO This usage is

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Hi, I found some code which was referencing directly some CONFIG_XENO_OPT_DEBUG_ variables with things like: #ifdef CONFIG_XENO_OPT_DEBUG_FOO This

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Jan Kiszka
Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Hi, I found some code which was referencing directly some CONFIG_XENO_OPT_DEBUG_ variables with things like: #ifdef

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Philippe Gerum
On Mon, 2010-04-19 at 17:58 +0200, Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Hi, I found some code which was referencing directly some

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Philippe Gerum
On Mon, 2010-04-19 at 18:14 +0200, Jan Kiszka wrote: Philippe Gerum wrote: On Mon, 2010-04-19 at 17:58 +0200, Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Jan Kiszka wrote: Philippe Gerum wrote: config XENO_OPT_DEBUG_FOO bool ... config XENO_OPT_DEBUG_FOO_P int default 1 if XENO_OPT_DEBUG_FOO default 0 and XENO_DEBUG() could be extended to test for CONFIG_XENO_OPT_DEBUG_FOO_P when given FOO. I'm just not sure if this can be

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Jan Kiszka
Philippe Gerum wrote: On Mon, 2010-04-19 at 18:25 +0200, Philippe Gerum wrote: On Mon, 2010-04-19 at 18:14 +0200, Jan Kiszka wrote: Philippe Gerum wrote: On Mon, 2010-04-19 at 17:58 +0200, Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Philippe Gerum
On Mon, 2010-04-19 at 19:22 +0200, Jan Kiszka wrote: Philippe Gerum wrote: On Mon, 2010-04-19 at 18:25 +0200, Philippe Gerum wrote: On Mon, 2010-04-19 at 18:14 +0200, Jan Kiszka wrote: Philippe Gerum wrote: On Mon, 2010-04-19 at 17:58 +0200, Jan Kiszka wrote: Gilles Chanteperdrix wrote:

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Philippe Gerum wrote: config XENO_OPT_DEBUG_FOO bool ... config XENO_OPT_DEBUG_FOO_P int default 1 if XENO_OPT_DEBUG_FOO default 0 and XENO_DEBUG() could be extended to test for

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Philippe Gerum wrote: config XENO_OPT_DEBUG_FOO bool ... config XENO_OPT_DEBUG_FOO_P int default 1 if XENO_OPT_DEBUG_FOO default 0 and XENO_DEBUG()

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Philippe Gerum wrote: config XENO_OPT_DEBUG_FOO bool ... config XENO_OPT_DEBUG_FOO_P int default 1 if XENO_OPT_DEBUG_FOO default 0 and XENO_DEBUG()

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Philippe Gerum wrote: config XENO_OPT_DEBUG_FOO bool ... config XENO_OPT_DEBUG_FOO_P int default 1 if XENO_OPT_DEBUG_FOO

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Jan Kiszka
Gilles Chanteperdrix wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Philippe Gerum wrote: config XENO_OPT_DEBUG_FOO bool ... config XENO_OPT_DEBUG_FOO_P int default 1 if

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Jan Kiszka wrote: Gilles Chanteperdrix wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Philippe Gerum wrote: config XENO_OPT_DEBUG_FOO bool ... config XENO_OPT_DEBUG_FOO_P int

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Jan Kiszka
Gilles Chanteperdrix wrote: Jan Kiszka wrote: My compiler still complains about undefined 'y0' in the enabled case. I'll try to dig into a different direction now: Automatic generation during build. This is what the kernel does as well when the preprocessor gives up. Would even save the

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: My compiler still complains about undefined 'y0' in the enabled case. I'll try to dig into a different direction now: Automatic generation during build. This is what the kernel does as well when the preprocessor gives up. Would

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Jan Kiszka
Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: My compiler still complains about undefined 'y0' in the enabled case. I'll try to dig into a different direction now: Automatic generation during build. This is what the kernel does as well when the

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: My compiler still complains about undefined 'y0' in the enabled case. I'll try to dig into a different direction now: Automatic generation during build. This is what the kernel

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Jan Kiszka
Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: My compiler still complains about undefined 'y0' in the enabled case. I'll try to dig into a different direction now: Automatic generation during

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: My compiler still complains about undefined 'y0' in the enabled case. I'll try to dig into a different direction now: Automatic

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Jan Kiszka
Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: Gilles Chanteperdrix wrote: Jan Kiszka wrote: My compiler still complains about undefined 'y0' in the enabled case. I'll try to dig into a different

Re: [Xenomai-core] [RFC] fix XENO_OPT_DEBUG bugs.

2010-04-19 Thread Gilles Chanteperdrix
Jan Kiszka wrote: diff --git a/scripts/prepare-kernel.sh b/scripts/prepare-kernel.sh index 24b1f17..d8038e0 100755 Please let me know what precisely you dislike in this approach. You have to re-run prepare-kernel when you modify the source. Normally, you have to anyway as you add some header