Re: [Xenomai-help] libnative and libxenomai dependy problem

2012-04-23 Thread Gilles Chanteperdrix
On 04/23/2012 03:57 AM, Willy Lambert wrote: 2012/4/23 Gilles Chanteperdrix gilles.chanteperd...@xenomai.org: On 04/23/2012 01:57 AM, Willy Lambert wrote: Hi, I just run into the same kind of problem of a one year old discussion :

Re: [Xenomai-help] Smi workaround on ICH8M

2012-04-23 Thread Gilles Chanteperdrix
On 04/23/2012 03:51 AM, Willy Lambert wrote: Hi, I have a message in dmesg about SMI workaround : Xenomai: SMI-enabled chipset found, but SMI workaround disabled (check CONFIG_XENO_HW_SMI_WORKAROUND). You may encounter high interrupt latencies! My kernel should be

Re: [Xenomai-help] Smi workaround on ICH8M

2012-04-23 Thread Philippe Gerum
On 04/23/2012 03:51 AM, Willy Lambert wrote: Hi, I have a message in dmesg about SMI workaround : Xenomai: SMI-enabled chipset found, but SMI workaround disabled (check CONFIG_XENO_HW_SMI_WORKAROUND). You may encounter high interrupt latencies! My kernel should be

Re: [Xenomai-help] Smi workaround on ICH8M

2012-04-23 Thread Willy Lambert
2012/4/23 Philippe Gerum r...@xenomai.org: On 04/23/2012 03:51 AM, Willy Lambert wrote: Hi, I have a message  in dmesg about SMI workaround : Xenomai: SMI-enabled chipset found, but SMI workaround disabled          (check CONFIG_XENO_HW_SMI_WORKAROUND). You may encounter          high

Re: [Xenomai-help] Smi workaround on ICH8M

2012-04-23 Thread Willy Lambert
2012/4/23 Willy Lambert lambert.wi...@gmail.com: 2012/4/23 Philippe Gerum r...@xenomai.org: On 04/23/2012 03:51 AM, Willy Lambert wrote: Hi, I have a message  in dmesg about SMI workaround : Xenomai: SMI-enabled chipset found, but SMI workaround disabled          (check

Re: [Xenomai-help] Smi workaround on ICH8M

2012-04-23 Thread Gilles Chanteperdrix
On 04/23/2012 01:05 PM, Willy Lambert wrote: 2012/4/23 Philippe Gerum r...@xenomai.org: On 04/23/2012 03:51 AM, Willy Lambert wrote: Hi, I have a message in dmesg about SMI workaround : Xenomai: SMI-enabled chipset found, but SMI workaround disabled (check

[Xenomai-help] Jitter while generating PWMs with GPIO from RTDM driver

2012-04-23 Thread Andrey Nechypurenko
Hi Folks, Following my tests with PWM generation using GPIO in user space [1], I've made the RTDM module [2] to further reduce the jitter. As a result, jitter was improved, but still under heavy system load the servo motor I am trying to control starts shaking. Now, I fill stuck and hope to get

Re: [Xenomai-help] Jitter while generating PWMs with GPIO from RTDM driver

2012-04-23 Thread Gilles Chanteperdrix
On 04/23/2012 01:56 PM, Andrey Nechypurenko wrote: Hi Folks, Following my tests with PWM generation using GPIO in user space [1], I've made the RTDM module [2] to further reduce the jitter. As a result, jitter was improved, but still under heavy system load the servo motor I am trying to

Re: [Xenomai-help] Jitter while generating PWMs with GPIO from RTDM driver

2012-04-23 Thread Andrey Nechypurenko
retval = rtdm_task_init(pwm_task[i], // there is currently only one element in this array                       pwm-task,                       pwm_task_proc,                       0,                       RTDM_TASK_HIGHEST_PRIORITY,                       2000); // 20ms period Do not

Re: [Xenomai-help] Jitter while generating PWMs with GPIO from RTDM driver

2012-04-23 Thread Gilles Chanteperdrix
On 04/23/2012 02:27 PM, Gilles Chanteperdrix wrote: On 04/23/2012 01:56 PM, Andrey Nechypurenko wrote: Hi Folks, Following my tests with PWM generation using GPIO in user space [1], I've made the RTDM module [2] to further reduce the jitter. As a result, jitter was improved, but still under

Re: [Xenomai-help] Jitter while generating PWMs with GPIO from RTDM driver

2012-04-23 Thread Gilles Chanteperdrix
On 04/23/2012 02:35 PM, Andrey Nechypurenko wrote: retval = rtdm_task_init(pwm_task[i], // there is currently only one element in this array pwm-task, pwm_task_proc, 0, RTDM_TASK_HIGHEST_PRIORITY,

Re: [Xenomai-help] Jitter while generating PWMs with GPIO from RTDM driver

2012-04-23 Thread Andrey Nechypurenko
retval = rtdm_task_init(pwm_task[i], // there is currently only one element in this array                       pwm-task,                       pwm_task_proc,                       0,                       RTDM_TASK_HIGHEST_PRIORITY,                       2000); // 20ms period Do not

Re: [Xenomai-help] Jitter while generating PWMs with GPIO from RTDM driver

2012-04-23 Thread Gilles Chanteperdrix
On 04/23/2012 02:51 PM, Gilles Chanteperdrix wrote: On 04/23/2012 02:35 PM, Andrey Nechypurenko wrote: retval = rtdm_task_init(pwm_task[i], // there is currently only one element in this array pwm-task, pwm_task_proc, 0,

Re: [Xenomai-help] Jitter while generating PWMs with GPIO from RTDM driver

2012-04-23 Thread Andrey Nechypurenko
Another trick, which this time really is a workaround is to program the timers to wake up a little bit early, and spin to wait for the exact time wanted. Sounds like the black magic exercise! :-) I would try to stay on the bright side as long as I can :-) Thanks Gilles! It is really great to

Re: [Xenomai-help] Jitter while generating PWMs with GPIO from RTDM driver

2012-04-23 Thread Philippe Gerum
On 04/23/2012 02:57 PM, Andrey Nechypurenko wrote: retval = rtdm_task_init(pwm_task[i], // there is currently only one element in this array pwm-task, pwm_task_proc, 0, RTDM_TASK_HIGHEST_PRIORITY,

Re: [Xenomai-help] Jitter while generating PWMs with GPIO from RTDM driver

2012-04-23 Thread Wolfgang Grandegger
On 04/23/2012 01:56 PM, Andrey Nechypurenko wrote: Hi Folks, Following my tests with PWM generation using GPIO in user space [1], I've made the RTDM module [2] to further reduce the jitter. As a result, jitter was improved, but still under heavy system load the servo motor I am trying to

Re: [Xenomai-help] Jitter while generating PWMs with GPIO from RTDM driver

2012-04-23 Thread Andrey Nechypurenko
Following my tests with PWM generation using GPIO in user space [1], I've made the RTDM module [2] to further reduce the jitter. As a result, jitter was improved, but still under heavy system load the servo motor I am trying to control starts shaking. Now, I fill stuck and hope to get some

Re: [Xenomai-help] Jitter while generating PWMs with GPIO from RTDM driver

2012-04-23 Thread Wolfgang Grandegger
On 04/23/2012 03:25 PM, Andrey Nechypurenko wrote: Following my tests with PWM generation using GPIO in user space [1], I've made the RTDM module [2] to further reduce the jitter. As a result, jitter was improved, but still under heavy system load the servo motor I am trying to control starts

[Xenomai-help] Using rt_dev_send from user space

2012-04-23 Thread Willy Lambert
Hi, The short story is that I tried to call rt_dev_send on a CAN RTDM driver, and it fails with an EPERM (Operation not permited) return code. It's as if I was using rtcansend without the RT_TASK rt_task_desc;. Is it an intended behavior ? Do I have a way to configure this to be accessible from

Re: [Xenomai-help] rt_event_wait makes linux crash if executed while debugging with gdbserver

2012-04-23 Thread Philippe Gerum
On 04/13/12 16:49, Fabio Visona wrote: Hello, I am trying to debug a Xenomai task through gdbserver over ethernet, with: gdbserver host:12345 --attach 240 where 240 is the PID of the Xenomai real-time task I want to debug. After connecting with the gdb client, running continuosly is fine,