Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-26 Thread Oversea Site via xmail
: Oversea Site via xmail xmail@xmailserver.org To: XMail Users Mailing List xmail@xmailserver.org Sent: Tue, May 26, 2015, 1:56 PM Subject: Re: [xmail] BUG : XMAIL 1.27 with SSL FEDORA 4 X86_64 GLIBC 2.3.6-3 (I can't upgrade it to the lastest version. Because I have a chiliasp 3.6.2 32-bit run ASP

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-26 Thread Bart Mortelmans via xmail
Subject: Re: [xmail] BUG : XMAIL 1.27 with SSL FEDORA 4 X86_64 GLIBC 2.3.6-3 (I can't upgrade it to the lastest version. Because I have a chiliasp 3.6.2 32-bit run ASP VBSCRIPT on APACHE 1.3 32-bit software, it need GLIBC 2.3.x and Kernel 2.6) KERNEL 3.3 MOD FROM FC15 (It will display KERNEL

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-26 Thread U.Mutlu via xmail
Oversea Site via xmail wrote on 05/26/2015 07:56 AM: Anyway I will test this issue in other linux distribution in VM, such as CentOS. (You can give me any linux distribution, let's build the same platform in VM. I use virtualbox. If you could test it with Debian 7 (wheezy) i386, that would

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-26 Thread Oversea Site via xmail
STUNNEL to do a POP3 tunnel again, the problem will fix. Original Message From: Bart Mortelmans b...@bim.be To: t...@os.st, XMail Users Mailing List xmail@xmailserver.org Sent: Tue, May 26, 2015, 3:13 PM Subject: Re: [xmail] BUG : XMAIL 1.27 with SSL Is there any way for you to test

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-26 Thread Bart Mortelmans via xmail
@xmailserver.org Sent: Tue, May 26, 2015, 1:56 PM Subject: Re: [xmail] BUG : XMAIL 1.27 with SSL FEDORA 4 X86_64 GLIBC 2.3.6-3 (I can't upgrade it to the lastest version.. Because I have a chiliasp 3.6.2 32-bit run ASP VBSCRIPT on APACHE 1.3 32-bit software, it need GLIBC 2.3.x and Kernel 2.6) KERNEL

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-26 Thread U.Mutlu via xmail
Bart Mortelmans via xmail wrote on 05/26/2015 03:55 PM: It might be difficult to determine if the problem is with XMail or with the client. And even if for example Tencent actually closes the connection incorrectly, it should be better if XMail would be able to handle such an improperly closed

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-26 Thread U.Mutlu via xmail
of the sockets they create. cu Uenal Original Message From: Bart Mortelmans b...@bim.be To: t...@os.st, XMail Users Mailing List xmail@xmailserver.org Sent: Tue, May 26, 2015, 3:13 PM Subject: Re: [xmail] BUG : XMAIL 1.27 with SSL Is there any way for you to test if the problem exists if you

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-26 Thread U.Mutlu via xmail
U.Mutlu via xmail wrote on 05/26/2015 04:38 PM: Bart Mortelmans via xmail wrote on 05/26/2015 03:55 PM: It might be difficult to determine if the problem is with XMail or with the client. And even if for example Tencent actually closes the connection incorrectly, it should be better if XMail

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-25 Thread U.Mutlu via xmail
Oversea Site via xmail wrote on 05/25/2015 09:23 PM: I found the bug on XMAIL 1.27 with SSL (POP3S is main), SSMTP service maybe has a same bug too 1. it will have too many FIN_WAIT_2 on POP3S with two many requests, It is because of some non-popular WINDOWS CLIENT e.g. tencent foxmail ,

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-25 Thread U.Mutlu via xmail
, May 26, 2015, 10:11 AM Subject: Re: [xmail] BUG : XMAIL 1.27 with SSL Oversea Site via xmail wrote on 05/25/2015 09:23 PM: I found the bug on XMAIL 1.27 with SSL (POP3S is main), SSMTP service maybe has a same bug too 1. it will have too many FIN_WAIT_2 on POP3S with two many requests

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-25 Thread U.Mutlu via xmail
U.Mutlu via xmail wrote on 05/26/2015 07:06 AM: Oversea Site via xmail wrote on 05/26/2015 05:14 AM: No Log Error. No Fatal Error log. No Core Dump It's not RAM or HW problem. It's XMAIL internal issue, because when I switch to stunnel, all problems solved. And then when I test K9-MAIL with

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-25 Thread Oversea Site via xmail
[root@bravo logs]# cat /proc/sys/net/ipv4/tcp_fin_timeout 10 [root@bravo logs]# Original Message From: U.Mutlu via xmail xmail@xmailserver.org To: U.Mutlu um4...@mutluit.com, XMail Users Mailing List xmail@xmailserver.org Sent: Tue, May 26, 2015, 1:28 PM Subject: Re: [xmail] BUG

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-25 Thread Oversea Site via xmail
26, 2015, 1:06 PM Subject: Re: [xmail] BUG : XMAIL 1.27 with SSL Oversea Site via xmail wrote on 05/26/2015 05:14 AM: No Log Error. No Fatal Error log. No Core Dump It's not RAM or HW problem. It's XMAIL internal issue, because when I switch to stunnel, all problems solved. And then when I

Re: [xmail] BUG : XMAIL 1.27 with SSL

2015-05-25 Thread Oversea Site via xmail
: Tue, May 26, 2015, 10:11 AM Subject: Re: [xmail] BUG : XMAIL 1.27 with SSL Oversea Site via xmail wrote on 05/25/2015 09:23 PM: I found the bug on XMAIL 1.27 with SSL (POP3S is main), SSMTP service maybe has a same bug too 1. it will have too many FIN_WAIT_2 on POP3S with two many requests