Re: [PATCH 1/4] shadowfb calls GetGlyphs() so list libXfont as a dependency

2012-06-25 Thread Yaakov (Cygwin/X)
On Sun, 2012-06-24 at 09:31 -0700, Alan Coopersmith wrote: I was thinking of making it so that libXfont didn't call those functions directly, but required the caller to call a new init callbacks API that passed in pointers to them, much like the RegisterFPEFunctions functions does for each

Re: [PATCH] xkb: fill in keycode and event type for slow keys enablement

2012-06-25 Thread Daniel Stone
Hi, On 25 June 2012 03:16, Peter Hutterer peter.hutte...@who-t.net wrote: @@ -462,15 +469,18 @@ AccessXFilterPressEvent(DeviceEvent *event, DeviceIntPtr keybd)     if (ctrls-enabled_ctrls XkbAccessXKeysMask) {         /* check for magic sequences */         if ((sym[0] == XK_Shift_R) ||

Re: [PATCH 01/14] xfree86: use udev to provide device enumeration for kms devices (v9)

2012-06-25 Thread Dave Airlie
On Wed, Jun 20, 2012 at 9:10 PM, Keith Packard kei...@keithp.com wrote: Dave Airlie airl...@gmail.com writes: +        else if (strcmp(udev_device_get_subsystem(udev_device), drm)) +            goto no_probe; +        else if (strncmp(sysname, card, 4)) +            goto no_probe; bikeshed

resend first few reviewed patches for hotplug

2012-06-25 Thread Dave Airlie
These 7 patches replace the first 6 of the previous series, after Keith's review. The new patch just cleans up some code before we add gpu support to it making the patches cleaner. Dave. ___ xorg-devel@lists.x.org: X.Org development Archives:

[PATCH 1/7] xf86: cursor code got mangled by indenting

2012-06-25 Thread Dave Airlie
From: Dave Airlie airl...@redhat.com This fixes some really ugly code that got mangled by the indenting. Signed-off-by: Dave Airlie airl...@redhat.com --- hw/xfree86/ramdac/xf86Cursor.c | 31 +++ 1 file changed, 11 insertions(+), 20 deletions(-) diff --git

[PATCH 5/7] xf86: cleanup helper code to use a pointer.

2012-06-25 Thread Dave Airlie
From: Dave Airlie airl...@redhat.com This is in preparation for gpu screens in here, just use a pScrn pointer to point at the new screen. Signed-off-by: Dave Airlie airl...@redhat.com --- hw/xfree86/common/xf86Helper.c | 18 ++ 1 file changed, 10 insertions(+), 8 deletions(-)

[PATCH 3/7] screen: split out screen init code. (v2)

2012-06-25 Thread Dave Airlie
From: Dave Airlie airl...@redhat.com This is a precursor for reusing this code to init gpu screens. v2: fixup int check as per Keith's review. Signed-off-by: Dave Airlie airl...@redhat.com --- dix/dispatch.c | 44 +++- 1 file changed, 27 insertions(+),

[PATCH 4/7] dix: introduce gpu screens. (v3)

2012-06-25 Thread Dave Airlie
From: Dave Airlie airl...@redhat.com This patch introduces gpu screens into screenInfo. It adds interfaces for adding and removing gpu screens, along with adding private fixup, block handler support, and scratch pixmap init. GPU screens have a myNum that is offset by GPU_SCREEN_OFFSET (256),

[PATCH 6/7] xfree86: add DDX gpu screen support. (v3)

2012-06-25 Thread Dave Airlie
From: Dave Airlie airl...@redhat.com This just adds the structures and interfaces required for adding/deleteing gpu screens at the DDX level. The platform probe can pass a new flag to the driver, so they can call xf86AllocateScreen and pass back the new gpu screen flag. It also calls the gpu

[PATCH 7/7] xserver/config: add udev/drm hotplug callbacks. (v2)

2012-06-25 Thread Dave Airlie
From: Dave Airlie airl...@redhat.com This adds callbacks into the ddx for udev gpu hotplug. v2: fix some strncmp returns. Reviewed-by: Keith Packard kei...@keithp.com Signed-off-by: Dave Airlie airl...@redhat.com --- config/udev.c | 42 ++

[PATCH 1/2] Revert the unused 1.4.0 protocol

2012-06-25 Thread Dave Airlie
From: Dave Airlie airl...@redhat.com This patch reverts: Revert Make SetCrtcConfigs take flags bits to allow partial configuration changes This reverts commit 105a161a3f5fb67f5fe7e4119629d424672804aa. Revert Define new semantics for scanout pixmap destruction. This reverts commit

[PATCH 2/2] randr: add provider object (v3.1)

2012-06-25 Thread Dave Airlie
From: Dave Airlie airl...@redhat.com A provider object represents a GPU or virtual device that provides rendering or output services to the X server. This is the first rev of a protocol to enumerate providers devices, set their roles, and provide generic properties based on output properties for

Re: [PATCH 00/19] Reworking initializion of data sent to clients

2012-06-25 Thread Alan Coopersmith
On 06/25/12 02:38 AM, Michal Suchanek wrote: Hello, thanks for these patches. These will hopefully quiet valgrind complaints about garbage. Yes, that was another motivation - it should help silence a lot of false alarms about reading uninitialized padding values when writing to clients, at

Re: [PATCH xev] Add a -event parameter to control the event mask

2012-06-25 Thread Aaron Plattner
On 06/24/2012 06:21 PM, Peter Hutterer wrote: On Fri, Jun 22, 2012 at 01:45:47PM -0700, Aaron Plattner wrote: It's annoying to have to sift through a lot of unrelated events if all you care about is one specific class of events (e.g. RandR events). Add a -event parameter that can be used to

Re: [PATCH 01/14] xfree86: use udev to provide device enumeration for kms devices (v9)

2012-06-25 Thread Michal Srb
On Thursday 14 of June 2012 15:43:35 Dave Airlie wrote: +int +xf86platformProbeDev(DriverPtr drvp) +{ +Bool foundScreen = FALSE; +GDevPtr *devList; +const unsigned numDevs = xf86MatchDevice(drvp-driverName, devList); +int i, j; + +/* find the main device or any device

Re: [PATCH 01/14] xfree86: use udev to provide device enumeration for kms devices (v9)

2012-06-25 Thread Dave Airlie
On Mon, Jun 25, 2012 at 4:56 PM, Michal Srb m...@suse.com wrote: On Thursday 14 of June 2012 15:43:35 Dave Airlie wrote: +int +xf86platformProbeDev(DriverPtr drvp) +{ +    Bool foundScreen = FALSE; +    GDevPtr *devList; +    const unsigned numDevs = xf86MatchDevice(drvp-driverName,

Re: [PATCH 1/2] Revert the unused 1.4.0 protocol

2012-06-25 Thread Keith Packard
Dave Airlie airl...@gmail.com writes: None of this was ever used in the X server and I think it should probably be addressed in smaller pieces later. Signed-off-by: Dave Airlie airl...@redhat.com Acked-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpex4FDR2sS9.pgp

Re: [PATCH 1/7] xf86: cursor code got mangled by indenting

2012-06-25 Thread Keith Packard
Dave Airlie airl...@gmail.com writes: From: Dave Airlie airl...@redhat.com This fixes some really ugly code that got mangled by the indenting. Signed-off-by: Dave Airlie airl...@redhat.com Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpM47QKwlxp2.pgp

Re: [PATCH xev] Add a -event parameter to control the event mask

2012-06-25 Thread Peter Hutterer
On Mon, Jun 25, 2012 at 07:54:25AM -0700, Aaron Plattner wrote: On 06/24/2012 06:21 PM, Peter Hutterer wrote: On Fri, Jun 22, 2012 at 01:45:47PM -0700, Aaron Plattner wrote: It's annoying to have to sift through a lot of unrelated events if all you care about is one specific class of events

[PATCH xev v2] Add a -event parameter to control the event mask

2012-06-25 Thread Aaron Plattner
It's annoying to have to sift through a lot of unrelated events if all you care about is one specific class of events (e.g. RandR events). Add a -event parameter that can be used to tune which events to select. When not specified, all events are selected. Signed-off-by: Aaron Plattner

[PATCH xev v3] Add a -event parameter to control the event mask

2012-06-25 Thread Peter Hutterer
From: Aaron Plattner aplatt...@nvidia.com It's annoying to have to sift through a lot of unrelated events if all you care about is one specific class of events (e.g. RandR events). Add a -event parameter that can be used to tune which events to select. When not specified, all events are

[PATCH 0/4] some coverity fixes

2012-06-25 Thread Peter Hutterer
Amidst a bunch of false positives, these 4 are real and easy-to-address fixes. There may be more coming up if I find the time. Cheers, Peter ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info:

[PATCH 1/4] xfree86: fix use-after-free issue in checkInput

2012-06-25 Thread Peter Hutterer
*dev is the condition of the while loop we're in, reset to NULL after freeing Signed-off-by: Peter Hutterer peter.hutte...@who-t.net --- hw/xfree86/common/xf86Config.c |1 + 1 file changed, 1 insertion(+) diff --git a/hw/xfree86/common/xf86Config.c b/hw/xfree86/common/xf86Config.c index

[PATCH 2/4] dix: fix dereference before null check

2012-06-25 Thread Peter Hutterer
Found by Coverity. Signed-off-by: Peter Hutterer peter.hutte...@who-t.net --- dix/touch.c |4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/dix/touch.c b/dix/touch.c index aa17faf..8799502 100644 --- a/dix/touch.c +++ b/dix/touch.c @@ -160,11 +160,13 @@

[PATCH 3/4] dix: fix memory leak in TouchEventHistoryReplay

2012-06-25 Thread Peter Hutterer
Don't leak if ti-history is NULL. Found by coverity. Signed-off-by: Peter Hutterer peter.hutte...@who-t.net --- dix/touch.c |7 +-- 1 file changed, 5 insertions(+), 2 deletions(-) diff --git a/dix/touch.c b/dix/touch.c index 8799502..fcf7dd5 100644 --- a/dix/touch.c +++ b/dix/touch.c

[PATCH 4/4] Xi: extend PropagateMask to EMASKSIZE

2012-06-25 Thread Peter Hutterer
Number of devices is 2 + MAXDEVICES, with index 0 and 1 reserved for XIAll{Master}Devices. At the current size, PropagateMask would be overrun in RecalculateDeviceDeliverableEvents(). Found by Coverity. Signed-off-by: Peter Hutterer peter.hutte...@who-t.net --- Xi/extinit.c |2 +- 1 file

[PATCH] dri2: Fix authentication for v8 clients.

2012-06-25 Thread Christopher James Halse Rogers
The legacy logic was embarassingly wrong; AuthMagic should return errno, so returning FALSE only when AuthMagic returns nonzero is exactly wrong. https://bugs.freedesktop.org/show_bug.cgi?id=51400 Signed-off-by: Christopher James Halse Rogers christopher.halse.rog...@canonical.com ---

Re: [PATCH xev v3] Add a -event parameter to control the event mask

2012-06-25 Thread Peter Hutterer
On Mon, Jun 25, 2012 at 05:01:20PM -0700, Aaron Plattner wrote: On 06/25/2012 04:52 PM, Peter Hutterer wrote: From: Aaron Plattner aplatt...@nvidia.com It's annoying to have to sift through a lot of unrelated events if all you care about is one specific class of events (e.g. RandR events).

Re: [PATCH xev v3] Add a -event parameter to control the event mask

2012-06-25 Thread Aaron Plattner
On 06/25/2012 04:52 PM, Peter Hutterer wrote: From: Aaron Plattner aplatt...@nvidia.com It's annoying to have to sift through a lot of unrelated events if all you care about is one specific class of events (e.g. RandR events). Add a -event parameter that can be used to tune which events to

[PATCH v2] xkb: fill in keycode and event type for slow keys enablement

2012-06-25 Thread Peter Hutterer
eventType is set for the type that triggered a XkbControlsNotify event. Technically, SlowKeys is triggered by a timer which doesn't have a matching core event type. So we used to use 0 here. Practically, the timer is triggered by a key press + hold and cancelled when the key is released before

[PATCH synaptics 1/2] eventcomm: simplify conditions

2012-06-25 Thread Peter Hutterer
As of 3f9794a8a0f019a4b153941c9ec1927c7797ce6f, slot_index is always = 0 when we get to either of these conditions. Signed-off-by: Peter Hutterer peter.hutte...@who-t.net --- src/eventcomm.c | 31 +++ 1 file changed, 11 insertions(+), 20 deletions(-) diff --git

[PATCH synaptics 2/2] eventcomm: proto_data is not null, don't check

2012-06-25 Thread Peter Hutterer
We allocate it just a few lines north of here, and already dereferenced it. Signed-off-by: Peter Hutterer peter.hutte...@who-t.net --- src/eventcomm.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/eventcomm.c b/src/eventcomm.c index 84f929f..172a59e 100644 ---

Re: [PATCH 0/3] Make pseudoramiX available to hw/xwin

2012-06-25 Thread Yaakov (Cygwin/X)
On Fri, 2012-06-22 at 14:56 +0100, Jon TURNEY wrote: Jon TURNEY (3): Various fixes for pseudoramiX.c Fix pseudoramiX.c compilation without darwin.h Move pseudoramiX code from hw/xquartz to top-level Makefile.am |2 + configure.ac|