Re: [PATCH 18/36] privates: when pixmap privates increase, bump the totalPixmapSize

2012-07-03 Thread Dave Airlie
On Tue, Jul 3, 2012 at 7:49 PM, Keith Packard kei...@keithp.com wrote: Dave Airlie airl...@gmail.com writes: On Tue, Jul 3, 2012 at 7:26 PM, Keith Packard kei...@keithp.com wrote: This sounds like what we want, do we have any examples of this sort of thing already, I could take a look

Re: [PATCH 08/36] xfree86: add platform bus hotplug support (v2)

2012-07-03 Thread Keith Packard
Dave Airlie airl...@gmail.com writes: It uses one private in the prime code for pixmaps, as it has to store the framebuffer id in it for slave scanout pixmap. Ok, so it's only touching pixmaps at least. If we add privates API to allocate private screen space, then we can change the

Re: [PATCH] randr: add provider object (v7)

2012-07-03 Thread Dave Airlie
On Tue, Jul 3, 2012 at 7:01 PM, Keith Packard kei...@keithp.com wrote: Dave Airlie airl...@gmail.com writes: The current problem is I'm not sure any OS exposes muxless and mux in one OS. Mac OSX always uses muxed, Vista the same, and I think Windows 7 always exposes muxless if the bios

Re: [PATCH] glx: Revert part of 9838b703

2012-07-03 Thread Ian Romanick
On 07/02/2012 06:29 PM, Eric Anholt wrote: Ian Romanicki...@freedesktop.org writes: From: Ian Romanickian.d.roman...@intel.com The server does not want GL extension prototypes. It never links with anything that could possibly provide implementations of these functions. It *is* the provide,

Re: [PATCH 04/19] Use C99 designated initializers in dix Replies

2012-07-03 Thread Alan Coopersmith
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 07/ 2/12 10:47 AM, Keith Packard wrote: Alan Coopersmith alan.coopersm...@oracle.com writes: Ok, I like the general plan here, but there are a mish-mash of styles which doesn't really seem neater than the original code. If we can, indeed,

Re: [PATCH 04/19] Use C99 designated initializers in dix Replies

2012-07-03 Thread Keith Packard
Alan Coopersmith alan.coopersm...@oracle.com writes: I can take a pass over to see about converting all to that style. Would you even want to see it used where the blocks were more natural, such as I'm thinking the most important thing right now is to make it easy to write and review --

[PATCH evdev] Don't re-open mtdev after PreInit

2012-07-03 Thread Peter Hutterer
==16557== 388,240 (3,520 direct, 384,720 indirect) bytes in 10 blocks are definitely lost in loss record 1,669 of 1,671 ==16557==at 0x4A06F18: calloc (vg_replace_malloc.c:566) ==16557==by 0xC3EAD4D: mtdev_new (core.c:345) ==16557==by 0xC3EAE6B: mtdev_new_open (core.c:383) ==16557==

Screen-specific private allocations

2012-07-03 Thread Keith Packard
The first patch extends the existing private allocation mechanism to provide 'screen-specific' privates. These work almost exactly like global privates, but space for them is allocated only in objects associated with a single screen. In other words, a Window allocated on screen 0 will not have

[PATCH 2/3] Use new screen-specific privates for fb window and gc privates

2012-07-03 Thread Keith Packard
This ensures that only screens using fb will have this space allocated. Signed-off-by: Keith Packard kei...@keithp.com --- fb/fb.h| 24 +--- fb/fballpriv.c | 29 - fb/fboverlay.c |4 ++-- fb/fbscreen.c |4 ++-- fb/fbwindow.c |

[PATCH 3/3] Use screen-specific privates for exa pixmap and gc privates

2012-07-03 Thread Keith Packard
Signed-off-by: Keith Packard kei...@keithp.com --- exa/exa.c | 10 -- exa/exa_priv.h | 12 2 files changed, 8 insertions(+), 14 deletions(-) diff --git a/exa/exa.c b/exa/exa.c index 0f90e59..623ece0 100644 --- a/exa/exa.c +++ b/exa/exa.c @@ -38,8 +38,6 @@ #include

[PATCH 1/3] Add screen-specific privates.

2012-07-03 Thread Keith Packard
Screen-specific privates areas are only allocated for objects related to the target screen; objects allocated for other screens will not have the private space reserved. This saves memory in these objects while also allowing hot-plug screens to have additional private allocation space beyond what

Re: [PATCH evdev] Don't re-open mtdev after PreInit

2012-07-03 Thread Peter Hutterer
On Wed, Jul 04, 2012 at 09:28:12AM +1000, Peter Hutterer wrote: ==16557== 388,240 (3,520 direct, 384,720 indirect) bytes in 10 blocks are definitely lost in loss record 1,669 of 1,671 ==16557==at 0x4A06F18: calloc (vg_replace_malloc.c:566) ==16557==by 0xC3EAD4D: mtdev_new (core.c:345)

Re: [PATCH 17/36] privates: remove asserts that stop dynamic increasing of privates size.

2012-07-03 Thread Keith Packard
Dave Airlie airl...@gmail.com writes: but privates have always longed remained something I run away screaming from everytime I see them. I've posted a patch that adds screen-specific privates so that the modesetting driver can use those to allocate pixmap privates in a way that won't upset

Re: [PATCH 05/36] xf86: cleanup helper code to use a pointer.

2012-07-03 Thread Aaron Plattner
On 07/02/2012 03:12 AM, Dave Airlie wrote: From: Dave Airlie airl...@redhat.com This is in preparation for gpu screens in here, just use a pScrn pointer to point at the new screen. suggested by Keith. Reviewed-by: Keith Packard kei...@keithp.com Signed-off-by: Dave Airlie airl...@redhat.com

Re: [PATCH 04/36] dix: introduce gpu screens. (v3)

2012-07-03 Thread Aaron Plattner
On 07/02/2012 03:12 AM, Dave Airlie wrote: From: Dave Airlie airl...@redhat.com diff --git a/render/glyph.c b/render/glyph.c index acb573f..c121e64 100644 --- a/render/glyph.c +++ b/render/glyph.c @@ -687,6 +687,8 @@ miGlyphs(CARD8 op, PicturePtr GetGlyphPicture(GlyphPtr glyph, ScreenPtr

[PATCH] Don't include touch state for emulated button press events

2012-07-03 Thread Chase Douglas
When a touch begin is pointer emulated, do not include touch state when calculating the button state for the initial motion and button press events. This ensures the logical state of the buttons prior to the events is set properly. Signed-off-by: Chase Douglas chase.doug...@canonical.com ---

[PATCH] Add regression test for button press event button state for touch begin

2012-07-03 Thread Chase Douglas
When a touch begin is pointer emulated, the initial motion and button press events should not have the first button set in the button mask. The button mask represents the state of the buttons *before* the event. Signed-off-by: Chase Douglas chase.doug...@canonical.com --- The original bug report

Re: [PATCH evdev] Don't re-open mtdev after PreInit

2012-07-03 Thread Chase Douglas
On 07/03/2012 04:45 PM, Peter Hutterer wrote: On Wed, Jul 04, 2012 at 09:28:12AM +1000, Peter Hutterer wrote: ==16557== 388,240 (3,520 direct, 384,720 indirect) bytes in 10 blocks are definitely lost in loss record 1,669 of 1,671 ==16557==at 0x4A06F18: calloc (vg_replace_malloc.c:566)

Re: [PATCH xorg-gtest] Ensure xorg-gtest implementation is included in xorg-gtest{-all,_main}.cpp

2012-07-03 Thread Chase Douglas
On 07/02/2012 07:37 PM, Peter Hutterer wrote: On Mon, Jun 18, 2012 at 11:17:19AM -0700, Chase Douglas wrote: GNU automake puts -I. -I.. at the beginning of every invocation of g++. This breaks xorg-gtest compilation if there is a file of the same name as an xorg-gtest implementation file in

Re: [PATCH xorg-gtest 1/9] Add a few linebreaks into the standard error notice

2012-07-03 Thread Chase Douglas
On 07/03/2012 07:52 AM, Chase Douglas wrote: Everything in the series looks good. Reviewed-by: Chase Douglas chase.doug...@canonical.com And pushed: 3774f91ba3722bd56b532dde549aef1df1749a51..b6dcdde9ecd63e2ea54ce0bfbeb4570a4d91a6c4 -- Chase ___

Re: [PATCH xorg-gtest] Rename headers to use dashes only

2012-07-03 Thread Chase Douglas
On 07/03/2012 07:47 AM, Chase Douglas wrote: On 07/02/2012 08:17 PM, Peter Hutterer wrote: Mixing dashes and spaces in xorg-gtest_foobar.h is a painful naming convention. Use dashes only instead, and provide compat headers plus a warning for those using the old header files. Those users should

Re: [PATCH 2/5] os: add OsBlockSIGIO and OsReleaseSIGIO

2012-07-03 Thread Peter Hutterer
On Mon, Jul 02, 2012 at 11:30:13PM -0700, Keith Packard wrote: Peter Hutterer peter.hutte...@who-t.net writes: void OsReleaseSignals(void) { #ifdef SIG_BLOCK if (--BlockedSignalCount == 0) { sigprocmask(SIG_SETMASK, PreviousSignalMask, 0); +

Re: [PATCH 3/5] xfree86: use OsBlockSIGIO from the ddx

2012-07-03 Thread Peter Hutterer
On Mon, Jul 02, 2012 at 11:17:11PM -0700, Keith Packard wrote: Peter Hutterer peter.hutte...@who-t.net writes: We can ignore the wasset argument now since the DIX will keep proper refcounting. Ok, so I was thinking that we should change the API here, but really what we should do is plan

Re: [PATCH xorg-gtest 01/16] Add a new class representing the X server

2012-07-03 Thread Peter Hutterer
On Tue, Jul 03, 2012 at 07:59:46AM -0700, Chase Douglas wrote: On 07/02/2012 11:44 PM, Peter Hutterer wrote: This class is a Process, so it's a drop-in replacement for the current Environment, but it provides a few methods to talk to the server being started. Signed-off-by: Peter Hutterer

Re: [PATCH xorg-gtest 05/16] xserver: move testing startup to the XServer object

2012-07-03 Thread Peter Hutterer
On Tue, Jul 03, 2012 at 10:30:28AM -0700, Chase Douglas wrote: On 07/02/2012 11:44 PM, Peter Hutterer wrote: Signed-off-by: Peter Hutterer peter.hutte...@who-t.net It makes sense to move the startup to the XServer object, but the environment should then contain an XServer object and start

Re: [PATCH xorg-gtest 06/16] xserver: move Terminate and Kill handling here

2012-07-03 Thread Peter Hutterer
On Tue, Jul 03, 2012 at 10:33:50AM -0700, Chase Douglas wrote: On 07/02/2012 11:44 PM, Peter Hutterer wrote: Signed-off-by: Peter Hutterer peter.hutte...@who-t.net --- include/xorg/gtest/xorg-gtest-xserver.h | 13 src/environment.cpp | 31

Re: [PATCH xorg-gtest 16/16] Add Device::GetDeviceNode() to return device node path from an evemu device

2012-07-03 Thread Peter Hutterer
On Tue, Jul 03, 2012 at 11:40:25AM -0700, Chase Douglas wrote: On 07/02/2012 11:44 PM, Peter Hutterer wrote: evemu doesn't export this information and even evemu-device just trawls through the file system to print this info. So do the same here, noting the time before evemu_create() and the

<    1   2