Re: [PATCH 1/2] xwayland: Update screen size on output removal

2015-11-17 Thread Olivier Fourdan
Hi - Original Message - > > Or does Xwayland perhaps have a requirement for compositors to have > > no output space to the left and/or right of 0,0? > > I don't know if there's such a written requirement, but reading the code as > you did, I don't think it expect outputs to a have

Re: [PATCH] modesetting: and entity setup to generic probe path.

2015-11-17 Thread Emil Velikov
On 17 November 2015 at 00:23, Dave Airlie wrote: > From: Dave Airlie > > Totally untested, cross fingers hope it works. > > Signed-off-by: Dave Airlie > --- > hw/xfree86/drivers/modesetting/driver.c | 25 + > 1

[PATCH] modesetting: create entities for pci and old probe. (v2)

2015-11-17 Thread Dave Airlie
This moves the code from the platform case into a common function, and calls that from the other two. v2: Emil convinced me we don't need to lookup pEnt here, so let's not bother. Reported-by: Mark Kettenis Signed-off-by: Dave Airlie ---

Re: [PATCH] modesetting: and entity setup to generic probe path.

2015-11-17 Thread Dave Airlie
On 17 November 2015 at 21:57, Emil Velikov wrote: > On 17 November 2015 at 00:23, Dave Airlie wrote: >> From: Dave Airlie >> >> Totally untested, cross fingers hope it works. >> >> Signed-off-by: Dave Airlie

Re: [PATCH] modesetting: and entity setup to generic probe path.

2015-11-17 Thread Dave Airlie
On 18 November 2015 at 07:13, Mark Kettenis wrote: >> From: Dave Airlie >> Date: Tue, 17 Nov 2015 10:23:37 +1000 >> >> From: Dave Airlie >> >> Totally untested, cross fingers hope it works. > > Seems that does the trick. Okay I've

[PATCH 2/2] modesetting: create entities for pci and old probe.

2015-11-17 Thread Dave Airlie
This moves the code from the platform case into a common function, and calls that from the other two. Reported-by: Mark Kettenis Signed-off-by: Dave Airlie --- hw/xfree86/drivers/modesetting/driver.c | 51 ++--- 1 file

[PATCH 1/2] modesetting: drop platform_dev pointer.

2015-11-17 Thread Dave Airlie
This isn't used anywhere, so no point storing it until we need it. Signed-off-by: Dave Airlie --- hw/xfree86/drivers/modesetting/driver.c | 8 +--- hw/xfree86/drivers/modesetting/driver.h | 3 --- 2 files changed, 1 insertion(+), 10 deletions(-) diff --git

Re: [PATCH xserver 01/20] Remove non-smart scheduler. Don't require setitimer.

2015-11-17 Thread Adam Jackson
On Wed, 2015-11-11 at 22:02 -0800, Keith Packard wrote: > This allows the server to call GetTimeInMillis() after each request is > processed to avoid needing setitimer. -dumbSched now turns off the > setitimer. I'm not sure there are real systems we'd be protecting by not requiring setitimer.  

Re: [PATCH xserver 08/20] hw/kdrive: Use NotifyFd interface for kdrive/linux APM monitoring

2015-11-17 Thread Adam Jackson
On Wed, 2015-11-11 at 22:02 -0800, Keith Packard wrote: > >  static void > -LinuxApmWakeup(void *blockData, int result, void *pReadmask) > +LinuxApmNotify(int fd, int mask, void *blockData) >  { > -fd_set *readmask = (fd_set *) pReadmask; > - > -if (result > 0 && LinuxApmFd >= 0 &&

Re: [PATCH xserver 16/20] hw/xfree86: Use NotifyFd for device and other input fd wakeups

2015-11-17 Thread Adam Jackson
On Wed, 2015-11-11 at 22:02 -0800, Keith Packard wrote: > Remove code in xf86Wakeup for dealing with device and other input and > switch to using the new NotifyFd interface. I'm happy to address this up later, but I note that IHRec and the notify_fd struct are now basically identical, there's

Re: [PATCH xserver 03/20] os: Implement support for NotifyFd X_NOTIFY_WRITE

2015-11-17 Thread Adam Jackson
On Wed, 2015-11-11 at 22:02 -0800, Keith Packard wrote: > @@ -1174,12 +1192,16 @@ SetNotifyFd(int fd, NotifyFdProcPtr notify, int mask, > void *data) >  void >  HandleNotifyFds(void) >  { > -struct notify_fd *s, *next; > - > -xorg_list_for_each_entry_safe(s, next, ¬ify_fds, list) { > -  

Re: [PATCH xserver 18/20] Remove readmask from screen block/wakeup handler

2015-11-17 Thread Adam Jackson
On Wed, 2015-11-11 at 22:02 -0800, Keith Packard wrote: > With no users of the interface needing the readmask anymore, we can > remove it from the argument passed to these functions. > > Signed-off-by: Keith Packard > --- >  composite/compalloc.c   |  4 ++-- >  

Re: [PATCH v2] configure.ac: Use libsystemd in REQUIRED_LIBS check

2015-11-17 Thread Peter Hutterer
On Tue, Nov 17, 2015 at 10:39:48AM +0200, Jussi Kukkonen wrote: > REQUIRED_LIBS needs to be set to the correct systemd library, > otherwise the later check will either fail or use the wrong > pc file. > > Signed-off-by: Jussi Kukkonen > --- > > > Changes since v1: > *

Re: [PATCH xserver 01/20] Remove non-smart scheduler. Don't require setitimer.

2015-11-17 Thread Keith Packard
Adam Jackson writes: > On Wed, 2015-11-11 at 22:02 -0800, Keith Packard wrote: >> This allows the server to call GetTimeInMillis() after each request is >> processed to avoid needing setitimer. -dumbSched now turns off the >> setitimer. > > I'm not sure there are real systems we'd

Re: [PATCH xserver 03/20] os: Implement support for NotifyFd X_NOTIFY_WRITE

2015-11-17 Thread Keith Packard
Adam Jackson writes: > ISTR the server currently has a "write then read" strategy for deadlock > avoidance (and accidentally better reliability when low on memory).  Do > we want to do that here too, and if we do, do we split this into > walking the list twice to enforce the

Re: [PATCH xserver 08/20] hw/kdrive: Use NotifyFd interface for kdrive/linux APM monitoring

2015-11-17 Thread Keith Packard
Adam Jackson writes: > This tripped me up at first (here and elsewhere in the series), it > looks weird to read an fd that isn't the one passed in as an argument. Yeah, trying for minimal patches sometimes doesn't result in the best code. I can change these easily enough. --

[PATCH v2] configure.ac: Use libsystemd in REQUIRED_LIBS check

2015-11-17 Thread Jussi Kukkonen
REQUIRED_LIBS needs to be set to the correct systemd library, otherwise the later check will either fail or use the wrong pc file. Signed-off-by: Jussi Kukkonen --- Changes since v1: * Set both HAVE_SYSTEMD_DAEMON and REQUIRED_SYSTEMD_DAEMON inside the

[PATCH v2 xf86-input-libinput 2/4] Copy the device capabilities to the X driver struct

2015-11-17 Thread Peter Hutterer
And use those copied caps instead of the direct device capability calls. No functional changes at this point, this is preparation work for selectively disabling capabilities on a device. Signed-off-by: Peter Hutterer --- No changes to v1 src/xf86libinput.c | 34

Re: [PATCH xf86-input-libinput] Unref the libinput context on pre_init failure

2015-11-17 Thread Hans de Goede
Hi, On 17-11-15 09:20, Peter Hutterer wrote: A device that fails pre_init has a ref to the libinput context but may not have a pInfo->private. For those devices we never call libinput_unref() and the libinput struct never gets freed. Thus if at least one device didn't pass pre_init, we never

Re: [PATCH v2 xf86-input-libinput 4/4] Split mixed pointer/keyboard devices into two separate X devices

2015-11-17 Thread Hans de Goede
Hi, Patches 1-3 look good to me and are: Reviewed-by: Hans de Goede I've a couple of comments on this one inline. On 17-11-15 09:36, Peter Hutterer wrote: The server struggles with devices that are both, the protocol (especially XI2) requires a fairly strict separation

[PATCH v2 xf86-input-libinput 4/4] Split mixed pointer/keyboard devices into two separate X devices

2015-11-17 Thread Peter Hutterer
The server struggles with devices that are both, the protocol (especially XI2) requires a fairly strict separation of pointer vs keyboard devices. Though the server has a couple of hacks to route events correctly, mixed devices still experience bugs like [1]. Instead of advertising the device as

[PATCH v2 xf86-input-libinput 3/4] Add a helper function for the driver context initialization

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- New patch in v2 src/xf86libinput.c | 27 --- 1 file changed, 16 insertions(+), 11 deletions(-) diff --git a/src/xf86libinput.c b/src/xf86libinput.c index b1b1943..bc6e677 100644 --- a/src/xf86libinput.c +++

[PATCH v2] glamor: Make glamor_name_from_pixmap work without DRI3

2015-11-17 Thread Mark Kettenis
This function is used by the modesetting driver to implement DRI2 and shouldn't fail on systems that don't support DRI3. Remove the check for DRI3 and rename glamor_egl_dri3_fd_name_from_tex to glamor_egl_fd_name_from_tex. Signed-off-by: Mark Kettenis --- glamor/glamor.c

[PATCH] glamor: Make glamor_sync_init work with --disable-xshmfence

2015-11-17 Thread Mark Kettenis
Signed-off-by: Mark Kettenis --- glamor/glamor_sync.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/glamor/glamor_sync.c b/glamor/glamor_sync.c index fbc47d4..907e0c6 100644 --- a/glamor/glamor_sync.c +++ b/glamor/glamor_sync.c @@ -97,6 +97,9 @@