Jinjiang Ling created YARN-7698:
-----------------------------------

             Summary: A misleading variable's name in 
ApplicationAttemptEventDispatcher
                 Key: YARN-7698
                 URL: https://issues.apache.org/jira/browse/YARN-7698
             Project: Hadoop YARN
          Issue Type: Improvement
          Components: resourcemanager
            Reporter: Jinjiang Ling
            Assignee: Jinjiang Ling
            Priority: Minor


I find there are two variables named "appAttemptId" in 
ApplicationAttemptEventDispatcher.
{code:java}
public static final class ApplicationAttemptEventDispatcher implements
      EventHandler<RMAppAttemptEvent> {
    ....
    public void handle(RMAppAttemptEvent event) {
      ApplicationAttemptId appAttemptID = event.getApplicationAttemptId();
      ApplicationId appAttemptId = appAttemptID.getApplicationId();
      ....
    }
{code}
The first one is named as "{color:red}appAttemptID{color}" which is the true 
attempt id. 
The other one is named as  "{color:red}appAttemptId{color}", but I think it's 
currect name should be "appId".

I'm not sure there are any reason to name the application id as "appAttemptId". 
But I think two "appAttemptId" in one function may cause some misleading, so 
it's better to fix the second one to "appId"



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to