[jira] [Commented] (YARN-733) TestNMClient fails occasionally

2013-06-02 Thread Hudson (JIRA)
[ https://issues.apache.org/jira/browse/YARN-733?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672461#comment-13672461 ] Hudson commented on YARN-733: - Integrated in Hadoop-Yarn-trunk #228 (See

[jira] [Commented] (YARN-733) TestNMClient fails occasionally

2013-06-02 Thread Hudson (JIRA)
[ https://issues.apache.org/jira/browse/YARN-733?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672498#comment-13672498 ] Hudson commented on YARN-733: - Integrated in Hadoop-Hdfs-trunk #1418 (See

[jira] [Updated] (YARN-746) rename Service.register() and Service.unregister() to registerServiceListener() unregisterServiceListener() respectively

2013-06-02 Thread Steve Loughran (JIRA)
[ https://issues.apache.org/jira/browse/YARN-746?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Steve Loughran updated YARN-746: Attachment: YARN-746-001.patch Patch -designed to go in after the big YARN-117 commit -it updates

[jira] [Updated] (YARN-530) Define Service model strictly, implement AbstractService for robust subclassing, migrate yarn-common services

2013-06-02 Thread Steve Loughran (JIRA)
[ https://issues.apache.org/jira/browse/YARN-530?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Steve Loughran updated YARN-530: Attachment: YARN-530-014.patch Pulled the {{ServiceShutdownHook}} code off to YARN-679, this

[jira] [Commented] (YARN-117) Enhance YARN service model

2013-06-02 Thread Hadoop QA (JIRA)
[ https://issues.apache.org/jira/browse/YARN-117?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672623#comment-13672623 ] Hadoop QA commented on YARN-117: {color:red}-1 overall{color}. Here are the results of

[jira] [Commented] (YARN-530) Define Service model strictly, implement AbstractService for robust subclassing, migrate yarn-common services

2013-06-02 Thread Hadoop QA (JIRA)
[ https://issues.apache.org/jira/browse/YARN-530?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672626#comment-13672626 ] Hadoop QA commented on YARN-530: {color:red}-1 overall{color}. Here are the results of

[jira] [Updated] (YARN-678) Delete FilterService

2013-06-02 Thread Steve Loughran (JIRA)
[ https://issues.apache.org/jira/browse/YARN-678?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Steve Loughran updated YARN-678: Attachment: YARN-678-001.patch deletes filter service. This patch is built on the YARN-746

[jira] [Assigned] (YARN-746) rename Service.register() and Service.unregister() to registerServiceListener() unregisterServiceListener() respectively

2013-06-02 Thread Steve Loughran (JIRA)
[ https://issues.apache.org/jira/browse/YARN-746?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Steve Loughran reassigned YARN-746: --- Assignee: Steve Loughran rename Service.register() and Service.unregister() to

[jira] [Commented] (YARN-749) Rename ResourceRequest (get,set)HostName to (get,set)ResourceName

2013-06-02 Thread Sandy Ryza (JIRA)
[ https://issues.apache.org/jira/browse/YARN-749?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672636#comment-13672636 ] Sandy Ryza commented on YARN-749: - +1, have thought this would be a good change for a while.

[jira] [Updated] (YARN-749) Rename ResourceRequest (get,set)HostName to (get,set)ResourceName

2013-06-02 Thread Arun C Murthy (JIRA)
[ https://issues.apache.org/jira/browse/YARN-749?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Arun C Murthy updated YARN-749: --- Attachment: YARN-749.patch Straight-fwd patch, re-factored with eclipse. Rename

[jira] [Commented] (YARN-749) Rename ResourceRequest (get,set)HostName to (get,set)ResourceName

2013-06-02 Thread Arun C Murthy (JIRA)
[ https://issues.apache.org/jira/browse/YARN-749?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672649#comment-13672649 ] Arun C Murthy commented on YARN-749: [~sandyr] 'resource name' seems more likely to

[jira] [Commented] (YARN-749) Rename ResourceRequest (get,set)HostName to (get,set)ResourceName

2013-06-02 Thread Hadoop QA (JIRA)
[ https://issues.apache.org/jira/browse/YARN-749?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672655#comment-13672655 ] Hadoop QA commented on YARN-749: {color:green}+1 overall{color}. Here are the results of

[jira] [Commented] (YARN-749) Rename ResourceRequest (get,set)HostName to (get,set)ResourceName

2013-06-02 Thread Hitesh Shah (JIRA)
[ https://issues.apache.org/jira/browse/YARN-749?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672679#comment-13672679 ] Hitesh Shah commented on YARN-749: -- Looks good to me. +1. Rename

[jira] [Commented] (YARN-749) Rename ResourceRequest (get,set)HostName to (get,set)ResourceName

2013-06-02 Thread Hadoop QA (JIRA)
[ https://issues.apache.org/jira/browse/YARN-749?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672697#comment-13672697 ] Hadoop QA commented on YARN-749: {color:green}+1 overall{color}. Here are the results of

[jira] [Commented] (YARN-749) Rename ResourceRequest (get,set)HostName to (get,set)ResourceName

2013-06-02 Thread Hudson (JIRA)
[ https://issues.apache.org/jira/browse/YARN-749?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672710#comment-13672710 ] Hudson commented on YARN-749: - Integrated in Hadoop-trunk-Commit #3833 (See

[jira] [Updated] (YARN-398) Enhance CS to allow for white-list of resources

2013-06-02 Thread Arun C Murthy (JIRA)
[ https://issues.apache.org/jira/browse/YARN-398?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Arun C Murthy updated YARN-398: --- Summary: Enhance CS to allow for white-list of resources (was: Allow white-list and black-list of

[jira] [Commented] (YARN-398) Enhance CS to allow for white-list of resources

2013-06-02 Thread Arun C Murthy (JIRA)
[ https://issues.apache.org/jira/browse/YARN-398?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672743#comment-13672743 ] Arun C Murthy commented on YARN-398: I'm changing scope of this jira to restrict it to

[jira] [Created] (YARN-750) Allow for black-listing resources in CS

2013-06-02 Thread Arun C Murthy (JIRA)
Arun C Murthy created YARN-750: -- Summary: Allow for black-listing resources in CS Key: YARN-750 URL: https://issues.apache.org/jira/browse/YARN-750 Project: Hadoop YARN Issue Type: Sub-task

[jira] [Commented] (YARN-398) Enhance CS to allow for white-list of resources

2013-06-02 Thread Hadoop QA (JIRA)
[ https://issues.apache.org/jira/browse/YARN-398?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672746#comment-13672746 ] Hadoop QA commented on YARN-398: {color:green}+1 overall{color}. Here are the results of

[jira] [Moved] (YARN-751) CLONE - CapacityScheduler incorrectly utilizes extra-resources of queue for high-memory jobs

2013-06-02 Thread Arun C Murthy (JIRA)
[ https://issues.apache.org/jira/browse/YARN-751?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Arun C Murthy moved MAPREDUCE-5290 to YARN-751: --- Component/s: (was: capacity-sched)

[jira] [Commented] (YARN-696) Enable multiple states to to be specified in Resource Manager apps REST call

2013-06-02 Thread Konstantin Boudnik (JIRA)
[ https://issues.apache.org/jira/browse/YARN-696?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672750#comment-13672750 ] Konstantin Boudnik commented on YARN-696: - +1 patch looks good. If there's no

[jira] [Updated] (YARN-696) Enable multiple states to to be specified in Resource Manager apps REST call

2013-06-02 Thread Konstantin Boudnik (JIRA)
[ https://issues.apache.org/jira/browse/YARN-696?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Konstantin Boudnik updated YARN-696: Target Version/s: 3.0.0, 2.1.0-beta Enable multiple states to to be specified in

[jira] [Commented] (YARN-720) container-log4j.properties should not refer to mapreduce properties

2013-06-02 Thread Siddharth Seth (JIRA)
[ https://issues.apache.org/jira/browse/YARN-720?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672761#comment-13672761 ] Siddharth Seth commented on YARN-720: - +1. Looks good. Committing this. Thanks Zhijie.

[jira] [Commented] (YARN-720) container-log4j.properties should not refer to mapreduce properties

2013-06-02 Thread Hudson (JIRA)
[ https://issues.apache.org/jira/browse/YARN-720?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672769#comment-13672769 ] Hudson commented on YARN-720: - Integrated in Hadoop-trunk-Commit #3834 (See

[jira] [Updated] (YARN-635) Rename YarnRemoteException to YarnException

2013-06-02 Thread Siddharth Seth (JIRA)
[ https://issues.apache.org/jira/browse/YARN-635?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Siddharth Seth updated YARN-635: Attachment: YARN-635.2.txt Rebased patch. bq. Doubtful on YarnRemoteException renaming.

[jira] [Resolved] (YARN-751) CLONE - CapacityScheduler incorrectly utilizes extra-resources of queue for high-memory jobs

2013-06-02 Thread Arun C Murthy (JIRA)
[ https://issues.apache.org/jira/browse/YARN-751?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Arun C Murthy resolved YARN-751. Resolution: Invalid I verified that this doesn't happen in YARN. The user-limit computation is

[jira] [Resolved] (YARN-747) Improve CapacityScheduler to support allocation to specific locations

2013-06-02 Thread Arun C Murthy (JIRA)
[ https://issues.apache.org/jira/browse/YARN-747?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Arun C Murthy resolved YARN-747. Resolution: Duplicate Duplicate of YARN-398 since I moved black-list out of there...

[jira] [Commented] (YARN-635) Rename YarnRemoteException to YarnException

2013-06-02 Thread Hadoop QA (JIRA)
[ https://issues.apache.org/jira/browse/YARN-635?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672809#comment-13672809 ] Hadoop QA commented on YARN-635: {color:green}+1 overall{color}. Here are the results of

[jira] [Commented] (YARN-730) NMClientAsync needs to remove completed container

2013-06-02 Thread Hudson (JIRA)
[ https://issues.apache.org/jira/browse/YARN-730?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13672811#comment-13672811 ] Hudson commented on YARN-730: - Integrated in Hadoop-trunk-Commit #3835 (See

[jira] [Created] (YARN-752) Throw exception if AMRMClient.ContainerRequest is given invalid locations

2013-06-02 Thread Sandy Ryza (JIRA)
Sandy Ryza created YARN-752: --- Summary: Throw exception if AMRMClient.ContainerRequest is given invalid locations Key: YARN-752 URL: https://issues.apache.org/jira/browse/YARN-752 Project: Hadoop YARN