[jira] [Comment Edited] (YARN-8103) Add CLI interface to query node attributes

2018-06-21 Thread Bibin A Chundatt (JIRA)


[ 
https://issues.apache.org/jira/browse/YARN-8103?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16519051#comment-16519051
 ] 

Bibin A Chundatt edited comment on YARN-8103 at 6/21/18 8:10 AM:
-

[~Naganarasimha]

Attached updated patch with new line addition for NodeCLI too..

Additional fixes:

# NodeAttributekey and NodeAttribute equals fix



was (Author: bibinchundatt):
[~Naganarasimha]

Attached updated patch with new line addition for NodeCLI too..

> Add CLI interface to  query node attributes
> ---
>
> Key: YARN-8103
> URL: https://issues.apache.org/jira/browse/YARN-8103
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Bibin A Chundatt
>Assignee: Bibin A Chundatt
>Priority: Major
> Attachments: YARN-8103-YARN-3409.001.patch, 
> YARN-8103-YARN-3409.002.patch, YARN-8103-YARN-3409.003.patch, 
> YARN-8103-YARN-3409.004.patch, YARN-8103-YARN-3409.005.patch, 
> YARN-8103-YARN-3409.WIP.patch
>
>
> YARN-8100 will add API interface for querying the attributes. CLI interface 
> for querying node attributes for each nodes and list all attributes in 
> cluster.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org



[jira] [Comment Edited] (YARN-8103) Add CLI interface to query node attributes

2018-06-04 Thread Naganarasimha G R (JIRA)


[ 
https://issues.apache.org/jira/browse/YARN-8103?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16501238#comment-16501238
 ] 

Naganarasimha G R edited comment on YARN-8103 at 6/5/18 3:53 AM:
-

Thanks for the patch and apologies for the delayed response.
 Major Comments :
  
 * I agree with the approach of not storing and updating the attributes in 
RMNode and instead request NodeAttributesManager to share the information. But 
was also wondering whether the API(RMNodeImpl.getAllNodeAttributes) is useful 
based on current scenarios ? All the callers are eventually converting it into 
a set of attributes and utilizing it. So i would prefer to change the api to 
just return the set of attributes applicable on a node and when needed let the 
caller take care of sorting based on the prefix( which is anyway not a current 
scenario)

Few other comments:
 * hadoop-yarn/bin/yarn ln no 58: i think "client" was missing from earlier 
which we need to add it
 * NodeAttributesCLI ln no 195: i think its better to use null here instead of 
"handler" for better readability
 * NodeAttributesCLI ln no 88,96 : unused variables
 * TestNodeAttributesCLI ln no 405: testListAttributes is encapsulating 
NodesToAttributes tests too, may be it can captured as a different case
 * NodeAttributesCLI ln no 355 : HashSet => HashSet
 * NodeAttributesCLI ln no 394 : HashSet => HashSet
 * NodeCLI ln no 349: formatNodeAttribute : instead of having new formatting 
here why not update NodeAttributePBImpl.toString ?
 * NodeCLI ln no 317 : IMO it would better to wrap each attribute in a new line 
?
 * TestClusterCLI : does not capture any case for listing of attributes 
(basically need to capture multiline)
 * BuilderUtils ln no 211 : space is required before Set

Some of the findbugs and checkstyle seems to be valid can you have a look at 
them ?

Kudos NodeAttributesCLI has been handled well !


was (Author: naganarasimha):
Thanks for the patch and apologies for the delayed response.
Major Comments :
 
 * I agree with the approach of not storing and updating the attributes in 
RMNode and instead request NodeAttributesManager to share the information. But 
was also wondering whether the API(RMNodeImpl.getAllNodeAttributes) is useful 
based on current scenarios ? All the callers are eventually converting it into 
a set of attributes and utilizing it. So i would prefer to change the api to 
just return the set of attributes applicable on a node and when needed let the 
caller take care of sorting based on the prefix( which is anyway not a current 
scenario)


Few other comments:
 * hadoop-yarn/bin/yarn ln no 58: i think "client" was missing from earlier 
which we need to add it
 *  NodeAttributesCLI ln no 195: i think its better to use null here instead of 
"handler" for better readability
 *  NodeAttributesCLI ln no 88,96 : unused variables
 *  TestNodeAttributesCLI ln no 405: testListAttributes is encapsulating 
NodesToAttributes tests too, may be it can captured as a different case

Some of the findbugs and checkstyle seems to be valid can you have a look at 
them ?

Kudos NodeAttributesCLI has been handled well !

> Add CLI interface to  query node attributes
> ---
>
> Key: YARN-8103
> URL: https://issues.apache.org/jira/browse/YARN-8103
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Bibin A Chundatt
>Assignee: Bibin A Chundatt
>Priority: Major
> Attachments: YARN-8103-YARN-3409.001.patch, 
> YARN-8103-YARN-3409.002.patch, YARN-8103-YARN-3409.WIP.patch
>
>
> YARN-8100 will add API interface for querying the attributes. CLI interface 
> for querying node attributes for each nodes and list all attributes in 
> cluster.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org



[jira] [Comment Edited] (YARN-8103) Add CLI interface to query node attributes

2018-04-11 Thread Naganarasimha G R (JIRA)

[ 
https://issues.apache.org/jira/browse/YARN-8103?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16434648#comment-16434648
 ] 

Naganarasimha G R edited comment on YARN-8103 at 4/11/18 10:17 PM:
---

Thanks [~bibinchundatt], for detailing it out. 

[~cheersyang], As part of  YARN-6856, we decided to have feature specific 
grouping thats when we introduced *node-attributes* option directly under yarn 
command instead of placing it as suboption under *rmadmin* option. This was 
done primarily for two reasons
 # It would be more ideal to capture all related operations under one heading 
so that its easier to use. (similar to kubernetes). 
 # Lesser commands to type in the CLI.

  So what we are planning is which ever sub-option requires admin access will 
get validated and others will be available for access by all users. so here 
replace, add and remove will be using *ResourceManagerAdministrationProtocol* 
and for other options which [~bibinchundatt] was mentioning will be using 
*ApplicationClientProtocol*

And as part of last weeks call we decided to go with first listing which Bibin 
mentioned. And of the last 3 points mentioned by [~bibinchundatt] 1 & 3 is up 
for discussion. IMO i thought it better to be grouped together because that was 
the reason which we introduced a option *node-attributes* .

 

   


was (Author: naganarasimha):
Thanks [~bibinchundatt], for detailing it out. 

[~cheersyang], As part of  YARN-6856, we decided to have feature specific 
grouping thats when we introduced *node-attributes* option directly under yarn 
command instead of placing it as suboption under *rmadmin* option. This was 
done primarily for two reasons
 # It would be more ideal to capture all related operations under one heading 
so that its easier to use. (similar to kubernetes). 
 # Lesser commands to type in the CLI.

  So what we are planning is which ever sub-option requires admin access will 
get validated and others will be available for access by all users. so here 
replace, add and remove will be using *ResourceManagerAdministrationProtocol* 
and for other options which [~bibinchundatt] was mentioning will be using 
*ApplicationClientProtocol*

And as part of last weeks call we decided to go with first 3 list which Bibin 
mentioned. And of the last 3 points mentioned by [~bibinchundatt] 1 & 3 is up 
for discussion. IMO i thought it better to be grouped together because that was 
the reason which we introduced a option *node-attributes* .

 

   

> Add CLI interface to  query node attributes
> ---
>
> Key: YARN-8103
> URL: https://issues.apache.org/jira/browse/YARN-8103
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Bibin A Chundatt
>Assignee: Bibin A Chundatt
>Priority: Major
>
> YARN-8100 will add API interface for querying the attributes. CLI interface 
> for querying node attributes for each nodes and list all attributes in 
> cluster.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org



[jira] [Comment Edited] (YARN-8103) Add CLI interface to query node attributes

2018-04-11 Thread Weiwei Yang (JIRA)

[ 
https://issues.apache.org/jira/browse/YARN-8103?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16433875#comment-16433875
 ] 

Weiwei Yang edited comment on YARN-8103 at 4/11/18 12:55 PM:
-

Hi [~bibinchundatt]

 Could you please brief the CLI syntax and output example? Are you suggesting 
to add a single "-attributes" command (single end-point) in "rmadmin" command 
set? 

Thanks


was (Author: cheersyang):
Hi [~bibinchundatt]

 

Could you please brief the CLI syntax and output example? Are you suggesting to 
add a single "-attributes" command (single end-point) in "rmadmin" command set? 

Thanks

> Add CLI interface to  query node attributes
> ---
>
> Key: YARN-8103
> URL: https://issues.apache.org/jira/browse/YARN-8103
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Bibin A Chundatt
>Assignee: Bibin A Chundatt
>Priority: Major
>
> YARN-8100 will add API interface for querying the attributes. CLI interface 
> for querying node attributes for each nodes and list all attributes in 
> cluster.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org