Re: [zd1211-devs] Problems loading FW on ARM9 platform

2007-01-13 Thread Jon Smirl
In the kernel config under Device Drivers, Generic Driver Options, make sure user space firmware loading support is enabled. Blame the Debian developers for this mess. Mircocode used to be built into the device drivers in the init section and then tossed after the driver initialized. But that

Re: [zd1211-devs] Problems loading FW on ARM9 platform

2007-01-13 Thread Nikolaj
Hi, In the kernel config under Device Drivers, Generic Driver Options, make sure user space firmware loading support is enabled. It was already set. linux-2.6.20-rc3$ cat .config |grep FW_LOADER CONFIG_FW_LOADER=y I wonder what the -19 error from my dmesg is: 7DEV: registering device: ID

Re: [zd1211-devs] Problems loading FW on ARM9 platform

2007-01-13 Thread Jon Smirl
On 1/13/07, Nikolaj [EMAIL PROTECTED] wrote: Hi, In the kernel config under Device Drivers, Generic Driver Options, make sure user space firmware loading support is enabled. It was already set. linux-2.6.20-rc3$ cat .config |grep FW_LOADER CONFIG_FW_LOADER=y I wonder what the -19

Re: [zd1211-devs] Problems loading FW on ARM9 platform

2007-01-13 Thread Nikolaj
I wonder what the -19 error from my dmesg is: 7DEV: registering device: ID = '1-3' 7dev_uevent - dev_uevent() returned -19 7DEV: Unregistering device. ID = '1-3' #define ENODEV 19 /* No such device */ Do you have the sysfs file system mounted? The userspace code uses it to

Re: [zd1211-devs] Problems loading FW on ARM9 platform

2007-01-13 Thread Jon Smirl
If you read about how udev works you can run it manually from the command line once you figure out how to set up all of the environment variables it needs. That should let you debug what is happening. As far as I know firmware loading works on ARM processors, there's just some piece missing on