Re: [zones-discuss] zpools in zones

2009-07-15 Thread Edward Pilatowicz
On Wed, Jul 15, 2009 at 11:28:21AM -0700, Alastair Neil wrote: I am trying to set up two zones to exactly duplicate a production server one for test and one for development. The production server has a number of zpools which are specifically named and the scripts we are testing expect this

Re: [zones-discuss] zpools in zones

2009-07-15 Thread Alastair Neil
How then do you create two zpools with the same name one for the test zone and one for the devel zone? -- This message posted from opensolaris.org ___ zones-discuss mailing list zones-discuss@opensolaris.org

[zones-discuss] sysidcfg requires zlogin

2009-07-15 Thread Patrick J. McEvoy
I am trying to pre-configure zones with sysidcfg as described in: http://docs.sun.com/app/docs/doc/817-1592/z.login.task-38?l=ena=viewq=sysidcfg+and+containers Basically: clone a zone zoneadm -z zone ready edit zonepath/root/etc/sysidcfg zoneadm -z zone boot The problem is

Re: [zones-discuss] zpools in zones

2009-07-15 Thread Bryan Allen
+-- | On 2009-07-15 12:24:43, Alastair Neil wrote: | | How then do you create two zpools with the same name one for the test zone and one for the devel zone? You don't. But you can easily hack around it. e.g.,

Re: [zones-discuss] sysidcfg requires zlogin

2009-07-15 Thread Christine Tran
On Wed, Jul 15, 2009 at 3:32 PM, Patrick J. McEvoyno-re...@opensolaris.org wrote: I am trying to pre-configure zones with sysidcfg as described in: http://docs.sun.com/app/docs/doc/817-1592/z.login.task-38?l=ena=viewq=sysidcfg+and+containers Basically: clone a zone zoneadm -z

Re: [zones-discuss] sysidcfg requires zlogin

2009-07-15 Thread Steffen Weiberle
On 07/15/09 17:27, Christine Tran wrote: On Wed, Jul 15, 2009 at 3:32 PM, Patrick J. McEvoyno-re...@opensolaris.org wrote: I am trying to pre-configure zones with sysidcfg as described in: http://docs.sun.com/app/docs/doc/817-1592/z.login.task-38?l=ena=viewq=sysidcfg+and+containers

Re: [zones-discuss] sysidcfg requires zlogin

2009-07-15 Thread Patrick J. McEvoy
If you have a correct sysidcfg, you will never need to go thru the system identification prompt at zlogin -C. Please post your sysidcfg. network_interface=vphys1 { primary hostname=zweb1 ip_address=192.168.17.1 netmask=255.255.255.0 protocol_ipv6=no

Re: [zones-discuss] sysidcfg requires zlogin

2009-07-15 Thread Patrick J. McEvoy
YMMV. If you have an exclusive-ip zone you will have to touch /etc/hostname.NIC in the zone as well. I am using exclusive-ip, but touching the hostname.NIC files did not make a difference. Another oddity I did not mention in the original post is that I get different behavior on zlogin

Re: [zones-discuss] zpools in zones

2009-07-15 Thread Alastair Neil
Easy is a relative term. I'd rather not have to refactor the code to work around a deficiency in the virtualisaton method. I've decided to switch to a full hypervisor and leave zones for less problematic configurations. -- This message posted from opensolaris.org

Re: [zones-discuss] sysidcfg requires zlogin

2009-07-15 Thread Patrick J. McEvoy
If you have a correct sysidcfg, you will never need to go thru the system identification prompt at zlogin -C. Just to be clear: I don't have to go through system identification at zlogin -C, but I have to do a zlogin -C to get sysconfig to happen. That is, once I do zlogin -C and get to the

Re: [zones-discuss] sysidcfg requires zlogin

2009-07-15 Thread Patrick J. McEvoy
If I get rid of the second interface and use network_interface=PRIMARY then things work. When I use two interfaces and the primary keyword I get two copies of sysidnet that seem to hang around forever (or until zlogin): swag...@sol:~# ps -fz zweb1 UID PID PPID CSTIME TTY

Re: [zones-discuss] sysidcfg requires zlogin

2009-07-15 Thread Patrick J. McEvoy
The sysidtool-net script does this: /sbin/ifconfig -a plumb /dev/null 21 Then fires off sysidnet. I embedded these two lines in sysidtool-net /sbin/dladm show-link /etc/dladm-show-link /sbin/ifconfig -a /etc/ifconfig-a and the results show that the VNICs do not appear: