[Zope-dev] ZCatalog reindex_object

2000-12-31 Thread Chris Withers
Michael Bernstein wrote: reindex_object - should be called when an object is edited Hmmm... didn't see this method listed in the interfaces wiki. Where did you find it? I just inserted a call to catalog_object which did the job but I wonder what the difference between index_object abd

Re: [Zope-dev] ZCatalog reindex_object

2000-12-31 Thread Steve Alexander
Chris Withers wrote: Michael Bernstein wrote: reindex_object - should be called when an object is edited Hmmm... didn't see this method listed in the interfaces wiki. Where did you find it? reindex_object is a method of the mix-in class CatalogAwareness.

Re: [Zope-dev] ZCatalog reindex_object

2000-12-31 Thread Chris Withers
Steve Alexander wrote: reindex_object is a method of the mix-in class CatalogAwareness. Ah, that's okay then, since Squishdot doesn't have anything to do with CatalogAwareness. I think calling index_object should work, as a well-implemented catalog will do the right thing. However, calling

[Zope-dev] Re: [squishdot] ZCatalog reindex_object

2000-12-31 Thread Michael Bernstein
Chris Withers wrote: Michael Bernstein wrote: reindex_object - should be called when an object is edited Hmmm... didn't see this method listed in the interfaces wiki. Where did you find it? I found it in the 'Creating a CatalogAware ZClass' HowTo:

[Zope-dev] UNEXPECTED: Acquisition.Explicit may acquire implicitly

2000-12-31 Thread Dieter Maurer
While trying to understand, what the "bself= self.aq_explicit" in "OFS.DTMLMethod.__call__" should do, I detected an unexpected behaviour: usually, this "bself" acquires implicitly from its container (though not from its context) More precisely: if "bself.aq_self" is itself an

[Zope] New install - no management screen?

2000-12-31 Thread Glenn Gillis
After installing 2.2.4 on a Windows 2000 workstation to begin learning Zope I'm having trouble getting the management screen to display. When connecting to http://localhost:8080/manage I can log in successfully, created a new user with the "manager" role and get the tree (control panel, acl

Re: [Zope] New install - no management screen?

2000-12-31 Thread Martijn Pieters
On Sun, Dec 31, 2000 at 12:39:37AM -0800, Glenn Gillis wrote: After installing 2.2.4 on a Windows 2000 workstation to begin learning Zope I'm having trouble getting the management screen to display. When connecting to http://localhost:8080/manage I can log in successfully, created a new user

Re: [Zope] New install - no management screen?

2000-12-31 Thread Aleksander Salwa
On Sun, 31 Dec 2000, Glenn Gillis wrote: After installing 2.2.4 on a Windows 2000 workstation to begin learning Zope I'm having trouble getting the management screen to display. When connecting to http://localhost:8080/manage I can log in successfully, created a new user with the "manager"

[Zope] RE: New install - no management screen? (resolved)

2000-12-31 Thread Glenn Gillis
Thanks for the suggestions. It turns out to have been an Internet Explorer thing. I pulled the site up in Netscape and everything works fine. I was on IE 5.01 SP1, upgrading to 5.5 SP1 seems to have resolved the problem. ___ Zope maillist - [EMAIL

[Zope] reporting 2.3.0a1 bugs

2000-12-31 Thread Timothy Wilson
Hey everyone, I've discovered a couple problems with 2.3.0a1. Should those be submitted to the collector, or is there somewhere else to report problems with development versions? -Tim -- Tim Wilson | Visit Sibley online: | Check out: Henry Sibley HS | http://www.isd197.k12.mn.us/

RE: [Zope] RE: New install - no management screen? (resolved)

2000-12-31 Thread Randall F. Kern
I realize you've already worked around this problem, but I've seen this on some installations of IE. The solution I've found is to delete all cookies from the client. -Randy -Original Message- From: Glenn Gillis [mailto:[EMAIL PROTECTED]] Sent: Sunday, December 31, 2000 8:57 AM To:

[Zope] date: Are month and day required?

2000-12-31 Thread Kyler B. Laird
We just ran into some strange behavior with date properties. Although hour, minute, second, timezone, ... are not required, day and month seem to be. Is there a way to specify only the year or only the year and month? (The ZQR was referenced, but I didn't find info there.) Thank you.

Re: [Zope] reporting 2.3.0a1 bugs

2000-12-31 Thread Martijn Pieters
On Sun, Dec 31, 2000 at 12:16:08PM -0600, Timothy Wilson wrote: I've discovered a couple problems with 2.3.0a1. Should those be submitted to the collector, or is there somewhere else to report problems with development versions? Please report them to the collector. Thanks! -- Martijn

[Zope] UNEXPECTED: Acquisition.Explicit may acquire implicitly

2000-12-31 Thread Dieter Maurer
While trying to understand, what the "bself= self.aq_explicit" in "OFS.DTMLMethod.__call__" should do, I detected an unexpected behaviour: usually, this "bself" acquires implicitly from its container (though not from its context) More precisely: if "bself.aq_self" is itself an

Re: [Zope] Re: Z-Commerce components

2000-12-31 Thread Jason Cunliffe
Hi Brad Delighted to hear that Wampum and Zope work well for you. I just took a quick look at your site - very nice. However it seems very slow to load even a simple page and when I tried to but something the Checkout pages came up with broken icons :-( Am I unlucky or do you have a problem?