[Zope-dev] Re: Python warnings behavior and stacklevel=2

2006-02-17 Thread Julien Anguenot
Stefan H. Holek wrote: This turned out to be a bug in FSPythonScripts (no __file__ in script globals). Fixed on all branches of CMF = 1.5. Great ! Thanks. J. On 13. Feb 2006, at 16:48, Julien Anguenot wrote: Florent Guillaume wrote: Julien Anguenot wrote: Tim Peters wrote:

[Zope-dev] Re: merge zope-dev and zope3-dev?

2006-02-17 Thread Chris Withers
Philipp von Weitershausen wrote: We'd have to declare the zope3-dev list for obsolete and make people not send messages to it. We'd just have to define a date and time. All subsequent mail traffic would be handled by zope-dev. Okay, who actually makes this call and how to we set a date?

[Zope-dev] Re: [Zope3-dev] Re: merge zope-dev and zope3-dev?

2006-02-17 Thread Gary Poster
On Feb 17, 2006, at 6:26 PM, Chris Withers wrote: Philipp von Weitershausen wrote: We'd have to declare the zope3-dev list for obsolete and make people not send messages to it. We'd just have to define a date and time. All subsequent mail traffic would be handled by zope-dev. Okay, who

[Zope-dev] Re: [Zope3-dev] Re: merge zope-dev and zope3-dev?

2006-02-17 Thread Benji York
Gary Poster wrote: On Feb 17, 2006, at 6:26 PM, Chris Withers wrote: Philipp von Weitershausen wrote: We'd have to declare the zope3-dev list for obsolete and make people not send messages to it. We'd just have to define a date and time. All subsequent mail traffic would be handled by

[Zope-dev] Re: [Zope3-dev] merge zope-dev and zope3-dev?

2006-02-17 Thread Fred Drake
On 2/16/06, Chris Withers [EMAIL PROTECTED] wrote: To be clear: I'm talking _only_ about merging the dev lists, _not_ the user lists. The users lists are still largely independent, but it seems like just about every post to the dev list now has a bearing on both Zope 2 and Zope 3, especially

Re: [Zope-dev] Re: [Zope3-dev] Re: merge zope-dev and zope3-dev?

2006-02-17 Thread Paul Winkler
if we're voting, I'm +0. -- Paul Winkler http://www.slinkp.com ___ Zope-Dev maillist - Zope-Dev@zope.org http://mail.zope.org/mailman/listinfo/zope-dev ** No cross posts or HTML encoding! ** (Related lists -

Re: [Zope-dev] Re: [Zope3-dev] Re: merge zope-dev and zope3-dev?

2006-02-17 Thread Jim Fulton
Gary Poster wrote: On Feb 17, 2006, at 6:26 PM, Chris Withers wrote: Philipp von Weitershausen wrote: We'd have to declare the zope3-dev list for obsolete and make people not send messages to it. We'd just have to define a date and time. All subsequent mail traffic would be handled by

[Zope] Zope scheduling problem

2006-02-17 Thread Nicholas Watmough
Hello, I'm not sure if this is the correct forum for my question. I'm running Zope 2.9.0 (though I've tried it on 2.8.5, with the same problem). I have a Python script in a Zope folder that checks a specified email address, packages all the emails and attachments, and adds them into a

[Zope] Re: Zope scheduling problem

2006-02-17 Thread Pawel Lewicki
Nicholas Watmough napisaƂ(a): Hello, I'm not sure if this is the correct forum for my question. I'm running Zope 2.9.0 (though I've tried it on 2.8.5, with the same problem). I have a Python script in a Zope folder that checks a specified email address, packages all the emails and

Re: [Zope] Zope 2.9 and SSL

2006-02-17 Thread Martijn Pieters
On 2/16/06, Ron Bickers [EMAIL PROTECTED] wrote: On Thu February 16 2006 03:31, you wrote: http://www.lighttpd.net/ How many millions of people use this a day? I have no idea. Far less than use Apache, of course, but the number appears to be growing steadily. The netcraft survey for

Re: [Zope] Zope 2.9 and SSL

2006-02-17 Thread Ron Bickers
On Fri February 17 2006 04:32, Martijn Pieters wrote: The netcraft survey for February counted 21699 instances of lighttpd; Zope was counted 41656 times: http://survey.netcraft.com/Reports/200602/ The numbers are those seen by Netcraft during January. Lighttpd is barely three years old.

Re: [Zope] Re: Zope scheduling problem

2006-02-17 Thread Stefan H. Holek
Uhm, you sure this patch is a good idea? Why not use portal_catalog.unrestrictedSearchResults? Stefan On 17. Feb 2006, at 10:14, Pawel Lewicki wrote: Hi, The problem is with portal_catalog. See/apply this patch http://www.zope.org/Collectors/CMF/380 Pawel -- Anything that happens,

Re: [Zope] Error Value: 'File' object has no attribute 'manage_fixupOwnershipAfterAdd'

2006-02-17 Thread Chris Withers
Roman Klesel wrote: form OFS.Image import File - I build a class _File(File): I really doubt you need to do that... - pimped it up a little bit. What, specifically, did you add? - _setObject'ed it You shouldn't be calling that directly... Chris -- Simplistix - Content Management,

Re: [Zope] Error Value: 'File' object has no attribute 'manage_fixupOwnershipAfterAdd'

2006-02-17 Thread Chris Withers
Roman Klesel wrote: for id in self.manage_targets.keys(): title = self.manage_targets[id]['name'] self.tgt_folder=Folder() This is dangerous...

Re: [Zope] Re: restricting permissions for direct access only

2006-02-17 Thread Chris Withers
Michael Shulman wrote: I don't understand what inheriting proxy roles from callers has to do with allowing users to access protected resources above their user folders. They seem like totally different questions to me. Could you please explain? Nothing, different threads, crossed wires,

Re: [Zope] Zope 2.9 and SSL

2006-02-17 Thread Chris Withers
Ron Bickers wrote: Both lighty and Apache use OpenSSL. Good point ;-) I'm using it and haven't seen any battlefield casualties so far. ;-) Apache has its share of (even recent) security issues, including some related to mod_ssl. Honestly, I see that as a good thing! It's a bit like the

[Zope] proxy roles don't get passed down a method call chain?

2006-02-17 Thread Chris Withers
Tres Seaver wrote: IIRC, if you had scripta calling scriptb, you used to be able to give scripta a proxy role and scriptb would also execute with that role. However, again IIRC, in current Zope releases, if you give scripta a proxy role, when it calls scriptb, scriptb will just run with the

Re: [Zope] SSL Digest Auth

2006-02-17 Thread Chris Withers
Andrew Milton wrote: In Digest Auth the browser 'hashes' the username and password the user enters and simply sends the hash. The webserver does the same and compares the hash to the hash sent by the browser. If they match then you're allowed in. In Basic Auth the username and password are

Re: [Zope] installing PIL on Window Zope

2006-02-17 Thread Chris Withers
Allen Huang wrote: Hi... I assume that you mean to make modification to the path to the python interpreter in Zope at the \etc\zope.conf right? No, you need to make the changes in runzope.bat, zope.conf is too late in the startup process... cheers, Chris -- Simplistix - Content

Re: [Zope] Zope 2.9 and SSL

2006-02-17 Thread Martijn Pieters
On 2/17/06, Ron Bickers [EMAIL PROTECTED] wrote: I noticed that my lighttpd server that proxies to Zope responds as Zope/ZServer, not lighttpd. If I recall, Apache said Apache. There must be many more Zopes than netcraft shows, right? No, Zope behind Apache with ProxyPass also reports as

Re: [Zope] Zope scheduling problem

2006-02-17 Thread Martijn Pieters
On 2/17/06, Nicholas Watmough [EMAIL PROTECTED] wrote: I've set a proxy for the script so it runs as a Manager. However, when I set a ZopeScheduler to run this script, I get an error where the ZCatalog doesn't find any results when I search for the PloneArticle instance. Now the article I am

[Zope] Re: where to install rtf2xml script to work with Zope andTextIndexNG?

2006-02-17 Thread Owen K
Thanks Andreas. ___ Zope maillist - Zope@zope.org http://mail.zope.org/mailman/listinfo/zope ** No cross posts or HTML encoding! ** (Related lists - http://mail.zope.org/mailman/listinfo/zope-announce

Re: [Zope] Zope 2.9 and SSL

2006-02-17 Thread Ron Bickers
On Fri February 17 2006 05:19, Martijn Pieters wrote: On 2/17/06, Ron Bickers [EMAIL PROTECTED] wrote: I noticed that my lighttpd server that proxies to Zope responds as Zope/ZServer, not lighttpd. If I recall, Apache said Apache. There must be many more Zopes than netcraft shows, right?

Re: [Zope] Granting access by reading http headers (Consulting opportunity)

2006-02-17 Thread Marc Schnapp
If anyone here has the consulting expertise to help implement a solution, please email me separately at m + schnapp + service + marc + dot + com. (See my elaborations below) Chris Withers wrote: Marc Schnapp wrote: We're running Plone for internal departmental use. I'm going to lock down

Re: [Zope] Zope 2.9 and SSL

2006-02-17 Thread Tino Wildenhain
Ron Bickers schrieb: On Fri February 17 2006 05:19, Martijn Pieters wrote: ... Ok. I thought it was reporting Apache for me before, but I don't recall for sure. Does using mod_rewrite with [P] report the same? Yes, and its working internally identically :-) Apache as frontend proxy

Re: [Zope] Granting access by reading http headers (Consulting opportunity)

2006-02-17 Thread Tino Wildenhain
Marc Schnapp schrieb: If anyone here has the consulting expertise to help implement a solution, please email me separately at m + schnapp + service + marc + dot + com. Its much easier as you might think. You dont even change Zope for this if you are using apache as front end proxy via usual

Re: [Zope] Zope 2.9 and SSL

2006-02-17 Thread Ron Bickers
On Fri February 17 2006 14:05, Tino Wildenhain wrote: Apache as frontend proxy returning apache must be a common urban legend. This pops up from time to time albeit its so easy to check and make sure ;-) Except that I don't have Apache installed anymore. :-) I know at one time it did not

Re: [Zope] Granting access by reading http headers (Consulting opportunity)

2006-02-17 Thread Marc Schnapp
Thanks for the approach! We will be using Apache as the proxy. Question: So if the conditions match: client-ip = your special crawler and useragent = your crawler - RequestHeader set Cookie ... Am I writing a cookie that Plone would recognize as the Google mini Plone user? Would you know

[Zope] TextIndexNG3 install problem

2006-02-17 Thread Owen K
Hi all, I am trying to install TextIndexNG 3.1.5 on Windows. I recompiled the pyd files successfully using MinGW. However TextIndexNG3 setup fails to find them, traceback included below. There are three instructions from the fine manual and elsewhere that I am trying to follow: 1. README says

[Zope] Re: TextIndexNG3 install problem

2006-02-17 Thread Owen K
Update: I have learned how to uncomment configure.zcml by removing a matching pair !-- -- ; then restarted Zope. At this point the traceback looks the same as documented below and the install configlet does not appear in Plone 2.1.2 add/remove products page. There is an error reported on that

Re: [Zope] TextIndexNG3 install problem

2006-02-17 Thread Andreas Jung
--On 17. Februar 2006 16:01:34 -0500 Owen K [EMAIL PROTECTED] wrote: Hi all, I am trying to install TextIndexNG 3.1.5 on Windows. I recompiled the pyd files successfully using MinGW. However TextIndexNG3 setup fails to find them, traceback included below. There are three instructions from