[Zope] Socket.error problem

2000-10-08 Thread Ronald L. Chichester

I'm getting the exact same socket.error message that appeared on this
list in March, 2000.  (See the attached problem.txt file.)
Specifically, this is the error message that I get when I start zope.
The person who kindly identified the problem didn't provide a solution.
I have my netstat -a results attached as netstat.txt.  Could someone
tell me how I can resolve this port conflict?

Incidentally, I'm using Mandrake 7.1 in a fairly standard configuration.

Thanks in advance,

Ron
 ./.



This is the reply that was provided to the first person who encountered
this problem (and submitted it to the list):

MESSAGE

You have another process that is "bind" to port 98...

this is the registered port for "tacnews".

try "netstat -a" under the shell...

- Message d'origine -
De : Ulf Byskov [EMAIL PROTECTED]
À : [EMAIL PROTECTED]
Envoyé : lundi 13 mars 2000 11:28
Objet : [Zope] socket problem


 When I try to start Z Server i get the following error messages:

 File

"/WWW/Docs/product_development/teams/AMD_framework/dev/Zope/ZServer/medusa/a

syncore.py",
 line 205, in bind
 return self.socket.bind (addr)
 socket.error: (98, 'Address already in use')


 I don't use the number 98 in any address or port (http=80, ftp='' and
 monitor='')
 so what could this error be about ?




/MESSAGE


[nobody@localhost Zope-2.2.2-linux2-x86]$ ./start
--
2000-10-08T-5:31:03 PROBLEM(100) ZServer Computing default hostname
--
2000-10-08T-5:31:03 INFO(0) ZServer Medusa (V1.16.4.3) started at Sun OCt  8 00:31:03 
2000
Hostname: localhost.localdomain
Port:8080

Traceback (innermost last):
File ?/usr/local/Zope-2.2.2-linux2-x86/z2.py?, line 634, in ?
logger_object=lg)
File "/usr/local/Zope-2.2.2-linux2-x86/ZServer/FTPServer.py?, line 619, in 
__init__
apply(ftp_server.__init__, (self, None) + args, kw)
File ?/usr/local/Zope-2.2.2-linux2-x86/ZServer/medusa/ftp_server.py?, line 
725, in  __init__ self.bind ((self.ip, self.port))
File ?/usr/local/Zope-2.2.2-linux2-x86/ZServer/medusa/asyncore.py?, line 242, 
in bind   return self.socket.bind (addr)
socket.error: (98, ?Address already in use?)



Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address   Foreign Address State  
tcp0  0 *:6000  *:* LISTEN  
tcp0  0 *:3053  *:* LISTEN  
tcp0  0 *:8021  *:* LISTEN  
tcp0  0 *:postgres  *:* LISTEN  
tcp0  0 *:www   *:* LISTEN  
tcp0  0 *:smtp  *:* LISTEN  
tcp0  0 *:printer   *:* LISTEN  
tcp0  0 *:pop3  *:* LISTEN  
tcp0  0 *:telnet*:* LISTEN  
tcp0  0 *:ftp   *:* LISTEN  
tcp0  0 *:auth  *:* LISTEN  
tcp0  0 *:sunrpc*:* LISTEN  
udp0  0 *:xdmcp *:* 
udp0  0 *:sunrpc*:* 
raw0  0 *:icmp  *:* 7   
raw0  0 *:tcp   *:* 7   
Active UNIX domain sockets (servers and established)
Proto RefCnt Flags   Type   State I-Node Path
unix  1  [ ] STREAM CONNECTED 26342  @00d9
unix  0  [ ACC ] STREAM LISTENING 1402   public/showq
unix  0  [ ACC ] STREAM LISTENING 1398   private/smtp
unix  0  [ ACC ] STREAM LISTENING 1389   private/bounce
unix  0  [ ] STREAM CONNECTED 194@001d
unix  1  [ ] STREAM CONNECTED 26259  @00cb
unix  0  [ ACC ] STREAM LISTENING 2816   /var/run/pcgi.soc
unix  0  [ ACC ] STREAM LISTENING 1406   private/error
unix  9  [ ] DGRAM382/dev/log
unix  0  [ ACC ] STREAM LISTENING 2792   /tmp/.font-unix/fs-1
unix  0  [ ACC ] STREAM LISTENING 1687   /dev/gpmctl
unix  0  [ ACC ] STREAM LISTENING 1410   private/local
unix  0  [ ACC ] STREAM LISTENING 1414   private/cyrus
unix  1  [ ] STREAM CONNECTED 26267  @00ce
unix  1  [ ] STREAM CONNECTED 26253  @00c8
unix  0  [ ACC ] STREAM LISTENING 2848   /tmp/.X11-unix/X0
unix  0  [ ACC ] STREAM LISTENING 1418   private/uucp
unix  1  [ ] STREAM  

[Zope] DTML Method not working

2000-10-08 Thread Ronald L. Chichester

I took some code that was in the (work-in-progress) O'Riley book on
Zope.  In that example, then had a DTML Method used for identifying
folders and hyperlinking to them.  The code is as follows:

ul
dtml-in expr="objectValues('Folder')"
 lia href="dtml-absolute_url;"dtml-var title_or_id/abr/li
/dtml-in
/ul

The problem is, it doesn't work.  I know the method is being invoked
because there is some other text that is indeed being inserted.
Moreover, there are sub-folders in the folder that calls the method.

Does anyone know what the problem is?  Is it a permission issue.  The
standard_html_header and _footer, show up just fine, along with logos
and such.  The only part that isn't showing up is the stuff that was
supposed to be generated by the dtml-in block.

Any hints?

Thanks in advance.

Ron
 ./.


___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




Re: [Zope] DUMB NEWBIE QUESTION

2000-10-17 Thread Ronald L. Chichester

I had this problem myself.  I'm using Mandrake 7.1.  There are some things to do, 
depending on which distribution you are using.  What I did was use KPackage to 
uninstall Zope.  Then you get

http://www.zope.org/Members/nemeth/howtos/zopeandapacherh61

and follow the instuctions.  This works for RedHat and Mandrake.  Should also work for 
Turbo Linux and may work for others.  That should get you started.

Hope that helps.

Ron
 ./.

CURTIS David wrote:

 Friends of Zope,

 I am trying to get MySQL database connection installed.  I was told that I need to 
use source Zope instead of RPM's !  Fine with me but how do I install Zope source 
over RPM.  I tried unpacking Zope Source and installing but it creates a new 
directory tar -xvf Zope-2.1 instead of creating a /var/zope.  Also zope starts 
automatically.  Are there techniques to work around this???


 ___
 Zope maillist  -  [EMAIL PROTECTED]
 http://lists.zope.org/mailman/listinfo/zope
 **   No cross posts or HTML encoding!  **
 (Related lists -
  http://lists.zope.org/mailman/listinfo/zope-announce
  http://lists.zope.org/mailman/listinfo/zope-dev )


___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )