Re: [Zope] NEWBIE HELP can not get Zope to start

2000-09-08 Thread Martijn Pieters

On Thu, Sep 07, 2000 at 10:12:16PM -0400, Douglas Eadline wrote:
 6. OK, I'll add a user. I go to acl_users and add a user.
   
 7. I quit netscape, and restart and attempt to login as
the new user - DOES NOT WORK
 
 8 I check /var/zope/access - no new user added

Only the superuser (more accuratly the bootstrap user now) is defined in
the access file. All other users are defined in User objects in the Object
Database. You will notice that the file var/Data.fs will have grown.

 9. I quit netscape and re-login as superuser.
I look at the user I added, now the password field
has more stars in it than the password I assigned.
The confirm field has 1 star less than the password field.

For security reasons, the page with the password and confirm fields is not
rendered with the original password; you can view the source to see this,
the password would have to be sent verbatim in order to do that. In stead,
the magic values 'password' and' 'confirm' are used, to indicate that you
didn't want to change the user password, only the other fields.

One possible explanation for the denial of your login is that you filled
something in the domains field, which should only be used if you want to
limit the domains a user can login from, and made a mistake there. The
format is a _space seperated_ list of domains, each of which can use the
'*' wildcard for any part between the dots and can be an ip or a name:

  10.0.0.* localhost *.mydomain.com

If you did fill in that field, clear it, and try again. Also note that
both user id and password are case sensitive. Try a simple username and
password first, like 'test' and 'test'.

Let us know if you succeed!

-- 
Martijn Pieters
| Software Engineermailto:[EMAIL PROTECTED]
| Digital Creations  http://www.digicool.com/
| Creators of Zope   http://www.zope.org/
| ZopeStudio: http://www.zope.org/Products/ZopeStudio
-

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




Re: [Zope] NEWBIE HELP can not get Zope to start

2000-09-08 Thread J M Cerqueira Esteves

On Thu, Sep 07, 2000 at 10:12:16PM -0400, Douglas Eadline wrote:

 6. OK, I'll add a user. I go to acl_users and add a user.

Did you give it the "manager" role?


Best regards
  J Esteves
-- 
 jmce: +351 919838775 ~ http://artenumerica.com/ ~ http://artenumerica.org/

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




Re: [Zope] NEWBIE HELP can not get Zope to start

2000-09-08 Thread Phil Harris

Douglas,

You seem to be doing as expected, however a few points to note:

see below:

- Original Message -
From: "Douglas Eadline" [EMAIL PROTECTED]
To: [EMAIL PROTECTED]
Sent: Friday, September 08, 2000 3:12 AM
Subject: [Zope] NEWBIE HELP can not get Zope to start



 I have tried this 10 times with several versions of Zope and
 I get the same result - Zope will not let me add a user or log in.

 Here are my steps:

 1. download and install latest RPMS:
  Zope-2.2.1-1.i386.rpm
  Zope-zserver-2.2.1-1.i386.rpm

 2. Start zope:

 /etc/rc.d/init.d/zope start

 3. login as superuser

 superuser
 123

 4. See first Zope Screen

 5. Attempt to run the tutorial as described in the Content Managers Guide

Zope will not let superuser do this

 6. OK, I'll add a user. I go to acl_users and add a user.

 7. I quit netscape, and restart and attempt to login as
the new user - DOES NOT WORK

When you created the user did you give it managment permissions or is it
only a 'normal' user?

 8 I check /var/zope/access - no new user added

The new user doesn't get added to the access only superusers are put in
there (I think there has been some talk about having multiple su's tho).

The new user is put into the ZODB and accessed from there.


 9. I quit netscape and re-login as superuser.
I look at the user I added, now the password field
has more stars in it than the password I assigned.
The confirm field has 1 star less than the password field.

This is pure obfuscation, the password fields are set to a value that zope
recognises as you saying 'just change the properties associated with this
user, but leave the password alone'.


 I do not get it. Is there something to read that explains
 how to start Zope and try the tutorial?

As above, the only thing I can think of is that you didn't give the new user
the correct permissions.


 Or is this some secret only Zope hackers know?

No secrets, we don't have secrets here ;)

hth

Phil
[EMAIL PROTECTED]



 Doug
 ---
 Paralogic, Inc.   | PEAK |  Voice:+610.814.2800
 130 Webster Street|   PARALLEL   |Fax:+610.814.5844
 Bethlehem, PA 18015 USA   |  PERFORMANCE |http://www.plogic.com
 ---


 ___
 Zope maillist  -  [EMAIL PROTECTED]
 http://lists.zope.org/mailman/listinfo/zope
 **   No cross posts or HTML encoding!  **
 (Related lists -
  http://lists.zope.org/mailman/listinfo/zope-announce
  http://lists.zope.org/mailman/listinfo/zope-dev )


___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




Re: [Zope] NEWBIE HELP can not get Zope to start

2000-09-08 Thread Steve Spicklemire


 "Martijn" == Martijn Pieters [EMAIL PROTECTED] writes:

 
 7. I quit netscape, and restart and attempt to login as the new
 user - DOES NOT WORK
 
Martijn One possible explanation for the denial of your login is
Martijn that you filled something in the domains field, which
Martijn should only be used if you want to limit the domains a

Another common problem I've seen is that folks don't select a *role*
for their new user did you give the new user the 'manager' role?

-steve



___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




Re: [Zope] NEWBIE HELP can not get Zope to start

2000-09-08 Thread Martijn Pieters

On Fri, Sep 08, 2000 at 06:50:20AM -0500, Steve Spicklemire wrote:
 
  "Martijn" == Martijn Pieters [EMAIL PROTECTED] writes:
 
  
  7. I quit netscape, and restart and attempt to login as the new
  user - DOES NOT WORK
  
 Martijn One possible explanation for the denial of your login is
 Martijn that you filled something in the domains field, which
 Martijn should only be used if you want to limit the domains a
 
 Another common problem I've seen is that folks don't select a *role*
 for their new user did you give the new user the 'manager' role?

A common error here is to assume that the list of Roles you see are the
Roles the USer has been given. In stead, it is a list of _possible_ Roles,
you need to select which ones this User will have.

-- 
Martijn Pieters
| Software Engineermailto:[EMAIL PROTECTED]
| Digital Creations  http://www.digicool.com/
| Creators of Zope   http://www.zope.org/
| ZopeStudio: http://www.zope.org/Products/ZopeStudio
-

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




Re: [Zope] NEWBIE HELP can not get Zope to start

2000-09-08 Thread Douglas Eadline

On Fri, 8 Sep 2000, Martijn Pieters wrote:

 On Thu, Sep 07, 2000 at 10:12:16PM -0400, Douglas Eadline wrote:
  6. OK, I'll add a user. I go to acl_users and add a user.

  7. I quit netscape, and restart and attempt to login as
 the new user - DOES NOT WORK
  
  8 I check /var/zope/access - no new user added
 
 Only the superuser (more accuratly the bootstrap user now) is defined in
 the access file. All other users are defined in User objects in the Object
 Database. You will notice that the file var/Data.fs will have grown.
 
  9. I quit netscape and re-login as superuser.
 I look at the user I added, now the password field
 has more stars in it than the password I assigned.
 The confirm field has 1 star less than the password field.
 
 For security reasons, the page with the password and confirm fields is not
 rendered with the original password; you can view the source to see this,
 the password would have to be sent verbatim in order to do that. In stead,
 the magic values 'password' and' 'confirm' are used, to indicate that you
 didn't want to change the user password, only the other fields.
 
 One possible explanation for the denial of your login is that you filled
 something in the domains field, which should only be used if you want to
 limit the domains a user can login from, and made a mistake there. The
 format is a _space seperated_ list of domains, each of which can use the
 '*' wildcard for any part between the dots and can be an ip or a name:
 
   10.0.0.* localhost *.mydomain.com
 
 If you did fill in that field, clear it, and try again. Also note that
 both user id and password are case sensitive. Try a simple username and
 password first, like 'test' and 'test'.
 
 Let us know if you succeed!
 
 

It works now. I needed to highlight the manager Role.


Thanks.

Doug
-- 
---
Paralogic, Inc.   | PEAK |  Voice:+610.814.2800
130 Webster Street|   PARALLEL   |Fax:+610.814.5844
Bethlehem, PA 18015 USA   |  PERFORMANCE |http://www.plogic.com
---


___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




[Zope] NEWBIE HELP can not get Zope to start

2000-09-07 Thread Douglas Eadline


I have tried this 10 times with several versions of Zope and
I get the same result - Zope will not let me add a user or log in.

Here are my steps:

1. download and install latest RPMS:
 Zope-2.2.1-1.i386.rpm 
 Zope-zserver-2.2.1-1.i386.rpm

2. Start zope:

/etc/rc.d/init.d/zope start

3. login as superuser

superuser
123

4. See first Zope Screen

5. Attempt to run the tutorial as described in the Content Managers Guide

   Zope will not let superuser do this

6. OK, I'll add a user. I go to acl_users and add a user.
  
7. I quit netscape, and restart and attempt to login as
   the new user - DOES NOT WORK

8 I check /var/zope/access - no new user added

9. I quit netscape and re-login as superuser.
   I look at the user I added, now the password field
   has more stars in it than the password I assigned.
   The confirm field has 1 star less than the password field.

I do not get it. Is there something to read that explains 
how to start Zope and try the tutorial?

Or is this some secret only Zope hackers know?

Doug
---
Paralogic, Inc.   | PEAK |  Voice:+610.814.2800
130 Webster Street|   PARALLEL   |Fax:+610.814.5844
Bethlehem, PA 18015 USA   |  PERFORMANCE |http://www.plogic.com
---


___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )