Re: [Zope] ZWikiWebs Product

2001-01-11 Thread Chris Withers

Simon Michael wrote:
 
 The separate
 zwikiwebs product is due to be retired and not recommended.

It has been :-)

cheers,

Chris

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




[Zope] ZWikiWebs Product

2001-01-10 Thread Matthew Monacelli

Has anyone else had trouble using the ZWikiWeb product?  As Manager, there
are no problems, but users I have added cannot add ZWikiWebs in their own
folders.  While already logged in, a login box comes up, meaning they do not
have the necessary permissions.  When I cancel the box, I get the Zope error
message stating that the user is not authorized to access Control_Panel.  I
have given the user role (that I created) access to view contents, view, use
factories, change zwiki pages, and serveral others.  Is there something I am
missing?

Thanks,
Matt

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




Re: [Zope] ZWikiWebs Product

2001-01-10 Thread Marty Stitt



I have a 2.2.5 based system with the Yihaw and ZWikiWeb products installed.

When I try to add a ZWikiWeb within a Yihaw folder, I experienced a
permissions problem that sounds like what you describe.  But, I did find that
I could install a wiki object within a standard Folder object without this
problem.  So, when you say that users can't install them in "their own
folders", what type of folder is that?  Instead of trying to debug why a
wikiweb object couldn't be put into a Yihaw Folder, I just reworked my design
to let me put my wiki objects into a standard folder, and then created a
linkage so that the users involved could get at the wiki.

Within the Security tab of the management page for the wiki object, there are
two permissions you want to assign to some role your users have:  "Add ZWiki
Pages", and "Change ZWiki Pages".





Matthew Monacelli wrote:
 
 Has anyone else had trouble using the ZWikiWeb product?  As Manager, there
 are no problems, but users I have added cannot add ZWikiWebs in their own
 folders.  While already logged in, a login box comes up, meaning they do not
 have the necessary permissions.  When I cancel the box, I get the Zope error
 message stating that the user is not authorized to access Control_Panel.  I
 have given the user role (that I created) access to view contents, view, use
 factories, change zwiki pages, and serveral others.  Is there something I am
 missing?
 
 Thanks,
 Matt
 
 ___
 Zope maillist  -  [EMAIL PROTECTED]
 http://lists.zope.org/mailman/listinfo/zope
 **   No cross posts or HTML encoding!  **
 (Related lists -
  http://lists.zope.org/mailman/listinfo/zope-announce
  http://lists.zope.org/mailman/listinfo/zope-dev )

-- 
Martin Stitt
Chief Software Engineer
Esker, Inc.
email: [EMAIL PROTECTED]
phone: (608) 273-6000 x331
fax:   (608) 273-8227
web:   http://www.esker.com

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




Re: [Zope] ZWikiWebs Product

2001-01-10 Thread Simon Michael

Off the top of my head -

you don't mention whether they have Add ZWiki Webs permission -
presumably they do

are you using the zwikiwebs.zexp shipped with zwiki ? The separate
zwikiwebs product is due to be retired and not recommended.

-Simon

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )