Re: [Zope-CMF] Test setup problems with Zope 2.13

2010-07-28 Thread Hanno Schlichting
Morning. On Tue, Jul 27, 2010 at 1:09 PM, yuppie y.2...@wcm-solutions.de wrote: The whole registerPackage concept is a can of worms. We need real ZCML directives for *all* the stuff currently done in initialization functions. And to deprecate the usage of initialize instead of expanding that

Re: [Zope-CMF] Test setup problems with Zope 2.13

2010-07-28 Thread yuppie
Hi! Hanno Schlichting wrote: Zope2 has: registerClass registerIcon registerIcon is defined in CMFCore, not in Zope2. HelpSys (effectively deprecated) CMF brings in: ToolInit ContentInit ContentInit is only used for BBB. It registers oldstyle constructors. I'd love to see someone

Re: [Zope-CMF] Test setup problems with Zope 2.13

2010-07-28 Thread Charlie Clark
Am 28.07.2010, 14:28 Uhr, schrieb Hanno Schlichting ha...@hannosch.eu: Well, right. Except in Plone / Archetypes this and variants based on it are still the only option. Archetypes doesn't know about add views or any of that new IFactory pattern. Hi, thanks for reverting the changes and all

Re: [Zope-CMF] Test setup problems with Zope 2.13

2010-07-27 Thread yuppie
Hi! Hanno Schlichting wrote: On Sat, Jul 24, 2010 at 3:26 PM, Hanno Schlichtinghanno-+xqisr9sqhvsq35pwsn...@public.gmane.org wrote: Hhm. This all looks like a can of worms to me. I think I'll still revert my changes for 2.13 and see if I find the proper motivation to fix this for 2.14

Re: [Zope-CMF] Test setup problems with Zope 2.13

2010-07-25 Thread Hanno Schlichting
On Sat, Jul 24, 2010 at 3:26 PM, Hanno Schlichting ha...@hannosch.eu wrote: Hhm. This all looks like a can of worms to me. I think I'll still revert my changes for 2.13 and see if I find the proper motivation to fix this for 2.14 instead. I reverted this now and all tests pass again. Both CMF

Re: [Zope-CMF] Test setup problems with Zope 2.13

2010-07-24 Thread Hanno Schlichting
On Thu, Jul 22, 2010 at 2:00 PM, yuppie y.2...@wcm-solutions.de wrote: yuppie wrote: +...@layer.onsetup    def installPackage(name, quiet=0):        '''Installs a registered Python package.''' Oops! For some unknown reason @layer.onsetup was explicitly removed here:

Re: [Zope-CMF] Test setup problems with Zope 2.13

2010-07-22 Thread yuppie
Hi Hanno! Hanno Schlichting wrote: Looks like nobody feels like jumping into the test layers waters. Finally found some time to look into this. Unless someone does in the next days, I'll revert the OFS / OFSP refactoring on Zope trunk. AFAICS this is the point where you went astray:

Re: [Zope-CMF] Test setup problems with Zope 2.13

2010-07-22 Thread yuppie
yuppie wrote: +...@layer.onsetup def installPackage(name, quiet=0): '''Installs a registered Python package.''' Oops! For some unknown reason @layer.onsetup was explicitly removed here: http://svn.zope.org/?view=revrev=89898 ???, Yuppie

Re: [Zope-CMF] Test setup problems with Zope 2.13

2010-07-11 Thread Charlie Clark
Am 11.07.2010, 13:54 Uhr, schrieb Hanno Schlichting ha...@hannosch.eu: Hi. Maybe you have noticed from my commits today, but we have some test setup problems in Zope 2.13. I tried to solve those, but failed so far. Unfortunately we don't have nightly test runs for any CMF + Zope 2.13

Re: [Zope-CMF] Test setup problems with Zope 2.13

2010-07-11 Thread Hanno Schlichting
Hi Charlie, On Sun, Jul 11, 2010 at 7:31 PM, Charlie Clark charlie.cl...@clark-consulting.eu wrote: 2010-07-11 19:23:38 ERROR Application Couldn't install BTreeFolder2 Traceback (most recent call last): ...     stat_info = os.stat(path) OSError: [Errno 2] No such file or directory: