[Zope-CMF] Re: GenericSetup now incompatible with Zope 2.8?

2006-06-07 Thread Philipp von Weitershausen
yuppie wrote: Jens Vagelpohl wrote: This checkin seems to have broken Zope 2.8-compatibility: http://svn.zope.org/GenericSetup/trunk/tests/common.py?rev=68391r1=41338r2=68391 Specifically, the line from zope.testing.cleanup import cleanUp breaks Zope 2.8, I checked all stable tags (2.8.5,

[Zope-CMF] Re: GenericSetup now incompatible with Zope 2.8?

2006-06-07 Thread yuppie
Hi Philipp! Philipp von Weitershausen wrote: yuppie wrote: Should be fixed now: http://svn.zope.org/?rev=68474view=rev Simply avoiding the cleanup in Zope 2.8 isn't a proper fix. You should instead do the following (which works across all Zopes): from zope.testing.cleanup import

[Zope-CMF] Re: GenericSetup now incompatible with Zope 2.8?

2006-06-03 Thread Martin Aspeli
On Sat, 03 Jun 2006 12:16:06 +0100, Jens Vagelpohl [EMAIL PROTECTED] wrote: -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 This checkin seems to have broken Zope 2.8-compatibility: http://svn.zope.org/GenericSetup/trunk/tests/common.py? rev=68391r1=41338r2=68391 Specifically, the line

[Zope-CMF] Re: GenericSetup now incompatible with Zope 2.8?

2006-06-03 Thread yuppie
Jens Vagelpohl wrote: This checkin seems to have broken Zope 2.8-compatibility: http://svn.zope.org/GenericSetup/trunk/tests/common.py?rev=68391r1=41338r2=68391 Specifically, the line from zope.testing.cleanup import cleanUp breaks Zope 2.8, I checked all stable tags (2.8.5, 2.8.6, 2.8.7)