[Zope-CMF] Re: Help with Frostbite! Tres... Pls. reply to this and previous two in thread...

2005-11-29 Thread sureshvv
Question 4: I had a skins python script with proxy = Manager. This seems to fail 
inside the Frostbitten product. Is there a workaround?


Suresh

___
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See http://collector.zope.org/CMF for bug reports and feature requests


[Zope-CMF] Re: Help with Frostbite

2005-10-21 Thread sureshvv



1. Got an error about same_type being undefined. So I had to define this
function in my __init__.py

2. Got some errors about container not defined. I replaced these with
context. But not sure if I can do that everywhere.


Another weirdness.

1. The Python Scripts moved into __init__.py seem to be getting invoked without 
parameters other than self. I am having to provide default values for all of 
them and then get their values out of self.REQUEST. Is this by design or is

another Product that I have stepping all over Frostbite?

Suresh

___
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See http://collector.zope.org/CMF for bug reports and feature requests


[Zope-CMF] Re: Help with Frostbite

2005-10-19 Thread sureshvv

Tres Seaver wrote:

-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

robert rottermann wrote:




I would first try removing SpeedPack and redoing the Frostbite
generation.  Then, if the extracted templates in the generated file are
incorrect, you can bug me, with examples, drawn from stock Plone, which
are not being exported directly.


Got rid of SpeedPack and things have improved considerably :)

1. Got an error about same_type being undefined. So I had to define this
function in my __init__.py

2. Got some errors about container not defined. I replaced these with
context. But not sure if I can do that everywhere.

Suresh







___
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See http://collector.zope.org/CMF for bug reports and feature requests


[Zope-CMF] Re: Help with Frostbite

2005-10-18 Thread Tres Seaver
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

robert rottermann wrote:

 do you have SpeedPack installed?
 then you can not add any elements but the two types you mentioned.
 
 I had the same situation,  and helped myself by adding the frostbyte
 stuff to a directory in custom.
 You the have to adjust skinpath properties.

Good suggestion.  SpeedPack uses psyco, which is known to have funky
effects on things like debugging (it makes 'pdb.set_trace()' fail
silently, for one thing).

I would first try removing SpeedPack and redoing the Frostbite
generation.  Then, if the extracted templates in the generated file are
incorrect, you can bug me, with examples, drawn from stock Plone, which
are not being exported directly.

If the exported templates look correct (in the source), but are
rendering incorrectly under SpeedPack, then you may need to choose between:

 - running with SpeedPack and without your generated product

 - fixing SpeedPack

 - copying the still-pertinent parts of SpeedPack (like the psyco
   optimizations) into your generated product, and removing
   SpeedPack altogether.


Tres.
- --
===
Tres Seaver  +1 202-558-7113  [EMAIL PROTECTED]
Palladion Software   Excellence by Designhttp://palladion.com
-BEGIN PGP SIGNATURE-
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFDVNLH+gerLs4ltQ4RAktAAJsHUnYYcSAWiJuCO4nhemDdLFKfbwCg2d94
4s9dMTkgZAjgTUPV0dG0CIE=
=h9ly
-END PGP SIGNATURE-

___
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See http://collector.zope.org/CMF for bug reports and feature requests


[Zope-CMF] Re: Help with Frostbite

2005-10-17 Thread Tres Seaver
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

sureshvv wrote:
 
 Tres Seaver wrote:
 
 I don't see how that could be -- the skins tool add list is not filtered
 at all in stock CMF or in Plone.  What software provides your skins tool?
 
 Plone 2.1

I can't reproduce this issue in a Zope with Plone 2.1 installed,  Unless
you can tell me what the skins tool is doing that keeps you from being
able to add arbitrary objects to it, I doubt I can help you (it might be
the source of the rest of your problem, as well).



Tres.
-- 
===
Tres Seaver  +1 202-558-7113  [EMAIL PROTECTED]
Palladion Software   Excellence by Designhttp://palladion.com
-BEGIN PGP SIGNATURE-
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFDU/fe+gerLs4ltQ4RAj5WAJ43MFiW3M98YhwiLDa+g8wvOAN+kACgy/3o
FKZEYak7B3A7PHLzKppm1Wc=
=sLzU
-END PGP SIGNATURE-

___
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See http://collector.zope.org/CMF for bug reports and feature requests