[Zope-dev] Error Message

2001-01-26 Thread Andre Schubert
Hi all The last time i get some times the following error: 2001-01-26T08:45:55 ERROR(200) ZODB Couldn't load state for '\000\000\000\000\000\000\260\256' Traceback (innermost last): File /usr/share/zope_2.2/Zope-2.2.0-src/lib/python/ZODB/Connection.py, line 442, in setstate AttributeError:

[Zope-dev] AttributeError when adding ZClass product (PortalMembership)

2001-01-26 Thread Morten W. Petersen
Hi guys, I have a problem with a product. This product, let's call it product SuperSecret, adds a number of folderish objects to the new instance when it is created. Now, if we name the SuperSecret product instance for a, and the class instance that raises the AttributeError b, I will show you

[Zope-dev] ZCatalog FieldIndex bug in Zope 2.3.0b3

2001-01-26 Thread Chris Withers
Hi, FieldIndex's don't work quite right in 2.3. Try this: - create a Catalog with a FieldIndex called 'test' - create a DTML document with a property 'test', value 'fish' - catalog the document - now change the value of the property to 'finger' and re-catalog. If you now search for

RE: [Zope-dev] ZCatalog FieldIndex bug in Zope 2.3.0b3

2001-01-26 Thread Brian Lloyd
PS: Tabular reporting ZSearch Interfaces generated from Catalogs have quite badly b0rKen results forms, in that, for some reason, the search form ends up in a column of the results table, very confusing... Huh? I cannot reproduce this at all (or even see how it could happen, looking at

[Zope-dev] Key error using manage_changeProperties

2001-01-26 Thread Espen Sorbye Frederiksen
I am pssing the category argument to the method below. The category variable is representing a propety of the Log object. My code below works ok when I get the property (1), but fails when I try to update that property (2) with a new value. I have tried to use _[category] but it disallowes the

Re: [Zope-dev] ZCatalog FieldIndex bug in Zope 2.3.0b3

2001-01-26 Thread Chris Withers
Brian Lloyd wrote: PS: Tabular reporting ZSearch Interfaces generated from Catalogs have quite badly b0rKen results forms, in that, for some reason, the search form ends up in a column of the results table, very confusing... Huh? I cannot reproduce this at all (or even see how it

Re: [Zope-dev] ZCatalog FieldIndex bug in Zope 2.3.0b3

2001-01-26 Thread Chris McDonough
This is fixed in CVS. ChrisP works fast. :-) - Original Message - From: "Chris Withers" [EMAIL PROTECTED] To: "Chris McDonough" [EMAIL PROTECTED] Sent: Friday, January 26, 2001 11:23 AM Subject: Re: [Zope-dev] ZCatalog FieldIndex bug in Zope 2.3.0b3 Chris McDonough wrote: I've

Re: [Zope-dev] ZCatalog FieldIndex bug in Zope 2.3.0b3

2001-01-26 Thread Chris Withers
Chris Withers wrote: Okay, tracked down what's happening, can't understand why :-( Some data points before I rush off... - ZDebug doesn't like 2.3 very much :-S - Python Scripts rock ;-) However, from what ZDebug did show, it seems that the object the catalog has found ends up on the top of

Re: [Zope-dev] Server seems to stop responding.

2001-01-26 Thread Andy McKay
I think I've traced to a hack of ZCache, I nuked with much better results. I guess I'll wait for zope 2.3 Cheers. -- Andy McKay. - Original Message - From: "Chris McDonough" [EMAIL PROTECTED] To: "Andy McKay" [EMAIL PROTECTED]; [EMAIL PROTECTED] Sent: Thursday, January 25, 2001

Re: [Zope-dev] ZCatalog FieldIndex bug in Zope 2.3.0b3

2001-01-26 Thread Christopher Petrilli
On 1/26/01 11:41 AM, "Chris McDonough" [EMAIL PROTECTED] wrote: I've put the fieldindex bug in the collector. This is now fixed... It was a bizarre logic problem, but I could reproduce it easily :-) Thanks for finding this. Chris -- | Christopher Petrilli | [EMAIL PROTECTED]

Re: [Zope-dev] Passing arguments to DTML Methods

2001-01-26 Thread Jon Franz
This is an undocumented (afaik) feature of DTML methods/documents - due to the way python argument mapping works, you can pass any value into a 'local' variable in a DTML method like thus: dtml-var "myDTMLmethod(foo=5,greg=Sally)" this the above case, Sally could be a legal variable value that

[Zope-dev] FW: Re: [Zope-dev] Passing arguments to DTML Methods

2001-01-26 Thread Jon Franz
PS: my example assumes you _only_ want passed arguments to be usable to the DTML method you are calling - if you want to pass parameters And get the default namespace, you have to pass it ('_') also. My util methods that use params Only use those params (I try to keep a clean interface) - but

Re: [Zope-dev] ZCatalog FieldIndex bug in Zope 2.3.0b3

2001-01-26 Thread Christopher Petrilli
On 1/26/01 11:56 AM, "Chris Withers" [EMAIL PROTECTED] wrote: Chris Withers wrote: Okay, tracked down what's happening, can't understand why :-( Some data points before I rush off... - ZDebug doesn't like 2.3 very much :-S - Python Scripts rock ;-) However, from what ZDebug did

[Zope-dev] Fw: apparent problems with LocalFS after zope upgrade

2001-01-26 Thread Jonothan Farr
I'm getting reports of some very strange behavior with Zope 2.2.5 using the LocalFS product, which seems to involve the authentication mechanism somehow. I'm rather at a loss where to even begin troubleshooting here. If anyone has any suggestions they would be much appreciated. Thanks, --jfarr

[Zope-dev] ANNOUNCE: Zope 2.3.0 final released

2001-01-26 Thread Brian Lloyd
Hello all, Zope 2.3.0 final has been released - you can download it from Zope.org: http://www.zope.org/Products/Zope/2.3.0/ Zope 2.3 is focused on improving productivity, ease of use and performance. New features in the 2.3 release supporting these goals include: - Scripts

Re: [Zope-dev] ANNOUNCE: Zope 2.3.0 final released

2001-01-26 Thread Andy McKay
Congrats! -- Andy McKay. - Original Message - From: "Brian Lloyd" [EMAIL PROTECTED] To: [EMAIL PROTECTED] Sent: Friday, January 26, 2001 1:06 PM Subject: [Zope-dev] ANNOUNCE: Zope 2.3.0 final released Hello all, Zope 2.3.0 final has been released - you can download it from

[Zope-dev] Looks like 2.3.0 final didn't fix bug with copying ZCatalogs ...

2001-01-26 Thread Bill Anderson
...but the error message looks better ;^)= Installed fresh 2.3.0, and Membership, so I could finish the testing, and preop a 2.3.0 compatible release (mmm Python Scripts yummy), but upon the install trying to copy the MemberCatalog I get the following traceback. Perhaps it is an issue with