Re: [Zope-dev] Zope and Python compatibility

2003-01-14 Thread Toby Dickenson
On Monday 13 January 2003 7:46 pm, Casey Duncan wrote: I personally feel like Zope should run on 2.2.x whether required or not. Requiring 2.2.x does have the advantage of limiting the possible blessed configurations on which Zope will run, thereby making development, support and bug fixing

[Zope-dev] Zope and Python compatibility

2003-01-13 Thread Lennart Regebro
What would the arguments be for sticking with Zope 2.1.3 for Zope 2.7? I feel most people want to use the latest and greatest versions, usually... Or? Of course, if the requirement could be 2.1.3 *or* 2.2.2, that would be nice, but is that realistic?

Re: [Zope-dev] Zope and Python compatibility

2003-01-13 Thread Chris Withers
Lennart Regebro wrote: Of course, if the requirement could be 2.1.3 *or* 2.2.2, that would be nice, but is that realistic? This would be best and I don't see why it shouldn't happen... cheers, Chris ___ Zope-Dev maillist - [EMAIL PROTECTED]

Re: [Zope-dev] Zope and Python compatibility

2003-01-13 Thread Charlie Reiman
To: Lennart Regebro [EMAIL PROTECTED] cc: [EMAIL PROTECTED] Subject: Re: [Zope-dev] Zope and Python compatibility From: Guido van Rossum [EMAIL PROTECTED] Date: Mon, 13 Jan 2003 09:56:23 -0500 What would the arguments be for sticking with Zope 2.1.3 for Zope 2.7? I feel most people want

Re: [Zope-dev] Zope and Python compatibility

2003-01-13 Thread Casey Duncan
On Monday 13 January 2003 09:56 am, Guido van Rossum wrote: What would the arguments be for sticking with Zope 2.1.3 for Zope 2.7? I feel most people want to use the latest and greatest versions, usually... Actually, most people don't care about the latest and greatest, and would prefer

Re: [Zope-dev] zope and python compatibility

2003-01-12 Thread Toby Dickenson
On Saturday 11 January 2003 4:06 pm, Jamie Heilman wrote: Guido van Rossum wrote: Without python 2.2 zope will continue to harbor remotely exploitable zlib-based memory exhaustion attacks. FWIW There are workarounds that work in 2.1.x, and I dont think any uses in Zope are

Re: [Zope-dev] zope and python compatibility

2003-01-12 Thread Guido van Rossum
On Saturday 11 January 2003 4:06 pm, Jamie Heilman wrote: Guido van Rossum wrote: Without python 2.2 zope will continue to harbor remotely exploitable zlib-based memory exhaustion attacks. FWIW There are workarounds that work in 2.1.x, and I dont think any uses in Zope are

Re: [Zope-dev] zope and python compatibility

2003-01-12 Thread Toby Dickenson
On Sunday 12 January 2003 8:16 pm, Guido van Rossum wrote: On Saturday 11 January 2003 4:06 pm, Jamie Heilman wrote: Guido van Rossum wrote: Without python 2.2 zope will continue to harbor remotely exploitable zlib-based memory exhaustion attacks. FWIW There are workarounds that

Re: [Zope-dev] zope and python compatibility

2003-01-11 Thread Jamie Heilman
Guido van Rossum wrote: Without python 2.2 zope will continue to harbor remotely exploitable zlib-based memory exhaustion attacks. FWIW Can you explain? Where does Zope even use zlib? dtml-tree for one, more recent versions of ztutils' tree code as well although its mitigated to an extent

Re: [Zope-dev] zope and python compatibility

2003-01-10 Thread Guido van Rossum
Zope 2.5 + Python 2.1 -- Good Zope 2.6 + Python 2.1 -- Good Zope 2.7 + Python 2.1 -- Bad Zope 2.5 + Python 2.2 -- Bad Zope 2.6 + Python 2.2 -- Bad Zope 2.7 + Python 2.2 -- Good I'm beginning to wonder whether Zope 2.7 shouldn't require Python 2.1.3 rather than 2.2.2.

Re: [Zope-dev] zope and python compatibility

2003-01-10 Thread Jamie Heilman
I'm beginning to wonder whether Zope 2.7 shouldn't require Python 2.1.3 rather than 2.2.2. The original motivation for requiring 2.2.x was to allow easy backporting of Zope 3 components, and that is no longer a goal. I've asked Brian to review the version decision in this light. Without

Re: [Zope-dev] zope and python compatibility

2003-01-10 Thread Guido van Rossum
Without python 2.2 zope will continue to harbor remotely exploitable zlib-based memory exhaustion attacks. FWIW Can you explain? Where does Zope even use zlib? --Guido van Rossum (home page: http://www.python.org/~guido/) ___ Zope-Dev maillist -

[Zope-dev] zope and python compatibility

2003-01-09 Thread Tena Sakai
Greetings zope-dev folks, Please help me out. I have seen below via google search: Zope 2.5 + Python 2.1 -- Good Zope 2.6 + Python 2.1 -- Good Zope 2.7 + Python 2.1 -- Bad Zope 2.5 + Python 2.2 -- Bad Zope 2.6 + Python 2.2 -- Bad Zope 2.7 + Python 2.2 -- Good This

Re: [Zope-dev] zope and python compatibility

2003-01-09 Thread Chris McDonough
This is right although it's been reported that Zope 2.6 works with Python 2.2 with no detected problems (so far). - Original Message - From: Tena Sakai [EMAIL PROTECTED] To: [EMAIL PROTECTED] Sent: Thursday, January 09, 2003 12:06 PM Subject: [Zope-dev] zope and python compatibility

Re: [Zope-dev] zope and python compatibility

2003-01-09 Thread Leonardo Rochael Almeida
On Thu, 2003-01-09 at 15:06, Tena Sakai wrote: [...] Zope 2.5 + Python 2.1 -- Good Zope 2.6 + Python 2.1 -- Good Zope 2.7 + Python 2.1 -- Bad Zope 2.5 + Python 2.2 -- Bad Zope 2.6 + Python 2.2 -- Bad Zope 2.7 + Python 2.2 -- Good This article/note was from

Re: [Zope-dev] zope and python compatibility

2003-01-09 Thread Jeffrey P Shell
On Thursday, January 9, 2003, at 10:06 AM, Tena Sakai wrote: Greetings zope-dev folks, Please help me out. I have seen below via google search: Zope 2.5 + Python 2.1 -- Good Zope 2.6 + Python 2.1 -- Good Zope 2.7 + Python 2.1 -- Bad Zope 2.5 + Python 2.2 -- Bad Zope 2.6 +

[Zope-dev] zope and python compatibility

2003-01-09 Thread Clemens Robbenhaar
Tena Sakai writes: Greetings zope-dev folks, Please help me out. I have seen below via google search: Zope 2.5 + Python 2.1 -- Good Zope 2.6 + Python 2.1 -- Good Zope 2.7 + Python 2.1 -- Bad Zope 2.5 + Python 2.2 -- Bad Zope 2.6 + Python 2.2 -- Bad

Re: [Zope-dev] zope and python compatibility

2003-01-09 Thread Adam Manock
I would strongly recommend using python version 2.1.3 for Zope 2.5.1 - 2.6.x and python = 2.2.2 for Zope 2.6.x. Adam On Thu, 2003-01-09 at 12:06, Tena Sakai wrote: Greetings zope-dev folks, Please help me out. I have seen below via google search: Zope 2.5 + Python 2.1 -- Good

Re: [Zope-dev] zope and python compatibility

2003-01-09 Thread Anthony Baxter
Leonardo Rochael Almeida wrote It is possible to run 2.6 under Python 2.2, but it's unsupported Note that you'll need 2.2.2. 2.2 and 2.2.1 have bugs that Zope triggers. -- Anthony Baxter [EMAIL PROTECTED] It's never too late to have a happy childhood.