[Zope-dev] Zope2.7.0rc2 AttributeError: 'NoneType' object has no attribute 'setHeader'

2004-02-05 Thread Tony McDonald
Hi all, We're in the process of migrating our sites to 2.7, so to get the guys up to speed we picked a site at random today. Did the /usr/local/zope/bin/mkzopeinstance.py jig (works very well), copied the Data.fs, some external methods, a Zwiki product and were good to go. This is from a

Re: FW: [Zope-dev] strange behavior of VirtualHostMonster

2004-02-05 Thread Casey Duncan
On Wed, 4 Feb 2004 22:50:27 -0600 [EMAIL PROTECTED] wrote: Okay, I debugged a bit more: [u'loginUser', u'usermgrFolder', '/', 'VHM'] = this looks weird to me It seems it's pretty okay, however the last line in VirtualHostMonster.__bobo_traverse__ says: return parents.pop() # He'll get

Re: [Zope-dev] Minor windows intaller bug and a question

2004-02-05 Thread Chris McDonough
On Wed, 2004-02-04 at 08:55, Sergey Volobuev wrote: Hi all, Installing 2.7.0rc2 windows zope installer, i noticed that it uses hard-coded value for instance directory. The proposed value is C:\Zope-Instance. However, some users (me :) don't have C: drive. For some reasons windows choose

Re: [Zope-dev] Minor windows intaller bug and a question

2004-02-05 Thread Lennart Regebro
From: Chris McDonough [EMAIL PROTECTED] Installing 2.7.0rc2 windows zope installer, i noticed that it uses hard-coded value for instance directory. The proposed value is C:\Zope-Instance. However, some users (me :) don't have C: drive. For some reasons windows choose G: letter for boot

RE: [Zope-dev] Minor windows intaller bug and a question

2004-02-05 Thread Tim Peters
[Chris McDonough, on the C:\Zope-Instance default] You can change the instance dir manually, no? You mean it's a bug that it doesn't detect your system drive and instead always uses C as the default, right? If so, yes, I agree, but likely it won't get fixed too soon as it's so minor. The

Re: [Zope-dev] Minor windows intaller bug and a question

2004-02-05 Thread Lennart Regebro
From: Chris McDonough [EMAIL PROTECTED] The old installer didn't create an instance home, it just created a software home. The software home is still put into program files by the new installer. Ah. Well, I'm not sure I think C:\ is such a good place for the default anyway. I'll test things

Re: [Zope-dev] Minor windows intaller bug and a question

2004-02-05 Thread Chris McDonough
On Thu, 2004-02-05 at 11:10, Lennart Regebro wrote: I find the default value strange. The old installer put it into the program files directory, which seem to me to be the reasonable place. Opinions on this? The old installer didn't create an instance home, it just created a software home.

RE: [Zope-dev] Minor windows intaller bug and a question

2004-02-05 Thread Chris McDonough
On Thu, 2004-02-05 at 11:37, Tim Peters wrote: The right drive letter is the value of InnoSetup's {sd} (system drive) constant, but I don't know how to feed that into the Pascal code that sets this up. I'm sure it's possible, I can probably figure it out. I'll put it on my todo list. - C

Re: [Zope-dev] Minor windows intaller bug and a question

2004-02-05 Thread Chris McDonough
On Thu, 2004-02-05 at 11:39, Lennart Regebro wrote: From: Chris McDonough [EMAIL PROTECTED] The old installer didn't create an instance home, it just created a software home. The software home is still put into program files by the new installer. Ah. Well, I'm not sure I think C:\ is

RE: [Zope-dev] Minor windows intaller bug and a question

2004-02-05 Thread Tim Peters
[Tim Peters] The right drive letter is the value of InnoSetup's {sd} (system drive) constant, but I don't know how to feed that into the Pascal code that sets this up. [Chris McDonough] I'm sure it's possible, I can probably figure it out. I'll put it on my todo list. Staring at the docs,

Re: [Zope-dev] Zope2.7.0rc2 AttributeError: 'NoneType' object has no attribute 'setHeader'

2004-02-05 Thread Dieter Maurer
Tony McDonald wrote at 2004-2-5 12:43 +: ... We have an index_html (initially DTML document, then tried method) that can be created (located at /prototype/myporfolio/index_html), have it's security settings changed quite happily. Then when the object is called we get the error in the

[Zope-dev] Re: Minor windows intaller bug and a question

2004-02-05 Thread Tres Seaver
Chris McDonough wrote: On Thu, 2004-02-05 at 11:39, Lennart Regebro wrote: From: Chris McDonough [EMAIL PROTECTED] The old installer didn't create an instance home, it just created a software home. The software home is still put into program files by the new installer. Ah. Well, I'm not sure I

Re: [Zope-dev] Zope2.7.0rc2 AttributeError: 'NoneType' object has no attribute 'setHeader'

2004-02-05 Thread Tony McDonald
Thanks for the response Dieter, On 5 Feb 2004, at 18:51, Dieter Maurer wrote: Tony McDonald wrote at 2004-2-5 12:43 +: ... We have an index_html (initially DTML document, then tried method) that can be created (located at /prototype/myporfolio/index_html), have it's security settings

[Zope-dev] Re: Zope2.7.0rc2 AttributeError: 'NoneType' object has no attribute 'setHeader'

2004-02-05 Thread Christian Heimes
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Dieter Maurer wrote: ~ Looks like RESPONSE is None. | | I do not see how this can happen... aol / but a CMFPhoto user reported a bug like this to me today. According to his traceback self.REQUEST had now attribute RESPONSE. That's really strange. :(