Re: [Zope-dev] zope2 webdav memory usage...

2008-01-15 Thread Chris Withers
Jim Fulton wrote: You know, you could have provided a link. I believe it's Dieter's policy never to actually provide links to anything ;-) Chris -- Simplistix - Content Management, Zope Python Consulting - http://www.simplistix.co.uk

[Zope-dev] Zope Tests: 5 OK

2008-01-15 Thread Zope Tests Summarizer
Summary of messages to the zope-tests list. Period Mon Jan 14 12:00:00 2008 UTC to Tue Jan 15 12:00:00 2008 UTC. There were 5 messages: 5 from Zope Unit Tests. Tests passed OK --- Subject: OK : Zope-2.7 Python-2.3.6 : Linux From: Zope Unit Tests Date: Mon Jan 14 20:52:03 EST 2008

[Zope-dev] proxies

2008-01-15 Thread Chris Withers
Hi All, I saw the zope.proxies module and wondered if it might be able to help me with two problems I need to solve: - can these proxies be used to keep track of a traversal path in much the same way (although no seperate containment and context chains needed) as the old Zope 2 acquisition

Re: [Zope-dev] KeyError in ZRDB.DA cache handling

2008-01-15 Thread Chris Withers
Hi there, J Cameron Cooper wrote: but we have that fix in our Zope 2.9.8: http://osdir.com/ml/web.zope.all-cvs/2006-11/msg00150.html Are you absolutely sure you're using a version of Zope with my patches included? Perhaps it is another high-load leak? I don't think it can be multiple

[Zope-dev] more on stacked component registries

2008-01-15 Thread Chris Withers
Hi All, Happy New Year, etc :-) Been working more on this stuff so finally have some more questions... Philipp von Weitershausen wrote: Okay, but where's this code? (ie: what .py should I look at for the local registry implementation) zope.app.component.site contains the LocalSiteManager

Re: [Zope-dev] python 2.5 and zope components?

2008-01-15 Thread Christophe Combelles
Chris Withers a écrit : Hi All, Is there a known/unknown list of what Zope 3 components work with Python 2.5 and what don't? there is a wiki page http://wiki.zope.org/zope3/Zope3UsingPython25 and a status list http://wiki.zope.org/zope3/ModuleImplementationStatus Christophe My memory

[Zope-dev] Re: more on stacked component registries

2008-01-15 Thread Raphael Ritz
Chris Withers wrote: [..] Actually, it doesn't. The handling of __bases__ appears to be done in the functions of the mysterious zope.interface.ro module. (that ro thing takes the biscuit for obscure naming :-( ) Without having a clue my first guess would be that this means 'Resolution

[Zope-dev] Re: KeyError in ZRDB.DA cache handling

2008-01-15 Thread J Cameron Cooper
Chris Withers wrote: Hi there, J Cameron Cooper wrote: but we have that fix in our Zope 2.9.8: http://osdir.com/ml/web.zope.all-cvs/2006-11/msg00150.html Are you absolutely sure you're using a version of Zope with my patches included? Yes; I've checked both version (this went in for

[Zope-dev] Zope 3 without ZODB

2008-01-15 Thread David Pratt
Hi Chris. I was scanning the lists looking for posts similar to this. Were you successful in getting something like this to work? Anyone else document anything like this? I wrote a different main.py at some point about a year or so ago so both twisted clients and servers to could be started

Re: [Zope-dev] zope2 webdav memory usage...

2008-01-15 Thread Dieter Maurer
Chris Withers wrote at 2008-1-15 09:42 +: You know, you could have provided a link. I believe it's Dieter's policy never to actually provide links to anything ;-) Indeed, I never search for others... If I have the link at hand, you may get a link, but if not, then your effort to search is

Re: [Zope-dev] Zope 3 without ZODB

2008-01-15 Thread Jim Washington
David Pratt wrote: Hi Chris. I was scanning the lists looking for posts similar to this. Were you successful in getting something like this to work? Anyone else document anything like this? I wrote a different main.py at some point about a year or so ago so both twisted clients and servers

Re: [Zope-dev] Re: KeyError in ZRDB.DA cache handling

2008-01-15 Thread Dieter Maurer
J Cameron Cooper wrote at 2008-1-15 10:01 -0600: I do not have a fix (or an explanation) for your problem -- but maybe I can suggest a workaround: you might replace ZSQLMethod by my CCSQLMethod. http://www.dieter.handshake.de/pyprojects/zope -- Dieter

[Zope-dev] [Zope2/Multi-Version-Eggs] Imports behaving strange

2008-01-15 Thread Andreas Jung
Hi, I have running Zope 2 application using SQLAlchemy 0.3.11/z3c.sqlalchemy 1.0.11 and needs to be migrated to SA 0.4/z3c.sqlalchemy 1.1. For the migration period I installed all four versions as multi-version eggs. For debugging purposes, my lib/python/Zope2/Startup/zopectl.py contains: