Re: [Zope-dev] Python 2.4 Support

2010-09-20 Thread Andre Schubert
Hi, On Fri, 17 Sep 2010 11:33:09 -0400 Jim Fulton j...@zope.com wrote: JF On Fri, Sep 17, 2010 at 11:28 AM, Stephan Richter JF srich...@cosmos.phy.tufts.edu wrote: JF On Friday, September 17, 2010, Tres Seaver wrote: JF i have a little question. JF Is there a chance to not drop Python2.4

[Zope-dev] Python 2.4 Support

2010-09-17 Thread Andre Schubert
Hi, i have a little question. Is there a chance to not drop Python2.4 Support for ZTK1.1? I ask because Redhat Enterprise Linux 5 is shipped with Python2.4, and should have been supported for some years from now. Regards, Andre pgpJ3FjGG17rV.pgp Description: PGP signature

[Zope-dev] Zope and streaming

2003-12-16 Thread Andre Schubert
Hi all, i have a little problem. I cant find a way howto stream data from a Zope behind Apache. My coworker was playing a little bit with mod_fastcgi, and found a way to stream data via the mod_fastcgi module in Apache. But if we tested this with a fast-cgi enabled Zope it does not work. It seems

Re: [Zope-dev] PCGI-Problem

2003-09-22 Thread Andre Schubert
On Sun, 21 Sep 2003 16:13:55 -0400 Casey Duncan [EMAIL PROTECTED] wrote: On Friday 19 September 2003 04:31 am, Andre Schubert wrote: On Thu, 18 Sep 2003 14:32:52 +0200 Andre Schubert [EMAIL PROTECTED] wrote: Hi all, i have a little problem. We have several Zope's running

Re: [Zope-dev] PCGI-Problem

2003-09-19 Thread Andre Schubert
On Thu, 18 Sep 2003 14:32:52 +0200 Andre Schubert [EMAIL PROTECTED] wrote: Hi all, i have a little problem. We have several Zope's running in our company. Versions are 2.5.1,2.6.1,2.6.2. All are running on Redhat Linux. All versions have the same problem, if i access them via pcgi and hit

[Zope-dev] PCGI-Problem

2003-09-18 Thread Andre Schubert
Hi all, i have a little problem. We have several Zope's running in our company. Versions are 2.5.1,2.6.1,2.6.2. All are running on Redhat Linux. All versions have the same problem, if i access them via pcgi and hit the Restart button in the Control Panel then the server goes down. If i do the

[Zope-dev] ConflictError

2003-03-28 Thread Andre Schubert
Hi all, i have a little problem with the following log-entry in my logfile. 2003-03-28T10:09:18 INFO(0) ZODB conflict error at /foo/bar/tab_kopf (1 conflicts since startup at 2003-03-28T10:09:03). After searching through several mailinglists i found that this error seem to occur when using

[Zope-dev] Security-Problem

2003-02-18 Thread Andre Schubert
Hi all, i have a little Security-Problem which results in the following Error reported by Shane Hathaway's nice VerboseSecurity: Error Type: Unauthorized Error Value: The owner of the executing script does not have the required permission. Access to 'foobar' of (Folder instance at 932b600)

Re: [Zope-dev] Security-Problem

2003-02-18 Thread Andre Schubert
On Tue, 18 Feb 2003 12:01:45 -0500 Shane Hathaway [EMAIL PROTECTED] wrote: On 02/18/2003 09:16 AM, Andre Schubert wrote: I try to explain what happens. Lets say i have a user called foo who has Manager-Roles across a Zope-site. foo has added 2 DTMLMethods to a folder called bar and foobar

Re: [Zope-dev] Zope-2.5.1 restart failed

2002-10-14 Thread Andre Schubert
On Fri, 11 Oct 2002 11:24:57 +0100 Chris Withers [EMAIL PROTECTED] wrote: Andre Schubert wrote: 2002-10-11T06:01:00 ERROR(200) ZODB Couldn't load state for '\x00\x00\x00\x00\x00\x00\x00T' Traceback (innermost last): File /usr/share/zope/lib/python/ZODB/Connection.py, line 447

[Zope-dev] Zope-2.5.1 restart failed

2002-10-10 Thread Andre Schubert
Hi all, i have a problem restarting my Zope-2.5.1 TTW. If i hit the Restart-button in the Control_Panel Zope seems to restart, but if i click on Root-Folder in the menu i got ValueError: I/O operation on closed file The stupid-log say the following 2002-10-11T06:00:45 INFO(0)

[Zope-dev] CallProfiler problem

2002-10-09 Thread Andre Schubert
Hi all, I have a problem removing the CallProfiler product from my Zope. After removing the product-directory from /usr/share/zope/lib/python/Products I got the following error after a restart: 2002-10-09T13:19:05 PROBLEM(100) ZODB Could not import class 'CallProfiler' from module

[Zope-dev] Zope 2.4.3 and Python 2.2

2002-08-20 Thread Andre Schubert
Hi there, are there any known issues or problem running Zope 2.4.3 under PYthon 2.2 instead of 2.1. I'am asking because my sysadmin has setup a new linux-box with RH7.3. RH7.3 only has Python 2.2 installed and there are no RPMs compiled against Python 2.2. If there are no problems a would try to

Re: [Zope-dev] Zope 2.4.3 and Python 2.2

2002-08-20 Thread Andre Schubert
know that this is not supported, but could there anything incompatible between Python 2.1 + Zope and Python 2.2 + Zope ? Greets, -aj - Original Message - From: Andre Schubert [EMAIL PROTECTED] To: zope [EMAIL PROTECTED] Sent: Wednesday, August 21, 2002 07:47 Subject: [Zope-dev] Zope

Re: [Zope-dev] Memory Leaks

2002-07-23 Thread Andre Schubert
On Tue, 23 Jul 2002 12:37:39 +0200 Stefan H. Holek [EMAIL PROTECTED] wrote: I do also see the ZPT expression stuff leaking. In my case in this order: Products.PageTemplates.Expressions.SubPathExpr Products.PageTemplates.Expressions.PathExpr Products.PageTemplates.ZRPythonExpr.PythonExpr

Re: [Zope-dev] Memory Leaks

2002-07-23 Thread Andre Schubert
On Tue, 23 Jul 2002 12:37:39 +0200 Stefan H. Holek [EMAIL PROTECTED] wrote: I do also see the ZPT expression stuff leaking. In my case in this order: Products.PageTemplates.Expressions.SubPathExpr Products.PageTemplates.Expressions.PathExpr Products.PageTemplates.ZRPythonExpr.PythonExpr

[Zope-dev] Permission Question

2002-05-13 Thread Andre Schubert
Hi all, i have i question on the permission-system of zope. Lets say i have a product which contains a zclass foo and i have created a role foo_role where every user belonges to this role is able to add foo instances. This works fine. But how do i define my permissions so, that all users which

Re: [Zope-dev] Permission Question

2002-05-13 Thread Andre Schubert
On Mon, 13 May 2002 21:16:24 +0200 Dieter Maurer [EMAIL PROTECTED] wrote: Andre Schubert writes: i have i question on the permission-system of zope. Lets say i have a product which contains a zclass foo and i have created a role foo_role where every user belonges to this role

Re: [Zope-dev] Security-Bug

2002-05-12 Thread Andre Schubert
On Wed, 8 May 2002 23:04:08 +0200 Dieter Maurer [EMAIL PROTECTED] wrote: Andre Schubert writes: could this be a bug in the security-machinery? Lets say we have a role foo, this role has the permission to view the management screens. Lets say we have a user bar which has the role

Re: [Zope-dev] Memory Leak Problem

2002-03-14 Thread Andre Schubert
the results were cached ) or the ZPsycopgDA ?? Regards, -- Andre SchubertEMail: [EMAIL PROTECTED] Tel: 03774 6625-78 km3 teledienst GmbH Fax: 03774 6625-79 ___ Zope-Dev maillist - [EMAIL PROTECTED] http

Re: [Zope-dev] Memory Leak Problem

2002-03-14 Thread Andre Schubert
Toby Dickenson schrieb: On Thu, 14 Mar 2002 13:50:13 +0100, Andre Schubert [EMAIL PROTECTED] wrote: After a restart my zope-processes are around 12MB. Sounds about right. Then i start my script and before i receive any result all processes are grown up to 26MB. Thats

Re: [Zope-dev] Memory Leak Problem

2002-03-14 Thread Andre Schubert
Andre Schubert schrieb: If have changed the that it skips the ZSQLMethod and sends the query used in the ZSQLMethod direct to the manage_test function from the ZPsycopgDA with the result that zope grows up after running the script. If it is possible that the mem-leak is somewhere in the DA

Re: [Zope-dev] Memory Leak Problem

2002-03-13 Thread Andre Schubert
Andre Schubert schrieb: Andy McKay schrieb: Didnt Shane do a leak finder product that can help debug this? http://www.zope.org/Members/hathawsh I will install the LeakFinder product on the server and look what happens If have installed LeakFinder this morning and restarted zope

[Zope-dev] Memory Leak Problem

2002-03-12 Thread Andre Schubert
, -- Andre SchubertEMail: [EMAIL PROTECTED] Tel: 03774 6625-78 km3 teledienst GmbH Fax: 03774 6625-79 ___ Zope-Dev maillist - [EMAIL PROTECTED] http://lists.zope.org/mailman/listinfo/zope-dev

Re: [Zope-dev] Memory Leak Problem

2002-03-12 Thread Andre Schubert
) -- Andre SchubertEMail: [EMAIL PROTECTED] Tel: 03774 6625-78 km3 teledienst GmbH Fax: 03774 6625-79 ___ Zope-Dev maillist - [EMAIL PROTECTED] http://lists.zope.org/mailman/listinfo/zope-dev

Re: [Zope-dev] Memory Leak Problem

2002-03-12 Thread Andre Schubert
-announce http://lists.zope.org/mailman/listinfo/zope ) -- Andre SchubertEMail: [EMAIL PROTECTED] Tel: 03774 6625-78 km3 teledienst GmbH Fax: 03774 6625-79 ___ Zope-Dev maillist - [EMAIL PROTECTED

[Zope-dev] sqlvar and longs

2002-03-06 Thread Andre Schubert
? Is there a product which patches this problem? If not i would write such a thing myself. Regards -- Andre SchubertEMail: [EMAIL PROTECTED] Tel: 03774 6625-78 km3 teledienst GmbH Fax: 03774 6625-79

Re: [Zope-dev] sqlvar and longs

2002-03-06 Thread Andre Schubert
only if the string-representation is not greater than the max-value of an integer. The following does not work for me. dtml-let longnumber=24L update tbl_test set adresse = dtml-sqlvar longnumber type=int /dtml-let Greetings -- Andre SchubertEMail: [EMAIL PROTECTED

Re: [Zope-dev] Zope 2.6 planning - call for contributors!

2002-02-28 Thread Andre Schubert
/listinfo/zope-announce http://lists.zope.org/mailman/listinfo/zope ) -- Andre SchubertEMail: [EMAIL PROTECTED] Tel: 03774 6625-78 km3 teledienst GmbH Fax: 03774 6625-79 ___ Zope-Dev maillist - [EMAIL

[Zope-dev] Possible Bug in Helpsys

2002-02-27 Thread Andre Schubert
or not ?? -- Andre SchubertEMail: [EMAIL PROTECTED] Tel: 03774 6625-78 km3 teledienst GmbH Fax: 03774 6625-79 ___ Zope-Dev maillist - [EMAIL PROTECTED] http://lists.zope.org/mailman/listinfo/zope-dev

Re: [Zope-dev] Possible Bug in Helpsys

2002-02-27 Thread Andre Schubert
Hi Chris, done. Issue #253 Update (Request) Unsorted menu in HelpSys mfg Chris McDonough schrieb: Hi Andre, Can you supply a bugreport (and maybe a patch) to the Collector? http://collector.zope.org/ Thanks, - C Andre Schubert wrote: Hi all, These days i worked on a Help

[Zope-dev] Memory Problem with 2.3.3

2002-02-20 Thread Andre Schubert
are growing up 10MB a day. If have also looked in the debug-information at the top-refcounts. OFS.Image.Image has a delta of around +1500... Is there a problem with OFS.Image.Image, are these objects never closed Please Help Regards, -- Andre SchubertEMail: [EMAIL PROTECTED

Re: [Zope-dev] ZClasses and Python

2002-02-19 Thread Andre Schubert
Hi, thank you very much, this works perfectly for me... :) Regards Tim McLaughlin schrieb: Take a look at ZClassEvents Andre Schubert wrote: Hi all, i have a little question on ZCLasses and Python. Lets Say i have python-base-class foo which is folderish. I have a zclass bar

[Zope-dev] ZClasses and Python

2002-02-07 Thread Andre Schubert
, then manage_editProperties is called( i'am right ). Is there a way to catch the manage_editProperties function(called from foobar) in my base-class foo Thanks as P.S.: I hope there is someone understanding this :) -- Andre SchubertEMail: [EMAIL PROTECTED] Tel

[Zope-dev] Bug Or Feature in ZopeSplitter

2002-01-14 Thread Andre Schubert
Hi all, After playing with Zope 2.4.3 and TextIndexes i found out that the TextIndex does not Index Digits( 12345 ). Thatswhy i looked in the sources and i saw in next_word, that there is the caracter checked with isalnum, but in check_synstop the caracter is checked with isalpha? This means

Re: [Zope-dev] Bug Or Feature in ZopeSplitter

2002-01-14 Thread Andre Schubert
I hope the changes I made will work. :) mfg as Chris McDonough schrieb: This is correct. The current splitter implementation ignores digits. You can make your own implementation that does not. Andre Schubert wrote: Hi all, After playing with Zope 2.4.3 and TextIndexes i found

Re: [Zope-dev] Zope Exceptions and translation

2001-12-05 Thread Andre Schubert
Seb Bacon schrieb: From: Trevor Toenjes [EMAIL PROTECTED] This proposal is dead-on to make the errors more accessible and customizable. This is the solution to some of my previous error_message threads. How do we move this from proposal to project? We need to define the scope

[Zope-dev] Zope Exceptions and translation

2001-12-03 Thread Andre Schubert
Hi all, I'am looking for several products to translate zope-site into german. I have found ZBabel and it works very fine for normal websites. It always works fine in the standard_error_message if there is an error_value and an error_type. But it doesnt work if i get an string exception, because

Re: [Zope-dev] Security Question

2001-11-28 Thread Andre Schubert
Danny William Adair schrieb: On Saturday 24 November 2001 01:40, Andre Schubert wrote: root/ index_html foo/ acl_users/ bar/ Image I have a image which could only be view by users with a role named foobar, these users are in acl_users. If i access

[Zope-dev] Authentication Problem with Postgres

2001-11-20 Thread Andre Schubert
Hi all, sometimes i have a curios problem with my Zope. Without any errors in any logs Zope could not authenticate himself with postgres. The error message is that there is a wrong password. After a restart of Zope everything works fine until the eror occurs again. My sysop has traced the

Re: Was:([Zope-dev] HELP PLEASE)

2001-10-18 Thread Andre Schubert
, but that was not the problem. The problem seems that if a SQL-query takes several time, then the error is raised. There was a message from Shai Berger written on Mon, 06 Aug 2001 18:44:06 +0300 which describes(for me) this problem. thanls as Andre Schubert schrieb: The only things i know, are the following lines

Re: [Zope-dev] HELP PLEASE

2001-10-12 Thread Andre Schubert
know this. If this error occurs a second time a know what i have to do. thanks as Robert Rottermann schrieb: I had this once (the slowing down) when an other process was eating up all memory and zope was constantly paged out. Robert - Original Message - From: Andre Schubert [EMAIL

[Zope-dev] HELP PLEASE

2001-10-11 Thread Andre Schubert
Hi all, i have serious problems with my zope. Last time he dies very often with error code 13,and since to today he slows down extremly. To view the Control_Panel/DebugForm it takes up to 1 minute and thats not acceptable. How can i track down these problems. I run Zope-2.2.4 on Immunix-RedHat

[Zope-dev] Database Authentication Problem

2001-10-04 Thread Andre Schubert
Hi, a have amysterious problem with my database-adapters. The problem is that sometimes all my database-adapters couldn't connect to my database. after a zope-restart everything works fine. I use Zope-2.2.5 Immunix Redhat 6.2 PostgreSQL 7.1.3 ZopeDA's are ZPygreSQL and ZPsycopg. If the error

[Zope-dev] Zope Dying

2001-09-26 Thread Andre Schubert
Hi, Yesterday our Zope(2.2.5) on redhat 6.2 immunix was dying 3-4 times in about 2 hours. There are nothing to report in all the logs zope can produce. But is there a way that zope makes a core dump when he is dying unexpectly? as ___ Zope-Dev

Re: [Zope-dev] Curiously Zope Hanging

2001-07-13 Thread Andre Schubert
Hi, Ok, we( my SysAdmin and i ) have found the problem of hanging. After hours of searching in the python Sources of all the Products which are involved we have nothing found. At this point my SysAdmin has the idea to trace the python processes with gdb. After this we could see that Zope was

[Zope-dev] Curiously Zope Hanging

2001-07-12 Thread Andre Schubert
Hi all, I have a problem with my Zope, he hangs unexpectly if i view a special Method which generates Diagrams with data from a PostgresDB. The data are selected by a timespan( default is 24 Hours ). The Method works as descripted bellow: First when i call foo, then the HTML-Code is rendered

Re: [Zope-dev] Curiously Zope Hanging

2001-07-12 Thread Andre Schubert
? I've had lots of trouble with Postgres and threads on FreeBSD. Have you tried starting Zope with '-D' to see if threads are an issue? -steve Andre Schubert wrote: Hi all, I have a problem with my Zope, he hangs unexpectly if i view a special Method which generates Diagrams with data

Re: [Zope-dev] Curiously Zope Hanging

2001-07-12 Thread Andre Schubert
on stdout of the 'start -D' process. 4) Post some real code so we can see what you're really up to (!?) -steve Andre Schubert wrote: Hi Steve, Immunix Redhat 6.2 Zope 2.3.3 Postgres 7.1.2 I'am running Zope with -M -D and with Stupid_log_file. But i don't find a problem

Re: [Zope-dev] Bug in TransparentFolders ???

2001-07-04 Thread Andre Schubert
the if there is a TransparentFolder then don't acquire its Permissions only Acquire its Objects. Is this right or did i forgot something??? thanks as Andre Schubert schrieb: Hi all, i think i have found a bug in using TransparentFolders. Let it explain step by step. First the Structure

[Zope-dev] TransparentFolder Problem

2001-06-28 Thread Andre Schubert
Hi, i have a problem with Acquisition and TransparentFolders. I have the following structure / Transparent_A Method_A Folder_B Transparent_B Method_A Folder_C Folder_B and Folder_C are non-transparent, Transparent_A and Transparent_B are transparent.

Re: [Zope-dev] TransparentFolder Problem

2001-06-28 Thread Andre Schubert
I have testet it on a devel server, but on this machine everything works fine. I forgot to say, that there is a siteroot in Folder_B and Folder_C and the Permissions in these Folders are different. If i have time i try to rebuild the situation step by step and tell you the Results thanks, as

[Zope-dev] TransparentFolderPatch and Security

2001-06-14 Thread Andre Schubert
Hi all, I have found a bug with Transp√ľarent FolderPatch and ZopeSecurity. Let me explain my structure. root: folder 1: foo: bar: foobar: foo 1: bar 1: Let me say that folder 1 is a normal Folder, foo and bar and foo 1 and bar 1 are

Re: [Zope-dev] using php on zope

2001-06-08 Thread Andre Schubert
Erik Enge schrieb: On Fri, 8 Jun 2001, Stian Jenssen wrote: Hi there! Hello :) I wan't to use php with zope, does anybody know how the header syntax shall look like? Tried diffrent syntaxes but i get wierd outputs, not as expected. Try this one:

Re: [Zope-dev] Browser Timeout

2001-06-01 Thread Andre Schubert
R. David Murray schrieb: On Thu, 31 May 2001, Andre Schubert wrote: I tested with lynx. If i type http://somewhere.com/foo/test i got no response because timeout, this means, that RESPONSE.setStatus and the first RESPONSE.write are sent back to the client if the body processing is done

Re: [Zope-dev] Browser Timeout

2001-05-31 Thread Andre Schubert
every command as it is processed back to the client. Or is it my Zope( 2.2.4 ) on Immunix 6.2 RedHat. as R. David Murray schrieb: On Wed, 30 May 2001, Andre Schubert wrote: Is it right, the the browser send a request and got the response when the site is completly rendered( all queries

[Zope-dev] Browser Timeout

2001-05-30 Thread Andre Schubert
Hi all, I have a very important problem with Zope. I want to display a html-site with diagramms, the diagrams are from a sql-db with over 30Mill. entries. My problem is that when i call the site, then for each diagram to display a sql-query is executed which costs time. When 20 or 30 query are

[Zope-dev] ZServer, FTP and setVirtualRoot

2001-05-16 Thread Andre Schubert
Hi all, i have a little problem with FTP. first i have a folder foo, in this Folder is a dtml-method which generates a session id add this id after the current path( http://xxx.yyy.com/foo/98347698234562/ ) and sets the result with REQUEST.setVirtualRoot as the SiteRoot. The dtml-method

[Zope-dev] Bug in dtml-in ????

2001-05-02 Thread Andre Schubert
Hi, I have found a error/bug in the dtml-in tag. I have an SQL-Query that returns traffic-data grouped by month and year. Th SQL-query returns 5 rows of data. I want a page to show only one month. If i use: dtml-in foo size=1 orphan=1 start=query_start dtml-if sequence-start dtml-if

Re: [Zope-dev] Bug in dtml-in ????

2001-05-02 Thread Andre Schubert
-sequence']=1 kw['next-sequence-start-index']=pstart-1 kw['next-sequence-end-index']=pend-1 kw['next-sequence-size']=pend+1-pstart except: pass and everything works well with size=1 as Andre

[Zope-dev] Security Management

2001-04-12 Thread Andre Schubert
Hi all, I have a question on the security system of zope. First i have a folder called foo in the root with acl_users and a doc called foo_doc: root/ bar_doc foo/ acl_users/ joe foo_doc If Anonymous users could'nt view the foo_doc. This means only logged in users

Re: [Zope-dev] Images and Products

2001-03-27 Thread Andre Schubert
Hi, i have found the error. I had somewhere definded '' in a Permission wich is the same as index_html. And this permission was not set to Anonymous. as Dieter Maurer schrieb: Andre Schubert writes: I have a little Problem on using Images in my Product. If i'am logged in as Manager i

[Zope-dev] Images and Products

2001-03-26 Thread Andre Schubert
Hi all, I have a little Problem on using Images in my Product. If i'am logged in as Manager i can View the Image, but if logged in as Anonymous i can't view the Image. The View permission is assigned to Anonymous Role and the Image Foo is assing to the View Permission, but i can't view the Image

Re: [Zope-dev] Images and Products

2001-03-26 Thread Andre Schubert
Hi, My Products Inherits Acquisition.Implicit. Anonymous Users have the View Permission and it's aquired into my Product. Is there a bugfix that i have forgot to fix ?? -as Dieter Maurer schrieb: Andre Schubert writes: I have a little Problem on using Images in my Product. If i'am

[Zope-dev] QuickTime VR Movies

2001-03-12 Thread Andre Schubert
Hi all, I have found an error or bug in handling QT VR Movies with Zope. I have uploaded three qt files into Zope as File objects. I also have installed this files in the normal appache directory. Now comes the error? If i do a wget with the files from the apache directory and thi files from

Re: [Zope-dev] QuickTime VR Movies

2001-03-12 Thread Andre Schubert
Hi, the content-type of the files is video/quicktime. If i get such a file with wget i got the correct content-type, but the binaries of the file are different to a file got from apache. mfg Casey Duncan schrieb: Andre Schubert wrote: Hi all, I have found an error or bug in handling

Re: [Zope-dev] Zope 2.2.4 Dying

2001-02-19 Thread Andre Schubert
schrieb: Andre Schubert wrote: Hi, I'am using Zope 2.2.4 with the required patches. Python 1.5.2 Immunix 6.2 (redhat) - Production System - with apache-1.3.14-2.6.2 under a Named Virtual Host Zope is running with Zope.cgi I would guess that Apache is disconnecting its pipe

[Zope-dev] AttributeError

2001-02-16 Thread Andre Schubert
Hi all, Could anyone help me to solve the following Error that occurs sometimes. 2001-02-16T09:11:42 ERROR(200) ZODB Couldn't load state for '\000\000\000\000\000\0008\004' Traceback (innermost last): File /usr/share/Zope-2.2.4/lib/python/ZODB/Connection.py, line 443, in setstate

Re: [Zope-dev] AttributeError

2001-02-16 Thread Andre Schubert
(Installed product ZopeTutorial (Zope Tutorial 1.0)) mysqlUserFolder (Installed product mysqlUserFolder (mysqlUserFolder-0.5.2)) as Steve Alexander schrieb: Andre Schubert wrote: Could anyone help me to solve the following Error that occurs sometimes. 2001-02-16T09:11:42 ERROR(200

Re: [Zope-dev] Zope 2.2.4 Dying

2001-02-16 Thread Andre Schubert
Hi, I'am using Zope 2.2.4 with the required patches. Python 1.5.2 Immunix 6.2 (redhat) - Production System - with apache-1.3.14-2.6.2 under a Named Virtual Host Zope is running with Zope.cgi as Shane Hathaway schrieb: Andre Schubert wrote: Hi, since the last time i had some problems

[Zope-dev] Zope 2.2.4 Dying

2001-02-15 Thread Andre Schubert
Hi, since the last time i had some problems with my zope server. The zope 2.2.4 running under linux dies unexpectly with the following messages. 2001-02-16T01:50:08 ERROR(200) zdaemon zdaemon: Fri Feb 16 02:50:08 2001: Aiieee! 5451 exited with error code: 13 -- 2001-02-16T02:29:38

[Zope-dev] Error Message

2001-01-26 Thread Andre Schubert
Hi all The last time i get some times the following error: 2001-01-26T08:45:55 ERROR(200) ZODB Couldn't load state for '\000\000\000\000\000\000\260\256' Traceback (innermost last): File /usr/share/zope_2.2/Zope-2.2.0-src/lib/python/ZODB/Connection.py, line 442, in setstate AttributeError:

[Zope-dev] ZCatalog doesnt find Items

2001-01-19 Thread Andre Schubert
Hi all, I have a problem with my ZCatalog object. If i have a Folder named Test and inside i create a ZCatalog object and some DTML-Objects/Methods the ZCatalog finds all Items. But when i install the ZCatalog in the root folder and start find Items a got the following error: Traceback

[Zope-dev] Meta-Types

2000-12-11 Thread Andre Schubert
Hi, i have a question on using meta_types in my Product. My Product contains some classes that are Folder, each Folder has different meta_types. One of these Folder(Folder4) can be added everywhere. These Folder should contain only the meta_types of the Parent Folder in which he was created.

[Zope-dev] Security Permissions

2000-11-27 Thread Andre Schubert
Hi, i have found the Security Permission below in the Zope Root that are not definded by myself. A D G Z a d h r s t Who can tell me where these Permissions come from? as ___ Zope-Dev maillist - [EMAIL PROTECTED]

[Zope-dev] 2 Zopes

2000-10-25 Thread Andre Schubert
Hi, Can anyone tell me a way to get Zope Objects from the first Zope-Installation to the second. I need this because i have to program a Product to putting data into different Zope Installations from one point of the Web. My boss want this way because he want a central point for data input,

[Zope-dev] ConflictError

2000-10-04 Thread Andre Schubert
Hi, who can tell me a story about the following error. thanks as 2000-10-04T15:49:35 INFO(0) Z2 CONFLICT Competing writes at, /Management/Geyer/Cluster_1/Verstaerker_1/Modem_7/chart_images Traceback (innermost last): File /usr/share/zope_2.2/Zope-2.2.0-src/lib/python/ZPublisher/Publish.py,

[Zope-dev] Question about Labels

2000-09-22 Thread Andre Schubert
Hi, I have a Product with a Label called Foo. Now what can i do, that when anyone clicked on the tab Foo first the function bar() is called and after that the HTML-File is displayed. as manage_options =({'label':'Foo', 'action':'manage_propertiesForm'},) def bar(self): do anything before

[Zope-dev] using a DA

2000-09-21 Thread Andre Schubert
Hi, i have a problem on using a DA in my Product. I have a Postgresql DA in my root-folder. If my Product is installed in the root-folder and i use: self.con_obj = DA.DA('id','','pgsql','',query) return self.con_obj() When i install my Product in a sub-folder of the root-folder and i call the

[Zope-dev] Problems with EMarket

2000-08-31 Thread Andre Schubert
Hi, I'm discovering the EMarket Product and test it to with it in our Firm. I'm working with Zope 2.2.0 and i have 2 problems. First I added a MarketItemsFolder to MarketItems then a added 2 MarketItems in the MarketItemsFolder but none of the 2 MarketItems shows on the website. The Items are

[Zope-dev] DB Connection Question

2000-08-08 Thread Andre Schubert
Hi, I have written a Product the uses a Databaseconnection to MySQL, that works fine. but the connection in coded into my Product, and now i want to use a Zope DatabaseConnection added to the same folder. How does this works, it is very important for me, because we want to change to another

[Zope-dev] System error

2000-07-24 Thread Andre Schubert
Hi, I have a problem on deleting a folder. I have made a product, which has some bugs. After i have added it to a Folder named test i can't open the Folder and a can't delete the Folder test because a System Error occurs. The following Error message occurs: !-- Traceback (innermost last):

[Zope-dev] Uploading a ImageFile

2000-07-13 Thread Andre Schubert
Hi, i have a question on uploading an image from my Product. I have a Product in http://server:8080/somewhere/Product. In my Product i call: self._setObject(id, File(id,title,'',content_type, precondition)) self._getOb(id).manage_upload(file) Now the image is on

[Zope-dev] SQL-Methods

2000-07-12 Thread Andre Schubert
Hi, i ave a problem, i do some sql-queries in my python product and would return the results like the ZSQLMethods. How do i have to return the data and field names from my python product to an dtml document so that i can work with it like ZMYSQL. ___

[Zope-dev] SQL-Output

2000-07-06 Thread Andre Schubert
Hi, i have a little problem on outputting data from an SQL-Query. The Problem is, that the user should select his own Fieldnames he want to show for output. The input form sends a request to the output form, with a query-string and some other stuff and a key named ausgabe. The key ausgabe is a

[Zope-dev] Searching in a MySQL-Database

2000-07-05 Thread Andre Schubert
Hi, i have a very important question. Is there a way to search in a mysql-database with the ZCatalog. Could i create a temporary file from a table and search it with the ZCatalog. If there are any Ideas please tell me. Thanks, as ___ Zope-Dev