[Zope-dev] Possible ZCatalog Bug

2001-04-05 Thread Edmund Goppelt
A ZCatalog when passed an empty mapping of search terms returns no records found in Zope 2.3.1, instead of all records. This is not the way I remember ZCatalog working in previous versions of Zope. Is this a bug? Too, can someone clue me in on the proper place to look for bugs in Zope before

Re: [Zope-dev] Possible ZCatalog Bug

2001-04-05 Thread Edmund Goppelt
On Thu, Apr 05, 2001 at 12:02:31PM -0400, Chris McDonough wrote: I tried this in the most recent 2.3 branch: dtml-var "catalog({})" And it returned all objects. Are you sure the mapping is empty? Yep, though I am passing in some other parameters. Here's the dtml code that failed:

Re: [Zope-dev] Possible ZCatalog Bug

2001-04-05 Thread Edmund Goppelt
On Thu, Apr 05, 2001 at 05:31:23PM -0400, Chris McDonough wrote: What does "cleanrequest" return? It removes null strings from the REQUEST variable. But I substituted the empty mapping {} and got the same anomolous behavior. -- Ed Goppelt ___

[Zope-dev] Homegrown vs. Storebought

2001-04-03 Thread Edmund Goppelt
I'd like to add two capabilities to my city government web site: 1. users should be able to initiate discussions about legislation pending before our City Council. i.e., discussions will be tied to the relevant bill document. 2. users must register in order to post. I'd like enough

Re: [Zope-dev] Are Versions Reliable?

2001-03-25 Thread Edmund Goppelt
On Sun, Mar 25, 2001 at 12:09:10PM +0100, Chris Withers wrote: 1. When people using your site don't need to write to the ZODB to use the site (it sounds like they do in your case) The users themselves do not write, but periodically an External Method receives email via xml and parses it into a

[Zope-dev] Bizarre Version Behavior

2001-03-24 Thread Edmund Goppelt
I'm worried that versioning is not working properly on my Zope 2.3.0 web site. Since my site is due to receive some major publicity, the flakiness of versioning worries me a good deal. I'm hoping some of the more experienced developers can advise me on whether I should continue to use

[Zope-dev] ZCatalog Bug?

2001-03-16 Thread Edmund Goppelt
The bug collector doesn't appear to be working, so I apologize if this issue has already been raised. ZCatalog is failing for me when I attempt to reindex the catalog after adding a keyword index. Zope complains of a name error for Except on line 118 of UnKeywordIndex.py. Here's the code in

[Zope-dev] Adding ZClass Instances via Python

2001-03-16 Thread Edmund Goppelt
Ok, I know there's a howto with a working solution to this problem, but this is *still* killing me: How does one add a ZClass Instance in a way analagous to adding, say, a DTML Document in a Python script? With the dtml document, it's easy: