[Zope-dev] 2.3.0. Unindex_object Tried To Unindex Nonexistent

2001-02-09 Thread Chris Withers

Christopher Petrilli wrote:
> 
> Steve is right, though I fixed that problem when it snuck up on me, but
> apparantly it never got merged into the branches correctly.  Don't we all
> love CVS?
> 
> I personally had a problem with using 'i' as anything but a iterator
> variable.

Right, okay, patched Zope as described in this thread. Now, every so often I get
something like the following showing up on the console:

--
2001-02-09T12:59:33 ERROR(200) UnTextIndex unindex_object tried to unindex nonex
istent document 11
--
2001-02-09T12:59:33 ERROR(200) UnTextIndex unindex_object tried to unindex nonex
istent document 13
--
2001-02-09T12:59:34 ERROR(200) UnTextIndex unindex_object tried to unindex nonex
istent document 13

What does this mean? Should I be worried about it? It looks like I should :-S

Any help would be appreciated,

cheers,

Chris

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



Re: [Zope-dev] 2.3.0. Unindex_object Tried To Unindex Nonexistent

2001-01-29 Thread Christopher Petrilli

Steve is right, though I fixed that problem when it snuck up on me, but
apparantly it never got merged into the branches correctly.  Don't we all
love CVS?

I personally had a problem with using 'i' as anything but a iterator
variable.

Chris
--
| Christopher Petrilli
| [EMAIL PROTECTED]
- Original Message -
From: "Steve Alexander" <[EMAIL PROTECTED]>
To: "Andy Dawkins" <[EMAIL PROTECTED]>
Cc: <[EMAIL PROTECTED]>; <[EMAIL PROTECTED]>; <[EMAIL PROTECTED]>;
"Christopher Petrilli" <[EMAIL PROTECTED]>
Sent: Monday, January 29, 2001 7:19 AM
Subject: Re: [Zope-dev] 2.3.0. Unindex_object Tried To Unindex Nonexistent


> Andy Dawkins wrote:
>
> > I'm having some more problems with the ZCatalog in Zope 2.3.0
> >
> > I've got a name error in the file UnTextIndex.py
> >
> > Error Type: NameError
> > Error Value: i
> >
> > I believe this is occuring when the catalog tries to unindex an object
> > that isn't currently indexed.
> >
> > The traceback reports line 332:
> >
> > File /usr/zope/zope-2_3_0/lib/python/SearchIndex/UnTextIndex.py, line
> > 332, in removeForwardEntry
> >
> > The line in question reads:
> > LOG('UnTextIndex', ERROR,
> > 'Unindex_objects tried to unindex nonexistent'
> > ' document %s' % str(i))
> >
> > The function never uses or declares i, however it does use documentId.
> > I think perhaps the i should have been documentId but I thought i would
> > check with you guys first.
> >
> > What do you think?
>
> You're right. In an earlier version in CVS, all the variables called
> "documentId" were called "i". I guess this one just missed the
> search-replace :-)  Of course, documentId makes for much more readable
> code; although "i" is faster to type :)
>
> Change it to documentId and you'll be fine.
>
> --
> Steve Alexander
> Software Engineer
> Cat-Box limited
> http://www.cat-box.net
>
>


___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )




[Zope-dev] 2.3.0. Unindex_object Tried To Unindex Nonexistent

2001-01-29 Thread Andy Dawkins

I'm having some more problems with the ZCatalog in Zope 2.3.0

I've got a name error in the file UnTextIndex.py

Error Type: NameError
Error Value: i

I believe this is occuring when the catalog tries to unindex an object
that isn't currently indexed.

The traceback reports line 332:

File /usr/zope/zope-2_3_0/lib/python/SearchIndex/UnTextIndex.py, line
332, in removeForwardEntry

The line in question reads:
LOG('UnTextIndex', ERROR,
'Unindex_objects tried to unindex nonexistent'
' document %s' % str(i))

The function never uses or declares i, however it does use documentId.
I think perhaps the i should have been documentId but I thought i would
check with you guys first.

What do you think?

-Andy

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )