[Zope-dev] Re: [Zope] setting default security permissions

2002-04-12 Thread Sidnei da Silva

Anyway, seems that there was a bug on the permission machinery, that was 
solved today with the people at ZC, during the Bug Day.

The fixes are on CVS.

[]'s

On Qui 11 Abr 2002 18:23, Tom Cameron wrote:
| After more experimenting, I discovered that a restart of the zope server
| solved the problem.
|
| Nice to know, but I dont really wish to restart zope everytime I make a
| change. I am using Zope 2.5 and it appears that the refresh does not
| refresh the default security permissions.
|
| Tom
|
| = -Original Message-
| = From: Sidnei da Silva [mailto:[EMAIL PROTECTED]]
| = Sent: Thursday, April 11, 2002 9:57 AM
| = To: [EMAIL PROTECTED]; Zope-dev
| = Cc: [EMAIL PROTECTED]
| = Subject: Re: [Zope] setting default security permissions
| =
| =
| = I had the same problem a few weeks ago, and i posted my bug to
| = the collector
| = with a example class.
| =
| = See there:
| = http://collector.zope.org/Zope/275
| =
| = This friday, 9:00am EST there will be a BugDay on
| = irc://irc.zope.org/#zope-dev
| =
| = Description of BugDays here:
| = http://dev.zope.org/CVS/BugDays
| =
| =
| = I hope someone will be able to discuss this bug with me during
| = the BugDay,
| = and anyone with the same problem to be around and help.
| =
| = []'s
| =
| = On Sab 06 Abr 2002 01:43, you wrote:
| = | I am building a python product. I am having trouble getting default
| = | security permissions to set.
| = | I am able to declare the permission properly, but the defaults
| = dont work.
| = |
| = | I try the line
| = | security = ClassSecurityInfo()
| = | security.setPermissionDefault('View User Home',
| = |   ['Anonymous','Authenticated'])
| = | security.declareProtected('View User Home', 'home')
| = |
| = | The 'declareProtected' works, but the 'setPermissionDefault'
| = has no effect
| = | on anything.
| = |
| = | I have no idea what else I need to be doing.
| = |
| = | Tom
| = |
| = |
| = |
| = |
| = | ___
| = | Zope maillist  -  [EMAIL PROTECTED]
| = | http://lists.zope.org/mailman/listinfo/zope
| = | **   No cross posts or HTML encoding!  **
| = | (Related lists -
| = |  http://lists.zope.org/mailman/listinfo/zope-announce
| = |  http://lists.zope.org/mailman/listinfo/zope-dev )
| =
| = --
| = Sidnei da Silva (dreamcatcher) [EMAIL PROTECTED]
| = X3ng Web Technology http://www.x3ng.com.br
| = GNU/Linux user 257852
| = Debian GNU/Linux 3.0 (Sid) 2.4.19-pre6-ben0 ppc
| =
| = But what we need to know is, do people want nasally-insertable
| = computers?
| =
|
|
|
| ___
| Zope maillist  -  [EMAIL PROTECTED]
| http://lists.zope.org/mailman/listinfo/zope
| **   No cross posts or HTML encoding!  **
| (Related lists -
|  http://lists.zope.org/mailman/listinfo/zope-announce
|  http://lists.zope.org/mailman/listinfo/zope-dev )

-- 
Sidnei da Silva (dreamcatcher) [EMAIL PROTECTED]
X3ng Web Technology http://www.x3ng.com.br
GNU/Linux user 257852
Debian GNU/Linux 3.0 (Sid) 2.4.19-pre6-ben0 ppc

Linux: because a PC is a terrible thing to waste
-- [EMAIL PROTECTED] put this on Tshirts in '93


___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



[Zope-dev] Re: [Zope] setting default security permissions

2002-04-11 Thread Sidnei da Silva

I had the same problem a few weeks ago, and i posted my bug to the collector 
with a example class.

See there:
http://collector.zope.org/Zope/275

This friday, 9:00am EST there will be a BugDay on 
irc://irc.zope.org/#zope-dev

Description of BugDays here:
http://dev.zope.org/CVS/BugDays


I hope someone will be able to discuss this bug with me during the BugDay, 
and anyone with the same problem to be around and help.

[]'s

On Sab 06 Abr 2002 01:43, you wrote:
| I am building a python product. I am having trouble getting default
| security permissions to set.
| I am able to declare the permission properly, but the defaults dont work.
|
| I try the line
| security = ClassSecurityInfo()
| security.setPermissionDefault('View User Home',
|   ['Anonymous','Authenticated'])
| security.declareProtected('View User Home', 'home')
|
| The 'declareProtected' works, but the 'setPermissionDefault' has no effect
| on anything.
|
| I have no idea what else I need to be doing.
|
| Tom
|
|
|
|
| ___
| Zope maillist  -  [EMAIL PROTECTED]
| http://lists.zope.org/mailman/listinfo/zope
| **   No cross posts or HTML encoding!  **
| (Related lists -
|  http://lists.zope.org/mailman/listinfo/zope-announce
|  http://lists.zope.org/mailman/listinfo/zope-dev )

-- 
Sidnei da Silva (dreamcatcher) [EMAIL PROTECTED]
X3ng Web Technology http://www.x3ng.com.br
GNU/Linux user 257852
Debian GNU/Linux 3.0 (Sid) 2.4.19-pre6-ben0 ppc

But what we need to know is, do people want nasally-insertable computers?



___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



[Zope-dev] RE: [Zope] setting default security permissions

2002-04-11 Thread Tom Cameron

After more experimenting, I discovered that a restart of the zope server
solved the problem.

Nice to know, but I dont really wish to restart zope everytime I make a
change. I am using Zope 2.5 and it appears that the refresh does not refresh
the default security permissions.

Tom

= -Original Message-
= From: Sidnei da Silva [mailto:[EMAIL PROTECTED]]
= Sent: Thursday, April 11, 2002 9:57 AM
= To: [EMAIL PROTECTED]; Zope-dev
= Cc: [EMAIL PROTECTED]
= Subject: Re: [Zope] setting default security permissions
=
=
= I had the same problem a few weeks ago, and i posted my bug to
= the collector
= with a example class.
=
= See there:
= http://collector.zope.org/Zope/275
=
= This friday, 9:00am EST there will be a BugDay on
= irc://irc.zope.org/#zope-dev
=
= Description of BugDays here:
= http://dev.zope.org/CVS/BugDays
=
=
= I hope someone will be able to discuss this bug with me during
= the BugDay,
= and anyone with the same problem to be around and help.
=
= []'s
=
= On Sab 06 Abr 2002 01:43, you wrote:
= | I am building a python product. I am having trouble getting default
= | security permissions to set.
= | I am able to declare the permission properly, but the defaults
= dont work.
= |
= | I try the line
= | security = ClassSecurityInfo()
= | security.setPermissionDefault('View User Home',
= |   ['Anonymous','Authenticated'])
= | security.declareProtected('View User Home', 'home')
= |
= | The 'declareProtected' works, but the 'setPermissionDefault'
= has no effect
= | on anything.
= |
= | I have no idea what else I need to be doing.
= |
= | Tom
= |
= |
= |
= |
= | ___
= | Zope maillist  -  [EMAIL PROTECTED]
= | http://lists.zope.org/mailman/listinfo/zope
= | **   No cross posts or HTML encoding!  **
= | (Related lists -
= |  http://lists.zope.org/mailman/listinfo/zope-announce
= |  http://lists.zope.org/mailman/listinfo/zope-dev )
=
= --
= Sidnei da Silva (dreamcatcher) [EMAIL PROTECTED]
= X3ng Web Technology http://www.x3ng.com.br
= GNU/Linux user 257852
= Debian GNU/Linux 3.0 (Sid) 2.4.19-pre6-ben0 ppc
=
= But what we need to know is, do people want nasally-insertable
= computers?
=



___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )