[Zope-dev] z3c.form bug with radio widget label

2008-12-12 Thread Johannes Raggam
hey,

i guess i found a bug in z3c.form.browser.radio.

in z3c.form.browser.radio, line 49 (class RadioWidget, def update), the 
line should read

label = term.value

instead of label = term.token

we found this, while trying to display some unicode characters (umlaute) 
in radio widget labels.
this issue is still valid in current trunk (file revision 78513).

i report it here, because i could not find a bug tracker for z3c.form. is 
there any?

cheers,
hannes

___
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] z3c.form bug with radio widget label

2008-12-12 Thread Marius Gedminas
On Fri, Dec 12, 2008 at 02:33:53PM +, Johannes Raggam wrote:
 hey,
 
 i guess i found a bug in z3c.form.browser.radio.
 
 in z3c.form.browser.radio, line 49 (class RadioWidget, def update), the 
 line should read
 
 label = term.value

You can't assume ``value`` will be a string.  People routinely use
all sorts of objects there.

 instead of label = term.token
 
 we found this, while trying to display some unicode characters (umlaute) 
 in radio widget labels.

You should really be explicitly specifying the titles for your terms.

 this issue is still valid in current trunk (file revision 78513).
 
 i report it here, because i could not find a bug tracker for z3c.form. is 
 there any?

https://bugs.launchpad.net/zope3

(Since https://bugs.launchpad.net/z3c.form doesn't exist.)

-- 
http://pov.lt/ -- Zope 3 consulting and development


signature.asc
Description: Digital signature
___
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )